Thanks!

Thanks go out to all that contributed to the creation of this document, especially to Greg Sardinskas who assisted with the writing and for his technical and engineering expertise; Julie Annino who served as editor; Mark Byrnes help with reviewing; Jeff Beckwith and John Rinaldi for their survey expertise and help developing the XIN; The Highway Crews that accepted the task to pilot the new InRoads version; The Vermont Agency of Transportation for allowing CTDOT to use content from their InRoads Fundamentals Manual; The Engineering Applications Staff for technical assistance; DonWallace for providing the valuable initial InRoads XM training; and the late Harry Smith for his encouragement to continue moving forward. The support that they have provided has been invaluable and is appreciated beyond measure.

Elaine Richard
Overview

The goals of the CTDOT InRoads XM Guide are:

- To provide detailed instructions and technical support on the methods and standards used by CTDOT with Bentley InRoads XM and beyond.
- To maintain interoperability and collaboration with Consultant Engineers and State Design staff.
- To provide assistance for locating InRoads resource files within CTDOT’s Digital Design Environment (DDE) and to guide users on how apply these files to project designs.
- To aid in the creation of high-value electronic data to be used for future applications such as an interactive decision system.

The CTDOT InRoads XM Guide will identify standard resource files, configurations, and CAD functions used in the creation high value data.

The material covered in this guide does not replace the need for other references and training regarding InRoads software. Additional publications and training may be needed for further clarification of CAD procedures and functions. The intent of this guide is not to prevent or limit individual initiatives and engineering judgment used in project design and development. Rather, it is meant to document standard digital design procedures currently in practice at CTDOT.

The main users of this guide include Designers, Planners, Surveyors, and CAD Managers that work at or with CTDOT staff. The information provided in this guide is subject to change as technology and experience warrant. Therefore, this guide will be updated as major revisions in design software and CTDOT DDE policies occur. Addendum to this guide will be available in digital format only.

Distribution

This manual, in its entirety, may be freely copied and distributed for the purpose of providing a consistent guide to InRoads Design requirements of the Connecticut Department of Transportation. The CTDOT InRoads XM Guide is available on the web at the following address: http://www.ct.gov/dot/lib/dot/documents/deng/CTDOT_InRoads_XM_Guide.pdf

Trademarks

“MicroStation” and “InRoads”, are registered trademarks of Bentley Systems, Incorporated. Other trade names, computer protocols, and file formats mentioned in this manual are the trademarks of their respective owners. In no event will the appearance of any graphic, description of a graphic, picture, screen display, or any other method of conveying meaning, be considered to impair the rights of the respective owners.
Prerequisites

The required prerequisites for installing and using InRoads XM are listed below.

- Software - InRoads Version 8.09.02.16, MicroStation Version 08.09.04.51
- For Consultant Engineers - Bentley Courses, InRoads Roadway Design for Existing Users or InRoads 101 (Version 8.9)
- CTDOT 2007 DDE
- Only available for projects using 2007 DDE Standards

Online Application Help

As mentioned earlier, this manual is not intended to be a sole source of information for the InRoads user. InRoads software has extensive online help available through Help on the InRoads Menu Bar. Additionally, when using the different InRoads dialog boxes, each box has a Help button. These buttons link directly to information specific to the InRoads process being performed. It is generally expected that new or even seasoned InRoads users will need to reference the online help regularly. The best solution to a problem usually requires testing and selecting from multiple options. Practice and experience using InRoads is the key to becoming a proficient InRoads user. Also, InRoads Help contains a media library with video presentations and examples of standard workflows.

In addition, there are other outside InRoads learning resources for CTDOT users. Employees can access the internet for help and training on the Bentley Learning Web site http://www.bentley.com/en-US/Training/, or call Bentley directly at 1-800-778-4277. To access these learning resources from Bentley Systems, Inc., CTDOT employees should contact Engineering Applications to have a Bentley User ID issued to them. However, Consultant Engineering firms need to purchase their own training subscriptions directly through Bentley.

CTDOT Engineering Applications has setup InRoads preferences and standardized CTDOT InRoads practices in an effort make using InRoads as productive as possible. Please contact Elaine Richard at 594-3278 or Greg Sardinskas at 594-3453 if you have questions regarding this manual or the CTDOT InRoads preference files.
CTDOT InRoads Courses

The following InRoads in-house courses are available or will be available shortly. Portions of this manual will be used for each class as outlined below. These courses are available to CTDOT Engineers InRoads users. Users will need to fill out a Training Needs Evaluation to be eligible for class placement. To access this form a user will need to go on the CTDOT intranet, under Documents and Forms choose Engineering Applications and select Training Needs Evaluation. Fill the form out and click on the Submit by Email button at the bottom of the page.

Currently Available
CTDOT InRoads XM Basics – Volume I, Sections 1-9
CTDOT InRoads XM Update - Volume I, Sections 1, 3, 6-9

Future Courses
CTDOT InRoads XM Plans Production - Volume II
CTDOT InRoads XM Storm and Sanitary Layout Tools - Volume III, Section 12 and 13
CTDOT InRoads XM Storm and Sanitary Drainage Design - Volume III, Section 14…
CTDOT InRoads XM Quantity Manager- Volume IV
# Table of Contents

## Volume I - InRoads Basics

### Section 1  Orientation to InRoads

1.1 InRoads File Types .......................................................... 12
1.2 Resource File Storage Location ...................................... 14
1.3 Lab 1 - Starting the InRoads Application ......................... 15
1.4 InRoads Interface and Explorer Windows ....................... 17
1.5 Project Defaults ............................................................. 17
1.6 Lab 2 - Project Start Up ................................................. 19
   1.6.1 Using Automated Project Defaults ............................ 19
   1.6.2 Setting up the Project File ........................................ 20
   1.6.3 Defining Discipline Settings ..................................... 24

### Section 2  Surfaces

2.1 Types of DTM Display .................................................... 26
2.2 Features in the DTM ........................................................ 26
2.3 View Surface Tools ....................................................... 27
2.4 Lab 3 - View Surface Tools ............................................. 28

### Section 3  The Managers

3.1 Named Symbology Manager ........................................... 33
3.2 Style Manager ............................................................... 33
3.3 Symbology and Style Name Configuration ....................... 34
3.4 Lab 4 - Editing the Managers ........................................... 36
   3.4.1 Changing Feature Properties .................................... 36
   3.4.2 Setting Existing Symbology ....................................... 36
3.5 Preference Manager ....................................................... 38

### Section 4  Horizontal Alignments

4.1 Lab 5 - Using Horizontal Alignment Tools ....................... 40
   4.1.1 Displaying Toolbars ................................................ 40
   4.1.2 Placing and Revising PIs ......................................... 41
   4.1.3 Defining Curve Sets ................................................ 43
   4.1.4 Redisplaying the Active Alignment ............................ 45
   4.1.5 Saving the Geometry Project .................................... 45
4.2 Lab 6 - Annotating a Horizontal Alignment ....................... 46
   4.2.1 Import the HWY Horizontal Annotation Toolbar ............ 46
   4.2.2 Define Stationing .................................................... 47
   4.2.3 Display Stationing .................................................... 47
   4.2.4 Display Bearings ...................................................... 48
   4.2.5 Display Curve Data .................................................. 49
   4.2.6 Display Intersection Coordinates ............................... 51

### Section 5  Profiles and Vertical Alignments

5.1 Lab 7 - Working with Design Profiles ............................... 52
   5.1.1 Placing a Profile Window .......................................... 52
   5.1.2 Updating a Profile Display ........................................ 53
   5.1.3 Creating a Vertical Alignment .................................... 54
   5.1.4 Defining Vertical Curves ........................................... 56
   5.1.5 Annotating a Vertical Alignment ................................. 56

### Section 6  Template Library

6.1 The CTDOT Standard Highway Template Library ............... 59
   6.1.1 Folder Descriptions ................................................ 59
   6.1.2 Affixes ..................................................................... 63
   6.1.3 Point Names .......................................................... 64
   6.1.4 Component Names .................................................. 64
6.2 The Facilities Standard Template Library .......................... 65
   6.2.1 Folder Descriptions ................................................ 66
   6.2.2 Point Names .......................................................... 67
# TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.1</td>
<td>Lab 18 – Getting Started</td>
<td>143</td>
</tr>
<tr>
<td><strong>SECTION 13</strong></td>
<td><strong>LAYOUT TOOLS</strong></td>
<td>146</td>
</tr>
<tr>
<td>13.1</td>
<td>Lab 19 - Drainage System Layout</td>
<td>146</td>
</tr>
<tr>
<td>13.1.1</td>
<td>Placing Catch Basins</td>
<td>146</td>
</tr>
<tr>
<td>13.1.2</td>
<td>Placing Pipes</td>
<td>151</td>
</tr>
<tr>
<td>13.1.3</td>
<td>View Drainage Tool</td>
<td>153</td>
</tr>
<tr>
<td>13.1.4</td>
<td>Annotate Structures Tool</td>
<td>154</td>
</tr>
<tr>
<td>13.1.5</td>
<td>Edit/Review Tool</td>
<td>155</td>
</tr>
<tr>
<td>13.2</td>
<td>Structure Tools</td>
<td>155</td>
</tr>
<tr>
<td>13.2.1</td>
<td>Using the Structure Tools</td>
<td>156</td>
</tr>
<tr>
<td>13.2.2</td>
<td>User Data for Inlets</td>
<td>157</td>
</tr>
<tr>
<td>13.2.3</td>
<td>Modify to Existing Survey Styles</td>
<td>158</td>
</tr>
<tr>
<td>13.2.4</td>
<td>Viewing a Network</td>
<td>160</td>
</tr>
<tr>
<td>13.2.5</td>
<td>Annotating Network</td>
<td>161</td>
</tr>
<tr>
<td>13.2.6</td>
<td>Drafting Notes</td>
<td>162</td>
</tr>
<tr>
<td>13.2.7</td>
<td>Drafting Notes</td>
<td>165</td>
</tr>
<tr>
<td>13.3</td>
<td>Lab 21 - Viewing Drainage as Solids</td>
<td>167</td>
</tr>
<tr>
<td><strong>SECTION 14</strong></td>
<td><strong>DRAINAGE DESIGN</strong></td>
<td>169</td>
</tr>
<tr>
<td>14.1</td>
<td>Future</td>
<td>169</td>
</tr>
</tbody>
</table>

## VOLUME IV – INROADS QUANTITY MANAGER .......... 170

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SECTION 15</strong></td>
<td><strong>QM FILE MANAGEMENT</strong></td>
<td>171</td>
</tr>
<tr>
<td>15.1</td>
<td>Future</td>
<td>171</td>
</tr>
<tr>
<td><strong>SECTION 16</strong></td>
<td><strong>QM TOOLS</strong></td>
<td>171</td>
</tr>
<tr>
<td>16.1</td>
<td>Assign Pay Items</td>
<td>171</td>
</tr>
<tr>
<td><strong>SECTION 17</strong></td>
<td><strong>QM REPORTING</strong></td>
<td>173</td>
</tr>
<tr>
<td>17.1</td>
<td>Future</td>
<td>173</td>
</tr>
</tbody>
</table>
List of Figures

Figure 1-1 InRoads Resource Folder .........................................................................................14
Figure 1-2 Setting the MicroStation Platform ...........................................................................15
Figure 1-3 MicroStation Manager .............................................................................................16
Figure 1-4 Description of LOCKS Tools ..................................................................................17
Figure 1-5 InRoads Interface ....................................................................................................17
Figure 1-6 Project Defaults Automated Settings ......................................................................20
Figure 1-7 InRoads New Dialog Box .........................................................................................21
Figure 1-8 InRoads Save As Geometry Projects Dialog Box ......................................................21
Figure 1-9 InRoads Roadway Designer Creating a New File .....................................................22
Figure 1-10 InRoads Project Options Dialog Box .....................................................................23
Figure 1-11 InRoads Save As Projects Dialog Box ..................................................................24
Figure 1-12 InRoads Options Dialog Box ................................................................................25
Figure 1-13 InRoads Preferences Dialog Box ..........................................................................25
Figure 2-1 InRoads View Perimeter Dialog Box .......................................................................28
Figure 2-2 MicroStation View of InRoads Generated Perimeter .............................................28
Figure 2-3 InRoads View Triangles Dialog Box .......................................................................29
Figure 2-4 MicroStation View of InRoads Generated Triangles .............................................29
Figure 2-5 InRoads View Contours Dialog Box .......................................................................30
Figure 2-6 MicroStation View of InRoads Generated Contours .............................................30
Figure 2-7 InRoads View Feature Dialog Box ..........................................................................31
Figure 2-8 MicroStation View of InRoads Generated Features .............................................31
Figure 2-9 InRoads Update 3-D/Plan Surface Display ............................................................32
Figure 3-1 InRoads Named Symbology Manager .......................................................................33
Figure 3-2 InRoads Style Manager ............................................................................................34
Figure 3-3 InRoads Edit Style Dialog Box ................................................................................34
Figure 3-4 InRoads Top Left corner of the Advanced Tab - Surface Properties Dialog Box ....36
Figure 3-5 InRoads Copy Named Symbology Dialog Box .......................................................37
Figure 3-6 InRoads Preference Manager ..................................................................................38
Figure 4-1 MicroStation View of an InRoads Generated Alignment ........................................39
Figure 4-2 InRoads Horizontal Curve Set Toolbar .....................................................................40
Figure 4-3 Mainline Horizontal PI Point Locations .................................................................42
Figure 4-4 InRoads Define Horizontal Curve Set .......................................................................44
Figure 4-5 Side Road Horizontal PI Point locations ..................................................................45
Figure 4-6 InRoads HWY Custom Horizontal Annotation Toolbar ........................................47
Figure 4-7 InRoads View Stationing Dialog Box ......................................................................48
Figure 4-8 InRoads View Horizontal Annotation Dialog Box ................................................49
Figure 4-9 MicroStation View of InRoads Generated Bearings .............................................49
Figure 4-10 InRoads Curve Set Annotation Dialog Box .............................................................50
Figure 4-11 MicroStation Screen Shot of InRoads Generated Curve Data ................................50
Figure 4-12 MicroStation Screen Shot of InRoads Generated Intersection Dat .........................51
Figure 5-1 InRoads Create Profile Dialog Box .........................................................................53
Figure 5-2 InRoads Update Profile Dialog Box ........................................................................54
Figure 5-3 InRoads Add Vertical PI Dialog Box .....................................................................55
Figure 5-4 InRoads Define Vertical Curve Set Dialog Box ...............................................................56
Figure 5-5 MicroStation Screen Shot of InRoads Annotated Vertical Alignment.......................57
Figure 6-1 InRoads Highway Design Custom Template Library.................................................59
Figure 6-2 InRoads Point Properties Dialog Box.........................................................................60
Figure 6-3 Contents of HWY Misc Components Folder...............................................................61
Figure 6-4 View of HWY Pavement Template ............................................................................62
Figure 6-5 View of HWY Typical Section Template .................................................................63
Figure 6-6 InRoads Affixes Dialog Box........................................................................................63
Figure 6-7 View of InRoads Template with Typical Point Naming................................................64
Figure 6-8 InRoads Component Properties Dialog Box...............................................................64
Figure 6-9 Facilities Custom Template Library............................................................................65
Figure 6-10 Available Facilities Custom End Conditions ............................................................66
Figure 6-11 Available Facilities Custom Pavement Templates ....................................................66
Figure 6-12 Available Facilities Custom Typical Sections ...........................................................67
Figure 6-13 Available Facilities Custom Misc. Components .......................................................67
Figure 6-14 InRoads Template Options Dialog Box .....................................................................68
Figure 6-15 InRoads Template Library Organizer Dialog Box.....................................................69
Figure 6-16 InRoads Create Template Dialog Box Renaming a Template.....................................70
Figure 6-17 InRoads Dialog Box Merging Components ...............................................................71
Figure 6-18 InRoads Component Properties Dialog Box Renaming Components......................72
Figure 6-19 Typical Section for CT_Rdwy2 ..................................................................................72
Figure 6-20 InRoads Point Properties Dialog Box.......................................................................73
Figure 6-21 Location of Facilities Template Library "Project Library" Folder ................................74
Figure 6-22 InRoads Point Properties Dialog Box .......................................................................75
Figure 6-23 InRoads Test end Conditions Dialog Box .................................................................76
Figure 6-24 InRoads Edit End Condition Priorities Notification ................................................77
Figure 6-25 InRoads Fix Priorities Component .............................................................................77
Figure 7-1 InRoads Roadway Designer Dialog Box .....................................................................79
Figure 7-2 InRoads Template Drops Dialog Box.........................................................................81
Figure 7-3 InRoads Edit Transition dialog box ............................................................................83
Figure 7-4 InRoads Edit Transition Midpoint Dialog Box.............................................................84
Figure 7-5 InRoads Create Surface Dialog Box ...........................................................................87
Figure 7-6 InRoads Surface Properties Dialog Box .....................................................................88
Figure 8-1 InRoads Superelevation Tables ..................................................................................90
Figure 8-2 View of Superelevation overlap ...............................................................................94
Figure 8-3 View of Superelevation with no overlap ...................................................................94
Figure 8-4 InRoads Report Browser Superelevation Report ..........................................................95
Figure 8-5 No Roll Over Defined ...............................................................................................96
Figure 8-6 Using Roll Over Locks ..............................................................................................97
Figure 9-1 InRoads Create Cross Section Dialog Box .................................................................99
Figure 9-2 InRoads End-Area Volumes Dialog Box ....................................................................100
Figure 9-3 Report Browser Message ..........................................................................................100
Figure 9-4 InRoads Report Browser Evaluation Folder ...............................................................101
Figure 9-5 InRoads Report Browser Basic End Area Report .......................................................101
Figure 9-6 MicroStation Screen Shot of InRoads Generated Cut and Fill ..................................102
Figure 9-7 InRoads Update Cross Section Dialog Box ...............................................................103
Figure 10-1 InRoads Plan and Profile Generator Main Tab ..........................................................108
Figure 10-2 InRoads Plan and Profile Generator Plan Controls Tab ............................................109
Figure 10-3 InRoads Plan and Profile Generator Sheet Layout Tab ............................................... 110
Figure 10-4 InRoads Plan and Profile Generator - Borders and Title Tab ........................................ 111
Figure 10-5 InRoads Plan and Profile Generator Sheet Index Tab .................................................... 112
Figure 10-6 InRoads Create Profile - Sheet Production ................................................................... 115
Figure 10-7 InRoads Plan and Profile Generator - Profile Controls Tab .......................................... 116
Figure 10-8 InRoads Place Plan Note Dialog Box ........................................................................... 119
Figure 10-9 InRoads Curve Set Annotation Dialog Box ................................................................. 120
Figure 10-10 Text Symbology for Curve Data ............................................................................... 121
Figure 10-11 Curve Set Annotation Advanced Tab ........................................................................... 122
Figure 10-12 InRoads View Vertical Annotation Dialog Box ......................................................... 124
Figure 10-13 InRoads Place Profile Note Dialog Box ....................................................................... 125
Figure 10-14 InRoads Update Profile Dialog Box ............................................................................ 127
Figure 10-15 InRoads Annotate Feature in Profile Dialog Box ....................................................... 128
Figure 10-16 InRoads Annotate Feature in Profile Dialog Box ....................................................... 128
Figure 11-1 Create Cross Section - Sheet Creation ........................................................................... 134
Figure 11-2 InRoads Annotation Cross Section Dialog Box ............................................................ 137
Figure 11-3 InRoads Annotate Cross Section Dialog Box – Right side of road ............................... 138
Figure 11-4 InRoads Annotate Cross Section Dialog Box – Left side of road ................................ 138
Figure 11-5 MicroStation View of InRoads Annotated Cross Section ............................................ 139
In general, InRoads XM provides Civil Engineering tools for road and corridor design. The following design functionalities include:

- Road, runway, taxiway and site modeling capabilities
- Alignment tools
- Typical sections
- Superelevation
- Volume and quantity computations
- Storm Drainage Structure layout
- Processing of Survey Data
- Plan Sheet Production tools

InRoads can be considered a toolbox containing an assortment of tools. Each tool has a specific function. When individual tools are combined and used in a particular order, it is called a workflow. Workflows are used to accomplish a specific project-related task. Examples of workflows can be found in each lab in this guide.

MicroStation is the platform application which allows InRoads data to be displayed. Thus, both MicroStation and InRoads applications work together to provide users with CAD functions. For example, InRoads uses MicroStation files to display CAD graphics for a Horizontal Alignment. A CAD file can be a design model and/or a sheet model (final plan sheet). This guide will outline the InRoads commands that are available to view, display and present InRoads design data in CAD files.
Section 1  Orientation to InRoads

1.1 InRoads File Types

The InRoads road design process uses several different file types. All InRoads data is stored in external files. The CAD file is used to view a graphical representation of the design data, but the graphics files do not store the InRoads Data. For example, if the graphics that represent the horizontal alignment are deleted, the InRoads geometry file is not modified.

The following InRoads resource files have been configured for the XM 2007 Environment:

**Preference File (*.xin)** - This file contains the control settings of all the dialog boxes within InRoads. The settings for surface, geometry and survey tools have all been confined to one .xin file, replacing the previous two .ini files, .fxp and .fwf files. This is the main source of standardization where all InRoads design and graphical output are configured to meet CTDOT standards.

**Template Library (*.itl)** – This file contains a storage area for typical sections. A template is comprised of a series of points and components that represent breakline features. These are processed later using the Roadway Designer command. Roadway features that have been processed are then saved to the design surface. CTDOT has two standard .itl files; one for roadway use and the other for airport taxiway and runway uses.

**Style Sheet (*.xsl)** - All style sheets have been provided by Bentley and are located on the local hard drive, in the Inroads directory under Civil/XML Data. The View XML Reports command allows users to select an .xsl style sheet, which specifies the exact information to pull from the .xml file and how to format it. To further clarify, the .xml file contains raw or computed data; the .xsl file specifies how to format the data into a report.

**Drafting Notes (*.dft)** - This file is used to enhance the production of final drawings. Use the commands across the design session to place intelligent annotation notes on features and geometry, in the plan, profile, and cross section views, as well as at the intersection of two alignments.

**Pay Items (*.mdb)** - This file is used with Quantity Manager. Quantity formulas and CTDOT pay items are stored in this Microsoft Access database.

**Drainage Structures (*.dat)** - This file is used with InRoads Storm and Sanitary. This file has been configured with CTDOT standard drainage structure information, including sizes, shapes, materials, and many other parameters.

**Rainfall Table (*.idf)** - This file is used with InRoads Storm and Sanitary. This file contains a table of Rainfall/Time of Concentration data that conforms to CTDOT drainage standards.
The following InRoads files need to be created for the project design:

**Projects (*.rwk)** - This file contains directory and file information for loading and saving InRoads data files. Once the project file is open, all of the specific project files are also opened.

**Roadway Design (*.ird)** - This file contains roadway model definitions. This file stores station and typical section information used by the Roadway Modeler command to create surface models along alignments. The Roadway Design (*.ird) is also the storage location for the superelevation design data.

**Surfaces (*.dtm)** - A Digital Terrain Model (DTM) file is a surface where existing ground and design terrain surface models are stored.

**Geometry Projects (*.alg)** – This file contains coordinate geometry and alignment information for a specific geometric project.

**Survey Data (*.fwd)** – This InRoads Survey Fieldbook data file is created by importing survey data from a field data collector.

**XML Data (*.xml)** - The XML Reports command, available as an application add-in under Tools on the pull down menu, generates XML data files. The XML files are not reports, but contain data that can be formatted into reports by using the View XML Reports command. XML data files are ASCII files that are not formatted as a report for direct viewing. A report is the output generated when users display data from an XML file using the View XML Reports command.

**Quantity Manager (*.mdb)** – This file contains a database of quantity information for a project.

**Drainage (*.sdb)** – This InRoads Storm and Sanitary file is where the project storm drainage design information is stored. This includes type and locations for catch basins, manholes and pipes.
1.2 Resource File Storage Location

The latest versions of all XM resource files will be kept in the workspace under \CTDOT_Standards\InRoads_XM_RSC. Before starting an InRoads project, copy the necessary files from the workspace into the designated folder. Resource files for Highway Design users are copied into the Highway discipline folder within the project container. Resource files for Facilities Design users are copied in the Facilities/Civil discipline folder within the project container. Resource files for Surveys are in the local directory under Bentley_V8, to improve the processing performance of the data.

The InRoads_RSC folder is still provided for legacy projects that use InRoads Version 8.5. Please refer to the 2007 DDE Manual for the resources provided in this folder. The InRoads_XM_RSC folder holds all of the resource files needed to run InRoads XM, Version 8.9. Figure 1-1 displays the subfolders for the resource files for InRoads 2004 Edition as well as the InRoads XM Edition.

![Figure 1-1 InRoads Resource Folder](image)
1.3 Lab 1 - Starting the InRoads Application

Before starting this lab make sure the MicroStation Workspace is mapped. For CTDOT users do the following if the W drive is not mapped.

- Open Windows explorer
- Select Tool > Map Network Drive
- Change Drive: to W and select Browse
- Select Conndot_01 > SH3dgs18 > CTDOT_V8_Workspaces and click on the OK button
  On the Map Network Drive Dialog Box select the Finish button

A. In Windows Explorer, browse to the workspace folder
   CTDOT_Standards\InRoads_XM_RSC\ XM_2007_Environment. Copy the following files in this to the project folder (e.g.999_Student##_2007\Highways\Eng_Data\InRoads or \999_Student##_2007\Facilities\Civil\eng_data).

   **Highway Users**
   - CT_civil.XIN
   - CT_items.mdb
   - CT_notes.dft
   - CT_rainfall.idf
   - CT_structures.dat
   - HW_typicals.itl

   **Highway Users**
   - HW_typicals.itl (copy for lab exercise only)

   **Facility Civil Users**
   - CT_civil.XIN
   - CT_items.mdb
   - CT_notes.dft
   - CT_rainfall.idf
   - CT_structures.dat
   - FAC_typicals.itl

B. From the windows start button, Select Programs > Bentley > InRoads Group XM. Data Point “Select CAD Platform” (see Figure 1-2).

C. Select MicroStation XM and click the OK Button.

![Figure 1-2 Setting the MicroStation Platform](image-url)
D. From the Accounting Menu, run the program **IR 89 Highways**. In the bottom right corner of the MicroStation Manager, select the project number (e.g. 999_Student##_2007). Browse to the Highway/MSta_Design folder and open the file **HW_InRoadsXM.dgn**

E. Create a new Interface and User if one does not exist for you already. Create the Interface first then the User. The name you input should match your Windows login exactly, this is case sensitive.

F. (see Figure 1-3). MicroStation XM and InRoads XM will automatically start up when the design file opens.

![Figure 1-3 MicroStation Manager](image-url)
1.4 InRoads Interface and Explorer Windows

When the InRoads application is opened, the InRoads Explorer, which contains a main menu bar and two windows for viewing and manipulating active data files and their contents, will appear. All InRoads commands are located on the main menu bar. Tool bars can be activated for quick access to the different commands and dialogs. If users right click on the gray space to the right of the InRoads main menu help, a shortcut to the LOCKS tool bar can be created. In order to activate this tool, click on locks and then go to the Customize dialog where all tool bars are listed. The lock tools are shown in Figure 1-4. Note that the common settings are in bold letters, such as ON or OFF.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Highlight Lock ON</th>
<th>Style Lock OFF</th>
<th>Pencil or Pen Mode</th>
<th>Delete Ink Lock OFF</th>
<th>Graphics or Features</th>
<th>Point Element No Snap</th>
<th>Station Lock ON</th>
<th>Report Lock OFF</th>
</tr>
</thead>
</table>

Figure 1-4 Description of LOCKS Tools

The left window, the Workspace Bar, contains a listing of active data. In Figure 1-5 the Geometry Project information is listed. The red square near the + symbol indicates the active Geometry Project. A right mouse click on geometry listed in the Geometry window will activate a shortcut dialog with options to Save, Copy, set Active, etc. Tabs at the bottom of the window allow users to toggle to the different data files types (i.e. Surface Data, Template Library File etc.) that are loaded with the project.

![Figure 1-5 InRoads Interface](image)

The right window displays information about data contained in the geometry project. In Figure 1-5 there are two (2) horizontal alignments listed and the COGO buffer. Again, the red square indicates the active horizontal alignment. The importance of active data will become more apparent in later sections of this manual. Each horizontal alignment has a name and description. As the scope and volume of data for each project increases, the description becomes more important. Therefore, all alignments should have meaningful descriptions.

1.5 Project Defaults
An organized work environment along with a standardized file management system provides a consistent way to maintain digital design data. These measures decrease the chance that users will create and/or work with incorrect InRoads files. Along with a standardized file management system, InRoads provides a way to set up project defaults and create a project file for each project. This in turn, allows users to work with the correct preferences and data files which are essential to project design. To ensure file integrity, the correct project files must not only be used, but also maintained and updated. InRoads users must master file management techniques for all InRoads design and data files. File management also eliminates the creation of multiple copies of the same file. Therefore, a standardized file management system greatly increases productivity by ensuring the availability of correct InRoads files and eliminating duplicate files.

By setting up the project defaults and creating a project file, users can quickly load all files needed for project design. Additionally, the project file helps coworkers load and analyze current design data. The Project Defaults command is used to open resource files including the preferences file (.xin), Storm and Sanitary files, drafting file, and the master item database. This command is also used to set up default directories for all file types that can be accessed through the File/Open and File/Save As dialog boxes. These include Project (.rwk), Surface (.dtm), Geometry (.alg), Typical Section Library (.itl), Roadway Design (.ird), Survey Data (.fwd), Storm and Sanitary (.sdb) and Quantity Manager (.mdb). All other files, which are opened or saved throughout the InRoads program, use the Project Default Directory setting. The project default file directories are stored in the computer’s registry on the local hard drive.

The following two methods, automated method and conventional method, can be used for setting up project defaults:

- **The automated method** based on variables, only has one configuration name. Files are opened and paths are driven by the project users select when opening MicroStation. Users can set a windows system environment variable to define a project working directory. Use Project Defaults to set the variable name using the syntax, $(variable) or %variable%.

- **The conventional method** allows each project to have its own Configuration Name based on hard-coded paths. When a particular configuration is saved and users exit the dialog, that configuration is remembered as the "Current" configuration. The next time InRoads is accessed all the directory paths are set according to the last configuration used. If the project has been changed, users will need to select the corresponding project configurations. This means a configuration name will be needed for every project that the user is working on.

A. Click to File-Project Defaults on the InRoads Main Menu.

B. Click on the New button and a new dialog box will appear type in a name for the configuration, click OK to save and close the box

C. Click the curser in the Preferences (*.xin) box and click the Browse button. The Open box will appear. Browse to the location of the CT_civil.xin file, click Open, Repeat for Drainage Structures, Drafting Notes and Pay Items.

D. Set Default Directory Paths, click the curser in the Project Default Directory and click the Browse button. The Open box will appear. Browse to the location of the InRoads project will be stored, Click Open.
E. Repeat for all other paths. With the exception on Style sheet.
F. For style sheet browse to C:Bentley_V8\civil\XML Data (or where InRoads is installed)
G. Save the configuration, Click the Apply button, then click the Close button.

The Projects File (*.rwk) is composed of a list of files that pertain to a specific project’s design data. Surfaces, a template library, geometry projects, a roadway library can all be saved to the projects file. When saving project files, the InRoads program places the entire path name in the .rwk file. If any of the files are moved, the .rwk file is invalid. Whenever the .rwk file is loaded, the software looks for the associated files in the same directory that the .rwk resides.

1.6 **Lab 2 – Project Start Up**

The second lab in this section, Lab 2, takes users through a series of steps to create an InRoads Project. Part of the process is setting up the project defaults, the Project File (.rwk), geometry (horizontal and vertical alignments), and surface models. By following these steps every time an InRoads project is created, users ensure that the proper files and settings are used throughout the design-life of a project.

1.6.1 Using Automated Project Defaults

A. Click to **File > Project Defaults** on the InRoads Main Menu.
B. Click on the Import... Button and browse to the workspace folder under CTDOT_Standards\InRoads_XM_RSC and select the reg file **Highway_XM.reg**

Note: When setting up a design, a user must select the .reg file that corresponds to the discipline (Highway_XM.reg or Consultant_XM.reg). It is important to select the correct file in order to get the correct subfolder paths.
C. To save the configuration, Click the Apply button, and then click the Close button.

Note: The code $(CT_DIRPATH) will inherit the project the user selects when starting MicroStation. To check to make sure the correct files are opened click on the Preference Tab as shown in Figure 1-6.
1.6.2 Setting up the Project File

A. Click to **File>Open** on the InRoads Main Menu. Change the Files of type to *.itl and select **HW_typicals.itl**. Click Open and then **Cancel**.

B. Click to **File>Open** on the InRoads Main Menu. Change the Files of type to *.dtm. Browse to the projects survey folder and click on the needed dtm. Click **Open** and then **Cancel**.

C. Click to **File > New** to create a name your geometry project. This command shown in Figure 1-7 does not create an actual file it only creates an internal name for the Geometry Project.

D. Click on the **Geometry** tab and type **Geometry_Project** in the name box. Click **Apply**

E. Change Type to Horizontal Alignment and type **Roadway_1**, set Style: AAA_CENTERLINE, Curve Definition: Arc, Click **Apply**

F. Change Type to Vertical Alignment and type **Roadway_1**. Style: AAA_CENTERLINE Curve Definition: Parabolic, Click **Apply**

G. Change Type to Horizontal Alignment and type **Roadway_2**. set Style: AAA_CENTERLINE, Curve Definition: Arc, Click **Apply**

H. Change Type to Vertical Alignment and type **Roadway_2optA**. Style: AAA_CENTERLINE, Curve Definition: Parabolic Click **Apply**

I. Change Type to Vertical Alignment and type **Roadway_2optB**. Style: AAA_CENTERLINE Curve Definition: Parabolic, Click **Apply**.
J. Create and Save the .alg (Geometry Project) file. Click to **File > Save > Geometry Project** on the InRoads Menu Bar. Click on the geometry name to save in the Active space and then the File name will appear in the File Name Box. Click **Save**, and then after the file is saved, click **Cancel**. See Figure 1-8.

K. Create and Save the .ird (Roadway Designer) file. Click to **Modeler > Roadway Designer...** on the InRoads Menu Bar. In the roadway designer choose **File > New** as shown in Figure 1-9 and input **Roadway.Designer** in the File Name field. Click **Save**, **Cancel** and Close the Roadway Designer.
Figure 1-9 InRoads Roadway Designer Creating a New File
L. Save files in the RWK (Project). Click to **File > Save > Project** on the InRoads Main Menu. Click the **Options (…)** button on the lower right corner of the Save As dialog box. The Project Options dialog box (Figure 1-10) will appear. Check **Add and Update** and click on each file under file name for all the files listed under each tab. When the Surfaces tab appears, only click on Add for the Existing surface. (Proposed surfaces will be created later in the design process. These files will need to be checked off under Add and Update columns).

![Figure 1-10 InRoads Project Options Dialog Box](image)

M. Click the **OK** button and the Project Options dialog box will close.
N. On the Save As dialog box (Figure 1-11) data point in the File name field and type in the name of the file e.g. **Project_File**. Click the **Save** button and then click **Cancel**.

![Figure 1-11 InRoads Save As Projects Dialog Box](image)

Note: After running the Roadway Designer and creating the proposed surfaces, these surfaces will need to be saved as .dtm(s) and added to the .rwk. See sections 7.3.3 Saving the Design Surface and 7.3.4 Project File Update for instructions.

1.6.3 Defining Discipline Settings

A. From the InRoads Menu Bar select **Tools < Options**. See Figure 1-12.

B. Select the **Preferences** Button and data point on the required discipline name. Select **Load** and **Close**. See Figure 1-13

C. Select the **General Tab**. In the **Preferred Preference Name** box select the required discipline name. See Figure 1-12

D. Data point on the **Apply** and **Close**.
Figure 1-12 InRoads Options Dialog Box

Figure 1-13 InRoads Preferences Dialog Box
Section 2  Surfaces

A computerized model of a 3-D ground surface is a visual representation of point data. This data, in x,y,z numerical coordinates, defines the Digital Terrain Model (DTM), also commonly referred to as a surface.

In InRoads, the DTM remains an integral and important part of a project. Feature data resides in the DTM and can be displayed in plan, profile and cross section view. Design analysis and computations are performed on the data in the DTM. The Surface tools allow users to place features, execute commands, view surface properties, and make design modifications to the design surface.

2.1 Types of DTM Display

In the InRoads project, surface representation and features can be displayed in three different Views or modes: 3-D Planimetric, Profile, and Cross Section.

- 3-D planimetric view, commonly referred to as plan, is a top-level aerial view of the entire surface. This view allows users to see any of the point types (random, breakline, contour, and so on) in the digital terrain model.
- Profile is an extracted side view of the vertical elevation of a surface along an entire active horizontal alignment (or just a portion of it). A legend, correlating surface line symbology, surface name and the scale used on the profile, can also be displayed.
- Cross Section is a portion of the roadway model at a specified location. Displayed in individual graphic windows, each section shows surface configurations perpendicular or at a skew angle to linear feature, such as the horizontal alignment (often the centerline of the roadway). Cross sections differ from profiles in that they show detailed sections of the surfaces, from one station to the next transverse to an alignment; profiles show surface elevations longitudinally along an entire alignment.

Together, these display modes allow users to view, evaluate, and design projects from various important perspectives. Objects in the DTM can be represented in one view or all of these views.

2.2 Features in the DTM

In InRoads, features are important to the design process. A feature is a unique instance of an item or 3-D entity that is represented in the DTM by lines, points, or text. A line is actually a linear segment. Points can be represented as symbols or cells. Annotation is considered text. The following are examples of common road design features:

- A single random point
- A single interior boundary
• A flowline
• A single curb line
• A single utility (pipe, pole, manhole)
• A collection of utilities (poles, manholes)

Therefore, a feature is any single component that is part of the DTM. Further, for features such as random points, users can store more than one random point feature type in a DTM. This flexibility allows users to control the display of the random points in the surface separately from other features, such as manholes.

In InRoads, features can be created or imported into the DTM with a level of “intelligence”. In other words, features know to display themselves as features in InRoads. Once features are defined or modified and displayed, they can be annotated within the design file.

2.3 View Surface Tools

InRoads provides users with display options for viewing DTMs, triangles, contours and features. The ability to display these design features allows users to visualize specific aspects of their designs with simple commands.

**View Perimeter**
The View Perimeter command displays the outermost edge of a triangulated digital terrain model. This command is very helpful for visualizing the boundaries of the triangulated model and for fitting the surface to the viewing screen so that you can see the results of subsequent commands.

**View Triangles**
The View Triangles command displays all or a portion of the triangles contained within the active surface. The software displays the triangles that are created when the model is triangulated. This command is used to help evaluate a model and pinpoint areas that either have too many or too few points.

**View Contours**
The View Contours command generates and displays elevation contours for the active surface. This command automatically generates major and minor contours, depression contours, and contour labels in the drawing. Major contours are contour lines that display at a specific elevation interval. Minor contours display a specified number of times between each major contour. These two types of contour lines work together to help users better visualize a surface.

**View Features**
The View Features command displays surface features in plan view, including breaklines, random points, interior boundaries, etc. The feature style associated with each feature determines whether or not the feature can be displayed in plan view and the type of symbology to use to display the feature.

The shapes representing the actual points are displayed as single characters at the exact x,y,z locations of the point. Additionally, for linear features (breakline features, contour features, interior features, and exterior features) the command can display line segments connecting the individual points that make up each of these features.
2.4 Lab 3 - View Surface Tools
Before starting this lab the **SV_Surface.dtm** file will need to be opened if it is not already.

This lab shows InRoads users how to use the different viewing tools to display surface data including the perimeter, triangles, Contours and Contour Elevations.

A. Make sure the style lock is off. The style lock will allow the dialog box to appear.

B. On the InRoads Main Menu Bar click on **Surface>View Surface >Perimeter** (Figure 2-1).

![View Perimeter Dialog Box]

C. Click on the Preference button, select the name **Survey, Load** and **Close**.

D. In the View Perimeter Box for Surface: select existing. Then click the **Apply**. In Figure 2-2, notice the line surrounding the roadway, this is the limit of the existing surface.

![MicroStation View of InRoads Generated Perimeter]
E. On the InRoads Main Menu Bar click on **Surface>View Surface> Triangles** (Figure 2-3).

![Figure 2-3 InRoads View Triangles Dialog Box](image-url)

F. Click on the Preference Button, select the name Survey, click **Load** and **Close**.

G. In the View Triangles Box for Surface: select existing. Then click the **Apply** button. In Figure 2-4, notice the triangles surrounding the roadway.

H. Using MicroStation tools with graphic group on, delete display of the perimeter and triangles.

![Figure 2-4 MicroStation View of InRoads Generated Triangles](image-url)
I. On the InRoads Main Menu Bar click on **Surface > View Surface > Contours** (Figure 2-5).

![Figure 2-5 InRoads View Contours Dialog Box](image)

J. Click on the Preference Button, then select the name Survey. Click **Load** and **Close**.

K. In the View Contours Box for Surface: select existing. Then click the **Apply** button. Notice the contours within the ground file (Figure 2-6).

![Figure 2-6 MicroStation View of InRoads Generated Contours](image)
L. Using MicroStation tools with graphic group on delete display of the contours.

M. On the InRoads Main Menu Bar click on **Surface > View Surface > Features** (Figure 2-7).

N. Right Click over the Features in the interface window and data point on **Select All** and click **Apply**. Figure 2-8 shows all the features in an existing DTM.

![Figure 2-7 InRoads View Feature Dialog Box](image1)

Figure 2-7 InRoads View Feature Dialog Box

![Figure 2-8 MicroStation View of InRoads Generated Features](image2)

Figure 2-8 MicroStation View of InRoads Generated Features
O. On the InRoads Main Menu Bar click on Surface>Update 3-D/Plan Display (Figure 2-9). This display dialog box allows users to display on or display off the Perimeter, Triangles, Contours and Features in your file. Note: There are other functions within this dialog box that will not be covered in this lab.

![Figure 2-9 InRoads Update 3-D/Plan Surface Display](image)

P. For Mode Select Display Off, right click over the features in the interface window and data point on Select All and click Apply.

Q. Click Close the Update 3-D/Plan Display dialog box.

R. Click Close the View Features dialog box.
Section 3  The Managers

3.1 Named Symbology Manager

The Named Symbology Manager (Figure 3-1) allows users to define their symbology settings (line style, weight, color and so on) for features and annotation. These settings, along with many other preference settings, are stored in the .xin preference file. This file has been customized to adhere to CTDOT standards.

![Named Symbology Manager](image)

Figure 3-1 InRoads Named Symbology Manager

3.2 Style Manager

The Style Manager (Figure 3-2) accommodates surface, geometric and survey features. A style describes how and where a feature will display. A feature style is assigned to individual features to determine whether points, line segments, or annotation for that feature can be displayed in plan view, in cross sections, or in profiles. Each feature style is linked to a name in the Named Symbology Manager. Once defined, the style is one-to-many; meaning any one style can be used to display many features. For example, a style for centerline could be used for both the roadway centerline as well as for any other secondary road centerline. When users select Style Manager from the Tools menu, all predefined CTDOT styles in the preference file are displayed. Figure 3-3 displays the options available for editing a Style.
3.3 Symbology and Style Name Configuration
The CTDOT XIN InRoads preference file uses the following naming conventions for symbology and styles:

**CT_Working** – Working Symbology (not used in final cut sheets)

**P_ALG** – Proposed Geometry

**P_COMP** – Proposed Components

**P_DRAIN** – Proposed Drainage (Storm and Sanitary)

**P_RDWY** – Proposed Linear Roadway Features

**P_SFTY** – Proposed Safety Features

**P_SHT** – Proposed Sheet Annotation and Set up

**P_SUB** – Proposed Sub-layer Roadway Linear Features

**P_SURF** – Proposed Surface Modeling Info

**SURVEY** – Existing Features (all caps, no under bar)
3.4 **Lab 4 – Editing the Managers**

Before starting this lab the **SV_Surface.dtm** file will need to be opened if it is not already.

### 3.4.1 Changing Feature Properties

A. Go to **Tools > Style Manager**

B. Scroll down to the Feature named **STREAM** and double click on this Feature style. This will open the **Edit Feature Style Box**.

C. Select the **Surface** folder and choose **settings**

D. Check on **Project Line Segments, Projected Points, Crossing Points, and Annotation** in the Profile Display area of the Dialog Box.

E. Click **Apply** and **Close** on the Edit Feature Style Box.

F. Click **Close** on the Feature Style Manager Box. By editing this feature, users will be able to display it in the vertical profile in future labs.

### 3.4.2 Setting Existing Symbology

A. On the InRoads Main Menu Select **Surface > Surface properties**. Select the **Advanced** Tab (Figure 3-4). Write down what appears in the cross Section field “Symbology:”, this field is case sensitive.

![Surface Properties Dialog Box](image)

**Figure 3-4 InRoads Top Left corner of the Advanced Tab - Surface Properties Dialog Box**

B. Go to **Tools > Named Symbology Manager**

C. Data point on the name **EXISTING** and select the **Copy** button. Type in the word **existing** in lower case as shown in Figure 3-5.

D. Click **Apply** and **Close** on the Copy Named Symbology Dialog Box. Note: The symbology name has to match symbology name given by the survey unit, and may vary for each project.
Figure 3-5 InRoads Copy Named Symbology Dialog Box
3.5 Preference Manager

The **Preferences Manager** (Figure 3-6) has been set up for the Highways, Facilities and Survey disciplines. This allows one .xin to be used by all units. Section 1.6.3 Defining Discipline Settings describes how to set the preferred preference when starting a project. The dialog box shown in Figure 3-6 was used to save the control settings on the dialog boxes to CTDOT standards. Users can load and access these settings during a design session.

![Figure 3-6 InRoads Preference Manager](image)
Section 4  Horizontal Alignments

This chapter will discuss various horizontal alignment commands that are available in InRoads. In this section, users will create horizontal alignments and annotate the alignments to CTDOT standards. Horizontal alignment data and vertical alignment data is stored in the Geometry Project (.alg). In Section 1.6.2, the process of creating a Geometry Project and naming a Horizontal Geometry was explained. One horizontal alignment can reference several vertical alignment options. But only one alignment, the active alignment, can be manipulated within a project at a single time.

In general, the basis for roadway design is the horizontal control geometry. A major part of the roadway design process is to define the straight and curved sections in the roadway. Often the horizontal geometry is the center or crown of the road. It is important to note that horizontal geometry affects the speed and safety of a roadway design. Therefore, the roadway design is tied to horizontal control geometry.

Proper engineering design of roadways is important and should follow state and federal guidelines. The Connecticut Department of Transportation Highway Design Manual and the AASHTO Geometric Design of Highways and Streets are the main sources for Engineering Design References. For most standard CTDOT roadway designs, the PI method for the layout of horizontal geometry is most often used. This method involves identifying the horizontal tangent line at the Point of Intersection (PI). The original ground survey drawing is used as a reference for locating existing geometry tangents and the PIs to tie in to. Figure 4-1 shows an example of three (3) tangent lines defined by four (4) PIs. PI–1 defines the Point of Beginning (POB) on this alignment, while PI -2 is a true point of intersection. These four points were defined using the insert PI command. Note: This next lab (Lab 5) will focus on the basic InRoads tools used to layout horizontal control geometry.

Figure 4-1 MicroStation View of an InRoads Generated Alignment
4.1 Lab 5 – Using Horizontal Alignment Tools

Before starting this lab the Geometry_Project.alg file will need to be opened if it is not already. If this file does not exist, is empty, or not complete open the file Completed_Naming.alg.

The exercises in Lab 5 are intended to familiarize users with the horizontal alignment tools available in InRoads. Users will learn how to place and revise PIs within a design, define curve sets, annotate the horizontal alignment, and use the various display settings.

4.1.1 Displaying Toolbars

A. Click on Tools > Customize. On the Toolbars Tab, toggle to the Horizontal Curve Set, Vertical Curve Set and Locks. Click on Close and dock them in a logical place on the InRoads Dialog box. Figure 4-2 shows the different horizontal design tools available on the toolbar.

Figure 4-2 InRoads Horizontal Curve Set Toolbar
4.1.2 Placing and Revising PIs

A. On the Locks toolbar, toggle Pen/Pencil to Pencil. Toggle on Report and Station locks and set the Point/Element toggle to No snap.

B. In MicroStation Turn ON the survey original ground reference file and window to the beginning of the project.

C. To modify an alignment, it must be made the active alignment. Select Geometry > Active Geometry. Change the Type field to Horizontal Alignment. Select the alignment Roadway_1 from the available list, and then click Apply. This will make the alignment Roadway_1 active for editing. Click Close. Another method is to right click in the Alignment to be activated in the workspace bar and choose Set Active.

D. Select Geometry > Horizontal Curve Set > Add PI.

E. For setting the PI-1, data point on the center of the existing roadway at the beginning of the project. Then data point to accept the point. Note: Always read and follow the MicroStation prompts at the bottom left corner of the application. (See Figure 4-3 for location of PIs.)
Figure 4-3 Mainline Horizontal PI Point Locations
F. After accepting PI-1, users will automatically be asked to select the next point. A dynamic display of the geometry tangent should follow the curser to the next point. Following the point placement on the previous page, data point and accept the location of PI-2. Note: PI-2 is not on the roadway centerline, rather it is where the first tangent will intersect the second tangent. It is not critical that PIs be placed exactly in the proper position on the first attempt. PIs can be moved to best fit a design.

G. Continue to work along the project by data pointing and accepting PI locations similar to what is shown in Figure 4-3.

H. It is a good practice to delete the graphics generated after creating geometry, and then redisplay the alignment elements. This will ensure that the saved alignment is the same as what is shown on the screen. Do not assume that the graphical elements shown on the screen are the same as what is in memory. If uncertain, redisplay the alignment elements. To redisplay the geometry, Select > Geometry > View Geometry > Active Horizontal.

I. The process for creating the horizontal geometry can be iterative. In some cases, the POB of the alignment then the POE (Point of Ending) are placed before any other PI points. The sequence for placing points does not matter. Try the tools below, place points where they seem reasonable, then insert and move points to get the desired alignment.

- Insert PI - Use this command to insert a PI between two existing PI locations. Select Geometry > Horizontal Curve Set > Insert PI (read and follow the MicroStation command line readout).
- Move PI - Use this command to move a PI that existing in the active alignment. Select Geometry > Horizontal Curve Set > Move PI.
- Delete PI - Use this command to delete a PI that exists in the active alignment. Select Geometry > Horizontal Curve Set > Delete PI.

J. When done trying out the commands in Step I, revise the alignment back to what is shown in Figure 4-3. Use Redisplay geometry, Select > Geometry > View Geometry > Active Horizontal.

4.1.3 Defining Curve Sets

When a PI is placed, there is no curve associated with it; rather it is just a straight element. When the PIs are in place, the curve can be added. To place a curve set between two straight elements, use the Define Curve command.

A. Select Geometry > Horizontal Curve Set > Define Curve. The Define Horizontal Curve Set dialog box appears and the first horizontal PI is listed in the dialog box.

B. There are several options on the Define Horizontal Curve Set dialog box. Figure 4-4 shows this box, and at the bottom notice the next > Last and Select curve navigation buttons. If users click the Next > button, all of the PI points will be displayed for the alignment. With the MicroStation view, each PI tangent set is highlighted as each curve becomes the active curve.
C. In the bottom portion of the Define Horizontal Curve Set dialog box, above the curve navigation buttons, is the Define By: option. Select the Radius option.

D. Set the Leading Transition to Clothoid, enter 0 in the key-in field, and TAB to the next field.

E. Set the Curve Set Type to SCS. Set the Define Transition By: to Length. Go to the First curve set in the horizontal alignment. Notice that the curve radius is set to 0.00 if it has not been changed. Enter in a 500 foot curve radius for the project. Click the TAB key to enter the data. Then click the Apply button. The curve should dynamically display the curve radius on the screen. If the radius is too large, the software will not accept it and will notify the user for a solution overlap.
F. Click **Next**. This will set the dialog box to the next PI. Select Radius 1, and key in **500**. Click **Apply**.

G. Make Roadway_2 active and place horizontal alignment for Perry Lane. Select the **Add PI** tool and in MicroStation choose the **Near Snap Point**. Add the following PIs and radius:
- PI-1 on the Roadway_1 alignment near the 24” Maple Tree,
- PI-2 on top of 15 for 15” RCP
- PI-3 Near the G in Gravel
- Input a 200 foot curve radius

The results of this exercise are shown in Figure 4-5.

4.1.4 Redisplaying the Active Alignment
To redisplay the alignment, select **Geometry > View Geometry > Active Horizontal**.

4.1.5 Saving the Geometry Project
Save the edited geometry by selecting **File > Save > Project**. This will save all the added files to the RWK file.
4.2 **Lab 6 - Annotating a Horizontal Alignment**

Before starting this lab the *Geometry_Project.alg* file will need to be opened if it is not already. If this file does not exist, is empty, or not complete open the file *Completed_Horizontal.alg*.

A customized toolbar has been created to help expedite the process of annotating Horizontal Alignments. The proposed alignments still need to be properly annotated by using the tools and preferences that follow CTDOT standards.

Stationing is linear horizontal measurement along the horizontal alignment. The View Stationing command controls the display of station annotation text along the active horizontal alignment. You can place stations along a horizontal alignment at a specified interval.

This command displays stationing for the following types:

- Regular – annotates at regular intervals along the alignment.
- Cardinal Stations – includes PCs, PTs and no-curve PIs, and indicates any place on the horizontal alignment where a change in alignment has occurred.
- PI – includes points of intersection for each curve set.
- Station Equation – annotations at station equations.
- Radius +A – annotates the radius (R).
- Event Points – indicates places on the horizontal alignment where something significant takes place. This could be an intersection on the alignment, an existing bridge or monument, or a building as defined by the user.

When InRoads users are ready to define the stationing for alignments, set the desired horizontal alignment active. By default the first PI placed in the geometry will have station 0+00. PIs added to the first PI that is placed will have negative station values; stations added after or inserted between the POB and POE will have positive values.

**General Stationing Rules:**

- No roadway horizontal alignment should start with a 0+00 Stationing value.
- Roadways should have significantly distinct stationing values, e.g. 10+00 vs. 80+00.
- Existing stationing should be matched when possible.

Lab 6 will show users how to import a horizontal annotation toolbar, define the stationing, and display various symbols and data related to the alignment.

### 4.2.1 Import the HWY Horizontal Annotation Toolbar

**A.** Click on **Tools > Customize > Import**

**B.** Click **BROWSE**, and select *W:\CTDOT_Standards\InRoads_XM_RSC\Toolbars \Hwy – Horizontal Annotation.tbr*.

**C.** Click **Open** and **Import**.

**D.** On the toolbars tab check on the Hwy – Horizontal annotation toolbar
E. Click **Close** and the tool bar will open. This can be docked anywhere on the screen. The seven commands on this toolbar will need to be completed to correctly annotate the alignment. Figure 4-6 displays the HWY Horizontal Annotation Toolbar.

![HWY - Horizontal Annotation Toolbar](image_url)

*Figure 4-6 InRoads HWY Custom Horizontal Annotation Toolbar*

### 4.2.2 Define Stationing

A. **Select > Geometry > Horizontal Curve Set > Stationing** or the **first tool** on the HWY Horizontal annotation tool bar.

B. In the Stationing dialog select the Horizontal Alignment “**Roadway_1**”.

C. In the Starting Station field, enter the stationing value for the alignment (e.g. 10+00). It is not required to type the (+).

D. Vertical Alignments options should be set to **Maintain Station Difference** unless specifically attempting to shift alignment stationing.

E. Click **Apply** and **Close**.

### 4.2.3 Display Stationing

A. Click on the **View Station Tool (third tool)** to display the stations, major ticks, minor ticks, PC & PT cardinal leaders.

B. Click on the main tab and enter the horizontal alignment name. The correct Symbology boxes should already be checked off.

C. Click the **Cardinal Stations** tab. The **Include Coordinates** should already be checked **ON**. See Figure 4-7.

D. Click **Apply** and **Close**.
4.2.4 Display Bearings

A. Click on the View Horizontal Annotation Tool (fourth tool on the Horizontal Alignment toolbar).

B. Click on the pick button and data point on the alignment to annotate. The alignment name should then be entered into the Annotate field see Figure 4-8.
C. Click **Apply** to add the bearings and Click **CLOSE**. Figure 4-9 shows the InRoads generated bearing.

4.2.5 Display Curve Data
A. Click on the **Curve Set Annotation Tool** (fifth tool on the horizontal alignment toolbar) to add text for curve data.

B. Click on the pick button and data point on the alignment that you want to annotate. The alignment name should then appear in the Horizontal Alignment field.

C. Select the **Advanced Tab** (Figure 4-10). On the Curve Number line data point in Prefix before the word CURVE and type in the name of your Roadway (eg. Route 123). See figure below.

![Figure 4-10 InRoads Curve Set Annotation Dialog Box](image1)

D. Click **Apply** and **Close**. Figure 4-11 shows the annotated curve

![Figure 4-11 MicroStation Screen Shot of InRoads Generated Curve Data](image2)
4.2.6 Display Intersection Coordinates

A. Click in the Place Alignment Intersecting Note tool (sixth tool on the horizontal alignment toolbar).
B. Click on the Plan folder to expand the list of plan notes.
C. Toggle on the Intersection option.
D. Select the note Intersection Alignment Annotation.
E. Toggle OFF the Rotate option.
F. Click Apply.
G. Identify the first horizontal alignment by data pointing on it.
H. Click again to accept it.
I. Identify the second horizontal alignment by data pointing on it.
J. Click again to accept it.
K. Data point in the “quadrant” or corner of the intersection to place the leader and text for the intersection alignment information to be placed.
L. The text will now be interactive with the cursor. Click again to place the graphics at the desired location. Figure 4-12 displays a section of an annotated Intersection Alignment.

![Figure 4-12 MicroStation Screen Shot of InRoads Generated Intersection Dat](image-url)
Section 5  Profiles and Vertical Alignments

This section will focus on the basic InRoads tools used to layout vertical control geometry. Vertical geometry is the defined vertical data at or relative to the horizontal control geometry. For example, the vertical geometry defines the grade of the roadway and the vertical curves. In order to layout and design the vertical geometry, a profile generated along a defined horizontal geometry is needed. Proper engineering design of roadway vertical control is important and should follow state and federal guidelines as explained in Section 4 of this manual.

5.1 Lab 7 - Working with Design Profiles

Before starting this lab the Geometry_Project.alg file will need to be opened if it is not already. If this file does not exist, is empty, or not complete open the file Completed_Horizontal.alg. The existing DTM (SV_Surface.dtm) will also need to be loaded if it is not already. These two files are considered a minimum in order to generate this profile.

Vertical geometry requires that an existing horizontal geometry to be defined and set active. Therefore, a profile along the horizontal geometry needs to be generated before the vertical geometry is defined. This profile is considered a working profile and should be generated in the main .dgn file. The profile preferences for Highway, Facilities and Survey will be used to design the vertical alignments. Section 10 details how to use the Plan and Profile Generator to create the final profile cut sheets using the Profile Bdr Format. For this section, the working profiles are used to define the vertical geometry.

5.1.1 Placing a Profile Window

A. Go to Evaluation > Profile> Create Profile (Figure 5-1 will appear).
B. Click on Preference and load Highway.
C. Click on Source and click Alignment. Make sure that Roadway_1 is the alignment listed. The Create data field should be set to Window and Data.
D. Click on General, the Set Name data field should be set to Roadway_1. In the Surfaces area, toggle on the existing surface. In the Exaggeration area, set the Vertical exaggeration to 10,000 and the Horizontal exaggeration to 1,000.
E. Select Include. Make sure that Crossing Features and Projected Features are checked. Set up the Bandwidth as shown below in Figure 5-1.
F. Click on the Details folder and for Title Text: input Roadway_1
G. In MicroStation, rotate the view to TOP, and then fit the view. Click the Apply button and data point to a blank area in the MicroStation View. This will place a profile window.
5.1.2 Updating a Profile Display

Before beginning this lab make sure Lab 3.4.1 Changing Feature Properties is complete. The steps below will result in the projected feature being deleted from the profile.

A. Select Evaluation > Profile > Update Profile (Figure 5-2 will appear).

B. In the Profile Set data field, select the profile set. It is possible that the profile set name is Roadway_1_1, because each time a new profile is created, a new profile set is also created. Select the most recently created set.

C. In the Mode section, toggle on Display Off.

D. Select Projected Features. In the Surfaces section, click the Existing surface. In the Projected Features section select all the STREAM features. Click Apply. Figure 5-2 shows the Update Profile dialog box.
Figure 5-2 InRoads Update Profile Dialog Box

E. Select **Surface**. In the Surfaces section, click the **existing** surface. Click **Apply**.

F. Try to figure out how to turn the Existing Surface and Projected Features back on.

### 5.1.3 Creating a Vertical Alignment

Section 1.6.2 Setting up the Project File of this manual explains the process for creating and naming a Vertical Geometry. At this point, there should be an empty vertical geometry. This had been created and named as a child of the Horizontal geometry which was used to create the profile.

A. Using the **View [Zoom]** command, set the MicroStation view so that only the profile is showing.

B. Make sure that the **Pen/Pencil** mode is set to **Pencil** and **Roadway_1** is active. Double click on the **Intersect Snap** in MicroStation.
C. Select **Geometry > Vertical Curve Set > Add Vertical PI**. Figure 5-3 shows the Add Vertical PI dialog box. Click **Apply**. Tentative to the intersection of station 11+00 and the existing surface in the profile window and data point to accept.

![Add Vertical PI Dialog Box](image)

The **Add Vertical PI** dialog box can be used to set a delta station, elevation, or grade on vertical elements. If a section were toggled on, that parameter would be set. This does not need to be used when creating or modifying a vertical alignment, but it is a helpful tool. Example: If the **Grade** section of the dialog box was toggled on, and a grade of 1.00% was entered in the dialog box, then as the user moves the cursor across the profile, the tangent line following the cursor would snap to the even 1% grades (-5.0%, -4.0%, -3.0%, etc.).

D. Click on the Key Point Snap in MicroStation. At the end of the alignment tentative to the existing ground on the profile window and accept the input. Read and follow the MicroStation command prompt to accept (data point) the VPI location.

Up to this point, there is a vertical alignment with a constant grade from the beginning of the project to the of the end project. Similar to the process of inserting or adding PI location in a horizontal alignment, the following steps show users how to add or insert PVI locations to the vertical alignment.

E. Select **Geometry > Vertical Curve Set > Insert Vertical PI**. Select **Station and Elevation** in the Insert Vertical PI dialog box. Enter station 1650 and elevation 340. Data point in the profile window. Read and follow the MicroStation command prompt to accept (data point) the VPI location.

F. Select **Insert Vertical PI**. Enter Station 2000 and elevation 353. Data point in the profile window. Read and follow the MicroStation command prompt to accept (data point) the VPI location.

G. Select **Insert Vertical PI**. Enter Station 2450 and elevation 345.58. Data point in the profile window. Read and follow the MicroStation command prompt to accept (data point) the VPI location.

H. Try the **Move and Delete Vertical PI tools**. Then put the VPI back to the stations and elevations listed above.
Notice that as the cursor moves, the tangent line follows it. The message “Out of Range”, means that the cursor is located such that the vertical alignment overlaps itself. If the message “Profile not found” appears, this means the cursor is no longer in the profile window.

5.1.4 Defining Vertical Curves

Now the vertical curves can be set. The Define Vertical Curve command works just like the Define Horizontal Curve as discussed in Section 4.1.3. The Define Vertical Curve command finds the first PVI or curve set on an alignment.

A. Select Geometry > Vertical Curve Set > Define Curve.

B. In the Vertical Curve (see Figure 5-4) section of the Define Vertical Curve dialog box, set Calculate By to Length of Curve and for Length, enter 300. Click Apply. The vertical alignment display is updated with the vertical curve definition.

C. Click Next and add a length. Enter 400 and click Apply.

D. Click Next and add a length. Enter 150 and click Apply.

E. Close the dialog box and Save the Project.

5.1.5 Annotating a Vertical Alignment

Vertical Geometry Annotation is the annotation of vertical elements in a profile.
A. Select **Geometry > View Geometry > Vertical Annotation**. Select the correct Horizontal Alignment and Vertical Alignment.

B. Select the Profile Set. Do not turn on any of the Limits.

C. Click **Apply**. The vertical alignment is annotated. Click **Close**. Figure 5-5 displays an annotated vertical alignment.

![Figure 5-5 MicroStation Screen Shot of InRoads Annotated Vertical Alignment](image)
Section 6  Template Library

Templates are used to define the transverse geometry of the roadway, airport taxiway and airport runway. Transverse geometry is basically the slope and distance perpendicular to the horizontal and vertical geometry to each transition point in the cross section. These are defined as template parameters in the Template Library, and the data is stored in the *.itl file. For the DDE, two separate CTDOT Template Libraries have been created where the standardized templates are stored and can be used as needed for project specific templates. The HW_typicals.itl file houses the roadway templates and the FAC_typicals.itl houses the airport taxiway and runway templates. The ability to create templates is one of the major changes implemented in InRoads 8.7 and later versions. The process of creating templates is now much more graphical. Template components and end condition components replace previous forms of creating templates.

InRoads Help documentation contains in-depth explanations describing Template Point and Template Components. Points are used to define longitudinal breakline features in a surface model (DTM). Components are a series of points that are connected. Each point in the component defines a transition or potential transition in the template.

End condition components are elements that ultimately seek a target. Often the target is the original ground or the active surface, but there are several other target types available. Multiple end conditions components can be attached to a point and defined to look for different parameters. The standard end conditions are based on the elevation difference between the existing and proposed ground, the bigger the difference the stepper the end condition slope. Once a target is found, the end conditions for that point are resolved. End condition priorities are assigned to control the order of the end condition target analysis. If the first end condition fails, the second will seek, if it fails, the third will seek and so on.
6.1 The CTDOT Standard Highway Template Library

Section 1.6.2 Setting up the Project File discussed how to add the standard template library to the project file. This section will cover the process for migrating standard templates into the project library folders. As stated earlier, roadway design uses the **HW_typicals.itl** file. This library contains typical sections, components and end conditions with predefined point names that are associated with CTDOT standard symbology. The templates located in the Bentley and Hwy folder should not be modified. Rather, they should be copied and modified in the Project Library folders. Below describes the folders showed on the left hand column in Figure 6-1.

- The first two folders contain Bentley standard templates and have not been modified to follow the CT DOT standards.
- The four HWY folders contain templates that adhere to the CTDOT standards and should not be modified.
- The Project Library folder contains three empty folders and will be the storage location for the project specific templates.

![Figure 6-1 InRoads Highway Design Custom Template Library](image)

6.1.1 Folder Descriptions

The four HWY folders (HWY End Conditions, HWY Misc Components, HWY Pavement, and HWY Typical Sections) are described below.

**Hwy End Conditions**

This folder contains pre-defined end conditions. The end conditions have been developed with **Feature Name Override** checked on. If users create their own end conditions, this will be
important option to have checked on. The end condition **Cut_for_Curb** should be attached to a cut condition snow shelf that has curbing. The end condition **Cut_for_Ditch** should be attached to a cut condition snow shelf that has no curbing. The end condition **Fill** should be attached to a fill condition snow shelf. Figure 6-2 displays the dialog box for Point Properties.

![Point Properties Dialog Box](image)

Figure 6-2 InRoads Point Properties Dialog Box

**HWY Misc Components**
This folder contains predefined pavement/curbing components when combined with the end condition components create a complete design cross section template. These components are copied and edited in the project Library folder. The sidewalk and pre-cast concrete barrier curb components are also in this folder. Figure 6-3 shows a sidewalk component, including a curbing/pavement component and barrier curb components.
Figure 6-3 Contents of HWY Misc Components Folder

- Curbing/Pavement component
- Barrier Curb components
- Curbing component
- Sidewalk component
HWY Pavement
The Hwy Pavement folder contains templates for both sides of the roadway from Edge of Road (EOR) right to EOR left (all travelways and shoulders). The dimensions of the lanes are 12 feet wide and with 4-foot wide shoulders. All slopes are set to 4%. See example in Figure 6-4.
HWY Typical Sections
This folder has combined components to create typical design cross section templates. These templates can also be copied in to a Project Library and edited as needed. Two complete typical sections with end conditions have been provided. See example in Figure 6-5.

- **2ln_Roadway_BLPC** – Two-lane roadway with Bituminous Concrete Park Curbing, 12 foot lanes with a slope of 1.5% and 4 foot shoulders and slope at 6%.
- **2ln_Roadway_NC** – Two-lane roadway with No Curbing, 12 foot lanes with a slope of 1.5% and 4 foot shoulders and slope at 4%.

![Figure 6-5 View of HWY Typical Section Template](image)

6.1.2 Affixes
All HWY end conditions and miscellaneous components have been drawn on the left. When these are pulled into create a project template affixes for suffix _lt and _rt should be toggled on, see Figure 6-6.

![Figure 6-6 InRoads Affixes Dialog Box](image)
6.1.3 Point Names
Each point that has been placed on a predefined template, end condition or component has a unique name with a Surface Feature Style associated to it. Points on the top surface will use a P_RDWY surface feature style. Points on the sub-layers under the top surface will use a P_SUB surface feature style. See Figure 6-7 for typical point names.

![Figure 6-7 View of InRoads Template with Typical Point Naming](image)

6.1.4 Component Names
Each predefined component has a surface feature style associated with it. Components use a prefix of P_COMP in the style name. Figure 6-8 shows an example of the P_Comp prefix in a style name.

![Figure 6-8 InRoads Component Properties Dialog Box](image)
6.2 The Facilities Standard Template Library

A CTDOT standard facilities template library has been created. This library contains predefined components and component assemblies that are saved as templates in the library. Standard Templates can be copied to the projects library folder. These templates can then be edited or used to assemble a design cross sectional template. The standard template library also contains a predefined point name list where point names are assigned style symbology. Figure 6-9 shows all folders located in the facilities template library. The right side of Figure 6-9 shows a template (2Ln_20’@1.0%) with the components displayed.

Figure 6-9 Facilities Custom Template Library
6.2.1 Folder Descriptions

FAC End Conditions
The Facilities (FAC) End Condition consists of different scenarios that may exist while designing a taxiway or runway. Figure 6-10 shows a list of the FAC End Conditions.

- The end condition Cut_for_Ditch_LT or RT should be attached to a cut condition grass shelf that has no curbing.
- The end condition Cut_for_EOP_LT or RT should be attached to a cut condition grass shelf that has curbing.
- The end condition Fill should be attached to a fill condition grass shelf.

FAC Pavement
Figure 6-11 shows a list of the FAC Pavement templates

- The taxiway pavement template (2Ln_20’@1.0%) consists of two (2) lanes, with a 20 foot width with a 10 foot grass component that is 4 inches thick.
- The second taxiway pavement template (4Ln_25’@1.0%) consists of four (4) lanes with a 20 foot width for the outside lane. The inside lanes may vary in width.
- The third taxiway pavement template provided consists of four (4) lanes, a 20 foot width for the outside lanes and 25 foot width for the inside lanes.
FAC Typical Sections
Figure 6-12 shows a list of the FAC Typical Sections

- The taxiway pavement template provided consists of components and end conditions.
- If any of the templates need to be changed, they should be copied and re-named to avoid losing the original template.

FAC Misc. Components
The items in the FAC Misc Components folder can be used to create unique templates that have not been supplied. Figure 6-13 shows a list of the FAC Misc. Components

6.2.2 Point Names
See Section 6.1.3 Point Names.

6.2.3 Component Names
See Section 6.1.4 Component Names.
6.2.4 Affixes
All FAC end conditions and miscellaneous components have been drawn on the left and right. InRoads users should ensure that affixes are off in the Template Options dialog box, as shown in Figure 6-14. If there are components or end conditions that are drawn from the left, by checking off the Apply Affixes, the LT and RT will be labeled when the template is mirrored.

![Figure 6-14 InRoads Template Options Dialog Box](image)

6.2.5 Template Library Organizer

The Template Library Organizer allows the designer to gather information from one .itl file and to put it into another file. For example, if a FAC designer is working on roadway, they can open the HW_Typical.itl file and copy the information needed into their own .itl. Figure 6-15 shows the Template Library Organizer which contains templates for FAC designers.
Figure 6-15 InRoads Template Library Organizer Dialog Box
6.3 **Lab 8 - Assembling Templates**

Before starting this lab `HW_typicals.tml` will need to be opened if it is not already.

### 6.3.1 Highway Process

This lab will show users how to combine the standard CTDOT delivered components to create a typical design cross section template. The pavement components, curb components, and end condition components can be copied and edited as needed.

A. Open the Template Library: Go to **Modeler > Create Template…**

B. Double click the template library in the left window listing to expand the library folders

C. Open the **Project Library** Folder and in **the Typical Sections** folder, and create a new template. Right click on the **Typical Sections** Folder and select **New > Template**. The new template will be highlighted in blue, type in **CT_RDWY1** and rename the new template. (See Figure 6-16)

![Create Template Dialog Box Renaming a Template](image)

D. On the Create template main menu click on **Tools > Options**. **Apply Affixes** should be on with suffix of _lt and _rt.

E. On the Create template main menu, click on **Tools > Dynamic Settings**. For X Step input, use **0.1** and for Y Step input **0.1**.

F. Double click (to set active) on the **CT_RDWY1** template, if is not highlighted with a red box. The active template is the one displayed in the editor window, the red outline on the template bullet icon indicates the active template in the list window.

G. In the **HWY Misc Components** folder, data point once on the **1ln_6%shr_BCPC** template and drag it into the new template. When the cursor is over the editor window, there will be a
pavement/curb component, drag the insertion point to the pink box at 0,0 and release the mouse button.

H. Next, drag 1ln_4%shdr into the same new template but right click while dragging and turn on Reflect. Continue dragging until the insertion point is over 0,0 (the CL point will turn white) and release the mouse button.

I. Next, change the lane widths from 12’ to 11’. In order to do so, double click on SHDR_rt, and the point properties Box will appear. In the Constraints area, input a value of 11 and Tab for constraint 1. Click Apply and Close. Notice all the sub layer SHDR points also change. Repeat for SHDR_lt but enter -11.

J. To merge pavement components, fit the template in the display window. Right click close to the center of the top pavement component and select Merge Components. This will delete the orange line down the center and create one orange shape. Continue this process with the pink and purple shapes. Figure 6-17 shows the dialog box for creating a template.

Figure 6-17 Inroads Dialog Box Merging Components
K. Double click on each pavement component and edit the name. Eliminate any previous left or right designation as shown Figure 6-18. Leave the Curbing components as is.

![Figure 6-18 InRoads Component Properties Dialog Box Renaming Components](image)

L. Click on the **HWY End Conditions** folder and using the processes below, drag the following templates to the correct Point name:

- With reflect off, slide the end condition **Cut_for_Curb** on to the point **SNOW_c_lt**.
- With reflect off, slide the end condition **Fill** on to the point **SNOW_f_lt**.
- With reflect on, slide the end condition **Cut_for_Ditch** on to the point **SNOW_rt**.
- With reflect on, slide the end condition **Fill** on to the point **SNOW_rt**.

M. Click the **Test** button. A warning button will appear; click **OK**. When the test **End Conditions** appear, click **Check Priorities**. Edit **SNOW_rt**, and change **Ditch_rt** to a value of **5**. Click **OK** and close the **End Condition Priorities box**.

N. Use the tools above to create a template. Create another template in your Project Library Typical Sections folder called **CT_RDWY2**. The left side of the road will be one lane using BCPC and the right will be two lanes with no curbing. Use the detail below in Figure 6-19 as a guide. Notice the two (2) foot shoulder and two percent (2%) cross slope.

![Figure 6-19 Typical Section for CT_Rdwy2](image)
O. In this next step users will create a local roadway, and change pavement thicknesses and component material. Go to the **HWY Typical Sections** folder and right click on **2In_Roadway_BCPC**. Click **Copy** and Paste it to your **Project Library Typical Sections** Folder. Change the name to **Local_Rdwy**.

P. Leaving the **Create Template** dialog box opened. On the InRoads Main Menu click **Tools > Style Manager**. Then data point on **P_COMP_SUPERPAVE1.5** and click the **Copy** button. Give the new style the name **P_COMP_PROCESSED_AGG** and type in a description. This new style item can be assigned a pay item to be used in Quantity Manager.

Q. Go back to the **Create Template** and select the **Local_Rdwy** template. Click on point **SHDR_b_rt** and change the constraint 2 value to **-0.300**. (See Figure 6-20 below). Continue entering the same value for all the points on this layer (**CL_b, EOR_b_rt, BOC_b_rt, EOR_b_lt, BOC_b_lt and SHDR_b_lt**).

![Figure 6-20 InRoads Point Properties Dialog Box](image)
R. Click on point \texttt{SHDR}\_sg\_rt and change Constraint 2 value to \texttt{-0.833}. Continue entering the same value for all the points on this layer (\texttt{CL}\_sg, \texttt{EOR}\_sg\_rt, \texttt{BOC}\_sg\_rt, \texttt{EOR}\_sg\_lt, \texttt{BOC}\_sg\_lt and \texttt{SHDR}\_sg\_lt).

S. Double click on the pink \texttt{Superpave\_Sub} component and change the style \texttt{P\_COMP\_PROCESSED\_AGG}. In the name field input \texttt{ProcessedAgg\_Sub}, Click \texttt{Apply} and then \texttt{Close}.

T. \texttt{Save} the template library and click \texttt{Close}.

6.3.2 Facilities Process

Before starting this portion of the lab \texttt{FAC\_typicals.tml} will need to be opened if it is not already.

This lab will show users how to combine the standard CTDOT delivered components to create a typical design cross section template. The pavement components, and end condition components can be copied and edited as needed.

A. Open the Template Library: Modeler > Create Template, open the \texttt{FAC\_typicals.itl} file.

B. Double click the template library in the left window listing to expand the library folders. Figure 6-22 shows the list of folders in the Template Library.

C. Open the Project Library folder and in the Typical Sections folder create a new template. Right click on the Typical Sections folder and select New > Template. The new template will be highlighted in blue, type in \texttt{Class\_Taxiway1} to rename the new template.

D. On the Create template main menu click on Tools > Options. Apply Affixes should be off because there are end conditions and components for the left and the right.

E. On the Create template main menu click on Tools > Dynamic Settings. For X: Step: input 0.1 and for Y: Step: input 0.1.

F. Double click (to set active) on the \texttt{Class\_Taxiway1} template, if it is not highlighted with a red box. The active template is the one displayed in the editor window, the red outline on the template bullet icon indicates the active template in the list window.

G. In the FAC Pavement folder, data point once on the \texttt{2Ln\_20’@1.0\%} template and drag it into the new template. When the cursor is over the editor window, the pavement component will appear. Drag the insertion point to the pink box at 0,0 and release the mouse button.
H. Now drag Cut_for_Ditch_LT into the same new template and connect it to the left edge of the template.

I. Then drag Cut_for_Ditch_RT_4:1max into the same new template and connect it to the right edge of the template.

J. Next, double click over the left most red dot in the template. Change the value for the Constraint 1 from -20.00 to -30.00; this will change the width of the template. Click the Apply button.

K. Next change the cross slope from 1% to 2%. Click the Apply button and then click Close. Figure 6-22 shows the Point Properties dialog box where the user is able to change the Constraint 1 and Constraint 2 values.

Figure 6-22 InRoads Point Properties Dialog Box
L. In the lower right hand corner of the Create Template box click the Test button.
M. Select the Active>-Surface, then select the Draw command.
N. Pan the orange line up and down this will show how the template end conditions work.
O. If creating templates, users might have to set their priorities.

Figure 6-23 InRoads Test end Conditions Dialog Box

P. Click on the Check priorities box within the test template interface window shown above in Figure 6-23.
Q. If a message box appears stating that there are no conflicts, then precede by either clicking Yes and continue to review or change priorities, or click No. Below, Figure 6-24 shows this message box and Figure 6-25 shows the Fix Priorities dialog box if the user opts to change the Priority.
If there is a conflict with the priorities or the order of the priorities needs to be changed, it can be modified in the Fix Priorities dialog box (see Figure 8-26). For this lab, the priority of the end conditions does not have to be changed. Therefore, save the data, close FAC.itl and open the HWY.itl file.
Section 7  Roadway Designer

After the templates are assembled, they are applied using the Roadway Designer. This process requires that the user define corridors with the required geometry such as horizontal, vertical and transverse (templates). Then it uses a variety of controls to create 3-dimensional (3-D) models of the roadway design. The intent of the Roadway Designer is to minimize the amount of edits made directly to the proposed DTM.

This section of the manual will provide a standard workflow that should be used as a guide for Roadway Designer commands and processes. InRoads Help provides in-depth explanations on all features of the Roadway Designer. A proposed surface model will be created using basic tools that are available in the modeler. The modeler has many advanced capabilities for controlling surface models; see InRoads Help documentation for more information.

Section 3 of this manual discussed how to create, save and load Roadway Designer .ird files.
Below Figure 7-1 is a list of items that describes the work area in Roadway Designer.

- **Menu Items** located at the top left corner of the dialog window.
- **Buttons** located directly below the menu items can be used as shortcuts to access menu items.
- **Plan View Window** located in the upper left corner is used to display and locate horizontal alignment and plan information while using the modeler.
- **Profile View Window** shown in the lower left corner is used to display vertical alignment and profile information while using the modeler.
- **Cross Section View Window** is located on the right side of the modeler, and is used to show the template component and end conditions along the corridor. The active surface is also shown, as well as all other targets associated with the templates that are referenced by the modeler.
7.1 Lab 9 - Using the Roadway Designer

Before starting this lab the following files will need to be opened if they are not already. If a file
does not exist or is not complete open the alternate sister file.

1. Geometry_Project.alg or Completed_Vertical.alg.
2. HW_typicals.tml or Completed_HW_typicals.tml
3. SV_Surface.dtm

These three files are considered a minimum in order to use the Roadway Designer

This next Lab will demonstrate to users the functions available in the Roadway Designer including
Corridor Manager, template drops and transitions.

7.1.1 Corridor Manager

Each new roadway or surface involves naming and creating a corridor based on an alignment or feature. A single Roadway Designer file (ird) may contain several corridor definitions. Typically, corridors are used to define roadways, but they can also define channels or ditches or any other surface that is based on a linear control.

- A. From the InRoads main menu select Modeler > Roadway Designer. At this point the Roadway Designer dialog with three empty view windows should appear. This dialog and all the windows are resizable using a mouse cursor.
- B. Select the Corridor > Corridor Manager command.
- C. In the Manage Corridor dialog box, type the name of the corridor, e.g. Mainline. Note: The corridor name will also be the name of the DTM created by this corridor.
- D. Set the Type to Alignment.
- E. Select Roadway_1 for the Horizontal Alignment
- F. Select Roadway_1 for the Vertical Alignment.
- G. PI Rounding for roadways will typically be 0.00
- H. The station range can be toggled off to allow the corridor to apply to the entire alignment from POB to POE of the vertical geometry.
- I. Use the ADD button to add or create this corridor. Then click Close.

7.1.2 Template Drops

When templates from the template library are applied to the assigned horizontal and vertical geometry of a corridor, this is referred to as a template drop. Templates are copied not referenced from the template library to the roadway modeler and are assigned station ranges. It is possible to drop different templates at defined station ranges to achieve changes in the roadway design. For example, one section of roadway may be two-lanes that transition into a bridge then back to a two-lane typical.

When templates are selected and used in the Roadway Designer, they are copied to the Roadway Designer .ird file. These templates are not automatically synchronized with the library from which
they originated. However, if the library that the template originated from is loaded, then the templates can be synchronized using the synchronize button on the bottom of the template drop dialog. If a template drop is red, this is an indication that the templates are out of sync with the template library. Note: It is not necessary to have synchronized templates, but it is good practice to keep the template library up-to-date with all template drops synchronized whenever possible.

A. From the Roadway Designer, select Corridor > Template Drops. From the Template Drops dialog, select the corridor, e.g. Mainline.

B. The station is the first station that this template will be applied. Key in STA 11+00 as the beginning of the vertical alignment.

C. An Interval is the spacing that templates will be dropped. Set this at a value appropriate for a project. For this example use 10.

D. In the Library Templates window, expand the library folders and select the design template, e.g. CT_RDWY1. Click the Add button. Figure 7-2 displays the Template Drops window from which to apply and adjust templates.

![Figure 7-2 InRoads Template Drops Dialog Box](Image)
E. Add the next Template Drop. For the station, enter 12+00 and select CT_RDWY1 again. Click the Add button to add to the list of template drops.

F. Add the next Template Drop. For the station, enter 14+00 and select CT_RDWY2. Click the Add button to add to the list of template drops.

G. Add the next Template Drop. For the station, enter 16+00 and select CT_RDWY2. Click the Add button to add to the list of template drops.

H. Add the next Template Drop. For the station, enter 18+00 and select CT_RDWY1. Click the Add button to add to the list of template drops.

I. Click on the Close button. On the Roadway Designer dialog box select File > Save to save the roadway designer file to the disk.

7.1.3 Template Transitions

When templates contain points that do not match up, such as templates with additional points or points of a different name, a transition must be defined. Notice in the example from the last section, Section ?, that two (2) yellow highlights were displayed in the plan view of the Roadway Designer Dialog. These highlights are an indication that a transition condition exists.

A. Right click over the yellow highlight and select the edit command. This will initiate the edit transition dialog box. This dialog box shows a window with an outline of the two templates that are transitioning. In the example shown in Figure 7-3, CT_RDWY2 travelway point does not exist in CT_RDWY1. Right click over points in this dialog to move the view angle. This action may be required to view all the points that do not match up. The bolded (+) indicates orphaned points.

B. Use the mouse to drawn lines that connect the travelway (bold red point) on CT_RDWY2 to the Shoulder point on CT_RDWY1. Click near the top bold red point, then click near the CT_RDWY1-SHDR_rt point.

C. Continue this process with the sub-layer bold red points until no bold points are left. Connect each bold point with it corresponding layers shoulder point.
D. Next click the **OK** button the Edit Transition Midpoint dialog will appear. Double click on the **SHDR_rt** point and change the horizontal constraint to **None**. Select the **OK** button on the **Transition Point Properties** dialog box and **OK** on the **Edit Transition Midpoint** dialog box as shown in Figure 7-4. The yellow highlight should turn blue indicating that edits have been made.

E. Double click on the right **EOR_rt** point and change the vertical and horizontal constraint to **None**. Click **OK** on the Transition Point Properties Dialog Box.
Figure 7-4 InRoads Edit Transition Midpoint Dialog Box
F. Repeat steps A, B, C s for the next transition but skip D and E. Do not edit the Transition Point Property. Click OK on the Edit Transition Midpoint dialog box.

G. Right click over the blue highlight and toggle off the check mark by enable. This will stop the transition from happening over the entire length of the template drops but will transition from the last interval template drop.

*Note:* The process of editing transitions may need to be repeated if there is a change to the template or the templates need to be synchronized. It is recommended that users hold off on the edit transition process until the templates are finished or when they require a revision.

### 7.2 Roadway Designer Surface Creation

The Roadway Modeler final output is in the form of surface digital terrain model (DTM). The combination of horizontal, vertical and transverse geometry, with Roadway Modeler tools create the surface from defined corridors. If there are several corridors in the modeler, they can be combined to create one surface or a new surface for each corridor. For the purpose of this manual, a new surface for each corridor will be created.

When using the Create Surface tools, select the appropriate corridor from a list. If necessary, users can toggle on the Create Alternate Surfaces option. There are many advanced tools available for creating surfaces; however, in this section the fundamental tools.

Creating a surface from the Roadway Modeler in past versions of InRoads was an iterative process. In the latest versions of InRoads, the surface should be relatively complete before a surface is created. Also, if the modeler is used to its fullest potential with a new DTM, significantly less direct edits than in previous versions of InRoads will be required. Many of the standard features of the edit and design surface tools from previous versions are still available.
7.3 **Lab 10 - Creating a Proposed Surface**

Before starting this lab the following files will need to be opened if they are not already. If file does not exist or is not complete open the alternate sister file.

1. *Geometry_Project.alg* or *Completed_Verical.alg*.
2. *HW_Roadway_Design.ird* or *Completed_Roadway_Design.ird*
3. *SV_Surface.dtm*

These three files are considered a minimum in order to create a design surface.

7.3.1 **Creating a Surface from the Roadway Modeler**

In this exercise, a proposed surface model will be created. The name of the surface model will, by default, be the same as the name of the corridor. The alternate surface option will be used to create a model for the bottom of the pavement. Finally, the properties of the surfaces will be modified, saved to a file, and added to the project .rwk file.

A. In the Modeler, set the **Active Surface** accordingly. In this example, set the active surface to the original ground, i.e. Existing.

B. From the Roadway Modeler, select **Corridor > Create Surface**.

C. From the **Create Surface** dialog box, select the one corridor to be created for the surfaces. For this example, select the **mainline**. If there are several corridors defined, they will all be selected automatically. Note: This dialog will run all corridors if not indicated by the user! Therefore, select only the corridors that are required. As shown in Figure 7-5.
D. Click the **Apply** button.

E. Close the dialog box when the process is completed. Click **Save** and then **Close** the Roadway Modeler.

F. In the MicroStation view pan the proposed roadway features that were created. Notice the Transitions at stations 14+00, 16+00 and 18+00.

### 7.3.2 Surface Properties

The surfaces created from the modeler have default properties and should be modified to display correctly in plan and cross section.
A. From InRoads, explore the workspace bar window and select the Surface tab.
B. **Right click** over the proposed surface and select Properties. (see Figure 7-6).
C. On the Main Tab, change the Preference field from Default to Highway. This will control the level that triangles will display on in plan view.
D. On the Advanced Tab, change Cross Section > Symbology to P_SURF_DESIGN. Check on the Use Features Only box.
E. On the Advanced Tab, change Profiles > Symbology to P_SURF_DESIGN.
F. Click the Apply and Close.

![Surface Properties](image)

Figure 7-6 InRoads Surface Properties Dialog Box

7.3.3 Saving the Design Surface

It is important to note, that the surface that was previously created in 7.3.1 is saved in virtual memory only. That means that this file does not exist on any physical memory at this point. For
VOLUME I - SECTION 7

this next exercise, the proposed surface will be saved to physical memory, and then added to the project .rwk file. Project .rwk file usage was explained in Section 3.

A. From the InRoads workspace bar window select the Surface Tab.

B. Right click over the proposed surface and select Save As. The surface that is being saved will be shown as the Active surface at the bottom of the Save As dialog box. At this point, from the pull down, select any of the loaded files to save. Use the pull down and select the Mainline surface. Notice that the file name is automatically filled in as Mainline.dtm.

C. Select the SAVE and Cancel.

Note: IF YOU DON’T CREATE A FILE NAME FOR YOUR PROPOSED SURFACES THE DATA WILL BE DELETED EVERY TIME YOU EXIT INROADS AND THE SURFACES WILL HAVE TO BE RE-CREATED IN THE ROADWAY DESIGNER

7.3.4 Project File Update

The project file will need to be updated with the newly created DTM. The RWK project files, not only saves time when loading the project, but it also allows others on the design team to load the files included in the design. As mentioned earlier in this manual, efficient InRoads design practices involves continual file management. Therefore keep the project file up-to-date. There are several types of files associated with the InRoads design, and the project file will help track design data.

A. Select FILE >SAVE AS on the InRoads Main Menu.

B. From the Save As dialog box, set the save as type to Project (*.rwk). Select Projects_file.RWK.

C. At the bottom of the Save As dialog box, select the Options button.

D. Select the Surface tab, click on Add, Update, and the file name Mainline.

E. Click OK, Save, Yes. Replace the existing project file with this new and revised one. Select Cancel on the Save As dialog when done.
Section 8  Superelevation

This chapter will describe the process of establishing Superelevation data stored in the InRoads Roadway Designer (IRD) file. The superelevation wizard in Roadway Designer sets up the superelevation. Several methods are available from the wizard; however, CTDOT uses the table method and selects one of the corresponding AASHTO tables. The superelevation tables are found in the workspace: \CTDOT_Standards\InRoads_RSC\Superelevation_Rate_Tables. Figure 8-1 shows the superelevation tables available in the workspace.

Figure 8-1 InRoads Superelevation Tables
Superelevation is stored in Roadway Designer as superelevation point controls. The point names in the templates that are used as superelevation control points should be consistent. The centerline of the road will be considered the Crown Point, and the left and right shoulder will be the left and right Range Points. Additionally, the left and right edge-of-road points will be used for the rollover locks. These points should be checked and edited to ensure they have consistent names.

Once template drops have been defined, it is possible to define the superelevation. Superelevation will use horizontal control lines to control range points and rollover points. Changes to the design, such as template point names or geometry stationing, will alter the superelevation. These types of revisions will require reworking or redefining the superelevation.

From the display superelevation option of the roadway modeler, different aspects of the superelevation can be viewed. Each window has a purpose, and Table 10-1 describes the windows and their use. The yellow line indicator in each window shows the current cross section template drop location.

<table>
<thead>
<tr>
<th>Super Display View</th>
<th>Description and usage of view windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>TOP LEFT</td>
<td>Plan view with color coded banking Blue = 8%, Orange = 6%, White = 0% and a gradient range in-between these colors</td>
</tr>
<tr>
<td>BOTTOM LEFT</td>
<td>Cross Section view of corridor backbone with color that match the plan view</td>
</tr>
<tr>
<td>TOP RIGHT</td>
<td>Color coded Profile view of the corridor</td>
</tr>
<tr>
<td>BOTTOM RIGHT</td>
<td>Banking Diagram Control line view; from this view edits to the banking can be made. Edits are done using a variety of tools we will use several of these in modifying the example design</td>
</tr>
</tbody>
</table>
8.1 Lab 11 - Using Superelevation Tools

Before starting this lab the following files will need to be opened if they are not already. If a file does not exist or is not complete open the alternate sister file.

1. Geometry_Project.alg or Completed_Vertical.alg.
2. Roadway_Designer.ird or Completed_Roadway_Design.ird
3. SV_Surface.dtm

These three files are considered a minimum in order to use create a Superelevation.

8.1.1 Table Wizard

A. Create a new roadway, select Corridor > Manage Corridors. In the Name field type in Superelevation. Set the following, Type: Alignment, Horizontal Alignment: Roadway_1, Vertical Alignment: Roadway_1. Click Add and Close.

B. Add Templates, select Corridor > Template Drops. Change interval to 10. Click on the following typical Project Library > Typical Sections > CT_RDWY1. Select Add and Close.

C. Click the Display Superelevation button. From the roadway modeler, select Superelevation > Create Superelevation Wizard > Table…

D. Click the pick button next to the Table field and browse to W:\CTDOT_Standards\InRoads_XM_RSC\Superelevation_Rate_Tables\06_40.sup

E. Use the mouse cursor with the shift key depressed to select all curves from the curve set list.

F. Click on the Load Values From Table button. This will update the curve set list to show that the table being used is the 06_40.sup. The Curve Set list should indicate that the correct superelevation tables are being used for each curve the design requires.

G. Click the Next button on the bottom of the Table Wizard. This will bring up the Superelevation Section Definitions dialog.

H. Use the Add… button to start the section definition. The section name by default will be Section 1.

I. For the Crown Point, select CL point. To do so, use either the pull down list or the target button to select the point on the screen from the modeler cross section view window.

J. Set the Left Range Point to SHDR_lt. Set the Right Range Point to SHDR_rt. For the rest of the settings, the pivot direction is OK at From Crown Point, and this is a 2 lane design. Click OK.

From the Superelevation Section Definitions dialog, review the definitions setting. The start-stop stations are indicated as well as the runoff lengths and more.

K. Click the Next button. The Superelevation Controls dialog box allows users to review the vertical control line data, along with their names, and any points and slopes involved the process. The Station rounding has been set at 1 foot by default but can be changed if required.
L. Click the **Finish** button. If there are **Overlaps**, the Fix Overlap dialog box will appear. For more information on this dialog box, refer to InRoads Help. For this exercise, the overlap edits will be corrected later in the dynamic super display window. **Close this dialog box.**

M. Click the **Display Superelevation** button to return to the other Roadway Design view. Click **Process All**. Browse through the corridor and see how the roadway behaves. Notice the odd sections in the transitions especially towards the end of the project. This appears because the wizard automatically choose the point SHDR\_rt to use TRWY1\_rt instead of CL for the reference point.

*The main super control is now defined. To toggle between the views, click on **Display Superelevation** button on the bottom right corner of the roadway designer dialog. The **Process All** button will make the display of superelevation in this window display completely.*

### 8.1.2 Edit Superelevation

In the example design, the Runoff overlaps in the superelevation control lines. This is a typical situation and the overlaps can be edited easily from the Banking Diagram Control line view. Additionally, the example design has overlapping full super start and stop stations for curve 1. In this next exercise, these errors will be edited and corrected while graphically viewing the changes in the roadway designer.

The same short-cut menu that had the Display List command has an **Edit Curve Set Stations** command. This will bring up a dialog that will list controls for the superelevation. From this dialog box, the Full Super start and stop stations will be edited.

**Change a Station**

A. Right click on bottom right superelevation view and select **Edit Curve Set Stations**. Make correct **Selection Name** active.

B. Change the Station value for the first Full Super in the list from STA 14+20 to STA 14+50 and click the **Apply** button. Click the **Process All** button. Notice the control line display immediately reflects the update. Close the **Edit Curve Set Stations** dialog box.

### 8.1.3 Full Super to Full Super Planar Transition

Overlapping curve transitions is common in designs. The process for creating Full Super to Full Super Planar is straightforward. There is an option to create full super to full super planar transitions in the **Fix Superelevation Overlap** dialog box. This approach would work perfectly in this example; however, the superelevation control points can be directly edited to create this transition. If curves have extreme overlaps, the **Fix Superelevation Overlap** dialog will not delete points that extend into full super sections.

The image in Figure 8-2 represents super control lines that overlap. The left lane shown as a red line, returns to a normal crown well into the entrance transition of reverse curves 1 & 2. In the next exercise, all control points that reside between the last full super of curve 1 and the first full super of curve 2 will be deleted.
8.1.4 Generate a Superelevation Report

A. Select **Superelevation** from the Roadway Designer main menu. Data point on **Roadway Design Superelevation Report**. In the dialog box, select the **All** button and click **Apply**.

B. A report will appear. Review the output data in **SuperelvationData.xsl** and **SuperelvationStaions.xsl**. The report browser shown in Figure 8-4 shows the Superelevation Station Report.
8.1.5 Apply Shoulder Rollover Lock

To this point, the transverse slope of the roadway has been altered from the center point (CRWN) of the road to the Left and Right Lane points using superelevation controls. Shoulder transverse slopes have remained at slopes as defined in the template. This may result in a sharp change in slope, especially where a full superelevation of +6%, changes to a shoulder with a transverse slope of -6%, resulting in an algebraic difference of 12%.

Shoulder Rollover Locks are used to limit the algebraic difference that can occur between transverse slopes. As a rule, CTDOT limits the rollover algebraic difference to 7% on the high side of a curve, and 0% on the low side of a curve. In the example project, rollover locks will be defined and applied to pavement sections between the shoulder and edge of road points.

A. From the roadway modeler menu, select Superelevation > Apply Shoulder Rollover Locks…

B. From the Apply Shoulder Rollover Lock dialog box, select Shoulder Point: EOR_Lt. Set the following values:

C. Control Line Name: EOR_Lt
D. High Side Difference = 7.00%
E. Low Side Difference = 0.00%
F. Both Maximums are OFF and Station Limits OFF
G. Click Apply.
H. Shoulder Point: **EOR_rt**
I. Control line Name: **EOR_rt**
J. High Side Difference = 7.00%
K. Low Side Difference = 0.00%
L. **Maximums** are OFF and Station Limits OFF
M. Click **Apply** and **Close**.
N. Using the Superelevation Display mode of the Roadway Modeler, view cross sections along the corridor to verify that the transverse slope is working according to the intended design. Figure 8-5 and Figure 8-6 display designs with and without roll over locks.
O. Update the proposed surface with the new data.
P. Open the Surface Properties dialog box and on the advanced tab choose the design surface. For cross sections click on Use Features Only. Click Apply and Close.

![Figure 8-5 No Roll Over Defined](image)
Figure 8-6 Using Roll Over Locks
Section 9  Evaluation

This section will discuss how to evaluate the results of using Roadway Designer. In particular, users will learn how to evaluate results by generating working cross sections and calculating earthwork quantities using the end-area volume method. Users will also learn how to generate a report of cross sectional volumes.

Cross sections are an integral part of design plans. Cross sections are used to display and annotate surfaces and features in a vertical plane. Normal cross sections are cut at a specified interval perpendicular to the mainline geometry. Custom cross sections can be defined at any skew angle where needed. When InRoads is used to its full potential, many of the tedious processes involved in drawing cross sections are automated.

The lab will focus on Average End-Area for volume calculations. End-area volumes can be computed using the cross sectional data stored in the design file. Multiple cross sections must first be extracted and written to the design file. The cross sections must contain data from at least two surfaces. When using the end-area command, select which cross section set to use. The volumes will be based on the surfaces that were displayed with the cross section set. If the graphics move, indicating a change in cross section to surface, the volumes must be recalculated. Use the fill factor parameter to control the factor at which fill volumes are scaled and use the cut factor parameter to control the factor at which the cut volumes are scaled. These parameters can be any positive number.

When creating earthwork quantity reports, control the output units of the cut, fill and net volumes using the software parameters. End-area volume report styles are available.
9.1 **Lab 12 – Working Cross Sections and Volumes**

Before starting this lab the following files will need to be opened if they are not already. If a file does not exist or is not complete open the alternate sister file.

1. **Geometry_Project.alg** or **Completed_Vertical.alg**.
2. **Superelevation.dtm** or **Completed_Superelevation.dtm**
3. **SV_Surface.dtm**

These three files are considered a minimum in order to use create cross sections and volumes.

9.1.1 Creating Working Cross Sections

A. Select **Evaluation > cross sections > create cross section**. Figure 9-1 shows the Create Cross Section dialog box.

![Create Cross Section Dialog Box](image)

**Figure 9-1 InRoads Create Cross Section Dialog Box**

B. Select **Preferences** and load the **Highway**. Close the preferences box.

C. Click on the existing and proposed surfaces.

D. Make sure **Interval** is set to 50.

E. Click **Apply** and data point in the file where to place the cross sections.
9.1.2 Generating End-Area Volumes

A. Select Evaluation > Volumes > End-Area Volume. The Dialog box shown in Figure 9-2 will appear.

![Figure 9-2 InRoads End-Area Volumes Dialog Box](image)

B. Select the name of the cross section set that was just created. A rectangle is displayed around the cross section set in the design file. It may be necessary to zoom out to see it.

C. For the general tab, make sure the existing and Mainline surfaces are checked on.

D. Make sure Create XML Report is checked on, click Apply and then click OK to the next message (see Figure 9-3). Figure 9-4 shows the listing of .xsl reports and Figure 9-5 displays the content of the Basic End-Area Volume report.

![Figure 9-3 Report Browser Message](image)
Figure 9-4 InRoads Report Browser Evaluation Folder

Figure 9-5 InRoads Report Browser Basic End Area Report
E. View the cross sections that have been created. The green shaded area represents fill, and the brown area represents the cut sections. Figure 9-6 shows the cross section with cut and fill sections.

![Figure 9-6 MicroStation Screen Shot of InRoads Generated Cut and Fill](image)

9.1.3 Updating Cross Sections

A. Click on Evaluation>Cross Section>Update Cross Section. Figure 9-7 shows the Update Cross Section dialog box.

B. Select the correct cross section set.

C. Select Display Off.

D. Select Mainline in the surface box.

E. Click Apply and watch the proposed work vanish from the cross section.

F. Now turn them back on.
Figure 9-7 InRoads Update Cross Section Dialog Box
Highway/Facility plan cut sheets will consist of referenced MicroStation design models and survey ground files. The CT DOT Plan Border will be placed in each cut sheet and the reference files will be clipped to show only what fits inside the border. The reference files will remain in its geospatial location and should never be moved. The cell border can be moved to fit around the geospatial location of the clipped reference files. Each plan sheet will show a different area of the project. Lab 14 will discuss in detail how to set up plan cut sheets.

For project consistency line work from the MicroStation design models and survey ground should not be copied in the cut sheet. This rule is vital to the integrity of project as other design units such as Traffic and Structure Bridge are referencing Highway/Facility MicroStation files. The survey ground file resides in the project container in the Survey discipline folder this file should never be copied to any design discipline folder. Users should contact Central Surveys if they need changes made to the survey ground file.

Highway/Facility profiles cut sheets are placed on separate sheets that match the limits of the plan cut sheets. Lab 15 will discuss in detail how to set up profile cut sheets.

Highway/Facility cross section sheets are all placed in one MicroStation file. This file will be created to only display the graphics for cross sections views. Plan and Profile information should not be placed in this file. Lab 16 will discuss in detail how to set up cross section cut sheets.

**Standard Cut Sheet Scales**
- Plan Sheet - scale 1”= 40’, occasionally projects may require the use of 20 scale (example- Culvert Replacement) or 80 scale plan sheets (example - Resurfacing)
- Profile Sheet - horizontal scale 1”= 40’, vertical scale 1”=4’
- Highway Cross Section Sheet - scale 1”= 5’
- Facility Cross Section Sheet - horizontal scale 1”= 5’, vertical scale 1”= .5’

**Lesson Objectives**
In this Volume we will…
- Generate plan sheets & profile sheets
- Annotate InRoads features and alignments on plan and profile sheets
- Place drafting notes on plan and profile sheets
- Generate Cross Sections Sheets
- Annotate Surfaces & Features on Cross Section Sheets
Section 10 Plan and Profile Sheets

10.1 Introduction

10.1.1 Overview of the Plan and Profile Generator

The Plan and Profile Generator command is used to automatically generate plan and profile sheets. It uses an automated reference file attachment system to create the sheets. The reference files are rotated and clipped based on the setup parameters. A clipping boundary is created for each sheet to control the clipping of multiple reference files.

To create plan sheets using The Plan and Profile Generator an InRoads Horizontal Alignment (.ALG) will need to be loaded. If profiles sheets are needed a DTM must also be loaded.

Plan and Profile Generator commands are conveniently grouped under task descriptive tabs. Below is a list of tabs. In general, these tabs simplify the plan and profile generation process. The parameters have been set for all the tabs and saved to the CTDOT XIN file so that only minor set up is required, as shown in Labs 14 and 15.

**Main Tab** – Specifies the type of views to be created and edits the parameters for plan views and profile views in the VDF file.
- Select the alignment to use to define the plan or profile path.
- Input the length of each sheet

**Plan Controls Tab** - Specifies the parameters for the automatic generation of plan views.
- Select which files will be referenced into each cut sheet.
- Enter left and right clipping widths

**Profile Controls Tab** – Specifies the parameters for the automatic generation of profile views.
- Select the surfaces for the elevation shifts
- Select the Profile Preference used for the Grid

**Sheet Layout Tab** - Specifies how the sheets will be created.
- Set up cut sheet file names (Host File)
- Select the seed file used to create each cut sheet (Seed Host File)

**View Layout Tab** – Sets the location of the border cell and scale in each cut sheet.

**Border and Title Tab** – Specifies the MicroStation Cell Border to be used in each cut sheet.

**Symbols and Details Tab** – Specifies how and where the north arrow will be placed.

**Match Lines Tab** - Specifies if and where match lines will be displayed and annotated.

**Sheet Index Tab** – Loads and saves VDF files and displays the sheet index and individual sheets.

**Station Lock**
Can be toggled on and off on the Locks Toolbar. The station lock is normally turned on while working with most InRoads commands but should be turned off when using the Plan and Profile Generator.
10.1.2 CT DOT MicroStation Design Plan Model VS Plan Cut Sheet

This section will describe the function of each type of sheet. The design model file is the main file that Inroads uses to display the 3d model of the design surfaces. The top view of the design model file is referenced into each plan cut sheet. All line work will reside in the design model file. A pay item call outs should never reside in the design model file. A catch basin cell should never reside in the plan cut sheet it should be referenced in from the design model.

**Location of MicroStation Elements**

**Design Model File**
- Drainage pipes, structures and flow lines
- Curbing, EOR, driveway limits and sidewalks
- Slope and grading limits
- Guide rail
- Right of way lines
- Centerline/Baselines
- Patterned areas for milling and seeding
- Structure item such as retaining walls and bridges

**Text**
- Stationing, PC and PT stations, PC and PT coordinates and bearings
- Right of way dimensions
- Lane, roadway, curb return dimensions

**Highway/ Facility Plan Cut Sheet**
- Pay Item Call outs
- Curbing Tables
- Curve data
- Coordinates for intersecting alignments
- Match Marks
- North arrow
- Cell border
- Border Sheet Tags
- Annotation for beginning, end and limits of project
10.2 Lab 14 - Generating Plan Sheets
This Lab will cover the process of creating plan cut sheets using the InRoads Plan and Profile Generator and MicroStation tools.

10.2.1 Start Up
Before starting Labs 14 the following will need to be completed.

A. Labs:
   1-3 Lab 1 – Starting the InRoads Application
   1.6 The first portion on Lab 2 – Project Start Up (1.6.1 Using Automatic Project Defaults)

B. Open InRoads files:
   PP_Alignment.alg.
   PP_Superelevation.dtm
   PP_Sideroad.dtm
   SV_Surface.dtm

C. Open the MicroStation file:
   HW_Final_InRoadsXM.dgn.
10.2.2 Sheet Creation

A. View the horizontal alignment and stationing for Roadway_1 in the MicroStation File. (see Section 4.1.4 and 4.2.3 if you need more direction)

B. Turn off the Station Lock.

C. Click Drafting > Plan and Profile Generator. Click on Preferences at the bottom of the dialog box and choose Highway Plan Bdr Format or Facilities Plan Bdr Format. Figure 12-1 shows the dialog box for the Plan and Profile Generator.

D. Select the Main tab and use the PICK BUTTON and data point on the Horizontal Alignment to run the plans generation along.

Figure 10-1 InRoads Plan and Profile Generator Main Tab
E. Select the **Plan Controls** tab and click **Model Files**. Browse to the **MSta_Design** folder and select **HW_Final_InRoadsXM.dgn**.

F. Toggle on **Nested Attachments**. This will attach the survey ground file to **HW_Final_InRoadsXM.dgn**.

![Plan and Profile Generator](image)

Figure 10-2 InRoads Plan and Profile Generator Plan Controls Tab
G. Select the **Sheet Layout** tab.

- Set the Host File path to `...Highways\MSta_Contract_Sheet_Files` and add the following in the File name space `HW_MSH_999_Student##_PLN-`
- Set the Seed Host File to `...CTDOT_Standards\Standards\seed\2007\CT_Sheet_Civil_2007.dgn`

![Figure 10-3 InRoads Plan and Profile Generator Sheet Layout Tab](image-url)
H. Select the **Border and Title** tab. (See Figure 12.3) In the Border section, toggle on **Cell** and in the name box select **Contract_BDR_Plan**.

I. Select **Apply**.

![Plan and Profile Generator](image)

**Figure 10-4 InRoads Plan and Profile Generator - Borders and Title Tab**
10.2.3 Saving the VDF File

A. To save the information that created the sheets, select **Save As**.

B. Browse to: `\Highways\MSta_Contract_sheet_Files` and type in **Plan_Sheet**. Click **Save**. This will store an ASCII file that has the definitions of how the sheets were created.

![Figure 10-5 InRoads Plan and Profile Generator Sheet Index Tab](image_url)

10.2.4 Viewing the Sheets

A. In the **Show Sheet** section of the dialog box, toggle on **Use Existing**.

B. In the **Sheet Index** section of the dialog box, select, with one click only, **PLN1** and then try **PLN2**.

C. Click **Show Sheet**. The command opens the design file that contains the plan sheet.
10.2.5 MicroStation Sheet Editing

A. On the InRoads Sheet Index Show Sheet **PLN1**
B. Open the MicroStation Level Manager and click the Locked level to be unlocked.
C. Adjust the Border as needed
D. Define the Sheet Layout, Click on Models > Define Sheet layout
E. Turn on Define Sheet Layout, and toggle off origin and rotation
F. The transient shape is now attached to the curser, locate the bottom left of the Plan Border then the bottom right.
G. Delete First Match Mark.
H. Adjust the fence as needed
I. Re-clip the referenced files
J. On the InRoads Sheet Index Show Sheet **PLN2**
K. Repeat Steps B through F
L. Delete the last Match Mark and re-clip the referenced files
10.3 Lab 15 - Generating Profile Sheets
This Lab will cover the process of creating profile cut sheets using the InRoads Plan and Profile Generator and MicroStation tools.

10.3.1 Start Up
Before starting Labs 15 the following will need to be completed.

A. Labs:
   1-3 Lab 1 – Starting the InRoads Application
   1.6 The first portion on Lab 2 – Project Start Up (1.6.1 Using Automatic Project Defaults)

B. Open InRoads files:
   PP_Alignment.alg.
   PP_Superelevation.dtm
   PP_Sideroad.dtm
   SV_Surface.dtm

C. Open the MicroStation file:
   HW_Final_InRoadsXM.dgn.
10.3.2 Sheet Creation

A. Click NEW and Clear the information in the VDF File Name field.

B. Open the MicroStation file HW_Final_InRoadsXM.dgn.

C. On the InRoads main menu go to Evaluation > Create Profile. The dialog box will appear as shown in Figure 12-4. Select the preference Highway Profile Bdr Format. Then select the controls folder and change the bottom Window Clearance to 20. Click the Preferences button and save this change to Highway Profile Bdr Format. Click Close.

D. In the Plan and Profile Generator click on the Preferences at the bottom of the dialog box and choose Highway Profile Bdr Format.
E. Click the **Profile Controls** tab. The Profile Preference should be set to **Highway Profile Bdr Format**. In the Surface section, toggle on the **Existing** surface and the design surface. Figure 12-5 shows the settings in the Profile Control tab of the Plan and Profile Generator.

F. Click on the name **existing** to highlight it blue.

G. Select the **Sheet Layout** tab.
   - Set the Host File name to **...Highways** and add the following name at the end of the path `HW_MSH_999_Student##.PRO`.
   - Set the Seed Host File to:
     - `...CTDOT_Standards\Standards\seed\2007\CT_sheet_civil_2007.dgn`
H. Select the **Border and Title** tab. In the Border section, toggle on **Cell** and in the name box select **Contract_BDR_Plan**.

I. Select **Apply** and follow the prompts.

### 10.3.3 Saving and Using the VDF File

A. To save the information that created the sheets, select **Save As**.

B. Browse to `\Highways\MSta_Contract_sheet_Files` and type in **Profile_Sheet**. Click **Save**. This will store an ASCII file that has the definitions of how the sheets were created.

C. Click in the VDF text box and click **Open**. Browse to the **Plan_Sheet.vdf** and click **Open**. The sheet index will now list the Plan Sheets (PLN1 and PLN2).

D. Click in the VDF text box and click **Open**. Browse to the **Profile_Sheet.vdf** and click **Open**. The sheet index will now list the Profile Sheets (PRO1 and PRO2)
10.4 Lab 16 Plan and Profile Sheet Annotation

This lab will cover the following:

Plan Sheet Annotation
Place Beginning of Project, End of Project, and Limit of Construction notes
Horizontal Alignment Data

Profile Sheet Annotation
Vertical Alignment
Place Beginning of Project, End of Project, and Limit of Construction notes
Label Proposed and Existing Ground
Existing feature

The Storm and Sanitary Drainage items and the Quantity Manager items will be annotated in Volumes III and IV.

10.4.1 Placing BOP, EOP and Limit of Construction Plan notes

A. Open the file HW_MSH_123_1234_PLN-1.dgn
B. Toggle the Pen/Pencil mode lock to Pen.
C. Select Drafting > Place Plan Note.
D. Choose the Plan folder and select the note BOP, click on the bottom right arrow to expand the box.
E. Input the State Project Number and Federal Project Number

F. Click Apply and follow the prompts. Select the Beginning location of the Project and place the note.

G. Choose the Plan folder and select the note Limit of Construction.

H. Click Apply and follow the prompts. Select the side road tie in location.

I. Open the file HW_MSH_123_1234_PLN-2.dgn

J. Select Drafting > Place Plan Note.
K. Choose the Plan folder and select the note EOP, click on the bottom right arrow to expand the box.

L. Input the State Project Number and Federal Project Number

M. Click Apply and follow the prompts. Select the Ending location of the Project and place the note.

10.4.2 Placing Horizontal Alignment Data

A. Select Geometry > View Geometry > Curve Set Annotation.

B. Toggle on Station Limits and use the pick buttons to select the limits of the first curve.

C. On the Main Tab in the Symbology Area double click on Text.

![Figure 10-9 InRoads Curve Set Annotation Dialog Box](image-url)
D. On the text Symbology dialog box. Toggle on View Independent and select Absolute Angle. Set the angle to 0.

E. Click **OK** on the Symbology dialog box. Click **Apply** on the Curve Set Annotation dialog box.

F. Use the MicroStation Move tool to move the placed Curve Data to a blank area inside the cut sheet.

![Text Symbology dialog box](image)

Figure 10-10 Text Symbology for Curve Data
G. Place the curve data for the side roads. In the Curve Set Annotation Dialog box, change the Alignment to Roadway_2 and do not use station limits.

H. Select the Advanced Tab. Enter the Prefix SIDE ROAD CURVE # for curve Number. Select Apply.

I. Use the MicroStation Move tool to move the placed Curve Data to a blank area inside the cut sheet.

![Figure 10-11 Curve Set Annotation Advanced Tab](image)

J. Next annotate the two intersecting alignments. Select Drafting > Place Alignment Intersection Note. Click Apply and follow the Prompts.

K. Close the dialog Box when complete.
L. Open the file **HW_MSH_123_1234_PLN-2.dgn** and annotate the last curve using the **Curve Set Annotation** command.

10.4.3 Placing the Vertical Geometry Annotation

A. Open the file **HW_InRoadsXM.dgn** and use the MicroStation view controls to window in on the Profile.

B. Select **Geometry > View Geometry > Vertical Annotation**. Select the correct Horizontal Alignment and Vertical Alignment.

C. Select the Profile Set. Do not turn on any of the Limits.

D. Click **Apply**. The vertical alignment is annotated. Click **Close**.
10.4.4 Placing the Beginning of Project and End of Project Profile Notes

A. Select **Drafting > Place Profile Note.**

B. Choose the Profile folder and select the note **BOP**, click on the bottom right arrow to expand the box.
C. Input the State Project Number and Federal Project Number

D. Click Apply and follow the prompts. In the profile window data point at the on the first PVI and place the note.

E. Choose the Profile folder and select the note **EOP**, click on the bottom right arrow to expand the box.
F. Input the State Project Number and Federal Project Number
G. Click Apply and follow the prompts. In the profile window data point at the on the Last PVI and place the note.

10.4.5 Label Proposed and Existing Ground

A. Select **Drafting > Place Profile Note**

B. Choose the Profile folder and select the note **Existing Ground call out**, click on the bottom right arrow to expand the box.

C. Click Apply and follow the prompts. In the profile window data point on the line representing the existing ground and place the note.

D. Repeat for **Proposed Grade call out**. In the profile window data point on the line representing the proposed grade and place the note.
10.4.6 Display crossing Features on the Profile

A. Select **Evaluation > Profile > Update Profile**

B. Toggle on **Display On** and click on **Projected Feature**.

C. In the Surfaces area select **existing**

D. In the Crossing Features area select **all the pipe features**.

E. In the Bandwidth Offset area Enter **-200** for the Left Offset and **200** for the Right offset

F. Click **Apply** and **Close**

G. In MicroStation zoom the window to the Profile.

![InRoads Update Profile Dialog Box](image.png)

Figure 10-14 InRoads Update Profile Dialog Box
10.4.7 Label existing features on the profile

A. Select **Evaluation > Cross Section > Annotate Feature In Profile**. Click on **Annotate** and select all the features except the stream features

![Annotate Feature In Profile Dialog Box](image1)

Figure 10-15 InRoads Annotate Feature in Profile Dialog Box

B. Select Points and make sure Feature Description is toggled on. Click **Apply** and **Close**

![Annotate Feature In Profile Dialog Box](image2)

Figure 10-16 InRoads Annotate Feature in Profile Dialog Box
C. Window in on the pipe between 14+50 and 16+30. Use MicroStation tools to clean up annotation. Delete, move, and rotate the text as needed.
D. Use MicroStation and Copy the bottom line of the 15” CMP to the top of the pipe. Copy the line for the top of the 24” RCP
Section 11 Cross Section Sheets

Typically, CTDOT generates cross sections at 50-foot intervals and at each driveway. In the lab exercise below, a standard set of cross sections along the example project mainline will be generated. These cross sections will show the existing ground surface model as well as the proposed surface model. Also, the cross section to CTDOT standards will be annotated.

The typical final cross section sets are cut perpendicular to the mainline horizontal alignment. The original ground surface is represented with a dashed line. The proposed surface is represented with a solid line. InRoads Version 8.7 and later has the ability to draw components for the proposed pavement and curb. Standard final cross sections are annotated with the centerline elevations, transverse slopes of the proposed pavement and roadside.

Final cut sheets can be created using the command Create Cross Sections. This command is used to extract cross sections along the active horizontal alignment. Multiple cross sections are extracted and displayed with the CTDOT standard cell border.

11.1 Lab 17 - Generation Cross Section Sheets

Before starting this lab the following will need to be completed.
Labs:
1-3 Lab 1 – Starting the InRoads Application
1.6 The first portion on Lab 2 – Project Start Up (1.6.1 Using Automatic Project Defaults)

Open InRoads files:
Completed_Vertical.alg.
Completed_Superelevation.dtm
SV_Surface.dtm

The file HW_InRoadsXM.dgn should now be opened in MicroStation XM along with InRoads XM.
11.1.1 Sheet Creation

A. Select **Surface > Surface Properties**. On the Main tab select the surface Superelevation. Select the Advanced tab and change both the Cross Section and Profile symbology to **P_SURF_DESIGN**. Toggle on **Use Features Only**. Click **Apply**.

B. Create a new the MicroStation file in the folder MSta_Contract_Sheet_Files and name it **HW_MSH_123_1234_XSC.dgn**.

C. From the InRoads main menu select **Evaluation > Create Cross Section** and load the InRoads Preference **Highway Xsc Bdr Format**.

C. In the **General** settings, toggle on the surfaces **Superelevation** and **existing**.
D. In the **Include** settings toggle on **Projected Features** and input **25** for Ahead Band and Back Band.
E. Select the **Layout** folder and **Sheet Border**. For the cell name select **Contact_BDR_XSC**.
This cell is being pulled into this list from the cell library CTDOT_Standards workspace \CTDOT_Standards\Standards\cell\CT_xsection_border.cel. If the cell does not appear, Contact_BDR_XSC, and refer to Section 17 behind the scenes.

F. Select Apply and follow the prompts.

![Create Cross Section](image)

Figure 11-1 Create Cross Section - Sheet Creation

11.1.2 Redisplaying Features on Cross Sections

The stream line style and the points may look very big to scale this down set the following.

A. Go to Tools > Named Symbology and edit STREAM

B. Change the Cross Section Line and Cross Section Point symbology as shown below.
### Edit Named Symbology

<table>
<thead>
<tr>
<th>Use</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Line</td>
<td>SV_WATR_STREAM</td>
</tr>
<tr>
<td>Default Text</td>
<td>SV_WATR_WATER_TX</td>
</tr>
<tr>
<td>Default Point</td>
<td>Not Initialized</td>
</tr>
<tr>
<td>Plan Line</td>
<td>Not Initialized</td>
</tr>
<tr>
<td>Plan Text</td>
<td>Not Initialized</td>
</tr>
<tr>
<td>Plan Point</td>
<td>Not Initialized</td>
</tr>
<tr>
<td>Profile Line</td>
<td>Not Initialized</td>
</tr>
<tr>
<td>Profile Text</td>
<td>Not Initialized</td>
</tr>
<tr>
<td>Profile Point</td>
<td>Not Initialized</td>
</tr>
<tr>
<td>Cross Section Line</td>
<td>SV_WATR_STREAM</td>
</tr>
<tr>
<td>Cross Section Text</td>
<td>SV_WATR_WATER_TX</td>
</tr>
<tr>
<td>Cross Section Point</td>
<td>SV_WATR_STREAM</td>
</tr>
</tbody>
</table>

### Line Symbology

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level</td>
<td>SV_WATR_STREAM</td>
</tr>
<tr>
<td>Color</td>
<td>119</td>
</tr>
<tr>
<td>Line Style</td>
<td>STREAM</td>
</tr>
<tr>
<td>Scale</td>
<td>0.1250</td>
</tr>
<tr>
<td>Weight</td>
<td>-0.5 ByLevel</td>
</tr>
</tbody>
</table>

---

135
Go to Evaluation > Cross Section > Update Cross Section and refresh the STREAM crossing and projected features on the displayed cross sections.

11.1.3 Annotating Cross Section Sheets

The Backbone
A. From the InRoads main menu, select Evaluation > Cross Section > Annotate Cross Section (See Figure 12-7).
B. Set the Pen Lock on and Delete Ink Lock Off.
C. Select the Highway preference.
D. Under the General folder, select the Roadway_1 Set and toggle on the Surface Superelevation.
E. Under the Segments folder choose Annotate. Hold the Control Button down and select the features on the backbone. Click the Apply button.
The Sideslopes

F. Select the Highway Xcs Sideslope Annot Preference.

G. Under the Annotate Cross Section folder select General and toggle on the Surface Superelevation.

H. Under the Segments folder / General, make sure the Minimum Annotation Width is set to 1. This will exclude the small curbing sections from getting annotated.

I. Under the Segments folder / Annotate, select all right side features from the EOR_rt out to the cut/fill point. Click the Apply button.
J. Under the Segments folder/Annotate, select all left side features from the EOR_Lt out to the cut/fill point. Click the **Apply** button.
Figure 11-5 MicroStation View of InRoads Annotated Cross Section
Station
Feature Description

Choose PVCE15 and annotate
InRoads has a product add-in Storm & Sanitary, this product has resource files that have been configured with CTDOT standards. InRoads Storm & Sanitary (S&S) has the ability to create physical 3-D models of storm sewer systems within a MicroStation environment. Digital Terrain Models (DTMs), alignments and a customized CTDOT resource files are used to create the models. S&S can analyze or design these systems; however, at this time StormCADD remains the preferred application at CTDOT. S&S is currently being used for layout proposes only, and can be displayed and annotated in plan views, profile views and cross sections sets. A future task of Engineering Applications is to analyze the S&S design output computations and ensure that the CTDOT drainage design standards are met. If the results show that S&S meets the CTDOT design standards, then S&S will be a viable digital design application.
Section 12  SS File Management

The resource file CT_structures.dat has been provided for use. This structure file has been populated with standard CTDOT catch basins and pipes information. The sizes and information match the current standard detail sheets that are provided with the project contract.

After the creation of the 3-D model the drainage system can be displayed and annotated in plan, profile and cross section views.

Prerequisites:

- A 3D MicroStation file populated with roadway and or site features.
- A horizontal alignment in InRoads Format (alg)
- An existing and or proposed DTM’s

12.1 Lab 18 – Getting Started

A. From the InRoads Menu Bar Click Tools > Product Add-Ins. Select Bentley InRoads Storm & Sanitary and toggle on Persist Product Add-Ins on Exit. Select the OK button.

B. Open your RWK (Project File). This should automatically open the alignment and DTM files. If you do not have a RWK, open the ALG and DTM files individually.

C. From the InRoads Menu Bar Click File > New. Select the Drainage Tab. For Type select Drainage Database and type in a name and Description. Click Apply and Close.
D. On the bottom of the InRoads Workspace Bar scroll to the Drainage tab. Right click on the Internal name and click Save As… Type in a file name, Click Save and Cancel. Add this file to the RWK. If you do not have a RWK create one now.

E. On the InRoads Menu Bar click File < New. Select the following:
   - **Type**: User Data Field
   - **Table**: Inlet
   - **Field Type**: Text
   - **Field Name**: Type in the word Suffix. Click the Apply and Close
Figure 12-4
Section 13  Lay Out Tools

The Lay Out Structures command lets you interactively place drainage structures, such as pipes, inlets, and manholes. This command is generally used once you have populated a 3D MicroStation file with roadway and or site features, created a horizontal alignment, and have loaded existing and or proposed DTM’s. After creating your drainage file, use the Lay Out commands to place the structures needed to design your drainage system.

13.1 Lab 19 - Drainage System Layout

Before starting this lab:

- Turn your Style Lock On
- Make the alignment active for the roadway you want to place drainage on
- View needed Proposed Roadway Features
- Window your MicroStation view to the location you would like to start
- Your MicroStation Depth lock turned is off

13.1.1 Placing Catch Basins

A. On the InRoads Menu click Drainage > Lay Out…

B. On the Drainage Lay Out dialog box select the Inlet tab, Click Options… on the bottom of the dialog box
C. Choose Type, standards have been set up for only Grate and Combination.
D. Choose Class. The following page provides detailed information on each selection.

**Combination TYPE "C" CB**
- C CB (ltA) – Left Side with Grate Type A
- C CB (ltB) – Left Side with Grate Type B
- C CB (rtA) – Right Side with Grate Type A
- C CB (rtB) – Right Side with Grate Type B

**TYPE "C", DOUBLE GRATE - TYPE I TOP**
- C CB DBL I (ltA) – Left Side with Grate Type A
- C CB DBL I (ltB) – Left Side with Grate Type B
- C CB DBL I (rtA) – Right Side with Grate Type A
- C CB DBL I (rtB) – Right Side with Grate Type B

**TYPE "C", DOUBLE GRATE - TYPE II TOP**
- C CB DBL II (ltA) – Left Side with Grate Type A
- C CB DBL II (ltB) – Left Side with Grate Type B
- C CB DBL II (rtA) – Right Side with Grate Type A
- C CB DBL II (rtB) – Right Side with Grate Type B

**SPECIAL ROUND TYPE "C" CB**
- RND C CB (ltA) – Left Side with Grate Type A
- RND C CB (ltB) – Left Side with Grate Type B
- RND C CB (rtA) – Right Side with Grate Type A
- RND C CB (rtB) – Right Side with Grate Type B
E. Adjust Depression height for type of curbing being used. Check the latest catch basin details sheets to verify all measurements. After selecting Type, Class and Depression click Apply and Close.

<table>
<thead>
<tr>
<th>2 inch Depression</th>
<th>1 inch Depression</th>
</tr>
</thead>
<tbody>
<tr>
<td>BCLC</td>
<td>Stone Curbing</td>
</tr>
<tr>
<td>BCPC</td>
<td>Granite Slope</td>
</tr>
<tr>
<td>Concrete Curbing</td>
<td>Curbing</td>
</tr>
</tbody>
</table>
F. On the Drainage Lay Out Dialog Box click on the large pick button in the Location area. Select the feature you would like to place the catch basin on. Follow the prompts to accept the input.

G. To place your next catch basin. Click options to change the Type, class or Depression and select your next location
13.1.2 Placing Pipes

H. On the InRoads Menu click Drainage > Lay Out…

I. Click on the Pipe Tab. Select the Options Button… on the bottom of the dialog box

J. Select the desired Shape, Material & size. Click Apply and Close
K. Click on the ID pick buttons to set the Upstream and Downstream Inlets or select the Northing and Easting pick buttons for free ends. Follow the on screen prompts.

L. Adjust Invert In, Invert Out and slope as needed. Click the Apply button.

M. Move on to placement of next pipe, if the shape, size or material is changing click the Options button to modify criteria.
13.1.3 View Drainage Tool

This tool is used to view your drainage network in plan only.

A. Turn style Lock ON.
B. On the InRoads Menu Bar select Drainage > View > Drainage…

Figure 13-8
13.1.4 Annotate Structures Tool

This tool is used to annotate your drainage network in plan only.

A. Turn your style lock OFF. On the InRoads Menu Bar select Drainage > View > Annotate Structures…

B. Click Apply and window your MicroStation view to see the annotation.
13.1.5 Edit/Review Tool

The Edit/Review command lets you modify/review the parameters for InRoads Storm & Sanitary drainage structures.

A. The style Lock Should be ON.

B. On the InRoads Menu bar click Drainage > Edit/Review…, Double click on the pipe or inlet in your MicroStation view you wish to edit

Or

On the Feedback Pane double click on the of type element (Inlets, Pipes) then right click on the ID and select Edit/Review

C. The Edit/Review dialog box will appear, now you can tab through the dialog box and adjust as necessary. Try the Following:

- Review all the information associated with a selected drainage structure.
- Type a description of the structure as well as an installation date and service date.
- Edit values and apply the changes to the structures.

---

Figure 13-11

Figure 13-12

13.2 Structure Tools
Move Structure
The Move Structure command lets you move a junction or structure within the drainage network using a rubber-banding technique. InRoads Storm & Sanitary automatically updates the design to reflect the new locations.

When a junction is moved, the bottom elevation is maintained. If a surface is loaded and if the structure being moved is a manhole or an inlet, the top of the structure is maintained relative to its original position with respect to the surface. For example, if the top of a manhole is 2 feet above the ground surface, the manhole still has that elevation after it is moved; however, its depth is adjusted to compensate for any changes in ground elevation. In all cases, the lengths, slopes, and end coordinates of all connecting structures are updated when a junction is moved.

When a pipe, channel, or culvert is moved, the end of the structure nearest the new location becomes dynamic and the other end remains fixed. At that point, any structure connecting to the dynamic end also becomes dynamic at the junction and fixed on the opposite end. Pipe-to-pipe connections (Y junctions) cannot be moved using the Move Structure command.

Insert Structure
The Insert Structure command allows you to insert manholes and inlets into your drainage network. The insert tool lets you insert a junction into a selected pipe. The selected pipe is divided creating two pipes that meet at the new junction.

Delete Structure
The Delete Structure command deletes a selected structure, including any labels and/or text associated with the structure from the active design.

---

**Bentley InRoads XM Edition**

**Lab 18 - Modify Drainage System**

**13.2.1 Using the Structure Tools**

Use the three tools above to modify your drainage network. Be sure to follow the MicroStation prompts so the new data gets properly input.
13.2.2 User Data for Inlets

The User Data tab on the Edit/Review dialog box lets you enter data specific to each user for each type of structure. A user data field was added in section 14.1, this is where atypical structures are identified. Examples of atypical structures are sumps over 4 feet, overall depth over 10 feet, need for a heavy duty top.

A. Open the Edit/Review Dialog box and click on the User Data Tab
B. In the User Data Field Click Suffix
C. In the User Data Value type in the special type of structure suffix
D. Examples:
   (4' SUMP) (MODIFIED) OVER 10' DEEP WITH HEAVY DUTY TOP

![Edit/Review Inlet Dialog Box]

Figure 13-14
13.2.3 Modify to Existing Survey Styles

The Styles tab on the Edit/Review Inlet and Edit/Review Pipe dialog boxes allows you to select the symbology for structure. The symbology determines how the inlet or pipe will be displayed in the graphics. Each structure and pipe has been predefined with standard proposed symbology. On the Styles tab an existing structure or pipe can be edited to use existing symbology.

A. Edit/Review on an inlet and Change the Point, Vault Inside and Vault Outside to the appropriate E_DRAIN style. Click Apply to save.

Figure 13-15
B. Edit/Review on a pipe and change the Center, Inside and Outside to the Styles as shown, Click **Apply** to save.

![Edit/Review Pipe](image)

*Figure 13-16*
Lab 19 - Profile - Viewing & Annotating Network

Before starting
- Turn your Style Lock On
- Create cut sheet profiles using the Plan and Profile Generator or create a un-cut long Profile used during the design process
- Make the alignment active for the roadway you want to place drainage on
- Window your MicroStation view to the profile display

13.2.4 Viewing a Network

A. On the InRoads Bar Menu select Evaluation > Profile > Create Profile…
B. Click the preferences button. Data point on Proposed Drainage Network and click Load and Close.
C. Network should be toggled on, use the pick buttons to select your main network truck line
D. Make sure “Existing Profile” is toggled on
E. Click Apply and select the profile view you would like to display your network on
13.2.5 Annotating Network

Proposed Drainage

A. On the InRoads Menu Bar Click Evaluation > Profile > Annotate Profile
B. Select the Preference Proposed Drainage Network
C. Select the **Apply** button
Existing Drainage

A. In MicroStation make a section set of all the annotation that should be existing

B. On the Highway Bar menu select Annotation > Profile > Existing Drainage

C. Select these tools to Change the Element Attributes and Text Attributes

13.2.6 Drafting Notes

Before starting
- On the InRoads Menu Bar click Tools > Options…
- Click on the Precision tab and Change Linear to 0
• Click Apply

A. On the InRoads Menu Bar Click Drafting > Place Profile Note

B. In the Note File Area Select the Profiles folder then the Storm and Sanitary Folder

C. Click on the note you would like to place. Select the Apply button and follow the prompts

Pre-defined Notes
Existing Pipe – leader
Existing Pipe - no leader
Existing Structure
Existing Structure w/ suffix
Proposed Pipe – leader
Proposed Pipe - no leader
Proposed Structure
Proposed Structure w/ suffix

Figure 13-21

Figure 13-22
Lab 20 - Cross Section – Viewing and Annotating Network

Before starting
- Turn your Style Lock On
- Create Cross Sections in a MicroStation view
- Make the alignment active for the roadway you want to place drainage on
- Window your MicroStation view to the cross section display

Update Cross Section
A. On the InRoads Menu Bar Select Evaluation > Cross Section > Update Cross Section
B. Select the correct **Cross Section Set** and the **Storm and Sanitary** folder
C. Toggle **Display ON**
D. Select the Crossing and Projected items you would like to display
E. For bandwidth select Redefine and enter 25 for both back and ahead bandwidth
F. Click **Apply**

---

**Figure 13-23**
13.2.7 Drafting Notes

Before Starting
- On the InRoads Menu Bar click **Tools > Options…**
- Click on the Precision tab and Change Linear to 0
- Click **Apply**

A. On the InRoads Menu Bar Click Drafting > Place Cross Section Note
B. In the Note File Area Select the Cross Section folder then the Storm and Sanitary Folder
C. Click on the note you would like to place
D. Select the Apply button and follow the prompts
E. Notice the Grate elevation takes in account the Depression (for Types “C-L” you will have to manually put in the depression)
Viewing Thickness of Pipe Material

A. On InRoads Menu Bar select Tools > Style Manager
B. Select P_Drain_Pipe_Outside
C. Select Surface Feature > Settings and toggle On the Items shown on the right
D. Click Apply and Close
E. Update your Cross Section Views

Final Editing
After using the drainage editing tools all profiles and cross sections views with drainage plotted on them will need to be refreshed with the updated network info.

Use the following Tools
- Evaluation > Profile > Update Drainage Profile
- Evaluation > Cross Section > Update Cross Section

All annotation will have to be deleted and redisplayed.

13.3 Lab 21 - Viewing Drainage as Solids

A. Turn Style Lock Off
B. On the InRoads Menu Bar select Tools > Application Add-Ins View Drainage as Solids Add-In
C. On the InRoads Menu Bar select Drainage > View > Drainage as Solids…
D. Toggle needed items
E. Click Apply and Close

![View Drainage as Solids](image)

Figure 13-26
F. On your MicroStation view control select Display Mode Smooth
Figure 13-27

Figure 13-28
Section 14  Drainage Design

14.1 Future
Volume IV – InRoads Quantity Manager
Section 15  QM File Management

15.1 Future

Section 16  QM Tools

16.1 Assign Pay Items

- Use the InRoads tool “Remove User Data” and remove the plan display drainage elements from Storm and Sanitary so it can be added to Quantity Manager.
- On the InRoads Menu Bar select Quantities > Assign Pay Items
- Click on the Pay Item Button and browse to the needed catch basin or pipe pay item
- Type in a name for the Pay Item
- Click the Apply button and choose the MicroStation Elements that correspond with the pay item.
- Data Point Twice to accept input and right click to finish.

- Move on to the next item; type in a new name
- Data point on the old pay item and click the delete Pay Item button
- Now add the new pay item by clicking on the Pay Item button
- Click Apply and follow the Prompts  From the InRoads Menu Bar select Quantities > Review/ Edit Pay Items
Scroll through the list and watch the MicroStation Element Highlight
Edit as necessary
If an element was needs to be deleted use the “Remove User Data” tool

Plan Sheet Call outs

Open your plan cut sheet file
On the InRoads Menu Bar select Tools > Options and change the Precision for Linear to 0
On the InRoads Menu Bar select Drafting > Place Plan Note
Use the predefined notes under the plan folder to place your call outs
Section 17  QM Reporting

17.1 Future
Appendix A Behind the Scenes

Cell Library List
InRoads looks for cells from MicroStation Cell Library Lists. These lists can be found if you click on Workspace-Configuration-Cells-Cell Library List. Below Cell Library List, is a MicroStation screen-shot of the directories included in the Cell Library List.

For Designers to utilize InRoads DTM features you will need the following paths assigned to your Cell Library List:
…\CTDOT_Standards\Standards\cell\2007\*.cel
…\Highways_Workspace\Standards\cell\*.cel
…\Survey_Workspace\Standards\cell\SV_V8_levels_40e.cel

Figure App A - 1Cell Library List
Level Libraries

The InRoads Symbology Manager places all features By-Level so the Highway DGN Library List needs to be mapped. Below DGN Library List, is a MicroStation screen-shot of the directories included in the DGN Library List. These lists can be found if you click on Workspace-Configuration-Primary Search Paths-DGN Library List. The paths to the DGN libraries should be listed here.

For Designers to utilize InRoads the Symbology Manager you will need the following paths assigned to your DGN Library List:

…\Highways_Workspace\Standards\dgnlib\ *.dgnlib
…\CTDOT_Standards\Standards\ dgnlib \*.dgnlib

Figure App A - 2DGN Library List
APPENDIX A

Custom Highway Toolbars

Below Highway’s Custom InRoads Toolbars is a windows screen-shot of the custom toolbars. The custom toolbars can be found in …\CTDOT_InRoads_RSC\Toolbars. These toolbars help to automate workflows instead of having to search through the InRoads pull down menus for tool selections.

Figure App A - 3 Highway’s Custom InRoads Toolbars
Appendix B  Self-paced Training

This manual can be used as both a self-paced tutorial and a course book for formal instructor-led training. The procedures below describe how to set up self-paced training projects for both CTDOT staff and outside Consultants.

A. Use a browser to navigate to the workspace and then go to \\CTDOT_Standards\InRoads_XM_RSC\Training\999_Student01_2007

B. Copy the 999_Student01_2007 folder to your D drive.

C. When opening MicroStation choose the 999_Student01_2007 project located in the bottom right hand corner of the MicroStation Manager as shown in Figure App B - 1 (Consultants will need to create this project, please refer to the 2007 DDE).

D. Browse to your D:\ 999_Student01_2007\Highway\MSta_Design and open HW_InRoadsXM.dgn

E. Set up the Project Defaults using the Conventional Method in Section 3.

Figure App B - 1 Bottom Right Corner of MicroStation Manager