Using LiDAR Data to Create InRoads SS2 Digital Terrain Models

The SELECTSeries Digital Design Environment
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Introduction</strong></td>
<td>2</td>
</tr>
<tr>
<td>1.1</td>
<td>Required Versions</td>
<td>2</td>
</tr>
<tr>
<td>1.2</td>
<td>Workflow Description</td>
<td>2</td>
</tr>
<tr>
<td>1.3</td>
<td>File Formats</td>
<td>2</td>
</tr>
<tr>
<td>1.4</td>
<td>Flow Chart</td>
<td>3</td>
</tr>
<tr>
<td>2</td>
<td><strong>LiDAR Data Retrieval</strong></td>
<td>4</td>
</tr>
<tr>
<td>2.1</td>
<td>Retrieving LiDAR Data from NOAA</td>
<td>4</td>
</tr>
<tr>
<td>2.2</td>
<td>Downloading and Saving the LiDAR Data Set</td>
<td>9</td>
</tr>
<tr>
<td>3</td>
<td><strong>Point Clouds</strong></td>
<td>10</td>
</tr>
<tr>
<td>3.1</td>
<td>Creating a 3D DGN File</td>
<td>10</td>
</tr>
<tr>
<td>3.2</td>
<td>Creating Point Clouds from LiDAR Data</td>
<td>12</td>
</tr>
<tr>
<td>3.3</td>
<td>Point Cloud Display</td>
<td>14</td>
</tr>
<tr>
<td>4</td>
<td><strong>Point Reduction Methods</strong></td>
<td>15</td>
</tr>
<tr>
<td>4.1</td>
<td>Reducing the Area and Density of POD Files</td>
<td>16</td>
</tr>
<tr>
<td>4.1.1</td>
<td>Area Reduction</td>
<td>16</td>
</tr>
<tr>
<td>4.1.2</td>
<td>Density Reduction</td>
<td>17</td>
</tr>
<tr>
<td>4.2</td>
<td>Data Acquisition Filter Descriptions</td>
<td>18</td>
</tr>
<tr>
<td>5</td>
<td><strong>InRoads Surface Tools</strong></td>
<td>20</td>
</tr>
<tr>
<td>5.1</td>
<td>Using Data Acquisition</td>
<td>20</td>
</tr>
<tr>
<td>5.2</td>
<td>Creating an InRoads DTM</td>
<td>22</td>
</tr>
<tr>
<td>5.3</td>
<td>Displaying InRoads DTM Graphics</td>
<td>23</td>
</tr>
<tr>
<td>6</td>
<td><strong>Appendix</strong></td>
<td>26</td>
</tr>
<tr>
<td>6.1</td>
<td>More about Point Clouds</td>
<td>26</td>
</tr>
<tr>
<td>6.2</td>
<td>When and Why Should Points be Reduced</td>
<td>27</td>
</tr>
</tbody>
</table>
Section 1  Introduction

1.1 Required Versions
MicroStation V8i (SELECTseries 4) - Version 08.11.09.832
InRoads V8i (SELECTseries 2) - Version 8.11.07.615

1.2 Workflow Description
This Workflow was developed for use with network drives (X-Drive) projects to instruct designers on how to retrieve 2016 LiDAR data from the online NOAA Data Access Viewer to create an InRoads SS2 digital terrain model (DTM). Prerequisites for using this workflow include basic MicroStation and InRoads knowledge.

1.3 File Formats
Statewide LiDAR can also be found in several locations. Keep in mind file formats found on websites might not be compatible with MicroStation V8i. Statewide LiDAR compatible with MicroStation V8i can be found in two places.

- **NOAA website - 2016 Flight**, available at [https://coast.noaa.gov/dataviewer/#/lidar/search/](https://coast.noaa.gov/dataviewer/#/lidar/search/)  Data is retrieved and downloaded from the website and then imported into a MicroStation Point Cloud POD file.

- **ProjectWise – 2004 Flight**, available through the Aerial Tools Application that runs inside of MicroStation and gets attached as a MicroStation Point Cloud POD file.

### Known Locations of Connecticut LiDAR Data

<table>
<thead>
<tr>
<th></th>
<th>Combatable with MicroStation V8i</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ProjectWise</strong></td>
<td></td>
</tr>
<tr>
<td>Statewide 2004</td>
<td>YES</td>
</tr>
<tr>
<td>5 FT Point Clouds</td>
<td></td>
</tr>
<tr>
<td><strong>NOAA Website</strong></td>
<td></td>
</tr>
<tr>
<td>2016 CRCOG LiDAR: Connecticut Statewide Points – ASCII X,Y,Z Pts</td>
<td>YES</td>
</tr>
<tr>
<td>2016 CRCOG LiDAR: Connecticut Statewide Points - LAS</td>
<td>NO</td>
</tr>
<tr>
<td>2016 CRCOG LiDAR: Connecticut Statewide Points - LAZ</td>
<td>NO</td>
</tr>
<tr>
<td><strong>UCONN/CT ECO</strong></td>
<td></td>
</tr>
<tr>
<td>Statewide 2016 DEM</td>
<td>NO</td>
</tr>
<tr>
<td>Statewide 2016 LAS</td>
<td>NO</td>
</tr>
</tbody>
</table>
1.4 Flow Chart

RETRIEVE DATA → DOWNLOAD DATA → CREATE DGN → IMPORT DATA

CREATE TERRAIN → POINT REDUCTION OPTIONAL → CREATE INROADS SS2 DTM
Section 2  LiDAR Data Retrieval

2.1 Retrieving LiDAR Data from NOAA

1. Go to the NOAA Data Access Viewer and search for your location. 
   https://coast.noaa.gov/dataviewer/#/lidar/search/

2. After entering a location or address the viewer may make the map zoomed in too far, you may need to zoom out a bit to see the map information.
3. Click the **Draw Search Area** icon. Click and drag from left to right to create a selection area. The area should be shaded.

4. To select a data set, click the **Cart** icon next to the **2016 CRCOG Lidar: Connecticut Statewide** data set title. The cart icon in the upper right should update and show the number of items added.
5. Click on the **shopping cart icon**. The MY CART page should appear, the data source you selected should be shown. Click **Next**.
6. The next page shows projection options. Set the *Projection, Datum and Unit fields* to those matching your survey ground file, if you do not have a survey file select NAD83 and NAVD88. Set the Output Options:

*Output Product: Point*

*Output Format: Points – ASCII X,Y,Z Pts.* then Click *Next.*

**NOTE:** If your survey is Horizontal Datum NAD27 and Vertical Datum NAVD88 extra steps will need to be completed in MicroStation as this is not an option on the NOAA website as it is a rare occurrence. In this case select the Vertical Datum NGVD29 and see AEC Applications for help with the vertical transformation.
7. On the next page enter your state email address. Click **Next**.

8. Review your selections and if correct, click **Submit**.

9. Take note of the *order number* provided on the confirmation page and make a note for the location, this will make it easier to sort out emails received later with the data links.

Your order number is **255156**. You will receive an email at **my.name@ct.gov** when your order has been processed, with a link to retrieve the data.

If you have questions about your request, contact us at **ocm.dds@noaa.gov**
2.2 Downloading and Saving the LiDAR Data Set

1. The first email you receive from Digital Coast is a confirmation of the data request. No action needs to be taken with this email. The second email contains the download link (keep in mind this link will eventually expire) for the data. Click the link in the email and save the zip file to your project. The third email you receive also contains links to the same data in the second email. This email can be ignored. Emails may take a few minutes to receive; your wait time will be longer for larger data sets.

2. After clicking the link, Select Save as. Browse to your project folder and the appropriate subfolder for your unit. Click Save.

3. In window explorer select the zip file, right click and choose Extract All. The files will extract into a folder and contain a .txt file(s) and an .xml file.

4. Erase the zip file once the files are extracted, once the files are unzipped the zip version is not needed.
Section 3  Point Clouds
In this section you will create a 3D MicroStation file used for the LiDAR data import. This DGN file will be used to pull the LiDAR data in to a Point Cloud MicroStation POD file.

3.1 Creating a 3D DGN File

1. Open MicroStation through accounting. Do not use an existing file that has elements already in it, this could slow the processing up when an InRoads DTM is getting created and displayed.

2. Create a brand new 3D MicroStation file using the correct seed file. Select the 3D geospatial seed file that matches your datum from the following path W:\Workspace\Standards\seed\Geospatial\ Follow the prompts to name and open the new file.

3. On the MicroStation main menu select Tools > Geographic > Select Geographic Coordinate System.
On the Geographic Coordinate sytem tool box select Edit Reprojection Settings.
4. On the Reprojection Settings dialog box set *Reproject Elevations* to *Yes* on both the Reference and Active Model tabs.

![Reprojection Settings dialog box](image1)

5. If you downloaded a 1983 State Plane data set with NAD83 horizontal information and chose a vertical datum of NGVD29 (rather than the typical NAVD88) you will need to adjust the Vertical Datum setting in MicroStation before importing the points.

   A. On the MicroStation main menu select *Tools* > *Geographic* > *Select Geographic Coordinate System*. On the Geographical Coordinate System tool box select *Details*.

   ![Geographic Coordinate System tool box](image2)

   B. On the Geographical Coordinate System Properties dialog box change the Vertical Datum to *National Geodetic Vertical Datum of 1929* and select *OK*.

![Geographic Coordinate System Properties](image3)
C. On the Geographic Coordinate System Changed dialog box select Reproject the Data to the new Geographic Coordinate System and select OK.

D. On the MicroStation main menu select File > Save Settings.

3.2 Creating Point Clouds from LiDAR Data

1. In MicroStation select the Point Clouds Icon.

2. The Point Clouds dialog will appear, Click the Attach button.

3. Windows Explorer dialog box will appear, browse to select the text files that were downloaded from the NOAA site. Change the Files of Type: to ASCII Files (*.txt) and select one or many files at once and click Open.
4. A dialog for converting ASCII will open, make sure the columns are set to x, y, z as shown below and make sure the geometry units are set to *survey feet* if the job is in English and *Meters* if the job is in metric. Click **OK**.

5. The save dialog will appear, save the file as a .pod file.
6. Click **Fit View** to see the points.
3.3 **Point Cloud Display**

1. Select the View Attributes icon on your View window.

2. For Point Cloud Presentation select *Elevation*.

3. To change the display click on the Magnifying Icon under Point Cloud Presentation. Select the desired look under *Depth* and *Colorization* and click *Save Settings*.

Tip: You can also set this from the Point Clouds dialog, choose *Settings > Presentation* and select Elevation. Right click to apply to open views.
Section 4  Point Reduction Methods
MicroStation can handle displaying very large Point Cloud POD files but InRoads SS2 cannot necessarily handle this amount of data. The points in the 2016 LiDAR are very close together so you may experience issues when trying to create or view an InRoads SS2 Surface created from the POD files that have not been reduced. When creating a surface from the LiDAR data a triangle is created to every point. For large data sets you will need to reduce the points in order to create the needed surfaces. InRoads support does not explicitly set a maximum size, so it is really just a function of the amount of free memory on the machine, and the amount of memory that the OS allocates to the program.

AEC Applications ran trials and suggests getting the number of points down to approximately 2 million in order to have a workable InRoads SS2 DTM. If the file you originally downloaded from NOAA is about 20 MB or less, skip to Section 5. If you have a very large area which contains multiple point clouds or the file from NOAA was larger than 20 MB the .pod file will need to be reduced. To be able to create and view the graphics of an InRoads DTM the point cloud needs to be reduced to about 2 million points.

This workflow shows two methods to reduce the amount of points before creating an InRoads SS2 DTM.

1. Point Cloud Export Tool
   - Reducing the Area of the point cloud
   - Reducing the Density of the point cloud
2. InRoads Data Acquisition Tool
   - Filtering the data on import
4.1 Reducing the Area and Density of POD Files

A point Cloud can be clipped and the density of the points can be filtered down. This reduction will need to be done on large data sets in order to have a manageable size DTM.

4.1.1 Area Reduction

1. First we will work on reducing the area of the POD files. Review the point clouds and place a boundary around the needed area. In the Point Clouds dialog box select Edit > Clip, Select Boundary Mode and the desired placement method and follow the prompts to clip the point cloud. This only clips out the display of the points. The points still exist in the point cloud, they are just hidden. To remove the points the point cloud will need to be exported and saved as a new file.

2. Highlight all the point clouds and select File > Export. In the Export Point Cloud box set the following:
   - Format = Pointools POD (*.pod)
   - Region Filter = Clip
   - Density = 100
   - Click OK.

3. When the next box appears select your project folder and rename the clipped POD file. Click Save.

4. Open the Point Clouds dialog box and select the newly created POD file. To see how many points are in the point cloud right click on the highlighted files in the point cloud window and select Element Information from the dropdown.

5. In the element information pane look at the metadata section, the number of points should be listed.
4.1.2 Density Reduction

1. To further reduce the size of the point cloud we will also need to reduce the density. In the Point Cloud window select File > Export.

2. The Point Cloud Export window will appear, set the format to .pod, and select a lower density or enter a lower density into the density field. To determine which density to input, perform the following calculation: 2,000,000/ number of points in your point cloud = ?. Convert the resulting decimal to %. Select the closest density setting to this number, or type in this density.

3. Click OK in the Export Point Cloud Window.

4. The save dialog will appear. Save the file as a .pod file and name it to indicate the amount reduced.

5. In the Point Cloud dialog box attach the new POD file and compare. Make sure you are happy with the density of the new POD file. The key is to flush out as many points as necessary but still maintain the same basic contour lines.

   When you are satisfied detach all the unneeded POD files.

6. Check to see how many points the reduced point cloud contains. Open the Point Clouds dialog box and select the newly created POD file. To see how many points are in the point cloud right click on the highlighted files in the point cloud window and select Element Information from the dropdown.

7. In the element information pane look at the metadata section, the number of points should be listed. If you are satisfied with the size move on to Section 5.

In this Example the point cloud has 3,261,629 points.

\[
\frac{2,000,000}{3,261,629} = 0.61 = 61\%
\]

Select 60 from the density dropdown or enter 61 into the field.
### 4.2 Data Acquisition

#### 4.2.1 Filter Descriptions

InRoads SS2 has a tool located on the Task Menu called Data Acquisition. This tool is used to bridge the transition on Point Cloud Data to InRoads DTM creation. This tool also has point reduction tools. Follow the steps in [Section 5](#) to use Data Acquisition to further reduce the data.

The **Tile Filter** uses an algorithm that divides the LIDAR data set into tiles. A best fit plane is calculated for each tile, and LIDAR points are removed if they fall within the user set Z tolerance to the plane.

The **TIN Filter** first separates the LIDAR points into tiles with a maximum of 2 million points and then repetitively triangulates each tile, filtering out points. The TIN Filter algorithm filters out the points if they fall within the user set Z tolerance of the triangle planes.

**No Filter** – No filtering is applied

**Z Tolerance** - common to both algorithms and is basically the variation in the Z coordinate that the surface is allowed to move during the filtering process. Typically for the first invocation of the filtering function, the Z tolerance should be set from 0.5 to 1.0 for imperial data sets and from 0.25 to 0.5 for metric data sets. Depending on the outcome and the desired result, the Z tolerance can be varied up or down.

**Max. Tile Points** - specifies that a tile will not be subdivided if it has less than this number of points. Typically this is set to five.

**Max. Tile Divisions** - the allowable level of recursion allowed and is the number of time the initial tiling set can be subdivided. Typically this is set to five.

**Start Tile Length** – The LIDAR data set is initially divided into tiles of this size, prior to recursion to the minimum tile points. The setting of this parameter requires some knowledge of the distance between the LIDAR points, which requires an inspection of the LIDAR points in MicroStation to determine. Typically set this to 10 times the distance between the LIDAR points.

**Course Filter** *(TIN option only)* – Filter more points with some blurring of ridges and valleys

**Fine Filter** *(TIN option only)* – Filters fewer points with less blurring of ridges and valleys

**Points Before Filter/Points After Filter/Reduction %** - Display of the number of points before and after filtering, plus the percentage reduction of points from before and after.
4.2.2  BENTLEY SUGGESTED SETTINGS FOR POD FILE IMPORT

In the Create Terrain From Point Cloud dialogue box
- Always use the “Tin Filter”.
- Input the “Z” Tolerance.
- Always use the “Coarse” option.
- Always use “Reinsert Points” option.
Section 5  InRoads Surface Tools

5.1 Using Data Acquisition

1. Select the point cloud in the point cloud window. In the Tasks toolbar in MicroStation go to Data Acquisition and click the Data Acquisition tool.

2. The Data Acquisition toolbox should appear, right click on the surface fields and select Create Surface... > Import from Point Clouds.
3. The Point Clouds Surface box will appear. If you did your reduction in the Point Clouds dialog box select **No Filter** and click **Accept**. If you still need to do a reduction select the desired Filter Option, **Tile Filter** or **Tin Filter** and enter in the tolerances. Select the **Filter** button to test the reduction, when you are happy with the results click **Accept**.

![Point Clouds Surface dialog box](image)

4. In the Data Acquisition box browse to your **newly created surface > Features**, expand the list check the **Major Contours** and **Minor Contours**. Spot check the contours against the point cloud.

![Data Acquisition box](image)
5.2 Creating an InRoads DTM

5. Right click the point cloud surface and go to *Export to... > InRoads DTM.*

6. A Save As dialog will appear, **Save** the DTM.

7. Before moving to the next step, exit MicroStation completely to clear the memory on the computer.
5.3 Displaying InRoads DTM Graphics

1. Open MicroStation through accounting and open and/or create a new design file, using one of the seed files below.
   
   W:\Workspace\Standards\seed\CT_Design_3D_V8i.dgn
   W:\Workspace\Standards\seed\CT_Design_3D_V8i.dgn

2. Activate InRoads Suite.

3. Open the DTM that was created. Right click on the surface and select **Triangulate**.

4. On the InRoads dialog box go to **Surface > View Surface > Perimeter**. On the View Perimeter dialog box load the Survey Preference, select the LiDAR surface and click **Apply**. Fit View and the perimeter will appear in your MicroStation view window.
5. To view contours, navigate to **Surface > View Surface > Contours**.

![Contour View in Bentley InRoads](image1.png)

6. On the View Contours dialog box click the **Preferences...** button. Select the **Survey** preference and click **Load**, then click **Close**. Before displaying the contours settings consider making adjustments to the display settings.

![View Contours Dialog](image2.png)
7. If you have a very large DTM you may need to adjust the contour settings to be able to view the contours. Click through each tab on the View Contours dialog box and adjust as needed. Adjusting one or many settings will help speed up the display and minimize crashing.

Main Tab
- Increase the contour interval and decrease the Minors per Major
- Turn off the Label display

Advanced
- Turn off Smooth

Labels
- Increase the text label spacing
- Uncheck the clipping box for labels

6. Select the desired surface settings and click Apply. The contours will appear in your window.
6.1 More about Point Clouds

A point cloud is a data file which can include a large number of points on the surface of an object. A point cloud is a set of vertices in a 3D coordinate system and these vertices are defined by X, Y and Z coordinates. Point clouds are usually created by 3D scanners. These devices measure a large number of points on the surface of an object and output a point cloud as a data file (*.POD). The point cloud represents the visible surface of the object that has been scanned or digitized. Point clouds are used for many purposes, especially to confirm measurements between the DGN model and the real world.

The Point Clouds tools allow you to import, control, visualize and manipulate point cloud images. You can import a point cloud into a DGN and use it as a visual reference. The Point Cloud dialog (File > Point Clouds), along with the Point Cloud toolbox (Tools > Point Cloud), lets you control all aspects of attaching and manipulating point cloud image files. A point cloud is treated as any standard element and can be part of a model or level. MicroStation Point Clouds are POD files, this format allows you to work with huge point clouds with great performance.

You can open multiple point cloud files simultaneously. Also, you can batch convert multiple point clouds files either to one POD file, convert the data to ASCII format or create a terrain model.
6.2 When and Why Should Points be Reduced

MicroStation can handle displaying very large Point Clouds POD files but InRoads SS2 cannot necessarily handle this amount of data. The 2016 LiDAR has points very close together. You may experience issues when trying to create an InRoads SS2 Surface from the POD files as the DTM cannot handle the same amount of data points as a point cloud. When creating a surface from the LiDAR data a triangle is created to every point. For large data sets you may need to reduce the points in order to create the needed surfaces.

When creating surfaces from point cloud data it is important to answer the following questions:
- What is the data being used for?
- How large of an area will be used?
- Is the area very flat, or very hilly?

How you answer these questions will affect how the data is manipulated. What the data is being used for is the most important of these questions, because it is directly affected by the level of detail in the data. If the LiDAR is being used as a starting place to determine sightlines, or large drainage calculations such as time of concentration, a less detailed surface is probably fine. If the surface is being used to figure out drainage issues on a small scale such as catch basin placement, the LiDAR surface may need to be fairly detailed. The size of the area is also important, for example, a very large area will need to have the number of points reduced to be able to create a DTM, however if the area is very flat, reducing the number of points too much could cause the contours to not show up properly or not be clearly representative of the area. In this case the area would need to be broken up and have multiple DTMs made to keep the level of detail of the surface, while keeping the file size manageable. A large hilly area may not be as affected by a reduction of points because the contours can still be interpolated properly. All data acquired through this process should only be used for preliminary designs.

The example below shows an area with a drainage channel and how reducing the points can cause the resulting contours to become somewhat misleading if not looked at carefully.

![Figure 1 - Image of the Drainage channel](image_url)
Figure 2 - Overlay of Survey Data on drainage channel

Figure 3 - Contours from surface with no reduction in points - channel is distinguishable
Figure 4 - Contours from surface with 90% reduction in points - channel is still distinguishable

Figure 5 - Contours from surface with 99% Reduction in points – channel is not distinguishable
Figure 6 - Zoomed in section with all contours overlaid on one another.
The opposite can also be true; sometimes too many points can be detrimental. The example below shows a section of Bradley Airport, the first surface is not reduced, the second surface is reduced by 99%. Too many points in this case, makes the slight dips in this very flat area appear to be craters in the surface when just looking at the contours. The second surface is more useful in this instance by getting rid of the extraneous points that give the impression of high and low points.

Figure 7 - Unreduced Surface with Zoom in of Contours

Figure 8 - Surface with Points Reduced 99% with Zoom in of Contours