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 INTRODUCTION  

The purpose of this manual is to introduce CTDOT users to  the latest OpenRoads technology. AEC Applications 

provides an OpenRoads Managed Workspace through the use of ProjectWise. This workspace provides the 

standardization users will need to prepare their design. All OpenRoads projects will be done in the 

ProjectWise (PW) document management system environment and will use Managed Workspaces to implement 

the latest CTDOT CADD Standards. 

Bentley ProjectWise (PW) is a collaborative environment which allows all parties involved in the project to 

use live data and to make real time decisions. It also allows CAD support to immediately update or edit any 

necessary Workspace resource.  All CTDOT employees should have a ProjectWise account.  If you do not, or if 

you experience difficulties logging in, please contact Julie Annino via email:  Julie.Annino@ct.gov 

When starting a new OpenRoads Project do not copy over or open any DGN files that were used on the X 

Drive, these files do not use the correct  settings.  You may reference them in as needed but using them and 

running OpenRoads will cause problems.  

Selecting the Bentley Institute Icon throughout this manual will l ink users to training videos on the Bentley 

LEARNServer.  These videos are part of the OpenRoads Technology – Getting Started Learn Path.  

Before getting started AEC recommends viewing these first 2 videos to get acclimated with the application 

and the terms used throughout this guide.  

 

Understanding 

OpenRoads technology 

Become Famil iar with 

the OpenRoads 

Interface and Tools 

mailto:Julie.Annino@ct.gov
http://learn.bentley.com/app/Public/ViewLearningPathDetails?lpId=106057
http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=106057&CourseId=115710&MediaID=5007163
http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=106057&CourseId=115709&MediaID=5007162


 

 

The steps in this chapter will only have to be done at the initial startup and then if again if a user gets 

upgraded software, they receive a new computer, or their computer has to be reimaged. The Steps in Chapter 

2 will need to be completed for every new project a user works on.  

Verify Software Installations  Step 1  

Verify that the required software versions have been installed on your computer by navigating to the 

Windows Start Menu and typing Programs into the search field. Select Show which programs are installed on 

your computer from the search results.   This wil l open the Contro l Panel’s Programs and Features which lists 

the names and versions of the installed programs. 

The required versions are as follows:  

ProjectWise Explorer V8i (SELECTseries 4) - Version 08.11.11.566  

MicroStation V8i (SELECTseries 4) - Version 08.11.09.832  

Bentley InRoads Suite V8i (SELECTseries 4) - Version 08.11.09.872 

 

 ProjectWise Set Up Chapter 1



 

 

Create a ProjectWise Desktop Shortcut Step 2  

1.  Select All Programs > Bentley > ProjectWise V8i.   

2.  Right click on ProjectWise Explorer and select Send to> Desktop. 

 

 

 
 
 

Log in to ProjectWise Step 3  

1.  Double click on the newly created ProjectWise Explorer 

Icon as shown above. 

2.  From the ProjectWise Explorer main menu, select 

Datasource > Log in… 

3.  Enter your User Name and Password then select the Log 
in button. 

4.  Browse to locate your Project under  
Documents\01.0 - Projects – Active 

5.  Become familiar with the new project folder structure, it 
is quite different than how the X drive was structured. 

Two important folders will be the Highway and Survey 
folders. 
330_Design_Data\Highways 

500_Pre_Design\03_Central_Survey 

 

 

 

 

 



 

 

Adjust ProjectWise Explorer Settings Step 4  
 
1.  If the Interface and View are not 

displayed, navigate through the main 

menu select View > Toolbar and toggle 
them on. 

 

 

 

 

 

2.  ProjectWise Explorer has Interfaces 
and Views to display certain attributes.  

Ensure that:  
Interface is set to CTDOT_Doc_Code  
View is set to Document 

 

 

3.  On the ProjectWise pull  down menu select 

Tools > Options ,  Select  the Settings  tab 

and uncheck Use URN Links.  Click Apply 

and OK.  

 



 

 

Configure ProjectWise Open With  Step 5  

User Program Associations must be removed in order for MicroStation platforms and user workspaces to 

function properly.  [Note: There is presently a service ticket filed for this]  

1.  From the ProjectWise Explorer main menu, 

select Tools > Associations > Programs  

 

 

 

 

2.  From the Program Associations dialog box, 

change Select an association view to User 

associations.  Scroll down to MicroStation.   

Note: In this case, MicroStation has its 

own unique icon displayed. (This is not the 

case for other programs such as MrSid and 

Outlook Message.)  This indicates that 

there are User associations activated 

which must be removed.   

3.  Expand the MicroStation tree to display 

Open, Viewer, & Markup.  If the 

MicroStation icon is just a generic icon 

that looks like a notepad, skip the 

remaining part of this step. 

4.  Expand MicroStation > Open and right 

click on the line containing \ustation.exe. 

Choose Unassociate and OK.   

5.  Repeat for each  \ustation.exe  instance under  Open .  Disregard Viewer and Markup. 



 

 

Set up Your User Preferences Step 6  

1.  On your desktop create a folder named PW Export. 

2.  In ProjectWise browse to 05.0 – Workspace 
Resources\3_Workspace_V8i\_Export\. Right click on the 
_Export folder and select Export… 

3.  Choose Send to Folder and select Next>. 

 

 

 

 

 

 

 

 

4.  Browse to an export folder created in step 1 and 

accept to overwrite any outdated files if prompted, 
and Finish. 

 



 

 

5.  On your desk top open the folder _Export folder\View Options – Civil and copy CT_Civil_pw.ucf and 
CT_MSTA_PW to C:\Bentley_V8i\Worksapce\Users. 

 

 



 

 

6.  Again go to the _Export folder on 
your desktop, double click on 

_Civil_Options_Prefs_Setup.bat  to 
automatically populate the civil 

folder with default preferences for 
Civil Options. 

 

 
 

 
 
 

 
 

 
 
 

 
 

 
 

7.  If you do not see Hidden 
Folder of File Extensions you 
will need to change your folder 

options in Windows Explorer. 



 

 

 

Verify Correct Project Workspace Step 1  
1.  Locate the Workspace location.  You will no longer 

be connected to the old workspace on the W drive, 

instead you will f ind the workspace at this location 
in ProjectWise, Documents\05.0 - Workspace 

Resources\3_Workspace_V8i 

2.  Check to make sure your project is configured to 
the correct workspace.  In ProjectWise explorer 

right click on the project folder and choose 
Properties.  All projects using OpenRoads SS4 

should use the following Blocks shown in the image 
below.  ProjectWise Configuration Settings Blocks 
(CSBs) are attached to projects so that CAD 

workspaces are read when a MicroStation design file 
is opened.  

3.  If you do not see the correct blocks please contact 
AEC applications and they will reset them.  Users do 
not have access to do this.  

4.  Click OK to close the box. 

 Project Start up Chapter 2



 

 

Copy Resource Files from the Workspace to your project Step 2  

The ITL and XIN will need to be copied over from the workspace to your project discipline folder  

1.  Browse to  

05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\data\feature_definitions\Civil_Feaures.xin 

Right Click and Select Copy.  Browse to your projects discipline folder right click and select  Paste.  When the 

Document Wizard appears select No Wizard and click the OK button. 

2.  Browse to 

05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\data\template_library\OpenRoads_Typicals.itl  

Right Click and Select Copy.  Browse to your projects discipline folder right click and select  Paste.  When the 

Document Wizard appears select No Wizard and click the OK button. 

 



 

 

Create a Document (MicroStation DGN File)  Step 3  
 

 

1.  Select the project subfolder that you wish to work in.  
Example: 01.0 - Projects - Active\1234-1234\300_Design_Data\Highway\ 

2.  From the main menu, select Document>New > Document….  

3.  In the Select a Wizard Dialog Box, select Advanced Wizard 
then OK. 

4.  On the Advanced Document Creation Wizard Welcome dialog 
box Select Next>. 

-Seed File Usage- 

 Use a 2D DGN seed file to start your Design Modeling (OpenRoads will automatically create a 3D model as your design 
progresses). 

 Survey will use one of the 3d DGN seed file to house the Existing Terrain. 
 DO NOT Drag and drop DGNs and Point Cloud files in from the betwork location.  These files have different working 

units and will not scale properly if opened in the ProjectWise environment. 

 Always start with new clean seed files. 
Geospatial OpenRoads seed files 

\Documents\05.0 – Workspace Resources\3_Workspace_V8i\Civil_Standards\seed\ 
2D_OpenRoads_DesignSeed_83.dgn 
2D_OpenRoads_DesignSeed_27.dgn 

3D_OpenRoads_DesignSeed_83.dgn 
3D_OpenRoads_DesignSeed_27.dgn 

FAQs - NAD & NGVD 
http://www.ngs.noaa.gov/faq.shtml#WhatNAD 
 

http://www.ngs.noaa.gov/faq.shtml#WhatNAD


 

 

5.  When prompted to Select Target Folder, verify that you are 
pointed to the correct folder and select Next>. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6.  From the Select a Template options, toggle on Use 
ProjectWise as a template and click the Select… 

button.  If this is not your first time creating a 
MicroStation file in ProjectWise, you may elect to 

toggle on Select from recent used templates and 
use a previously selected seed file stored in your 
file history and skip to the next step. 

 
 

 



 

 

7.  A Select Template Document dialog box will appear.  Browse to the seed files location:  
…05.0 - Workspace Resources\3_Workspace_V8i \Civil_Standards\seed\  

 
Choose the 2D seed file that correspond to your survey NAD year 1983 or 1927.  

2D_OpenRoads_DesignSeed_83.dgn 

or 

2D_OpenRoads_DesignSeed_27.dgn 

 
Select the Open button.  The template is now populated for Advanced Document Creation.  Select Next. 

8.  Select the fields to Define Document Attributes as 

shown.  Tab to accept each field.  The document file 

name will be built from these fields.  Be sure to enter 

a Label and Description.   These fields will be 

displayed and used for searching rather than the file 

name.  Select Next. 

9.  On the Document Properties Dialog Box select Next>. 

10.  On the Create a Document Dialog box select Next >. 

11.  Click Finish to Close.  The new file will now appear in 

ProjectWise. 

12.  To Update the ProjectWise Explorer Document View 

data point in the view and then select F5 on the 

keyboard.  This wil l refresh Label and Description. 

 



 

 

Open a MicroStation DGN file Step 4  

1.  In ProjectWise Explorer browse to your discipline folder and locate the 
DGN file you wish to open, right click on the DGN file and select Open 
With. By default MicroStation DGN f iles will open with MicroStation only 

(i.e. no InRoads nor OpenRoads) if double clicked on, so selecting open 
with is imperative if you want to run OpenRoads . 

 
 

 

 
 

2.  In the Open document with dialog box locate the Description column and select OpenRoads SS4.  This will 
use OpenRoads SS4 if it is installed and also complete CTDOT configurations.  The Managed Workspace will 

now begin to cache on your computer’s hard Drive. 
 
 

 
 

 
    



 

 

Ensure your User Preferences are working properly Step 5  

1.  Now that your MicroStation File is opened you should check to 
make sure your User Preferences are properly set.  On the 
MicroStation pull down menu select Workspace>Preferences. 

It should be named CT_CIVIL_PW 
 

 
 
 

 
 

 
 

 
 
 

 
 

 
 
 

2.  Ensure that all MicroStation Project Explorer settings for 

Browsers are set to True by selecting Settings > Project 

Explorer from the MicroStation menu. 

 

 

 

 

 

 

 

 

 



 

 

3.  At the bottom of the Right side of you screen check for docking of the 

Tasks, Project Explorer and Element Information Tabs. You can move 

and doc them as desired. 

 

 

 

4.  If the these menu are not visible you can manually turn them on using 

the MicroStation pull down menu. 

For the Tasks select Tools > Tasks. 

For Element Information select Element > Information. 

For the Project Explorer select File > Project Explorer. 

 

 

 

 

 

 

 

5.  Locate the Bentley Online Help Videos, On the Project Explorer 

there is a Tab named Links. Click on the down arrow and select 
Bentley Online. This will directly link you to Bentley’s  help and 
Training Videos. 

 

 

 



 

 

Set up Project Defaults Step 6  
 

1.  If the InRoads explorer dialog box is not visible 
you will need to open it. On the MicroStation pull 

down menu select Applications > InRoads > Tools 
>Show/Hide  

2.  On the InRoads Main menu select File > Project 
Defaults.  Select the New button and type PW 
followed by the project number.   

3.  In the Preference (*.xin) field browse the  XIN file 
that was copied to your discipline folder.  

4.  Copy that same path (not the file) in to the 
Default Directory Path for the Geometry Project 

(*.alg) and the Template Libraries (*.itl).  

5.  Click Apply and Close. 

6.  Open Project Defaults again and select Highway as 

your Preferred Preference.  

 

 
 
 

 
 

 
 
 

 
 

 
 



 

 

 

 

 

Creating and Viewing Terrain (Part 1)   Creating and Viewing Terrain (Part 2) 

Section 3.1 Obtain an Existing Terrain 
The concept of 2D and 3D files is very important when using OpenRoads. The existing terrain will be created 

using a seed file with a 3D model while the proposed design will be created using seed file with a 2D model.  

Keep in mind when using OpenRoads to design the MicroStation file with the 2D model wil l automatically 

create a 3D model , so you will be working with one file that had two models.  Most of the work a designer 

does will be done in 2D. The 3D views are mostly used for checking the model and visualization.   Below are 

three methods for creating an existing Terrain.  

-  Create from Fieldbook 

-  Create from File (DTM, LAS …) 

-  Create from Point Cloud 

3.1.1 Create from Fieldbook 
This will be done with new survey data where a DTM does not exist yet.  The Survey Unit will use OpenRoads 

to process the fieldbook instead of InRoads SS2. Please see OpenRoads Survey Workflow for further 

information on this process. 

 Existing Terrain Chapter 3

http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=106057&CourseId=114235&MediaID=5006516
http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=106057&CourseId=114234&MediaID=5006515


 

 

3.1.2 Create From DTM File 
Request an existing terrain DGN file from Survey.  In OpenRoads Survey will use the Create from File tool to 

convert the existing DTM to a Terrain.  Below are the steps they will use. 

1.  Complete Step 3 in Chapter 2 to create a new file.  

2.  Open the file (Step 4, Chapter 2) and in the task menu select Civil 

Tools\Terrain Model\ Create from File tool 

3.  The Select Files to Import dialog will appear. Browse to the 

location of the DTM file to import, highlight it and click OK. 

 

 

 

4.  Another dialog box should appear.  Fill out 

the fields as shown. 

Feature definition: Meshes/EX_TERR_Ground 

Import Options: Import Terrain Only 

Click Import     

 

 

 

 

 



 

 

5.  If an Import Failed error appears the 

following procedure must be done to the 

DTM. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6.  Go back and do #3 & 4.  Select Fit View tool and the 

terrain should appear in the file.  

 

 



 

 

3.1.3 Create From LAS File 
This method will be used when importing LAS files.  While OpenRoads can handle a larger amount of surface 

data then a traditional InRoads DTM it stil l has a breaking point. For example you will lock up if you try to 

import a LAS file that contains the entire State of Connecticut . The point cloud tools in the next section 2.1.4 

can be used to filter out unneeded areas of the LAS file data before importing to a terrain . Size Examples: A 

1000 KB file imported quickly while 100,000 KB (1.5 square miles) took some processing time. The view was 

slow to rotate and display.  

1.  Complete Step 4 in Chapter 2 to create a new file. Use the seed file Documents\05.0 - Workspace 

Resources\3_Workspace_V8i\Civil_Standards\seed\3D_OpenRoads_DesignSeed_83.dgn.  Open the file 

(Step 5, Chapter 2) 

2.  On the task menu select Civil Tools\Terrain Model\ Create from File tool 

3.  The Select Files to Import dialog will appear. Browse to the location of 

the LAS file to import, highlight it and click OK. 

4.  Another dialog box should appear.  Fill out the fields as shown.  

Do not select a Feature Definition yet, this will be set after the import.  

Click Import and close the dialog box. 

5.  Fit the view and change the feature definition to  

Meshes/EX_TERR_Ground 

 



 

 

3.1.4 Create from the Point Cloud tools using a “LAS file”  
This method will be used when importing a very large LAS file.  While OpenRoads can handle a larger amount 

of surface data then a traditional InRoads DTM it still has a breaking point.  The point cloud tools will be used 

to filter out unneeded areas of the LAS file data before importing to a terrain. 

1.  Complete Step 4 in Chapter 2 to create a new file. Use the seed file Documents\05.0 - Workspace 

Resources\3_Workspace_V8i\Civil_Standards\seed\3D_OpenRoads_DesignSeed_83.dgn and open the file 

(Step 5, Chapter 2) 

2.  On the MicroStation Primary Tool bar select the Point Clouds 

Icon.  On the Point Cloud Dialog Box select the Attach Icon.  

Browse to and select the LAS file.   

 

3.  In the Bentley Point Clouds dialogue box select Settings > 

Presentation. Highlight the Elevation and set as needed.  

Click on the Apply to Open Views button to visualize the 

existing ground surface and c lose the Presentation dialogue 

box. 



 

 

4.  In the Point clouds Dialog box use the Clip tool to clip out the 

unwanted area. Keep in mind this only clips what you see on the 

view display, the actual points are still in the cloud.  To get rid of 

these points select File > Convert.  Change the Region filter to Clip 

and click OK. Follow the prompts to create a new POD file.  

5.  The Create from POD file tool in OpenRoads will bring in the entire 

POD regardless of what is clipped out of the view display.  To only 

bring in the needed area attach the new smaller POD file and detach 

the original.   

 

 

 

 

6.  After visualizing the existing surface with the POD file, the Terrain 

Model can be created. From the Terrain Models task pane select 

Create from Point Cloud.  



 

 

7.  Set as shown. 

BENTLEY SUGGESTED SETTINGS FOR POD FILE IMPORT 

In the Import Terrain Model From Point Cloud dialogue box 

  Always use the “Tin Filter”.  

  Input the “Z” Tolerance. 

  Always use the “Coarse” option.  

  Always use “Reinsert Points” option.   

  Do not select a Feature Definition until after the 

Terrain Model is created. 

What is the “Z Tolerance”  

  An unaltered TIN (no filtering) will produce a 

huge file that could be difficult to work with. The 

Z tolerance is the amount of error that you are 

willing to accept in order to produce a TIN that is 

not too large to use. 

  Bentley reports that if you want to be absolutely 

sure that your final filtered TIN is within a 

certain accuracy of your original unfiltered TIN 

then Z tolerance should be ½ of that acceptable 

error (vertical accuracy). 

  The Survey Report should give you an idea of the 

vertical accuracy within a point cloud at a 95% 

confidence level. 



 

 

8.  Select the Test Filter button 

The “Test Filter” button allows you to test various settings before actually creating the Terrain Model.  

Default Triangulation Options can be changed here, before the Terrain Model is crea ted. 

  

9.  After the Terrain Model has been created. The POD File is no longer needed and can be detached from the 

design file. 

 

10.  Fit the view and change the feature definition to  Meshes/EX_TERR_Ground 

 



 

 

3.1.5 Create from Point Cloud tools using Earth Exploration 
If you are in the preliminary stages and do not have an official survey yet you can use the Earth Exploration 

Tools provided with the workspace.  These tools will aid you in loading aerial photography and Point Clouds in 

to a MicroStation file.  The Point C louds can then be imported in to OpenRoads to create an existing terrain.  

 

1.  Complete Step 4 in Chapter 2 to create a new file. Use the seed file Documents\05.0 - Workspace 

Resources\3_Workspace_V8i\Civil_Standards\seed\3D_OpenRoads_DesignSeed_83.dgn and open the file 

(Step 5, Chapter 2). 

2.  On the MicroStation Main Pull Down Menu select CTDOT Util it ies > Earth Exploration > Load Aerial Tools  

and pull in the needed Point Clouds. 

3.  Use the tool Create from Point Cloud to create an existing terrain. 

 

 

 



 

 

Section 3.2 Reference in the Existing Terrain 
1.  If you have not done so already create a 2D design file as shown in Chapter, 1 Steps 6 and right click and 

select Open With, select the OpenRoads SS4 option. 

2.  Once in the file go to the Reference tool and open the references dialog box. 

 

 

 

 

 

 

 

3.  In the references dialog click the Attach Reference button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

4.  In the Attach Reference dialog box browse to the needed DGN terrain file.  If Survey created it, the file 

will be in the 500_Pre_Design\03_Central_Survey folder.  Highlight it and click OK. 

 



 

 

5.  In the Reference Attachment Settings Dialog Box g ive 

the file a logical name, set the options as shown.  Be 

sure that the Nested Attachments is set to No Nesting 

and click Ok. 

 



 

 

6.  Go to your main view and click Fit 

View. The terrain should be displayed.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7.  To change the display of the view 

select the Element Selection Tool and 

click and hover over the terrain 

border (edge) to get the context menu 

to appear. Click the Properties button.  



 

 

8.  In the Override Symbology field select Yes to be able to 

change the display of features in the terrain model.  

9.  Now select Off for all of the fields you would like to display 

off such as flow arrows, low points etc.  

10.  The terrain model should now display with symbology turned 

off or on depending on your selected settings.  

 

 

 

 

 

 

 

 

11.  Now hover over the terrain model edge again to get the 

context menu to appear. Click the Set As Active Terrain 

Model button. If you have a file with the Ground features 

attach it as well.   If you select F10 your reference file 

colors will appear dithered out.  

 



 

 

Section 3.3 View the 3D Features 
The quickest way to do this is to select F9 on your Key board, but it is important to understand how this all 

happens.  Follow the instructions below to view your 2D features and 3D feature s in the same DGN file. 

1.  Open another view window. In this window open the View Attributes and select the default-3D model 

from the model field. 

2.  To make it a bit easier to see, in the display style field select Smooth Modeling from the dropdown list  

3.  Click the Fit View button in your view containing the default model and your view containing the 

default-3D model. Use the Rotate View command see your terrain in 3D.  Most of the modeling will be 

completed in the 2D window, the 3D view is useful for evaluating changes to the design visually.  

  



 

 

Section 4.1 Geometry Set Up 
1.  To set the Annotation Scale, go to Settings>Drawing Scale.  Toggle Annotation Scale On and set it to 1” = 

40 ‘. 

   

 

 

 

 

 

 

 

 

 

2.  Go to Tasks>Civil Tools> General Geometry and turn on the Feature Definition Toggle Bar (if it is not 

already on). 

  

 Geometry Chapter 4



 

 

3.  Go to tasks>civil tools>general geometry  

and turn on the Civil Accudraw toggle bar 

(but do not turn Civil Accudraw on yet). 

 

 

 

 

 

 

 

 

 

4.  Set the feature definition to GEOM_CL and 

make sure the Use Active Feature Definition 

button is on.  

 

 

5.  Review the horizontal alignment tools. 

 



 

 

Section 4.2 Importing Geometry from an InRoads ALG file 
1.  If you have multiple vertical alignments on one horizontal 

you will need to open the ALG before importing it into 

OpenRoads.  Make the opt ion that you would like to import 

is active for each horizontal with more than one option.  

2.  Select the Task on the General Geometry tools set and 

select the Import Geometry Icon. 

3.  Browse to the location of the ALG file . Click Cancel on the 

first dialog box if the file is located outside of ProjectWise.  

4.  The Alignment will come in default grey with no Feature 

Definition.  Select each alignment and set the Feature 

Definition, for Roadway Centerlines they should be set to 

Geometry Centerline/CEOM_CL 

 

 

 

 



 

 

Section 4.3 Creating Horizontal Geometry from PI’s 

 
 

 

If you use the Complex By PI method the alignment will be 

one element rather than multiple pieces, use the Feature 

Style Geometry Centerline/GEOM_CL.  This style will appear 

with stationing turned on.   

 

 

 

To add PI’s after laying out the initial alignment use the tool 

Horizontal Insert Fil let 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=106057&CourseId=115704&MediaID=5007157
http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=106057&CourseId=115704&MediaID=5007157
http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=106057&CourseId=115704&MediaID=5007157


 

 

Section 4.4 Creating Horizontal Geometry from Elements 

 
 

If you choose to use the Geometry from Elements tools you will need to use 

Complex By Elements after to create a single alignment. The issue with this 

method is if stationing is part of the feature definition annotation (as seen in 

GEOM_CL) the old stationing for the individual elements will display in 

addition to the new stationing for the complex element. To solve this issue 

the user can use a different feature definition for the initial layout and then 

set the GEOM_CL feature definition before using the Complex By Elements 

command.  

 

If using the Automatic method select the first element in the alignment and 

indicate the direction see the Pink Arrow below, the rest of the alignment 

should select automatically. Click to accept the complex.   

If using the Manual method, select each individual element in the alignment 

indicate the direction see the Pink Arrow (from start location to end). Right 

click to finish and accept the complex.  

 

    

http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=106057&CourseId=115706&MediaID=5007159


 

 

Section 4.5 Civil Accudraw 
 

 

 

The Basics of  Civil AccuDraw       Why You Need Civi l AccuDraw    Using Civi l AccuDraw to Communicate Design Intent  

 

The process for laying out side road elements is similar to main alignments but for added functionality/ 

intell igence to the elements the Civil Accudraw feature will be used. *Note: Make sure you turn off regular 

Accudraw when using Civil Accudraw.  

When using Civil Accudraw keep in mind which snaps are used and which fields are locked when placing the 

geometry, both will determine how the second alignment interacts with the first when it is adjusted. 

For the regular snaps here are a few examples:  

Perpendicular snap will keep the alignment attached to the first at a right angle, if no station is entered in 

the process it will move around the alignment.  

Key Point snap: this will make an element tied to the element that is selected, for example if I draw one line 

and key point snap my second alignment to this item, no matter where I move the first end point the start 

point of the line attached will follow.  

Civil Accudraw “snaps” explained : 

  Distance-Direction: a feature end point is located based on a given distance and direction  

  Distance Direction Unlinked: 

  Distance- Distance: feature is dependent on two defined distances, usually from a specific feature.  

  XY: feature is defined and tied to a specific XY location 

  Delta XY: feature is defined and tied to a specific point given a X and or Y offset from the given point  

  Station-Offset: feature is defined by a start specified by a station and offset from a given feature, and 

then has an end point defined by station offset or some other snap type depending on the requirement of 

the designer 

  Delta Station Offset: feature is defined by an offset from a chosen Station -Offset as above.   

http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=104644&CourseId=113251&MediaID=5006008
http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=104644&CourseId=113252&MediaID=5006009
http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=104644&CourseId=113253&MediaID=5006010


 

 

Section 4.6 Creating Side Road Alignments with Design Intent 
Try the following method to lock the Secondary alignment to the Main alignment.  

1.  Toggle on Civil Accudraw and set the Civil 

Accudraw snap type to Station-Offset. 

2.  Select a geometry tool: Line, Arc, 

Complex By PI, etc. A heads up menu 

should appear when the cursor is on the 

screen, prompting for a station.  

3.  Key in the letter O. A prompt to select a 

reference element should appear. Left 

click the Main alignment.  

 



 

 

4.  The stationing in the heads up prompt will now be 

stationing specific to the reference element , i.e. if the 

stationing runs from 1+00 to 3+00 those will be 

available, or 500+00 to 600+00 if the stationing was 

set differently. Key in a station on the element and hit 

enter. A small lock icon should appear to the right of 

the station field. 

 

 

 

 

 

5.  The cursor should now be in the offset field. Key in 0 

(zero) and hit Enter. The lock icon should appear to the 

right of this field as well. A small blue crosshair should 

now be at the intersection of the station chosen and 

offset distance. This ensures that the start of the 

secondary alignment will begin at the intersection of 

the main alignment. Left Click to accept the start point.  

 



 

 

Section 4.7 Renaming Alignments 
Geometry should be named when created; in the case of complex geometry the 

final complex element should be named. Individual components of a complex 

element can be named as well. Proper naming makes finding geometry in the 

Project Explorer much easier down the road.  

There are multiple methods for naming elements.  

1. During element creation:  

During element creation a dialog box will appear, a name can be entered 

into the Name field for each element created. This works for single 

elements and complex elements.  

 

2. Heads up menu:  

Left click the element and hover 

over it. A heads up menu should 

appear. Select the Properties 

command. A properties table will 

appear, change the name in the 

Feature Name field. 

 

 

3. Project Explorer: 

Go to the Project Explorer> Civil Model tab 

and right click on the element name. Select 

Properties from the dropdown menu. A 

properties table will appear, change the 

name in the Feature Name field. 

 



 

 

Section 4.8 Creating Vertical Geometry 
 

 

 

 

 

Creat ing Vert ical Geometry f rom Elements   Creat ing Vert ical Geometry f rom Known PI’s  

4.8.1 Displaying the Existing Ground 
1.  Open the profile view for the selected alignment .   In Tasks> Civil Tools> Vertical Geometry select the 

Open Profile Model command. A prompt will then ask the user to Locate Plan Element, Left click to select 

the Element. 

 

http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=106057&CourseId=115705&MediaID=5007158
http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=106057&CourseId=115703&MediaID=5007156


 

 

2.  A prompt to Select or Open View will appear. Select an 

unused view from the view groups box.  

 

 

 

 

 

 

 

 

 

 

 

 

 

3.  Once the view opens, left click inside 

the view. An X and Y axis should appear 

in the profile view and the alignment will 

be highlighted blue with chevrons in the 

plan view. This indicates which 

alignment is in the active profile view. 

  

 

 

 

 

 

 



 

 

4.  Display the existing surface on the profile model .  

Select the ground terrain model and hover to get the 

context menu to appear. Click the Set Active Terrain 

model command.  The terrain profile should appear 

in the profile view.  

 

 

 

 

 

 



 

 

4.8.2 Creating a proposed Profile  

This example will show how to create a very simple proposed profile. See the Bentley tutorials for more a 

detailed explanation of the vertical geometry tools.  

1.  Go to Tasks> Civil Tools> Vertical Geometry and select the Profile 

Line Between Points command. 

  

 

 

 

 

 

 

 

 

2.  The Profile Line Between Points dialog box will appear. Fill in the 

Name field (something that will help identify the profile later).  

  



 

 

3.  A prompt to Pick Profile View will appear, left 

click in the view window with the active profile 

(the one that has the existing ground displayed) . 

Ther Enter Start Point prompt will appear. In the 

profile view select your starting point, a blue 

perpendicular line in the Plan view shows 

represents the location of the start point. (In 

this example the end point of the exisitng ground 

was selected to tie the proposed alignment in 

with the existing ground.)  



 

 

4.  The next prompt is Enter End Point. In 

profile view select the end point, it will 

also be displayed in plan view with a 

perpendicular line.  

 

 

 

 

 

 

 

 

 

 

 

 

 

5.  The feature definition can be changed to 

make it easier to distinguish profile 

alternatives.  



 

 

6.  Add curves into the profile.  Go to Tasks> Civil 

Tools> Vertical Geometry and select the Profile 

Insert Curve command. 

  

 

 

 

 

 

 

7.  A Locate Tangent to Insert Curve prompt will 

appear. Left click to select the profile line.  

 

 

 

 

 

 

 

 

 

8.  The next prompt is Locate Vertex. Left click to 

select a vertex point for the curve.  

 



 

 

9.  It wil l now prompt for a Through Point. Make 

sure the Vertical Curve Parameter box is 

unchecked. Select a through point on the 

profile screen or by entering in a vertical 

curve parameter or length and left clicking 

through the heads up fields to accept. The 

proposed profile should now be displayed. 

 

 

 

 

 

 

 

4.8.3 Vertical Alignment Alternatives 
Multiple profile alternatives can be created on 

the same plan element. In this example there 

are two proposed profiles. It is here that 

properly naming elements is especially 

important. When selecting alternatives or 

comparing alignments, properly named 

elements will be much easier to identify in the 

project explorer, as well as identifying element 

dependencies. 

  

 



 

 

 

 

 

Understanding Component Display Rules 

The Template Library will look very similar to what you were used 

to with InRoads SS2. 

1.  To open the Template library in the Workspace go to Tasks > 

Civil Tools > Cooridor Modeling > Create Template or select 

F12. The Create Template Dialog Box will open and the 

Template Library file on the Workspace will be pointed to as 

read only.  

 

2.  If you would like to make modifications to the Templates 

select File > Open and open the Template Library file that you 

copied over in the getting started section on this manual .  

Click on the ITL and select Open. 
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3.  Use the Project Library Folders as your working area by copying the needed 

pre-designed templates down from the top folders.  This way you always have 

a fresh copy to use as your build you specific project templates.  

If you are going to build your own templates or modify the one supp lied you 

will need to have a vast understanding of which feature styles to use and what 

settings are specific to different point and component types. Browse to the 

template HWY Typical Section > 2ln_PS5_BCPC.  Double click on the different 

points, closed shapes and end conditions.   

Take note of the following settings.  

A.  Feature Styles 

B.  Feature Name Overrides 

C.  Superelevation Flags (new for OpenRoads)  

This template is a two lane road with bituminous concrete curbing using the 

pavement structure #5.  Pavement Structures are found Appendix B of The 

State of Connecticut MTG Pavement Design Catalog . 

 

http://www.ct.gov/dot/lib/dot/documents/dpavement/mtg_pavement_design.pdf
http://www.ct.gov/dot/lib/dot/documents/dpavement/mtg_pavement_design.pdf


 

 

A. FEATURE STYLES 

Point Feature Suffix…. 

On the top surface BKLN_ 

Below the top surface BKLN_Sublayer 

 

    
 

Components Suffix… 

Material_ 

 



 

 

B. FEATURE NAME OVERRIDES 

Points on end conditions 

Make sure to Use Feature Name Overrides on Cuts, Fills and the Snow shelfs . 

 

End conditions components 

In the end condition components, the "Use Name Override" needs to be set for like slopes.  For 

example, you have 4 possible ditch backslopes where only one at a time can solve.  Setting the 

feature name override in the component properties assures the model stitching using the same 

component name.  This is similar to what you have done correctly in the point properties for the 

point feature override. 



 

 

C. Superelevation Flags 

 

   

  



 

 

 

 

 

Model the Roadway Corridor 

Section 6.1 Design Stages 
Before creating a corridor it’s important to understand the Project 

Settings for Design Stages.  A design Stage is selected when first creating 

a corridor and it modified as the design progresses from conceptual to 

Final design.  Design staging helps users to optimize their computers 

processing speeds by the managing corridor modeling details to only what 

is needed for the stage they are in. 

Select the Project Explorer, Civil Standard Tab.  Under Libraries select 

Project_Settings.dgnlib\Coordor Design Stages.  Study at the Properties 

presets for each stage. 

 Corridor Modeling Chapter 6
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6.1.1 Template Management 
Manages the template drops on a straight piece of road.   

(Template Drop Interval Multiplier)   X     (Drop Interval)  

         Design Stage                          Create Template Drop  

                                                            Dialog Box 

Conceptual Design Stage -       5 X 10 = Template drop created every 50’ 

Design Design Stage-              2 X 10 = Template drop created every 20’ 

Final & Publish Design Stages - 1 X 10 = Template drop created every 10’ 

 

 

 

 

 

 

 

 

 



 

 

6.1.2 Include Critical Sections 
Manages the template drops at critical sections.  Publish is set to true for 

all fields,  this level of accuracy will not be needed in Conceptual and 

Design Stages in turn some of these are set to false.  

   

 

 

 

 

6.1.3 Display settings 
Display Settings point to the look and feel of the 

graphical representation of the corridor, these are 

displayed as construction classes as they is not a real 

world features.  Users can easily turn these off by 

deselecting Constructions in Veiw Attributes.  

  



 

 

6.1.4 Output Settings 
All the base Design Stages are set the same (Conceptual, 

Design, Final & Publish Design) for the Output Settings. 

There are separate stages set up for the output of different 

Mesh surfaces if needed. 

 

  

 

 

 

 

 

 

 



 

 

6.1.5 Updating the Design Stage 
Click on the graphical notches and select 

Properties, change the Design Stage Field to the 

desired selection. 

 

 

 

 

  



 

 

Section 6.2 Create a Corridor 
Corridors and models are no longer created in the Roadway Designer; they are 

created directly in the MicroStation Screen.  

1.  Go to Tasks> Civil Tools> Corridor Modeling and select the Create Corridor 

Command.  

2.  The Create Corridor dialog box will appear as well as a prompt to Locate 

Corridor Baseline. Enter in a name in the Corridor Name field, select a Design 

Stage and select the plan element for the corridor.  



 

 

3.  A prompt to Locate Profile Element will appear. Select the alignment in Profile view, select a profile from 

the dropdown menu in the dialog box, or right click to select the active profile. By selecting the Active 

Profile option the user can easily switch between profile alternatives and see how this affects the corridor 

model.  

 

 

 

 

 

 

 

 

 

 

 

4.  Enter a Corridor Name and left click to accept.  A 

corridor feature should now be displayed around the 

alignment (the shape may be a different color 

depending on which design stage was selected when 

creating the corridor.  

 



 

 

5.  The Select a Template prompt will appear, click the ell ipses 

button or Alt+Down to browse the templates. Select a template 

and Click OK. 

 

Note: If you right clicked off to cancel the command after the 

corridor was created you will need to select the Create Template Drop Icon to continue.  Follow the 

prompts to select a template. 

 

6.  Left click to accept and apply the template, follow the prompts for Start Station, End Station, Drop 

Interval, Minimum Transition, Maximum Transition, Description .   The components of the model should be 

displayed in plan view was well as the 3D model if it is open.   

 



 

 

Section 6.3 Superelevation  
Superelevation is calculated and created different ly in OpenRoads than InRoads,  it uses SRL and SEP files 

instead of SUP files. Much of the application is done graphically using the heads up menus rather than the 

templates.  

At this point the user should already have the following items:  

  Terrain file (existing ground surface) 

  Centerline geometry (horizontal alignment)  

  Profile geometry 

  Corridor 

  Template drop(s) 

 

Quick Step Preview:  

STEP 1.  Create Superelevation Sections 

STEP 2.  Create superelevation Lanes  

STEP 3.  Calculate Superelevation 

STEP 4.  Assign Superelevation to Corridor 

 

 

 



 

 

6.3.1 Step 1 - Create Superelevation Sections 
1.  Open the Level Manager and set the level CORR_Superelevation 

active.   

2.  The Superelevation tools are located under Tasks > Civil Tools > 

Corridor Modeling. Select Create Superelevation Sections and 

follow the prompts. 

 

 

 

 

  

3.  Give the Section a Name and specify the Minimum Tangent 

Length. 

Note: If you do not want to have multiple superelevation 

sections created set the Minimum Tangent Length to a very 

large number. This will force the product to create only one 

superelevation section for your entire corridor. The only reason 

you may want multiple sections is if your design speed changes 

within the limits of your corridor.   

4.  Data point the centerline alignment and left click to accept. 

5.  Another dialogue box should appear, select the Start and End 

Stations and click through to accept.  

 

 

 

 



 

 

6.  A green outline will appear around the Superelevation 

section that was just created 

 

   

6.3.2 Step 2 - Create superelevation Lanes 
1.  The next superelevation task will automatically start , 

Create Superelevation Lanes. This step needs to be done 

twice, once for the left lane and once for the right lane. 

For roads with more than two lanes additional super 

lanes will be required. In this example a two lane road is 

used.  

2.  Give a meaningful name to the lane. 

3.  Select which side of the centerline the lane is on . 

4.  Determine the inside edge offset (in the case of a two 

lane road each lane would have an offset of 0. For a 

multilane road the inside edge offset would be the width 

from the edge of the lane to the centerline.  

5.  In this example the normal cross slope is 1.5% because 

it is a two lane road, for a 4 lane road the outermost 

lanes would have a normal cross slope of 2%. See the 

HDM for more information on lane cross slopes. 

6.  Repeat process for each lane ( in this example the create 

super elevation lane command was done twice, once for 

the left, once for the right)  



 

 

6.3.3 Step 3 - Calculate Superelevation 
Once the lanes are created, right click to reset and move on to the next tool. The calculate superelevation 

dialogue should appear automatically.  

1.  Browse to the superelevation resource files and select File of Type. The SEP or SRL format can be used, 

each has multiple AASHTO years, select the most recent year.  

 

 

 

 

 

 

 

 

 

2.  The next dialogue box to appear will depend on which file type was selected for calculation. For the SEP 

file method, the dialogue box will ask for the following fields . Data point through the fields to accept the 

entries.  

a.  E selection, CTDOT uses an e max of 6% 

for rural roads and 4% urban roads.  

b.  L selection 

c.  Design speed 

d.  Transition ID 

e.  Number of lanes 

f.  facil ity 

 



 

 

6.3.4 Step 4 - Assign Superelevation to Corridor 
The next step is to assign the superelevationto the corridor.  

1.  Click the Assign Superelevation to Corridor Command  

2.  When prompted, select the super sections.  

3.  When prompted, select the corridor.  

4.  The associate superelevation window should appear. Check over the points to make sure there are no 

errors and that the superelevation points and pivot points make sense, SHDR_lt with the left super lane 

and SHDR_rt with the right super lane.   

 



 

 

5.  Click OK, The Superelevation graphics should appear.  The normal crown, reverse crown, and full super 

points should appear with labels as shown below.  

 
To get a thematic visualization of the super grade changes toggle on the fil l button in the view 

attributes window.  

 



 

 

Section 6.4 Modeling Intersections  
Side alignments are modeled a bit differently because the main line is constraining how the side road meets 

in. Alignments, models and corridors have to be adjusted to meet into the new proposed road.  The alignment 

for a side road meets in at the alignment of the main line, because of this, the side alignment has to match 

the main line until it is off of the main line, or the two models have to be warped to accommodate each 

other.  

6.4.1 Creating the Side Road Alignment 
1.  Follow the steps in section 3 to create the side road horizontal 

alignment and vertical profile window.  

2.  Display the points on the main line which cross the side road 

alignment. Go to Tasks> Civil Tools> Vertical Geometry and select the 

Profile Intersection Point command. 

 



 

 

3.  The prompt Locate Element to Show Intersection 

will appear. Select the side road alignment. 

 

 

 

 

 

 

 

4.  Another prompt will appear asking to Locate 

Element Which Intersects. This is asking which 

element crossing points the user wants to 

appear on the profile. In this example the Main 

Road alignment, shoulder line, and edge of 

road elements were selected. When finished 

selecting elements, right click to complete the 

selection. 

 

5.  The crossing points should now be displayed in 

the profile view. Fit view may be needed to 

locate the points, and the colors/ line weight 

may need to be changed to make them more 

visible.  

 



 

 

6.  Hovering over a point in profile view will tell 

the designer what feature the point is 

representing as well as geometric 

information. 

 

 

 

 

 

 

 

 

 

7.  Create profile elements for the side road 

alignment.  To maintain the side slope of the 

road, the side road alignment will need to 

match in to the main line. The points 

displayed earlier will help the des igner 

achieve this. Select the Profile Line Between 

Points command and connect the crossing 

points. In the example shown the top vertical 

alignment is only connected to one crossing 

point. The lower alignment is connected to 

all three of the crossing points. The Profile 

Complex By Elements command can connect 

individual elements to create a single profile. 

* Remember to use meaningful names when 

creating profiles.  



 

 

8.  This example shows the difference 

between the models using the top 

profile and the bottom profile.  

 

 



 

 

 

6.4.2 Creating the Side Road Corridor 
1.  Create the Side Road Corridor. Now that the profile is complete, a corresponding corridor needs to be 

created. *Remember to name the corridor correctly to avoid confusion later.  

2.  Attach a template to the corridor. The designer can edit the corridor as needed and create alignment 

elements for the corridors and adjust the template drops as needed, or they can use a civil cell.  

 



 

 

Section 6.5 Civil Cells 
 

 

 

Model an Intersect ion with  a Civil Cell  

There are many different types of civil cells that help automate design tasks. Civil cells use reference 

elements for placement, meaning you can use the same civil cell in many locations and it will change based 

on the reference elements used to place it. Civil cells can be edited after placement as well has “dropped” to 

allow the designer to use pieces of a civil cell if necessary .   

1.  To place a civil cell go to Tasks> Civil Tools> Civil 

Cells and select the Place Civil Cell command.  

2.  The Place Civil Cell dialog box will appear, click the 

ellipses button to browse available civil cells. When 

selecting a civil cell preview will be shown to the right 

of the selection. Click OK.                           

http://learn.bentley.com/app/VideoPlayer/LinkToIndividualCourse?LearningPathID=106057&CourseId=115698&MediaID=5007153


 

 

3.  The prompts that appear with each civil cell 

vary based on what type of civil cell is being 

placed or what the creator of the civil cell 

labeled the references as. The reference 

prompts are usually intuitive, so be sure to read 

the prompt.  In the example the prompts 

indicate two reference elements are needed, one 

for the Side Road Center L ine and one for the 

Main Line Edge of Road.   



 

 

4.  Elements of the civil cell should now appear 

on the screen, if there are alternative 

configurations you can view them at this 

point by selecting elements, or you can 

right click to move to the next step.  

 

 

 

 

 

 

 

 

 

5.  The next prompt will ask for the user to 

Select Corridors To Be Clipped. *note: this 

prompt will only appear if a clipping 

boundary was added to the civil cell when it 

was created. In this example the main line 

corridor and the side road corridors were 

selected. Right click to move on once the 

corridors (if any) have been selected.  

6.  Left click to accept civil cell placement.  

The corridor template graphics are visible 

on the main line. This will be edited in the 

next section. 

7.  Adjusting corridors.  Corridors have an 

outline around them identifying the limits 

of the corridor; this is similar to the outline 

in the Roadway designer from SS2.  



 

 

8.  Adjusting a corridor using properties. The heads up 

menu will appear if the corridor element is clicked and 

hovered over. From the menu, the designer can open 

the properties and change the start/ end range of the 

corridor.  The limits should change graphically.  

9.  Adjusting a corridor using handles. The designer can 

also adjust a corridor using handles. The lines 

perpendicular to the corridor graphic are the handles. 

When selecting a corridor graphic small blue numbers 

will appear at key points. Clicking on them will give you 

the abil ity to edit the number and adjust the value. 

There are also small blue arrows at some locations. 

These can be dragged to adjust the corridor 

dynamically instead, as well as snapped to certain 

locations if the element is snappable.  

10.  In this example, the side road corridor has been 

adjusted to the back of the civil cell corridor graphic. 

The side road surface is no longer breaking through the 

main line.  

11.  Editing geometric elements. Depending how an element 

is created, the designer can edit and adjust elements 

without disrupting and breaking apart the model. Many 

elements which selected will have blue handles appear 

as well as blue numbers. If there is a handle and 

number it means the element was created using design 

constraints. Many handles can be adjusted dynamically 

or the numbers can be entered manually. In some 

cases the changes may break an element but the undo 

command is useful when trying to edit elements.  



 

 

12.  In this example there are three stages shown. 

The plan view, cross section view and 3D view 

are all visible. The first picture is the original 

model, the second had the alignment 

straightened and the third shows the radii of the 

intersection increased. Only elements in the 2D 

view were changed. The OpenRoads software 

automatically adjusts dependent 2D geometry, 

cross sections, profiles, and 3D models. This 

means less work for the designer as profiles, 

cross sections and 3D models do not need to be 

re-run each time a design change is made, all of 

these elements adjust automatically. *note: 

because of the changes the program needs to 

make to the model, when changing element 

values, allow the program to catch up and 

display the changes before moving on to the 

next edit.   



 

 

Section 6.6 Enhancing the Model 
 

 

 

Review and Enhance the Complete Model  
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Sheet production for OpenRoads has not been completed, this software development will  not be finalized until 

the next Major Release in the CONNECT version.  You will need to convert your geometry back to an ALG file 

type to be able to use the Plan and Profile Generator.  You will also need to convert your top proposed surface 

back to a DTM.   If you do not have an existing DTM this will need to be converted back as well.  

If you chose to hide the InRoads dialog box you will need to open it 

again.  On the MicroStation top menu bar  go to  

Applications > InRoads Group > Tools > Explorer Show/Hide 
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Section 7.1 Exporting Data 

7.1.1 Export to an ALG 
 

1.  In InRoads Explorer select the Geometry tab, right 

click on Geometry Project and select New.  Type in a 

name in the Name field and click Apply and Close. 

 

 

 

 

 

 

 

 

 

2.  Right click on the new Geometry Project and select 

Save As.  If you completed Step 11 in the Step by 

Step start up you will see your project path on the top 

portion of the Save As dialog box.  The Internal name 

you gave will be fi lled in the File name field.  Select 

Save and Cancel. 

 

 

 

 

 



 

 

3.  Before exporting to the new ALG file make sure all horizontal and vertical alignments have feature names. 

A.  Click on the horizontal alignment in check Element information locate the Feature Name field.  If it is 

blank give it a name. 

B.  Click on the vertical alignment in check Element information locate the Feature Name field.  If it is 

blank give it a name. 

 

 

 

 

4.  Now you are ready to complete the export on the Task menu. On the 

task menu select the Export to Native tool. Follow the prompts and 

select the Horizontal alignments you wish to export.  It is not required 

to select the vertical alignment because they are children of the 

Horizontal and will automatically export with the Horizontal.  

  If you do try and select the verticals MicroStation will lock up and 

you will be kicked out of the application. 

  Check the InRoads Dialog box and confirm everything came over.  

  If you do not see a vertical appear in the alg i t’s because a Feature Name is missing (go back and do 

step 3) 



 

 

7.1.2 Export to an Existing DTM 
If there is not an existing DTM, designers will need to call Central 

Surveys and ask them to do the following in OpenRoads. 

1.  Select on Terrain Model on the task menu and select the Export to File 

icon.  In the Export Terrain pick box select:  

Select Terrain: Existing 

Export Format: InRoads DTM (.dtm) 

2.  Place the DTM in the ProjectWise project folder under 

\500_Pre_Design\03_Central_Survey\ 

 

 

 

7.1.3 Export to a Proposed DTM 
 

1.  Open your main design File. 

2.  Change the corridor’s Design Stage  to display the top mesh. 

a.  In View 1, select the corridor. (Use the handles if necessary)  

b.  From the context menu, select Properties 

c.  Change the Design Stage  to Publish Top Mesh. 

d.  The corridor model changes to display a mesh of the proposed top 

surface. 

After creating the top mesh along the corridor, we will create a new dgn 

in which the proposed terrain model will be stored. The main corridor will 

be referenced into the new file to be util ized in terrain creation.  



 

 

3.  Create a new 3D dgn to store the proposed terrain from the corridor  and open it. 

4.  Reference the Main Design File into the Proposed Terrain File. Set Live Nesting to 2. 

5.  Create a terrain model from the mesh.  

a.  On the task menu, open the Terrain Model toolbox. 

b.  Select the Create from Elements tool. 

c.  First, on the Create Terrain Model dialog box... 

  Set the Feature Definition to TERR_Contours 

  Name the terrain Proposed Terrain. 

 

d.  Then, following the prompts, locate the elements to add and 

select the mesh element. 

e.  Click Reset when done. 

f.  Set the feature type to Break Line. 

g.  For the Edge Option, select Max Triangle Length 

h.  Set the Max Side Length to 5.  The terrain model is created. 

 

i.  Turn off the display of the main file and review the terrain model. Do not detach the reference file.  

NOTE: This terrain model is linked or “ruled” to the corridor model in the main file. The terrain model 

will update when modifications to the corridor are made. If the referenced corridor is detached, the link 

between the terrain and the corridor will be broken.  



 

 

8.  Export the Proposed Terrain Model to its native file 

format.  The plan production tools rely on the native 

file format, therefore we will now export the proposed 

terrain model to its native file format.  

a.  Select the Proposed Terrain element in the file. 

b.  From the context menu, select the Export Terrain 

Model tool. 

c.  Select the DTM file format. 

d.  Click Save.  The terrain is saved into the 

selected native file format. 

 



 

 

Section 7.2 Plan Sheets 
1.  Open your main modeling DGN file.   

2.  Make sure the ALG and Proposed and Existing DTM’s 

are opened. 

3.  To generate plan sheets select Drafting > Plan and 

Profile Generator on the InRoads Dialog Box. 

4.  Select the Highway Preference and select each tab to 

edit as necessary (AT THIS POINT DO NOT CLICK ON 

THE PROFILE CONTROLS TAB, this will mess up your 

settings “INROADS GLITCH”) 

 

 

 

5.  On the Main Tab select the Horizontal Alignment. 



 

 

6.  On the Plan Controls select and browse to the needed Model 

Files… 

 

 

 

 

 

 

 

 

 

 

7.  On the Borders and Titles Tab the following should be set. 

Cell toggled on and is set to B-Contract. Retain Cell Levels 

for Each Sheet is on and the Scale is set to 480. 

  

 

 

 

 

 

 

 

 

 



 

 

8.  On the Sheet Layout Tab 

a.  Select to pick a Host File, this will be the name of the 

newly created Plan Sheet DGN files .  

b.  In the Save As dialog box direct your files to be created 

in the correct ProjectWise folder by clicking on the 

Change button.    

c.  Give your Document a Name, File Name and a description 

and click Save. 

 

 

 

 

 

 

 

 

 

 

d.  Select to pick a Seed File.   

Browse to 05.0 - Workspace Resources\3_Workspace_V8i\Standards\seed\Sheet_Seed2d.dgn 

 

 



 

 

 

7 .  On the View Layout Tab the Scale should be set to 1 = 40.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8 .  Select the Match Line tab and assure that the Match lines 

are set to level ANNOT_Sheet_Match_Mark. 

     

     

     

 

 



 

 

9.  Click Apply on the Plan and Profile Generator and 

plan cut sheets will be produced 

10.  Open each file and modify the Model Properties.  

Open the Models Dialog box, right click on the Sheet 

Model and select Properties, 

 

 

 

11.  In the Models Properties Dialog Box change annotation scale 

to 1”=40’.  Click the OK Button. 

 

 

 

 

 

 

 

 



 

 

12.  Back on the Models Dialog box select the Define Sheet 

Boundary Icon. Adjust the Models Sheet Boundary to line up 

with the Border. You will need to use both the rotate and 

move tools to accomplish this.  

 

 

  

 

 

 

 

 

 

13.  On the MicroStation top menu bar select Settings > Drawing Scale and 

assure the the Lock Auxil iary Coordinate System is NOT on.  

14.  On the MicroStation top menu bar select File > Save Settings. 

 



 

 

Section 7.3   Profile Sheets 
1 .  Create a 2D Design Model DGN File to house the Profile Grids .  Make sure the 

ALG and Proposed and Existing DTM’s are opened. 

2 .  To generate profile sheets Select Drafting > Plan and Profile Generator  on the 

InRoads Dialog Box 

3.  Load the Profile Generator Format Preference. Select each tab to edit as 

necessary (CLICK ON THE PROFILE CONTROLS TAB LAST. This needs to be 

done this way to work around an “INROADS GLITCH”) 

 

4.  On the Main Tab select the Horizontal Alignment. 

 



 

 

5.  On the Borders and Titles Tab the following should be set. Cell 

toggled on and is set to B-Contract. Retain Cell Levels for Each 

Sheet is on and the Scale is set to 480. 

 

 

 

 

 

 

 

 

 

 

 

 

 

6.  On the Sheet Layout Tab 

e.  Select to pick a Host File, this will be the name of the 

newly created Profile Sheet DGN files.  

f.  In the Save As dialog box direct your files to be created in 

the correct ProjectWise folder by clicking on the Change 

button.    

g.  Give your Document a Name, File Name and a description 

and click Save. 

h.  Select to pick a Seed File.   

Browse to 05.0 - Workspace 

Resources\3_Workspace_V8i\Standards\seed\Sheet_Seed2d

.dgn 



 

 

7 .  On the View Layout Tab the Scale should be set to 1 = 40.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8 .  On the Profiles Controls tab 

9 .  Click Apply on the Plan and Profile Generator and data point in 

the DGN to select the starting point for the profile grids.  This 

file wil l be automatically referenced into the profile cut sheets.  

10 .  Open the profile grid layout dgn. Using the InRoads dialog box 

view and annotate the vertical alignment.  

Geometry > View Geomentry > Active Vertical  

Geometry > View Geomentry >Vertical Annotation 



 

 

15.  Open each file and modify the Model Properties.  

Open the Models Dialog box, right click on the Sheet 

Model and select Properties, 

 

 

 

16.  In the Models Properties Dialog Box change annotation 

scale to 1”=40’.  Click the OK Button. 

 

 

 

 

 

 

 

 



 

 

17.  Back on the Models Dialog box select the Define Sheet 

Boundary Icon. Adjust the Models Sheet Boundary to line up 

with the Border.  

 

 

  

 

 

 

 

 

 

18.  On the MicroStation top menu bar select Settings > Drawing Scale and 

assure the the Lock Auxil iary Coordinate System is NOT on.  

19.  On the MicroStation top menu bar select File > Save Settings. 

 

 

 



 

 

Section 7.4 Cross Section 

7.4.1 Create a Cross Section DGN and Reference the Design 
Before moving on to create a new file for your cross sections you will need to verify a couple things in your 

main design files. The existing ground reference file’s display must be tuned the 3D Model. All the proposed 

and existing levels, features and components you need displayed in the cross sections need to be on as well.  

To create cross sections you will need to use Nested Attachments - Live Nesting to attach the main design 

model to the blank cross section file.     

1.  Create new file using a CTDOT 2d Seed file and 
attribute as shown. 

\05.0 - Workspace 

Resources\3_Workspace_V8i\Civil_Standards\seed

\2D_OpenRoads_DesignSeed_83.dgn 

or 

\05.0 - Workspace 

Resources\3_Workspace_V8i\Civil_Standards\seed

\2D_OpenRoads_DesignSeed_83.dgn 

 

2.  In the MicroStation pull down menu choose  File 
> References . 

3.  In the References dialog menu choose  Tools > 
Attach.  Select the file in your main modeling 

file. 

4.  Leave the Attachment Method set to  Interactive.   

5.  Select Open   to activate the Reference Attachment Settings dialog.  



 

 

6.  Populate the Reference Attachment Settings as shown.  

Orientation Coincident ‐ World 

Nested Attachments Live Nesting 

Nesting Depth 2 

Hint: Live nesting will automatically give access to the 3D model as  well as the existing terrain dgn file.  

7.  Select OK to attach the reference file.  

8.  Fit View to review the project location.  

Hint: Pressing the F8 Funct ion Key will toggle black background to white and toggle  on the level 

override symbology. This is setup as part of the Bentley-Civil workspace. Pressing F8 again will revert 

back to original settings. 

9.  Open the Level Display Dialog, Enable the Target Tree, and verify all levels are enabled. 

Hint: Turning off a level at this stage will also turn it off in the created cross section  Design Model. For 

a component to be displayed in the proposed cross section  Design Model, the level must be turned on in 

the 3D model before creating the sections. 

*If any level settings are changed, select File > Save Settings so the changes will be remembered when cross 

sections are created. 



 

 

7.4.2 Create the Proposed Cross Sections 
 

1.  Select Settings > Design File, Change Station Settings 

to a precision of 0.  

2.  Select the Create Cross Sections tool from the Corridor 

Modeling task menu. 

 

3.  Following the heads-up prompt, locate the alignment by selecting the red centerline alignment. 

4.  Select Preferences button from the bottom of the Create Cross Section dialog. 

5.  In the Preferences dialog select the preference named Highway. 

6.  Select Load. 

Preferences are predefined settings stored in the active XIN settings file for all three products (GEOPAK, 

InRoads, and MX). These preferences will be used for creating, annotating and computing end area 

volumes on proposed cross sections.  

7.  Close the Preferences dialog. 



 

 

8.  Under Model type in a name 

 

9.  Select Apply to create the cross sections into a new DGN Drawing Model. 

It wil l take a few moments for the cross sections to be created. A status bar appears in the lower right 

corner showing the progress. 

10.  Close the Create Cross Section dialog.  

 

 

    



 

 

7.4.3 Viewing the Cross Sections 
1.  Select the Cross Section Viewer  tool from the 

Corridor Modeling  task menu.  

2.  Verify the Cross Section Model setting is set the 

correct Cross Section Model. 

3.  Set the Zoom Factor  to 0.75. 

4.  Set the Movie Mode Time  to 1.0  sec. 

5.  Select Run  to automatically scan through the cross 

sections. 

6.  Hit the Esc  key on your keyboard to exit the 

movie mode. 

7.  Select a Cross Section station by clicking on it 

in the list and notice how the view updates to 

the selected cross section station value.  

8.  Press the Up  and Down  Arrow keys on your 

keyboard to step through the Cross sections in 

the list. 

9.  Close the Cross Section Viewer application. 

 

*Note that the Cross Sections are displaying an ‘X’ at each of the Crossing Features such as Centerline 

and Edge of Pavement. The Features must be displayed for them to be annotated, and are a 

construction class so they can easily be turn off in View Attributes. 

 



 

 

7.4.4 Annotating the Proposed Cross Sections 
1.  Select the Cross Sections  tool from the Corridor Modeling  task 

menu. 

2.  Select Preferences. 

3.  Select the preference entitled Object ‐ Off/Elev/Slope. 

4.  Select Load, to utilize the selected preferences in the previous 

step. 

5.  Close the Preferences selection dialog.  

  In the Annotate Cross Section dialog, set 

the General settings.  Make sure the correct 

Cross Section Model and Surface you would 

like to annotate is active. 

  Select a Cross Section Model 

  Select a Surface 

  Ensure that the Location  is set to 

Object. 

 

 

 

 

 

 

 

 

 



 

 

6.  To annotate the point features. Select the Segments Folder 

and turn off Include Segments.  

7.  Select the Features > Annotate folder  and Highlight the 

Features you would light to annotate.  Click Apply. 

 



 

 

8.  Select the Features Folder and turn off Include Features.  

 

 

 

 

 

 

9.  Select the Segments Folder and turn on Include Segments.  

10.  Select the Segments> Annotate folder and Highlight the 

Segment you would light to annotate.  Click Apply for each 

segment. 

 

 

 

 

 

 

   

 

 

 

 

      

 

 

 

 

 



 

 

11.  To turn off the X on the crossing Features select View Attributes  and turn of Constructions. 

 

 



 

 

7.4.5 ROW Lines Projected on Cross Sections 
Coming Soon 



 

 

7.4.6 Computing End Area Volumes 
 

 

 

 

End Area Volumes Overview 

 

 

 

End Area Volumes Unsuitable Materials Exceptions Factors 

 

 

 

 

End Are Volumes Classifications 

 

http://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/16530.video-end-area-volumes-overview
http://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/16531.video-end-area-volumes-unsuitable-materials-exceptions-factors
http://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/16532.video-end-area-volumes-classifications


 

 

Through CTDOT Piloting and suggestions from Bentley the following best practices have been established. 

1.  When using AutoTrack create a new 2D MicroStation file and reference in your OpenRoads file.  Do not 

use AutoTrack in your OpenRoads Modeling File.   
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