User’s Guide

Release 2.13

June 2014

Last Updated
June 2014

Prepared by

5700 SW 34th Street, Suite 1235, Gainesville, Florida 32608-5371 • Phone: (352) 381-4400 • Fax: (352) 381-4444 • info@infotechfl.com • www.infotechfl.com
# Contents

1. Before You Begin ...................................................................................................... 1-1  
   1.1 Overview .......................................................................................................... 1-1  
   1.2 Online Help ...................................................................................................... 1-2  
   1.3 Documentation Conventions ............................................................................ 1-2  

2. Working in Estimator ............................................................................................... 2-1  
   2.1 Estimator Windows and Commands ................................................................. 2-1  
      2.1.1 Working With Estimator Windows ....................................................... 2-1  
      2.1.2 Tree Area vs. Grid Area ........................................................................ 2-4  
      2.1.3 Hide/Show Columns ............................................................................. 2-5  
      2.1.4 Show/Hide Tree View ........................................................................... 2-6  
      2.1.5 Expand or Collapse All Tree View ....................................................... 2-7  
   2.2 Getting Help ..................................................................................................... 2-7  
      2.2.1 Using Online Help ................................................................................ 2-8  
      2.2.2 Getting Information About Estimator ................................................... 2-8  
      2.2.3 Generating a Support Request ............................................................... 2-8  
      2.2.4 Getting Estimator Support .................................................................. 2-10  
   2.3 Setting Up Your Working Environment ......................................................... 2-10  
      2.3.1 Setting Preferences .............................................................................. 2-10  
      2.3.2 Changing Your Password .................................................................... 2-18  
      2.3.3 Logout Current User ........................................................................... 2-19  

3. Introduction to Estimator and Cost Estimation .................................................... 3-1  
   3.1 Estimator Overview .......................................................................................... 3-2  
      3.1.1 Understanding Estimates ....................................................................... 3-2  
      3.1.2 Understanding Catalogs and Code Tables ............................................ 3-2  
      3.1.3 Understanding the Difference Between Estimate Groups and Catalogs ............................................................................................... 3-3  
   3.2 Highway Cost Estimation ................................................................................. 3-3  
   3.3 Cost-Based Estimation ..................................................................................... 3-4  
   3.4 Bid-Based Estimation ....................................................................................... 3-7  
      3.4.1 Overview ............................................................................................... 3-7  
      3.4.2 HIREG Methodology ............................................................................ 3-9  
      3.4.3 Weighted Average ............................................................................... 3-11  
      3.4.4 Regression Coefficients ...................................................................... 3-12  
   3.5 Reference Price Estimation ............................................................................. 3-20  

4. Estimator Basics ........................................................................................................ 4-1  
   4.1 Logging On to Estimator .................................................................................. 4-1  
      4.1.1 Starting Estimator ................................................................................... 4-1
4.1.2 Entering Your Username and Password ............................................... 4-2
4.2 Updating Your Catalogs ............................................................................. 4-3
4.3 Opening an Estimate or Current Catalog ................................................... 4-4
  4.3.1 Opening an Estimate File ...................................................................... 4-5
  4.3.2 Creating a New Estimate File ............................................................... 4-5
  4.3.3 Opening a Catalog ................................................................................. 4-5
4.4 Saving an Estimate .................................................................................... 4-6
  4.4.1 Saving Estimates ................................................................................... 4-6
  4.4.2 Using the Estimate Auto Save Utility ................................................... 4-7
  4.4.3 Using the Estimate Archive Utility ....................................................... 4-9
4.5 Printing an Estimate .................................................................................. 4-11
  4.5.1 Show Item Descriptions ...................................................................... 4-13
  4.5.2 Show Inactive Price Bases .................................................................. 4-13
  4.5.3 Hide Prices .......................................................................................... 4-13
  4.5.4 No Page Breaks Within Items ............................................................. 4-13
  4.5.5 Show Notes for Groups ....................................................................... 4-14
  4.5.6 Show Notes for Items .......................................................................... 4-14
  4.5.7 Total Item Quantities Across Groups .................................................. 4-14
  4.5.8 Summary of Quantities by Item and Group ........................................ 4-14
  4.5.9 Show Price Bases Details .................................................................... 4-14
  4.5.10 Report Alignment .............................................................................. 4-15
  4.5.11 Select Customized Report .................................................................. 4-15
  4.5.12 Setting Up the Printer ........................................................................ 4-15
4.6 Verifying an Estimate ................................................................................ 4-16
4.7 Undo and Redo .......................................................................................... 4-18
4.8 Cut, Copy, and Paste .................................................................................. 4-19
  4.8.1 Cut Command ..................................................................................... 4-19
  4.8.2 Copy Command .................................................................................. 4-19
  4.8.3 Paste Command ................................................................................... 4-20
4.9 Building Expressions ................................................................................ 4-20
4.10 Closing an Estimate or Catalog .............................................................. 4-22
4.11 Exiting Estimator ...................................................................................... 4-23

5. Working with Estimates ................................................................................. 5-1
  5.1 Working with the Estimate Header .......................................................... 5-1
    5.1.1 Adding Estimate Header Information ................................................. 5-1
    5.1.2 Changing Estimate Header Information .......................................... 5-5
    5.1.3 Using the Estimate as a Template .................................................... 5-5
    5.1.4 Setting the Estimate's Options .......................................................... 5-8
    5.1.5 The Web Services Tab ..................................................................... 5-9
  5.2 The Groups and All Items Tabs ............................................................... 5-10
    5.2.1 Introduction to the Groups Tab ......................................................... 5-10
    5.2.2 Introduction to the All Items Tab ....................................................... 5-11
  5.3 Working with the Estimate Item List ....................................................... 5-13
  5.4 Adding Items to Your Estimate .............................................................. 5-15
    5.4.1 Adding an Item While in the Groups Grid ....................................... 5-15
    5.4.2 Adding an Item in the All Items Grid ............................................... 5-15
5.4.3 Adding a Standard Item ................................................................. 5-16
5.4.4 Using the Find Item Window ......................................................... 5-17
5.5 Sorting the Item List .......................................................................... 5-20
5.5.1 Sorting the Estimate and Group Item Lists ...................... 5-20
5.5.2 Sorting the Items Before Adding an Item to Your Estimate ...... 5-20
5.6 Modifying the Estimate Item List ...................................................... 5-21
5.6.1 Changing an Item on the Estimate Item List .. 5-21
5.6.2 Deleting Items From the Estimate Item List ................. 5-21
5.7 Working with Item Price Bases ......................................................... 5-22
5.7.1 Working with Cost Sheets............................................................. 5-22
5.7.2 Working with Reference Prices ..................................................... 5-33
5.7.3 Working with Bid Histories ........................................................... 5-35
5.7.4 Modifying Price Basis in an Estimate ........................................ 5-36
5.8 Updating Price Information .............................................................. 5-38
5.9 Working with the Estimate Users List .............................................. 5-39
5.9.1 Adding Users to the Estimate Users List ............................. 5-41
5.9.2 Changing Estimate Users .............................................................. 5-42
5.9.3 Deleting Estimate Users ................................................................. 5-42
5.9.4 Sorting the Estimate Users List ...................................................... 5-43
5.10 Working with Estimator Funds ......................................................... 5-43
5.10.1 Printing the Estimate Funding Summary Report ............ 5-44
6. Additional Estimator Features ............................................................ 6-1
6.1 Estimate Extra Data ........................................................................... 6-1
6.1.1 Adding Extra Data to an Estimate .............................................. 6-1
6.1.2 Adding Extra Data to a Group ..................................................... 6-3
6.1.3 Adding Extra Data to an Item ....................................................... 6-4
6.1.4 Changing Extra Data Fields .......................................................... 6-6
6.2 Check for Catalog Updates ............................................................... 6-6
6.3 Deleting Inactive Price Bases ............................................................ 6-8
6.4 Adding Non-standard Items to the Estimate ......................... 6-9
6.4.1 Creating a Non-standard Item From an Item in the Standard Item Catalog .............................................................. 6-9
6.4.2 Creating a Non-standard Item Without Using the Standard Item Catalog .............................................................. 6-10
6.5 Renumbering Estimate Items ......................................................... 6-10
6.5.1 Renumber Estimate Items ............................................................. 6-11
6.5.2 Renumber Using Current Order ................................................... 6-13
6.5.3 Renumber Selected Items .............................................................. 6-14
6.6 Pricing an Item as a Percentage of the Estimate ......................... 6-15
6.7 Excluding an Item as Part of the Percentage Price ..................... 6-15
7. Working With Catalogs and Code Tables .............................................. 7-1
7.1 Working With Catalog Information ................................................. 7-1
7.2 The Standard Item Catalog ............................................................. 7-2
7.2.1 Viewing the Standard Item Catalog ........................................... 7-2
7.3 Working With Price Basis Catalogs .................................................. 7-5
7.3.1 Cost Sheet Catalog ................................................................. 7-5
7.3.2 Bid History Catalog ............................................................... 7-6
7.3.3 Reference Prices Catalog ..................................................... 7-7
7.4 Working With Rate Catalogs..................................................... 7-8
  7.4.1 Equipment Rate Catalog ...................................................... 7-9
  7.4.2 Labor Rate Catalog ............................................................ 7-10
  7.4.3 Material Rate Catalog ........................................................ 7-11
7.5 Working With Code Tables ...................................................... 7-11
7.6 Printing Catalog Reports .......................................................... 7-12
7.7 Finding Catalog Elements ....................................................... 7-13
  7.7.1 Expert Mode ..................................................................... 7-14
7.8 Scheduling Catalog Imports ..................................................... 7-16

8. Importing and Exporting ............................................................... 8-1
8.1 Importing Catalogs ................................................................. 8-1
8.2 Importing Estimates ............................................................... 8-2
  8.2.1 Importing an Excel Spreadsheet as an Estimate Using Estimator .................................................................................. 8-3
  8.2.2 Importing Project Data From Design Systems Using aecXML ...................................................................................... 8-7
8.3 Exporting Catalogs ................................................................. 8-7
8.4 Exporting Estimates ............................................................... 8-8

Appendix A: Glossary ........................................................................ A-1
1. Before You Begin

Before you use AASHTOWare Project Estimator™, browse through the beginning chapters of this manual. Read through this chapter before proceeding through the manual; it tells you how the Guide is organized, and the software and hardware configuration required to run Estimator.

This guide was written for a user without super-user privileges. For information on super-users, please read the Estimator System Manager’s Guide. Also, read the System Manager’s Guide if you install and maintain Estimator or manage the reference database, which describes these operations in detail, or if there are menu options available to you that are not discussed in this guide.

1.1 Overview

The Estimator User’s Guide is divided into eight chapters and a glossary. New Estimator users should read Chapter 2, which discusses the ways you can use Estimator and provides an overview of how the Estimator system operates.


Chapter 4, Estimator Basics, puts these skills to work at the lowest level and explains the basic tasks you perform in Estimator to generate an estimate. It describes how to perform fundamental system operations like logging on, opening a project, using the Expression Builder, and exiting Estimator.

Chapters 5, Working with Estimates, provide detailed information about how to work with estimates and how to use Estimator functions. Estimator windows and commands are described as they occur within the workflow. After you are comfortable with the Estimator system and understand the ways you can use Estimator to estimate, you can follow the processes described in these chapters to fine-tune your estimations.
Additional Estimator Features are discussed in Chapter 6. This chapter informs you of Estimator features that help make your estimates easier to use.

Chapter 7, Working With Catalogs and Code Tables, provide detailed information about how to work with Estimator catalogs and code tables. Estimator windows and commands are described as they occur within the workflow.

Chapter 8, Importing and Exporting, details how to import and export estimates and catalogs.

### 1.2 Online Help

The comprehensive online help provided with your Estimator software is an extension of the *Estimator User's Guide*. The online help provides a quick reference to menu commands and window fields.

To use the online help, select **Help Topics** from the **Help** menu to view a list of topics.

### 1.3 Documentation Conventions

This guide uses different techniques to help identify important information. Keys to press and buttons to click which invoke actions are identified in small caps, for example, “press the **ALT** key.” Tab names are also shown in small caps.

Menu choices and user entries (information to type in using the keyboard) are shown in **bolded** text.

Referenced publication titles and important terms are identified by **italics**.

- **Note:** Important notes are indented from both the right and left margins and flagged with small note icons. Notes contain extra information that may help you work more efficiently or understand a process more fully.

- **Caution:** Cautions look very similar to notes, but are flagged with an exclamation point icon. Read all cautions; they contain important information that should not be overlooked.
2. Working in Estimator

If you are a new Estimator user, you need to learn the software navigation mechanics before you can use Estimator to produce detailed estimates. This chapter explains Estimator system elements and how to make those elements interact. It tells you how to set up your working environment and describes Estimator windows and command menus.

2.1 Estimator Windows and Commands

You interact with Estimator through two basic elements: windows and commands. Windows display information and sometimes require you to enter information. Commands displayed in menus at the top of the screen or issued through shortcut keys and command buttons tell Estimator what function you want to perform.

2.1.1 Working With Estimator Windows

Estimator displays catalogs and estimates in windows. You can open several windows at the same time. The active window is the window in which you are currently working. The active window displays in the foreground and has a different colored (usually brighter) title bar. Only the active window receives your keyboard input. If you select Delete from the Edit menu with the wrong active window displayed, you could accidentally delete data. Make sure you know which window is currently active when you issue commands.

A window automatically activates when you open it. It remains active until you open another window or you activate a different open window. The lower half of the Window menu lists the names of all open windows in alphabetical order (a maximum of nine window names are listed in the Window menu at one time). A check mark appears next to the name of the active window (only one window can be active).
You can activate an inactive open window in one of three ways: by clicking anywhere in the window with a mouse, by pressing CTRL+F6 until the desired window is activated, or by choosing the name of the window you want to activate from the Window menu.

When you perform one of these actions, Estimator activates the selected window and, if the window was partially or completely hidden behind another window or windows, it reorganizes all the windows on the display screen so that the newly activated window is fully visible.

If 10 or more windows are open on the screen at one time, the Window menu includes the More Windows… command. When you select More Windows from the Window menu, Estimator displays the Select Window dialog box, which lists the names of all open windows (see Figure 2-2).
To activate an open window, select the name of the desired window from the Windows list box and click OK.

**Arranging Windows**

You can modify the way Estimator displays open windows on the screen. The upper half of the Window menu contains the commands Tile and Cascade, which allow you to establish how windows display. The Window menu is only available when a window is open.

These commands organize the layout of the open windows. Estimator enables these commands when two or more windows are open.

Select **Cascade** from the **Window** menu to organize the open windows into an overlapping, cascading format.

Select **Tile** (Vertically or Horizontally) from the Window menu to organize the open windows so all windows are simultaneously visible on the computer screen.

**Read-Only Windows**

If you do not have permission to edit an estimate or if the proper catalog is not loaded for that estimate, then the words Read Only appear in the title bar of the window (see Figure 2-3). If you work in windows that display this, you cannot make changes or additions to the catalog or estimate.

If you are accessing a catalog through a Web server, then data sharing can often be problematic between several users. Estimator allows the first user who checks out a
catalog to edit that catalog. Estimator grants subsequent users read-only access to the data.

An estimate also becomes a read-only estimate when the current catalog changes to one that is incompatible with the estimate, such as a different spec year or different system of measure.

### 2.1.2 Tree Area vs. Grid Area

Estimator displays list information in a tree area, and the corresponding detail information in a grid area.

![Figure 2-4. Catalog List in a Tree Area With Corresponding Catalog Selection in Grid Area](image)

The tree area, in the left pane, is a list of all information available for that particular window. The elements with plus signs represent a hierarchy of information for that particular element.

The grid area, in the right pane, displays the details of the selected information in the tree area, although you do not need to use the tree to access the information in the grid. If you select an element in the grid area, the tree displays the location of that information in the hierarchy.

Most information in Estimator is displayed with tree areas and grid areas, even if they are mixed with other types of displayed information.
To move around in the tree area, use the plus signs next to the group, item, or catalog to display the details in the grid area, and select the desired element in the tree area to display it in the grid area. Click the GO button next to the information in the grid area or use the navigational arrows to access the corresponding information in the tree area.

### 2.1.3 Hide/Show Columns

In addition to hiding the tree view, you can also hide columns in your estimate or catalog. For example, if your agency never uses the Alternate Code description for a group, you can hide that column from the grid area.

Each window in Estimator has its own columns for hiding or showing. The Show/Hide Columns window displays differently depending on where you are in Estimator.

1. With the estimate open, select **Hide/Show Columns** from the **View** menu. Estimator displays the Show/Hide Columns window.
This window lists the current columns, and shows which ones are displayed and which are hidden.

2. Select the columns you wish to hide in the right pane. Then click HIDE SELECTED. The selected columns move to the left pane.

3. Click ok. The selected columns are hidden in your estimate.

4. To show the hidden columns, select Show/Hide Columns from the View menu.

5. Select the columns to be shown, then click SHOW SELECTED. The columns moves from the Hide list to the Show list.

6. Click OK. The hidden columns are now visible.

If you had wanted to hide all the columns, you would have clicked the HIDE ALL button in the Show/Hide Columns window. If you wanted all the hidden columns visible, you would have clicked the SHOW ALL button.

### 2.1.4 Show/Hide Tree View

If you prefer to work in the grid area only, you can hide the tree area in Estimator catalogs and estimates. You can navigate using the grid area.

To hide the tree view, open the catalog or estimate. Select Show/Hide Tree View from the View menu. Estimator displays the grid area only.
When navigating with only the grid area, use the green GO buttons and the yellow directional arrows to move through the estimate or catalog. To view the tree area again, select **Show/Hide Tree Area** from the **View** menu.

### 2.1.5 Expand or Collapse All Tree View

Estimator has commands that will let you view all parts of the estimate in the tree area. When you choose to expand the tree view, Estimator acts as if you have clicked every plus (+) sign in the estimate or catalog. Each group, item, and price basis is visible when used in an estimate; each catalog and code table is visible when used in the current catalog.

To see all tree items for your selected estimate or catalog, select **Expand All Tree View** from the **View** menu.

You can also close each opened item at once using the Collapse All command. When you choose this command, Estimator acts as if you have clicked every minus (-) sign in the estimate or catalog.

To close all expanded tree items, select **Collapse All Tree View** from the **View** menu.

### 2.2 Getting Help

Estimator provides an online Help system you can access while using the application. Look in the online help for instructions on how to perform Estimator functions.
2.2.1 Using Online Help

You can access Help in a variety of ways, depending on the type of information you need. To get help on the active window, select Context Help from the Help menu. To browse the table of contents for the Estimator Help system, select Help Topics from the Help menu. To search for a specific topic, select Help Topics from the Help menu, and then select the Search tab.

Estimator Help is context sensitive. In other words, you can display help windows specifically to open windows and menu commands while you are working in Estimator. To get help on the active window, press SHIFT+F1. To get Help on a specific menu command, press F1 when the menu command is highlighted.

2.2.2 Getting Information About Estimator

When you select About Estimator… from the Help menu, the About Estimator window appears, which contains the full-length name of the Estimator program, the Estimator icon, the Estimator program release number, the copyright notice. It might also include Info Tech's address.

![About Estimator Window](image)

Figure 2-8. About Estimator Window

2.2.3 Generating a Support Request

The Generate Support Request command displays a support request form. Enter all the necessary information and save the file, then attach it to an e-mail and send it to the appropriate support option (see Section 2.2.4). Info Tech uses information on this form
to help solve Estimator problems. You can also suggest future enhancements you would like added to Estimator. When you choose Generate Support Request from the Help menu, Estimator displays the Generate Support Request dialog box (see Figure 2-9).

![Support Request Dialog Box](image)

Figure 2-9. Support Request Dialog Box

Enter your name and telephone number in the appropriate fields. In the Type field, click the down arrow and choose the type of request you are generating from the selection list. In the Priority field, click the down arrow and choose a priority level according to the importance of your request. In the Category field, select the type of problem you are having. In the Short Description field, give a brief description of the problem or comment. In the Long Description field, give a detailed description of the problem or comment. When you finish entering information for the request, click **Save**. Save the support request as a text file, and then e-mail it to Info Tech.

The Priority field has several options from which to choose. Use the following descriptions to help you choose the right one.

- **Low**
  
  Problem is a nuisance to business functions.

- **Medium**
  
  Problem is a definite issue that causes a minor inconvenience but does not prevent business functions from being completed.

- **High – Important**
  
  Problem is a major inconvenience but does not prevent critical business functions from being completed.

- **Critical – Very Important**
  
  Problem prevents implementation or upgrade of AASHTOWare Project from being completed. This classification is for use by licensees that are not in production use of the release and needs to include a date by which the fix
is needed. This classification should only be used on errors that would be considered Urgent if the licensee was in production use of the software.

| Urgent – Very Important | Problem stops the ability to perform a critical business function. This classification is for use by licensees that are in production use of the release. |

### 2.2.4 Getting Estimator Support

If you are a consultant working for a state transportation agency, please contact the Estimator representative at the agency to obtain technical support for Estimator.

If you are working at a state transportation agency and need technical support, send an e-mail message to Info Tech at customer.support@infotechfl.com, include Estimator in the subject line, and describe the problem in the body of the message. Also, you can call Info Tech at (352) 381-4400 during the hours posted on Cloverleaf™ to talk to Estimator Customer Support. This option is not available to consultants.

### 2.3 Setting Up Your Working Environment

You can set defaults in Estimator that manage how windows display on the screen, how often you save your work, and other preferences.

#### 2.3.1 Setting Preferences

You can modify your Estimator working environment according to your personal tastes. Select **Global Options** from the **Other Tools** menu to display the Estimator Options tab folder window shown in Figure 2-10.
General Tab

The Estimator Options dialog box contains several controls. Figure 2-10 shows the default condition for the controls. The Estimator System Manager sets the System Options, which are displayed, but unavailable; however, you can change the User Options.

Note: For descriptions of the system options, please see the System Manager’s Guide.

You can tell Estimator to automatically save your work by setting a time in the Auto Save Interval (minutes) field. Each time your estimate is saved, an archive file of the estimate is created by Estimator.

You can set the number of archives of one estimate that you want saved. For example, if your archive level is set to five, then each time you save your estimate, Estimator makes the last saved version into an archived file of the estimate. Estimator will then save five versions of your estimate before the oldest archive file is over-written.
**Numeric/Rounding Tab**

The numeric/rounding tab shows the way Estimator numbers its estimates, plus the way it rounds off the unit price, extended amount, and quantity. It also shows how groups and items are numbered.

![Figure 2-11. The Global Options Window - Numeric/Rounding Tab](image)

The fields on this tab are all set by the system manager.

**URLs Tab**

The **URLs** tab contains the paths for your catalog, estimate, template, and cache folder.
The Catalog Path (HTTP or File) field displays the location of the Estimator catalogs. This is the directory Estimator displays when you select Switch Current Catalog from the Catalog Tools menu. You can change this directory by entering a new one in the field, or by clicking the BROWSE button and selecting the new directory. The catalogs have to be in the directory displayed in this field or you will not be able to access them.

The Estimate Template Folder field shows the directory to which the estimates are saved. This field can only be edited by a super-user.

The Report Template Folder field displays the directory where customized print report templates are kept. This field can only be edited by a super-user.

The Templates Folder field displays the directory where templates are kept. This field can only be edited by a super-user.

The Cache Folder field displays the local directory that Estimator uses for file downloads when your user table or catalogs are stored on a web server.

**Internet Tab**

The INTERNET tab allows Estimator to connect to a server and look for catalog updates and download them into the Current Catalog.
In the URL field, enter the URL that the transportation agency has established as the Web site that contains the catalog update information. This address must be correct or you will not be able to download catalogs from the Internet. The need for a username and password depends on the security of the specified site.

If you select to automatically search for updates on startup, then when you log in to Estimator, a wizard announcing catalog updates may appear. If you decide not to check for updates on startup, then you can still check for new catalog information by selecting **Check for Catalog Updates** from the **Catalog Tools** menu.

The Download Folder field displays the local directory that Estimator uses for file downloads when you run the Catalog Update command.

Your ability to update your catalogs depends on your Estimator privileges.
**Proxy Tab**

The PROXY tab controls the way Estimator connects to the Internet.

![Proxy Tab Screenshot](image)

Figure 2-14. The Global Options Window - Proxy Tab

It is a good idea not to change any information in the tab unless told to by your system administrator or your network administrator. If you have any questions about the PROXY tab, contact your system administrator or your network administrator.

**Tree and Field Labels**

The TREE/FIELD LABELS tab allows the system manager to label certain elements of the estimate in the tree view and in the detail view. Only the system manager can change these options.

To change the labels in an estimate in the tree view, enter a value in the appropriate box in the Tree Labels column. To change the labels in an estimate in the detail view, enter a value next to the label listed under the Field Labels column.
Note: If upgrading from a version of Estimator prior to 2.11a, the values in the Tree Labels column are moved into the Field Labels column. The system manager should modify both the Tree and Field Labels values for their business process.

Figure 2-15. The Global Options Window – Tree/Labels Tab

The question mark (?) box next to each field contains the list of the fields after which the label can be named. For example, if you select %1 for the Item field, then the label will be based on the Item ID field, which is the %1 designation. If you do not include a % value, then the field will always be named after the text and will not change depending on any field names.

Catalog Tab

The CATALOG tab allows you to set preferences for importing obsolete items. Three choices will be available, and depending on the choice selected, obsolete items will or will not be added to the standard item catalog. This tab also has two other options: one is to prevent duplicate items codes in catalogs, and the other is to copy notes to estimates. For more information please see the Estimator System Manager’s Guide.
Verifications Tab

The Verifications tab allows the user to turn verification messages on or off. Often, verification messages are received because of business processes that do not require reporting each time the estimate is verified. This feature allows the user to turn off verification messages if desired.

Currently, verification messages default to business processes that were deemed necessary for the overall product and do not necessarily reflect agency business processes. When an estimate is verified, the verification messages are provided in a message popup window that identifies the error or warning, and the data can be saved in a CSV file.

The following verification options can be checked (allowing the verification messages to be displayed) or not checked (verification messages will not be displayed):

**Funding**

If this option is checked and a funding package is assigned to the estimate, then funding verification messages will be displayed if there are funding-related issues.

**Obsolete Items**

If this option is checked and the estimate has obsolete items, verification messages will be displayed.
**Duplicate Line Numbers**

If this option is checked and if existing estimates files or imported files have duplicate line numbers, verification messages will be displayed. Checking the "Prohibit Duplicate Line Numbers" checkbox in the General tab under Global Options will display verification messages for new estimates.

**AASHTOWare Project Compatibility**

If this option is checked and when the Estimate Option "Only Trns•port Item and Codes are allowed" is checked, verification messages are displayed.

**Multiple Active Price Bases**

If this option is checked, and if existing estimates files or imported files have multiple active price bases, verification messages will be displayed. Checking the "Prohibit Multiple Active Price Bases" checkbox in the General tab under Global Options will display verification messages for new estimates.

By default, all verification options are checked.

![Figure 2-17. The Global Options Window - Verifications Tab](image)

### 2.3.2 Changing Your Password

You should change your password the first time you run Estimator. This ensures that only you are using your Estimator account. If you forget your password, your system
manager can reset it for you. Your password should be changed periodically for security purposes. Select **Change Password** from the **Other Tools** menu to change your Estimator password. Estimator displays the Change Password dialog box shown in Figure 2-18.

![Change Password Dialog Box](image)

Because Estimator does not display passwords on the screen as you type them, you could potentially make a typing error without knowing it. Therefore, Estimator requires you to enter the new password twice. Click **OK**.

Estimator compares the two entries of the new password to make sure they match. If the two entries of the new password are not exactly alike, Estimator displays an error message. If this occurs, you must enter the information again. When the new password has been entered the same way twice, Estimator accepts the new password and includes it in the Estimator User Catalog. You must use the new password when you start a subsequent Estimator work session.

Your password is *case-sensitive*, which means that capital and lowercase letters must be typed as such each time you enter your password.

### 2.3.3 Logout Current User

The Logout Current User command allows you to log out the person who used Estimator on the computer before you without exiting the program. To use this command, select **Logout Current User** from the **Other Tools** menu. Estimator logs out the current user and displays the Login window in which you enter the new user’s user name and password.
3. Introduction to Estimator and Cost Estimation

Estimator is designed to estimate the cost of a construction project using items of the project and several estimation methods to determine the price of the items. To use Estimator productively, you must understand the grouping of the items and estimation methodologies used.

Contractors bidding on highway construction projects must determine approximately how much it costs to perform the required work so their bid is not so low that they lose money or so high that they lose the contract. Agencies that pay for highway construction need to know how much a project costs so they can set up funding and evaluate the bids they receive. Estimator helps agencies develop these highway construction detailed cost estimates.

Estimator makes sophisticated, technologically advanced highway construction estimation easy. Estimation typically involves an unwieldy quantity of information that must be logically divided to organize the estimation process. Estimator divides this information into manageable estimates and catalogs.

To determine the total cost of an estimate, the estimated cost for each item must be determined. Because quantity estimates have already been developed as part of the design process, the estimator's job becomes one of unit price estimation. The total of all individual item costs provides the cost of the complete construction estimate.

Estimator supports three approaches to estimate unit prices:

- Estimation based on the components (equipment, labor, and materials) used to produce the item (cost-based estimation).
- Estimation based on the historical price of the item from previous contracts (bid-based estimation).
- Estimation based on a subcontractor or supplier quote, or the estimator’s experience (reference price estimation).
Each of these estimation methods are discussed later in this chapter. All estimation methodologies can be used in a single estimate.

### 3.1 Estimator Overview

Information in an estimate can sometimes be overwhelming to the estimator. For that reason, Estimator breaks down the information into estimates and catalogs.

#### 3.1.1 Understanding Estimates

Estimator estimates store all items used in a construction estimate, their price bases, and supporting information about the contract. The estimate header information, Group List, and a group’s Item List comprise an estimate. The estimate header contains general information about the estimate, the Group List contains groups of related items, and the Item List is a detailed list of estimate items in a group. Estimator’s interface has been designed to allow estimators to quickly enter estimate groups and items and retrieve information from the Estimator catalogs.

The estimator has complete flexibility to estimate each item in the Item List with cost-based, bid-based, or reference-based methods. A single item can be part of multiple estimates that use different price basing methods for the item. When estimators use the item in an estimate, they can select the appropriate price basis method for the item. As an estimator adds and modifies the items associated with an estimate, Estimator automatically totals the estimated costs of the individual items and keeps a running tally of the cost of the entire estimate.

#### 3.1.2 Understanding Catalogs and Code Tables

Construction experience indicates that contract estimation involves a core set of information that is used to develop different estimates. Estimator catalogs are the information banks of the system storing core information for use in estimation. Estimator catalogs make the often-used data readily available through a well-organized, easy-to-use interface. Estimators can quickly use information from the catalogs in their estimates.

These catalogs are available in Estimator:

- Standard Item Catalog
- Price Bases Catalogs:
  - Cost Sheet Catalog
  - Bid History Catalog
  - Bid History Data Catalog
- Reference Price Catalog
- Rate Catalogs
  - Material Rate Catalog
  - Equipment Rate Catalog
  - Labor Rate Catalog

The Standard Item Catalog and the Cost Sheet Catalog draw on information from other catalogs. The Standard Item Catalog can use information from the Cost Sheet Catalog, Bid History Catalog, and the Reference Price Catalog to make up the price estimation of the item. The Cost Sheet Catalog uses information from the Equipment Rate Catalog, the Labor Rate Catalog, and the Material Rate Catalog to create the components of the cost sheet. The Bid History Data Catalog stores catalog data that makes up the bid histories.

Estimator code tables are used to fill in the header information of an estimate. The code tables are available in the catalog window. Code tables determine the available work types, counties, seasons, and other information used to comprise the estimate header.

### 3.1.3 Understanding the Difference Between Estimate Groups and Catalogs

Although estimate groups and catalogs both store items used in estimates, there are some fundamental differences between the two.

Items are stored in the Standard Item Catalog, ready to be selected for use in an estimate. They are not grouped together by any characteristic and are listed first numerically and then alphabetically by item number (unless they have been sorted to reflect otherwise).

Before an item is copied from the Standard Item Catalog to an estimate, a group has to exist in the estimate into which the item is placed. The estimator creates groups in the estimate to store items that relate to one another in some way. For example, this can include items that are all associated with a roadway or bridge. Each group can contain an unlimited number of items, and the estimator can arrange the items in any order in a group.

### 3.2 Highway Cost Estimation

Agencies that pay for highway construction need to know how much a project costs so they can set up funding and evaluate the bids they receive. Estimator helps agencies develop highway construction detailed cost estimates.

A detailed estimate is based on the plans for a construction project. It identifies all work that must be performed according to the plans and breaks down the project into work
items. Whenever possible, a work item is quantified (such as square yards of 6-inch-deep subbase), although some items are listed as lump sum items, which are items bid for and paid for as a single unit.

To determine the total cost of an estimate, the estimated cost for each item must be determined. Because quantity estimates have already been developed as part of the design process, the estimator's job becomes one of unit price estimation. The estimated cost of an item is the unit price multiplied by the quantity. The total of all individual item costs provides the cost of the complete estimate.

An estimator develops a cost-based estimate by determining how the work will be performed and then calculating the cost of the equipment, labor, and material required for the work.

An estimator develops a bid-based estimate (also known as a historical estimate) by analyzing previous bids on similar work and projecting what future bids will be from those data. Highway agencies find bid-based estimates useful because they often have historical bid data available. Bid-based estimates rely on other sources, such as BAMS/DSS, to provide the historical information.

An estimator develops a reference price estimate by asking a prospective subcontractor or supplier for an estimate. The subcontractor or supplier must develop the estimate, usually by using cost-based estimation. Rather than basing the estimated cost of an item on resource information found elsewhere, estimators might also want to enter an estimate for an item based on their own personal experience. Since many factors may affect the unit cost, this reference price estimation relies heavily on judgment calls by the estimator.

3.3 Cost-Based Estimation

Cost-based estimation provides the estimator with the most complete estimating data. Resources used can be tracked to a detailed level and can be modified and updated. Once the Cost Sheet Catalog is imported, it can include cost sheets for the most frequently used items. Estimators can develop more cost sheets and add them to the system or to individual estimates.

Each cost sheet describes the labor and equipment crew required to perform a task, the amount of work the crew performs each day (productivity), and the materials consumed in performing the task. The cost sheet also details assumptions about overhead costs and profit margins that must be obtained by the contractor performing the task. Estimator combines this information with the current costs of equipment, labor, and materials to determine a unit price.

You must have detailed knowledge about construction methods and the special circumstances for the estimate in question to create an accurate cost sheet. Expert estimators usually design cost sheets for use throughout an agency. Other estimators adjust the figures for any unusual, estimate-specific circumstances. Highway agencies,
which can rely on bid histories, usually prepare cost sheets only for major work items where costs are highly variable.

Estimator allows the estimator to use the same cost sheet as the price basis for different items in the same estimate. Whenever a cost sheet is attached to an item, Estimator copies it from the catalog, updates it with the latest equipment, labor, and material rates, and maintains a separate copy of the cost sheet specifically for that item. This allows the estimator to individually alter the components of a cost sheet for an individual estimate item without affecting other estimate items that use the same cost sheet.

There can be more than one cost sheet for a single item to represent different working conditions or assumptions. For example, the cost of item can be estimated with one or more cost sheets, depending on whether the estimate involves a large volume of an item or a standard volume. Figure 3-1 shows a typical Estimator cost sheet.

![Example Cost Sheet](image)

**Figure 3-1. Example Cost Sheet**

**Overhead Components**

Because overhead costs can be handled in a variety of ways, each Estimator cost sheet includes separate overhead factors for the equipment, labor, and material components of the item cost and a markup percentage that can be applied to the total direct cost.

The *equipment cost* for an item is the sum of the work hours per day and overtime hours per day times hourly rate.

The *labor cost* for an item is the hours of work per day times the hourly wage, plus the overtime hours per day times the overtime wage.

The *materials cost* for an item is the total cost of all materials required to produce one unit of the item.
The sample cost sheet shown in Figure 3-1 includes a 15 percent labor overhead, a 15 percent equipment overhead, and a 5 percent materials overhead. In addition, this cost sheet includes a 9 percent markup applied to the total cost.

Some estimators prefer to put all overhead costs in the markup calculation for the total cost instead of dividing the overhead unequally across materials, equipment, and labor components. Estimator allows you to follow either convention on any cost sheet.

**Production Rate**

The production rate is the number of units of the item that can be produced. Because production rates vary substantially from estimate to estimate, cost sheets in the Cost Sheet Catalog may contain average production rates. Each estimator can adjust production rates on an estimate-by-estimate basis by changing the rate or by filling in an adjustment value on a cost sheet.

**Cost Sheet Breakdown**

The cost sheets also include an equipment list, a labor list, and a materials list. The estimator can display individual windows for each list that identify how Estimator calculated the materials, equipment, and labor totals.

**Equipment List**

The Equipment List details all the equipment used to produce an item. Each piece or type of equipment used by the labor crew is listed with the name, description, quantity, and hourly rate of the equipment. The total equipment cost per day for each kind of equipment is calculated by multiplying the equipment units per day by the number of pieces of equipment by the equipment's cost per time unit.

The Equipment Rate Catalog lists all equipment and their respective rates. The Estimator system manager (or other designated personnel) must keep this catalog up-to-date by adding new equipment categories and changing rates as necessary.

**Labor List**

Each type of laborer needed for the estimate is listed with the laborer name, description of the laborer, the hourly wage and overtime wage based on an eight hours a work day for each unit. The total labor cost per day for each kind of laborer is calculated by multiplying the labor units per day by the number of laborers by the equipment's cost per time unit.

The Labor Rate Catalog lists all laborers and their respective rates. The Estimator system manager (or other designated personnel) must keep this catalog up-to-date by adding new labor categories and changing rates as necessary.
Materials List

The Materials List provides details about the materials needed to produce the item. Each kind of material is listed with a material name, a description, the material's unit of measure, and the cost of the material per unit of the material. Multiplying the quantity of the material by the price per unit yields the cost of each material per unit of finished item. Estimator calculates this value automatically.

Many kinds of materials might be needed to produce the finished item or there might be one or no materials needed. If no materials are needed, the cost sheet includes an empty Materials List.

The Material Rate Catalog lists all materials and their respective rates. The Estimator system manager (or other designated personnel) must keep this catalog up-to-date by adding new material categories and changing rates as necessary.

3.4 Bid-Based Estimation

When the estimator does not have a pre-defined cost sheet available or does not want to use a cost sheet, another option is to use historical bid prices. These prices can be developed with varying levels of sophistication.

While Estimator does not require that the user understand the methodology or the statistical analysis involved in the creation of bid histories, or even how Estimator uses the bid history file to create bid prices, users that do understand more about this process can make better use of this tool. The main points are explained in this section.

3.4.1 Overview

As stated before, bid-based estimates rely on other sources, such as BAMS/DSS, to provide the historical information. Specifically, the BAMS/DSS Historical Item Price Regression (HIREG) model (displayed in the Bid History Data Catalog) is used to analyze historical bid information and then generate a file that can be imported into Estimator for use in bid-based estimation.

BAMS/DSS HIREG Model

The Historical Item Price Regression model generates bid-histories that are used by other systems and processes. It creates regression models for selected item prices and/or estimate prices as a function of specific price qualifiers. In addition to Estimator using this information, it is also stored for use as input to the BAMS/DSS Bid/Estimate Review model, the BAMS/DSS historical item price regression service (scatter plots), SAS ad hoc analysis, and the AASHTOWare Project Cost Estimation System (CES) module. The model will also produce univariate average prices. The HIREG model calculates weighted average prices and regression coefficients.
Additional options are available so the user can also specify using all bids, all bids after excluding the high and low bid (by contract), or a specific number of bids (i.e. three low bidders). Lump sum items are automatically excluded from the analysis, however the mobilization item is an exception. The mobilization item number can be identified in a BAMS/DSS site-specific customization member so that it will be included in the HIREG analysis.

The reports produced by the HIREG model include information on how well a regression model fits each selected item's historical prices, the ranges of quantities found, the time period used, and messages if any item or parameter was excluded from analysis. In addition to reports, the HIREG model also produces a CSV file (ibidhist.csv) that contains bid history information for use by Cost Estimation and Estimator.

**Market Areas**

While you do not need to understand the full bid based estimation process, it is helpful to understand the concept of market areas. Market areas group counties into logical areas, such as political boundaries (districts or regions) or by some similarities among the counties within each area (primarily bidders).

For example, highway construction estimators have historically noticed that estimate items tend to cost the same in certain areas. In some states, however, getting construction labor in a warm area may be far cheaper than getting laborers to work in cold and remote corners of the state. These factors have led estimators to take into account the market area, or prevalent market conditions in their estimates. Fortunately, only one or two individuals in an agency need to set up market areas. If required, refer to the BAMS/DSS System Managers Guide for a more thorough discussion of market areas.

**Price Estimation**

The simplest method of bid-based estimation involves looking up a recent similar estimate that contains the item in question and determining how it was bid. For example, suppose item 203-05: Structure Excavation was recently bid on project 900321 with these results:

- Low Bidder $7.25/CY  
- 2nd Bidder $5.14/CY  
- 3rd Bidder $6.08/CY

The low bidder's price of $7.25 (the low bidder overall, not just on this item), the middle bidder's price of $5.14, the median price of $6.08, or the average price of all three bids, $6.16, could be used in the estimate. Any of these numbers could be justified, and any one of them might be close to the low bidder on the new project. This method of manually looking up a bid history has several weaknesses:

- It is time consuming and a great deal of data must be managed.
- It is not standard and not repeatable; different estimators might pick different historical estimates.
- It ignores most historical data for an item and focuses on only one estimate.

The more powerful and accurate method of bid-based estimation would be to import the historical bid information from BAMS/DSS. Considering the multitude of data subsetting and analysis options available in the HIREG model, this approach is clearly the more accurate. Bid-based histories can not be manually created in Estimator. They must be imported from statistical analysis software such as BAMS/DSS.

3.4.2 HIREG Methodology

This section provides an overview of what the HIREG model does at a high-level covering the basic methodology used for analysis.

**Subset and Organize Data**

In order to subset and organize the data in the bid history analysis, you must start with the BAMS/DSS data view identified in the profile. The view is a subset of the BAMS/DSS database, and the profile is conditions for the view. The contracts in the profile are subset by the contract list (from the SELECT model) and model picks if specified. Next, the data is organized for analysis with tasks such as converting the counties to areas (from the AREAS model) and determining the season.

If the Percent of Date Range to Select option on the Advanced options part of the PARAMETERS tab for HIREG model is set to a value less than 100, the set of data to be used for averages is subset further by date.

The data for the HIREG model is organized first by the contract list and model picks and then by tasks. It is further organized by the value in the Percent of Date Range to Select field. This is BAMS/DSS's way of ensuring irrelevant information is not figuring in to the historical bid analysis.

**Generate Averages**

The HIREG model calculates the weighted average price for an item by quantity level and when available, season, work type and market area. You do not have to generate average prices for your bid history, but when you do, the following steps take place:

1. Determine the distribution of quantity for an item.
2. Determine the distribution of price for an item.
3. Remove the items whose quantities and/or prices are outliers based upon the parameter settings.
4. Determine the quantity levels and map an item’s quantity to the appropriate level.

5. Calculate the average price and standard deviation weighted by quantity with each quantity level.

Section 3.4.3 will go in to greater detail regarding weighted averages.

**Generate Regressions**

The HIREG model calculates the regression coefficients for an item by quantity and when available, time, season, work type and market area. You do not have to generate regression prices for your bid history, but when you do, the following steps take place when generating the regression prices.

1. Perform an initial regression model using only quantity and date.

2. Remove outliers based upon the parameter settings.

3. Exclude the date variable from the models if it fails a series of tests based upon parameter settings.

4. Exclude the number of bidders, date squared, season, area, and/or work type variables if called for based upon parameter settings.

5. Determine which models can be calculated for an item based upon the minimum number of observations needed.

6. For each item to be modeled, calculate the level of improvement for each potential variable to be included in the estimation regression models.

7. Select variables to be included in the models for which the level of improvement is significant based upon parameter settings.

8. Run the estimation regression models including all variables which pass the selection requirements for number of observations, level of improvement, and parameter settings.

9. Calculate statistics on these models.

10. Exclude regressions that have a positive quantity relationship or are out of range when compared to the average based upon a parameter setting.

Section 3.4.4 will go in to greater detail regarding regression coefficients.
3.4.3 Weighted Average

Weighted averages can be refined by calculating them for related subsets of a bid history. For example, say the weighted average is different for four market areas. Each market area could use a weighted average based on only its own historical data; unfortunately, using only one market area’s historical data to compute an average will result in a lower number of values (hence a less reliable average) to compute the weighted average. For example, if Market Area 4 has only one estimate for its weighted average and Market Area 1 has only two, it would be better for those market areas to use a less-specific, statewide average that uses more estimates for its weighted average.

Weighted averages can be broken down by other factors as well, such as work type.

Estimator relies on a bid analysis program to determine which data breakdowns are statistically valid and which are not; thus, an item might have a single price (determined by analyzing all the historical bids), dozens, or even hundreds where the historical data have been broken down by quantity, type of work, and area of the state. Estimator uses the output of the BAMS/DSS Historical Item Price Regression (HIREG) model which is available to SHAs. Estimator stores this program's output and then matches the best weighted average with the estimate item.

Weighted averages are used for unit price estimation when there is only a moderate amount of historical bid data available. The average price is weighted by the quantity of the bid item in the historical data. For example, suppose an item had only three bids historically as shown in Table 3-1.

<table>
<thead>
<tr>
<th>Worktype</th>
<th>Quantity</th>
<th>Unit Price</th>
<th>Extended Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>ROAD</td>
<td>10</td>
<td>$300</td>
<td>$3,000</td>
</tr>
<tr>
<td>STR</td>
<td>20</td>
<td>$200</td>
<td>$4,000</td>
</tr>
<tr>
<td>ROAD</td>
<td>30</td>
<td>$100</td>
<td>$3,000</td>
</tr>
</tbody>
</table>

Table 3-1. Historical Item Bids

The average unit price would be $200 (the average of $300, $200, and $100), but the weighted average would be $166.67. The weighted average takes quantity into account so the $200 bid is weighted more heavily than the $300 bid and the $100 bid is weighted most heavily. The weighted average is computed by taking the total extended amount ($10,000 in this example) and dividing by the total quantity (60 in this example). Estimator uses the weighted average unit price of $166.67 as the estimated unit price of this item in future projects.

In many cases, the bid analysis model determines that there is enough data to produce weighted averages for subsets of the data broken down by work type (as shown in Table 3-1). For example, when it analyzes the data in Table 3-1, the model might decide that the weighted average of $166.67, which is based on the bid data, can be used in general
but that the weighted average of $150.00, which is based on the two projects with ROAD work types, should be used to estimate projects with ROAD work types.

There are three factors the model can use for breaking down the data into groups for weighted averages: work type, area of the state, and quantity level. Work type is the type of work and one work type is associated with each contract. Market areas are defined using the AREAS model. The quantity level is determined by the HIREG model by analyzing the bid quantities for the item and computing the fifth, twenty-fifth, fiftieth, seventy-fifth and ninety-fifth percentile quantities (if the twenty-fifth percentile quantity is 100, for example, that means that 25 percent of the projects containing the item had less than a quantity of 100).

The five percentiles divide quantities into six ranges (less than the fifth percentile; greater than or equal to the fifth percentile, but less than the twenty-fifth; and so on) numbered 0 through 5. By default, HIREG considers range 0 (less than the fifth percentile quantity) and range 5 (greater than or equal to the ninety-fifth percentile quantity) as statistical extremes and Estimator does not estimate items with quantities in those ranges; however these ranges can be changed during setting the parameters for the HIREG model.

When it searches for the best match, Estimator tries to match the quantity level, then the work type, and then the market area. For a given set of characteristics (for example, quantity level 4, work type ROAD, area 1), Estimator could theoretically find these eight possible matches ranked from best to worst:

<table>
<thead>
<tr>
<th>Quantity Level</th>
<th>Work Type</th>
<th>Market Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>ROAD</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>ROAD</td>
<td>*</td>
</tr>
<tr>
<td>4</td>
<td>*</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>*</td>
<td>*</td>
</tr>
<tr>
<td>*</td>
<td>ROAD</td>
<td>1</td>
</tr>
<tr>
<td>*</td>
<td>ROAD</td>
<td>*</td>
</tr>
<tr>
<td>*</td>
<td>*</td>
<td>1</td>
</tr>
<tr>
<td>*</td>
<td>*</td>
<td>*</td>
</tr>
</tbody>
</table>

Table 3-2. Theoretical Estimator Matches

The fact that Estimator picked the average for quantity level 4, work type ROAD, area * indicates that the bid analysis program did not produce the best possible average for this item with quantity level 4, work type ROAD, area 1, because there were not enough bids to analyze with those characteristics or because the bids were too variable.

3.4.4 Regression Coefficients

A problem with weighted averages from the bid-based estimation point-of-view is that they are discontinuous. For example, if an estimate item's quantity is near the cut-off
between the 50th and 75th percentile, a small change in the quantity might have no effect (if it does not push the item over the cut-off) or a significant effect (if it pushes it over the cut-off). Price should decrease smoothly as quantity increases. Price should also vary smoothly with time and usually goes up.

Historical bid prices are analyzed to determine the best fit for the coefficients to the data, which is known as regression. Regression requires more data for statistical validity than calculating weighted averages. Estimator applies the result of the regression analysis to estimate items. As with weighted averages, Estimator does not calculate the coefficients but relies on the BAMS/DSS HIREG model.

If Estimator is unable to use regression coefficients because the BAMS/DSS HIREG model does not have enough data to produce the regression coefficients, Estimator uses weighted average bid prices. Estimator also automatically switches to the average price when the regression price is out of range. BAMS/DSS can provide a historical bid rate for most non-lump-sum items. Unique items that are defined for a single estimate, or items with very few occurrences do not generate bid histories.

Finding the “best fit” for the coefficients to the data is done by first breaking down the data that is to be analyzed by the variables included in the data. These breakdowns are known as models. In addition to base quantity and time variables, regressions can include work type, market area, and season variables (depending on the BAMS/DSS HIREG options selected). Assuming the data being passed from BAMS/DSS includes work type, market area, and season, Table 3-3 shows the breakdown of which variables would be included in which models.

<table>
<thead>
<tr>
<th>Model Number</th>
<th>Work Type</th>
<th>Area</th>
<th>Season</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>5</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>6</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>7</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>8</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

Table 3-3. Variable Combinations Included in Models Using Work Type, Area, and Season
Now that we have a breakdown or structure by which we can analyze the data, two sets of statistics will be generated from the item’s bid history data using the model breakdowns generated for that data. The first set of statistics is the base data for each model. Table 3-4 is an example of this first set of statistics associated with item 202-03 spec year 00. The second set breaks down the data by unique or distinct values by variable. Table 3-5 is an example of the second set of statistics (Adjustment Coefficients) generated for a single model (model 6) for the same example item.

<table>
<thead>
<tr>
<th>Spec Year</th>
<th>Model Number</th>
<th>Root Mean Square</th>
<th>Weighted Average</th>
<th>Standard Deviation</th>
<th>Intercept</th>
<th>Quantity Coefficient</th>
<th>Date Coefficient</th>
<th>Date Squared Coefficient</th>
<th>Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>00</td>
<td>8</td>
<td>0.4903491069</td>
<td>0.000295178</td>
<td>0.0035873449</td>
<td>4.7037442814</td>
<td>-0.385057121</td>
<td>0.0001225527</td>
<td>0</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>6</td>
<td>0.4927036424</td>
<td>0.0004911241</td>
<td>0.0036946802</td>
<td>4.8107243505</td>
<td>-0.401675105</td>
<td>0.0001241842</td>
<td>0</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>2</td>
<td>0.494821647</td>
<td>0.0004716009</td>
<td>0.003731174</td>
<td>4.5218692842</td>
<td>-0.396539152</td>
<td>0.0001603011</td>
<td>0</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>5</td>
<td>0.4971138625</td>
<td>0.000315671</td>
<td>0.0036639315</td>
<td>4.5362076983</td>
<td>-0.381806376</td>
<td>0.0001490101</td>
<td>0</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>7</td>
<td>0.5200152144</td>
<td>0.0005993486</td>
<td>0.0036634648</td>
<td>6.3032727172</td>
<td>-0.437125691</td>
<td>-0.000045248</td>
<td>0</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>3</td>
<td>0.5306205685</td>
<td>0.0005552663</td>
<td>0.0040253709</td>
<td>5.9028896826</td>
<td>-0.430601242</td>
<td>-0.00002588</td>
<td>0</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>4</td>
<td>0.5326391668</td>
<td>0.0008916409</td>
<td>0.0042594908</td>
<td>6.6289835614</td>
<td>-0.480296799</td>
<td>-0.000113398</td>
<td>0</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>1</td>
<td>0.5404546106</td>
<td>0.0008552538</td>
<td>0.004371363</td>
<td>6.2225223446</td>
<td>-0.474323358</td>
<td>-0.000084916</td>
<td>0</td>
<td>202-03</td>
</tr>
</tbody>
</table>

Table 3-4. Base Model Data
Table 3-5. Adjustment Coefficients

<table>
<thead>
<tr>
<th>Spec Year</th>
<th>Model Number</th>
<th>Variable Type</th>
<th>Iteration Number</th>
<th>Beta</th>
<th>Value</th>
<th>Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>00</td>
<td>6</td>
<td>1:WT</td>
<td>1</td>
<td>-0.759036667</td>
<td>----</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>6</td>
<td>1:WT</td>
<td>2</td>
<td>-0.195702728</td>
<td>ASPH</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>6</td>
<td>1:WT</td>
<td>3</td>
<td>-0.774118018</td>
<td>GENA</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>6</td>
<td>1:WT</td>
<td>4</td>
<td>-0.600857664</td>
<td>GRDG</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>6</td>
<td>1:WT</td>
<td>5</td>
<td>-0.549362056</td>
<td>IMPS</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>6</td>
<td>1:WT</td>
<td>6</td>
<td>-0.349338294</td>
<td>ITS</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>6</td>
<td>1:WT</td>
<td>7</td>
<td>0</td>
<td>MTNC</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>6</td>
<td>3:SE</td>
<td>1</td>
<td>-0.070845886</td>
<td>FALL</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>6</td>
<td>3:SE</td>
<td>2</td>
<td>-0.185935905</td>
<td>SPRI</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>6</td>
<td>3:SE</td>
<td>3</td>
<td>0.0951517348</td>
<td>SUMM</td>
<td>202-03</td>
</tr>
<tr>
<td>00</td>
<td>6</td>
<td>3:SE</td>
<td>4</td>
<td>0</td>
<td>WINT</td>
<td>202-03</td>
</tr>
</tbody>
</table>

Now that we have all this item information based on the item bid history data, it’s time to actually use it in an estimate. Assume you have already imported the BAMS/DSS HIREG bid history data into the current Estimator catalog and you are adding an item to your estimate. If bid history data was generated for the item that you are adding, a Bid-based Regression Price will be attached to the item when it is added to your estimate. It is at this point that the last step in the process of finding the “best fit” for the coefficients to the data occurs.

When Estimator sees that there is a Bid-based Regression Price associated with this item, it will first try to determine which bid history regression model associated with this particular item should be used in calculating the item price. This is done by comparing the values Work Type, Season, and County on your estimate with the unique variable values in the second set of statistics (as in Table 3-5). For example, let’s say that the estimate Work Type is ASPH, Season is FALL, and County is 44. Estimator will find that, out of all the unique variable values of all the models in the second set of statistics, the only matches were on Work Type and Season. So, that means that we only want to use models which include one or both of those matched variables. Referencing Table 3-3, the only models appropriate to use would be model 1 (which include no variables) and models 2, 4, and 6 (which includes one or both of the matched variables). Models with a positive quantity coefficient should be removed at this point. This will have no effect on our example.

With the list of appropriate models filtered down to models 1, 2, 4, and 6, Estimator now needs to determine which of the remaining four models would be the best fit. This is done by comparing the Root Mean Square (RMS) of each of the remaining models. The model that has the lowest RMS will be selected as the best fit model regression, model 6 for this example.
With the best fit model regression selected, we can now calculate the unit price. The analysis model fits the data to a mathematical formula and Estimator then uses that formula to estimate the item's unit price. The formula is listed below:

\[
\text{Unit Price} = \exp (\text{Base Value} + \\
\quad \text{Season} + \\
\quad \text{Work Type} + \\
\quad \text{Highway Type} + \\
\quad \text{Urban/Rural} + \\
\quad \text{Area} + \\
\quad (\text{Quantity Coeff} \times (\ln (\text{Item Quantity}))) + \\
\quad (\text{DateCoeff} \times \text{DaysBetween1985AndBaseDate}) + \\
\quad (\text{DateSquaredCoeff} \times \text{DaysBetween1985AndBaseDate} \times \\
\quad \text{DaysBetween1985AndBaseDate})
\]

Where:

Base Value is a base value (or intercept) for the formula (Table 3-4)
Season is the adjustment coefficient for the season of the year (Table 3-5)
Work Type is the adjustment coefficient for the type of work (Table 3-5)
Highway Type is the adjustment coefficient for the type of highway (not currently passed from BAMS/DSS)
Urban/Rural is the adjustment coefficient for the urban/rural indicator (not currently passed from BAMS/DSS)
Area is the adjustment coefficient for the market area of the state (Table 3-5)
Quantity Coeff is the coefficient representing adjustment for quantity (Table 3-4)
Item Quantity is the quantity of the item
Date Coeff is the coefficient representing daily inflation (Table 3-4)
DateSquaredCoeff is the coefficient representing the Date Coeff squared (Table 3-4)

**Note:** LN is the natural logarithm, not the common logarithm.

Estimator uses the coefficients provided by the bid analysis model, combines them with the data for this project item, and produces a unit price estimate. So, using our example with an item quantity of 100 and a base date of 05/16/2007, we get:

\[
\text{Unit Price} = \exp (4.8107243505000001 + \\
-0.07084588599999997 + \\
-0.19570272799999999 + \\
0 + \\
0 + \\
0 + \\
(-0.40167510499999998 * 4.6051701859999996) + \\
(0.00012418419999999999 * 8170) + \\
(0 * 8170 * 8170) \\
) \\
= \exp (4.8107243505000001 + \\
-0.07084588599999997 + \\
-0.19570272799999999 + \\
0 + \\
0 + \\
0 + \\
-1.8497822180044192 + \\
1.0145849139999998 + \\
0 \\
) \\
= \exp (3.7089784324955812) \\
= 40.812091331292765356200597371075
3.5 Reference Price Estimation

If an item of work is subcontracted or consists solely of materials supplied by an outside firm, the estimator has no direct control over the cost and must obtain a quote from the prospective subcontractor or supplier. If the work is fairly standardized, such as putting up chain-link fence, it is worth keeping a list of previous price quotes. Old quotes can be used as rough estimates or to check on a new quote. Estimator stores price quotes as reference prices. Each reference price has a name, a price, and a description of how it was obtained. Reference prices can also be determined by the estimator’s own experience.

The description of a reference price should identify the source of the reference price, the date, and the initials of the estimator who added the reference price to the catalog. Reference prices can also be used to store an estimator’s opinion and document the source of that opinion.
4. Estimator Basics

Using Estimator to estimate costs can be as simple as building an estimate header and a Group List, and adding items from the Standard Item Catalog or, as later chapters describe in detail, manipulating estimations down to the finest details, adjusting individual items, assigning different price bases, and even modifying the price bases themselves. The information in this chapter includes basic Estimator functions, such as logging on and printing.

4.1 Logging On to Estimator

Your computer must be running Windows when you start Estimator. After Windows is running, you can run Estimator and other Windows-compatible programs.

4.1.1 Starting Estimator

Click the START button on the Taskbar to display the Start menu. Locate and place your mouse pointer over the Programs menu. A list of program icons is displayed. Locate the Estimator program group, then place your mouse pointer over it. A list of installed components for Estimator appears. Click the Estimator program icon to start the program. You can also create a shortcut to access Estimator.
Before you can use Estimator, you must identify yourself as an authorized user. Your system manager assigns you a username and password, which you must enter each time you begin Estimator.

To provide additional security against unauthorized access to estimate details, each Estimator estimate has authorized users. The system manager can assign various new estimate privileges to all Estimator users, ranging from none to owner. The person who first creates an Estimator estimate is also an authorized user of the estimate. The estimate owners (the person who creates the estimate, and those assigned owner privileges by the system manager) can give other Estimator users read or write privileges, as well as owner privileges.

If you are not on the user list for a specified estimate, you cannot work with that estimate until an owner authorizes you to do so. Only someone with owner privileges can authorize additional users on an estimate.
After you start Estimator, the Estimator splash screen and the login window appear (see Figure 4-2).

![Estimator Opening Window](image)

Figure 4-2. Estimator Opening Window

Enter your assigned User Name and Password in the appropriate fields, using the **TAB** key to advance to the next field. Click the **OK** button to submit your login information or click **CANCEL** to cancel the login operation.

In Estimator, user names are case **insensitive**. That means you can type the letters of your user name in uppercase or lowercase. Passwords are case sensitive, and must by typed exactly the way they were when first created.

### 4.2 Updating Your Catalogs

Once you successfully log in, you may be presented with an Update Catalog window.
If you want to download the updated catalogs, click YES. If you don't, click NO. You can disable the window by selecting the Disable check box. If you decide to disable the window, make sure you run the command manually.

Note: To manually use the Update Catalog command, select Check for Catalog Updates from the Catalog Tools menu.

Once you choose to update your catalogs, follow the instructions in the Check for Updates wizard.

4.3 Opening an Estimate or Current Catalog

Estimator stores information for your estimates in individual estimate files. To work in Estimator, you must create a new file for any new estimate or open an existing file to work on an estimate already defined. If this is your first time using Estimator (or if you want to start a new estimate), you must create a new file.

The system manager is responsible for creating and populating the catalogs. You do not have to open the Current Catalog to use the information it contains.
4.3.1 Opening an Estimate File

You can open an existing estimate by choosing an estimate from the bottom of the File menu (see Figure 4.4) or by selecting Open from the File menu and selecting an estimate file name.

Figure 4.4 File Menu With Recently Worked-on Estimates

4.3.2 Creating a New Estimate File

You can create a new estimate by selecting New from the File menu. Estimator opens a blank estimate, ready to be filled in with header and item information.

Note: If there are templates in the Templates folder, Estimator opens a window in which you can choose to open a blank estimate or an estimate template.

4.3.3 Opening a Catalog

Select Show Open Catalogs from the Catalog Tools menu to see the Current Catalog. If this is not the catalog you wish to use for your estimate, the Switch Current Catalog command located under the Catalog Tools menu closes the Current Catalog and then prompts you to open another catalog.

Estimator allows users to have more than one catalog open at a time. To open additional catalogs, select Open A Catalog from the Catalog Tools menu.
4.4 Saving an Estimate

Estimator allows you to work on multiple estimates simultaneously (side by side) within a single Estimator work session. You must be able to save the work you have done on an estimate and close an estimate that requires no immediate action.

4.4.1 Saving Estimates

While you work on an estimate, Estimator retains your work temporarily in the computer, but it does not automatically save your work. You must save open estimate(s) to store them permanently. Each Estimator estimate is stored in a separate estimate file, which you must name the first time you save it. When you exit, Estimator reminds you of any estimates you have changed but not yet saved and gives you a chance to save them.

Save your estimate frequently in case of a power failure or computer malfunction. If a power failure occurs before you save a new estimate, the estimate will be lost. If you have saved your work and a power failure occurs, you will lose only the work you did since the last time you saved the estimate.

Estimator employs an auto save function to aid you in saving your estimate. For more information on Estimator’s Auto Save utility, please see Section 4.4.2. You can also save an estimate as a template to keep from retyping the same basic information in multiple estimates.

Using Valid File Names

Every Estimator file must be given a unique name. The basic limitation to naming an estimate is that the file name can use a combination of letters, digits, and some special characters. Estimator appends .est to the file name so it can be easily recognized as an Estimator estimate file. The name you choose should also relate to the task to be handled by the estimate so you can recognize which file corresponds to which estimate. You might find it convenient to use the contract number as the file name; for example, 020521.est.

Using Save and Save As

Estimator has two commands you can use to save estimates. The appropriate command depends on whether you want to give the estimate a new file name. This file name is not necessarily the estimate name that appears in Estimator application fields, although it is a good idea to name the file with something recognizable as that estimate. The estimator uses an estimate name to identify printed report material. The file name you select when you save your estimate does not appear anywhere on the printed output; it is only used to keep track of where the estimate is stored in the computer.

The Save commands are used to store the active estimate. The active estimate includes the most recent changes or additions you made. These commands do not close the
estimate file; you can continue working on your estimate with the same window(s) open after Estimator executes the command.

When you choose Save As from the File menu, Estimator asks you to enter a new file name. When you provide the new file name, Estimator saves the active estimate with the most recent changes or additions using the new file name. (If the estimate was previously saved under a different file name, that version of the estimate remains undisturbed.)

When you choose Save from the File menu, Estimator saves the active estimate with the most recent changes or additions. You may not even notice any activity on your computer. If this is the first time you are saving your estimate, however, the Save command acts like the Save As command and you must enter a file name for your estimate.

### 4.4.2 Using the Estimate Auto Save Utility

The Auto Save utility, if activated, saves your estimate in a temporary folder. Once you save your estimate using the Save command, the temporary folder is deleted and the countdown for the auto save starts again. You can set the Auto Save utility to save your estimate anywhere from zero to every 15 minutes (a zero setting disables the auto save). Setting this function helps you recover newly added estimate information that was not saved in the event of a computer malfunction.

*Note:* You must first save your estimate using the Save or Save As command before the Auto Save utility will function.

To set the Auto Save utility:

1. Select Global Options from the Other Tools menu. The General tab displays.
2. Locate the Auto Save Interval (minutes) field in the middle of the General tab.
3. Using the arrows in the field, set the desired auto-save time. This can be anywhere from one to 15 minutes. Set the utility to zero if you do not want the auto save enabled.

4. Click ok to start the Auto Save utility or cancel to set the field back to the original time.

If you set the Auto Save utility to nine, then Estimator will save your estimate every nine minutes. Once you manually save your estimate, the auto-saved estimate is deleted until the next nine minutes have passed until Estimator again saves your estimate.

You can recover an estimate that was saved with the Auto Save utility if your computer was not properly turned off. To do this, follow the steps below:

1. Restart Estimator.

2. Select Open from the File menu. Estimator displays an Open Estimate window.

3. Select the estimate file and click OPEN.
4. If enough time has passed for the Auto Save utility to save your estimate, Estimator displays the Recovery window.

![Auto-Saved Estimate File](image)

Figure 4-6. Auto-Saved Estimate File

5. Click **YES** to replace the estimate with the more current saved estimate, or **NO** to open the estimate as it was when the computer was turned off. Selecting **NO** disables the auto save functionality for the rest of the estimate session, but will enable again when the estimate is closed and reopened.

### 4.4.3 Using the Estimate Archive Utility

The Estimate Archive utility is a fully customizable, automated estimate historian. It allows you to store up to nine previous versions of an estimate. Using estimates produced through the Archive Level function in the Global Options window, you can scan through estimate developments or undo recent changes.

The Archive Level determines how many previous version of the estimate are saved before the older ones are overwritten. For example, if the Archive Level is set to four, then the fifth time the estimate is saved, the first version of the estimate is overwritten. The newest archive is given the number one.

To enable estimate archiving:

1. Select Global Options from the Other Tools menu. The general tab displays.

2. The Archive Level field is located in the middle of the general tab. Use the arrows next to the field to determine the archive level.
3. Click APPLY if you are making more changes to the Options window, and OK when you are finished.

If you want to view the archives of an estimate, follow these steps:

1. While in Estimator, select Open from the File menu.
2. Click the down arrow in the Files of Type field and select All Files (*.*)
3. Select the archive of the estimate. The archives are saved with the same name as the estimate, but with the archive number appended to the .est extension.
4. Once the estimate is selected, click OPEN. Estimator opens the archive as a normal estimate.

If changes are made and saved to the opened archived estimate, then the archived estimate becomes the estimate, and the previous version of the estimate is moved into the archives.

### 4.5 Printing an Estimate

Estimator uses Crystal Reports® to produce a quality printout of your estimate. Your agency name will appear on the printed report provided the information has been entered by the system manager in the Global Options.

**Note:** For information on printing catalogs, please see the System Manager's Guide.

Open the estimate you want printed. Select **Print** from the **File** menu. Estimator displays a Print Message box that contains several options.
When none of these check boxes are selected, Estimator prints a normal estimate that lists estimate header information, items, quantities, units and unit prices, the extended amount for each item, group subtotals, and the estimate total.

**Note:** When alternate groups or items for those in the estimate exist, only the dollars for the lowest member of an alternate set are included in the estimate total. The dollars for all are shown at the item and group level, but the algorithm for group and total calculation considers only the lowest-cost items or groups.
If one or more of the boxes is selected, the printed information changes.

### 4.5.1 Show Item Descriptions

If enabled, the Show Item Descriptions option prints the item description and supplemental description fields as part of the item text in the report.

### 4.5.2 Show Inactive Price Bases

If enabled, the Show Inactive Price Bases works with the Show Price Bases Details option to display any inactive price basis associated with the items of the estimate. However, if Show Price Bases Details is set to None, then the inactive price bases are not printed.

### 4.5.3 Hide Prices

If enabled, the Hide Prices option hides the item prices and group totals. This allows you to use the estimate print out as a bid sheet. If this option is selected, the Show Price Basis Details drop down list becomes unavailable.

### 4.5.4 No Page Breaks Within Items

If enabled, the No Page Breaks Within Items option prevents an item and the item’s details from being split across two pages. When printing the item, the details will stay on one page.
4.5.5  **Show Notes for Groups**

If enabled, the Show Notes for Groups option prints any information on the NOTES tab of a group.

4.5.6  **Show Notes for Items**

If enabled, the Show Notes for Items option prints any information on the NOTES tab of an item.

4.5.7  **Total Item Quantities Across Groups**

If enabled, this option organizes the items numerically instead of by group. It combines like items together, sorts and lists the items by item and item supplemental description and only lists them once for the entire estimate. The item unit price is calculated by dividing the summed extended prices by the summed quantities for each grouping so the estimate total does not change. If this option is selected, the Show Notes for Groups option and Show Notes for Items option become unavailable.

4.5.8  **Summary of Quantities by Item and Group**

If enabled, this option sorts and lists by item, item supplemental description, and lastly group. Thus repeating item/item supplemental description pairs would be listed once within a group. The item unit price is calculated by dividing the summed extended prices by the summed quantities for each grouping so the estimate total does not change. If this option is selected, the Show Notes for Groups option and Show Notes for Items option become unavailable.

4.5.9  **Show Price Bases Details**

You can show the price bases details for the estimate items in two ways: Summary and Detailed. You can also choose not to show any price bases details by setting this option to None.

**Summary**

If the Show Price Bases Details is set to Summary, every price basis is listed for each item as is the price basis description. It also includes the unit price for the item based on the price basis type.

**Detailed**

If the Show Price Bases Details is set to Detailed, any bid-based price bases also includes the price basis details ranging from rate catalog information for cost sheets to the percent on top for reference prices.
4.5.10 Report Alignment

You can adjust the printed report’s margins.

![Report Alignment Options](image)

Figure 4-11. Report Alignment Options

Use the Portrait or Landscape check boxes to determine the layout of your printed estimate. If you choose Portrait, you can also set the alignment.

4.5.11 Select Customized Report

If you have custom reports created for printing the estimate, use the Select Customized Report field to assign a print report template to your estimate. If you do not have or do not specify a report, the default print options will be used.

4.5.12 Setting Up the Printer

Once you decide which options to print with your estimate and click OK, Estimator displays a Setup Printer window.

![Print Setup Window](image)

Figure 4-12. Print Setup Window
Select the printer using the drop down list in the Name field. This page can also help you determine if you want the estimate to print out portrait-style or landscape-style, the paper size, and other print options. Once all options for printing have been chosen, click OK. Click CANCEL if you decide not to print the estimate.

Once you select OK, a Printing Records status window appears. It shows you the progress of your print job until it has completed.

4.6 Verifying an Estimate

Once your estimate is complete, you can make sure all the information contained in the estimate is valid by selecting Verify Estimate from the Edit menu. Estimator displays a list of required fields that were left blank or have invalid entries. You can also access the Verify Estimate window by clicking the yellow CHECKMARK on the Estimator toolbar.

You can jump to a field that contains an error by double clicking on the ID. Enter the required information, and then verify your Estimate again.

Note: Errors in your estimate are also identified by an exclamation point (!) next to the error in the tree area.

You can save the estimate verification by clicking SAVE LOG. This creates a CSV file that can be viewed using spreadsheet software, such as Microsoft Excel®. To exit this window, click CLOSE.

If your estimate has no errors, the Verify Estimate command displays a window stating no errors were found.
**Verifications Tab**

The Verifications tab allows the user to turn verification messages on or off. Often, verification messages are received because of business processes that do not require reporting each time the estimate is verified. This feature allows the user to turn off verification messages if desired.

Currently, verification messages default to business processes that were deemed necessary for the overall product and do not necessarily reflect agency business processes. When an estimate is verified, the verification messages are provided in a message popup window that identifies the error or warning, and the data can be saved in a CSV file.

The following verification options can be checked (allowing the verification messages to be displayed) or not checked (verification messages will not be displayed):

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Funding</strong></td>
<td>If this option is checked and a funding package is assigned to the estimate, then funding verification messages will be displayed if there are funding-related issues.</td>
</tr>
<tr>
<td><strong>Obsolete Items</strong></td>
<td>If this option is checked and the estimate has obsolete items, verification messages will be displayed.</td>
</tr>
<tr>
<td><strong>Duplicate Line Numbers</strong></td>
<td>If this option is checked and if existing estimates files or imported files have duplicate line numbers, verification messages will be displayed. Checking the &quot;Prohibit Duplicate Line Numbers&quot; checkbox in the General tab under Global Options will display verification messages for new estimates.</td>
</tr>
<tr>
<td><strong>AASHTOWare Project Compatibility</strong></td>
<td>If this option is checked and when the Estimate Option &quot;Only Trns•port Item and Codes are allowed&quot; is checked, verification messages are displayed.</td>
</tr>
<tr>
<td><strong>Multiple Active Price Bases</strong></td>
<td>If this option is checked, and if existing estimates files or imported files have multiple active price bases, verification messages will be displayed. Checking the &quot;Prohibit Multiple Active Price Bases&quot; checkbox in the General tab under Global Options will display verification messages for new estimates.</td>
</tr>
</tbody>
</table>

By default, all verification options are checked.
4.7 Undo and Redo

Estimator has the ability to undo certain actions, or redo actions previously undone. *Undo* refers to the ability for the user to reverse recent changes. *Redo* is the ability to reintroduce a change that the user had undone. You can reverse numerous edits until the limit of changes is reached, and you can then redo those reversed edits. The changes are stored in Estimator’s *cache*, or memory.

The Undo and Redo commands are available for estimates, catalogs, and User Table documents. You can access the Undo command by selecting it from the Edit menu. The command displays what action will be undone. You cannot select the Redo command from the Edit menu until an Undo command has been issued.

After you use the Undo or Redo command, Estimator automatically displays the affected area of the command. For example, if you add an item to an estimate, and then Undo the addition, Estimator places the cursor in the changed field to remind you what changed.

**Note:** Importing a catalog, sorting, resizing a window, or other similar activities do not support the undo command.
If you save your work, the Undo and Redo cache is deleted, and you can no longer undo or redo any of your previous changes. The Auto-Save function does not affect the cache.

### 4.8 Cut, Copy, and Paste

Cut, copy and paste are Estimator features that add flexibility when the need arises to move data within estimates. In terms of cut, copy, and paste, the source is defined as “where the data comes from initially” and the destination is defined as “where the data is going.” The cut, copy, and paste commands are context sensitive, which means the type of active window and number of selected items you want to use as the source determines where paste is enabled. The destination has to be capable of holding the source. The copy and paste commands do not delete selected items. In fact, if you have more than one item selected in a list, the paste command is disabled.

**Note:** Pasting items into an estimate item list can throw off the item numbering. When you paste into an item list, you may wish to consider renumbering the items. Select **Renumber Estimate Items** from the **Edit** menu to renumber an estimate’s item list.

#### 4.8.1 Cut Command

The Cut command copies the currently selected items in a list window or the active window’s content to the clipboard, then deletes it from its current location. To do this, the clipboard acts as temporary storage and holds the data to be pasted into another location. However, if you cut or copy something else before the previously cut data is pasted, the data is deleted from the clipboard and cannot be retrieved.

To use the Cut command, select the desired text and choose **Cut** from the **Edit** menu.

#### 4.8.2 Copy Command

The Copy command copies the currently selected items in a list window or the active window’s contents to the clipboard. For example, you might want to copy items from one list to another or an entire cost sheet into a different cost sheet. To do this, the clipboard acts as temporary storage and holds the information to be pasted into another location. However, if you cut or copy something else before the previously copied data is pasted, the data is deleted from the clipboard and you will have to copy it again if you want to use it elsewhere.

To use the Copy command, select the desired text and choose **Copy** from the **Edit** menu.
4.8.3 Paste Command

The Paste command copies the contents of the clipboard into the active list or window. Paste is enabled if the data from the source window logically fits into the destination window. For example, it makes no sense to copy a group into an item list.

**Note:** Paste is disabled when multiple items are selected to prevent accidental overwriting of data.

To use the Paste command, select the desired text, and then select Paste from the Edit menu. Before using the Paste command, you must have first cut or copied the text. The information remains in the clipboard until something else is cut or copied.

4.9 Building Expressions

When entering data into numeric fields, you might want to calculate your value using mathematical constants, variable data elements in the system, or pre-defined formulas from the Code Tables FORMULAS. For example, you might want to enter a value that is 50 percent greater than another value you entered earlier. If so, you can use the Expression Builder window to enter a mathematical expression. To open the Expression Builder window, click the button with an ellipsis (…) beside a numeric field.

![Figure 4-15. Expression Builder Button](image-url)
Caution: Never use a comma in a number in the Expression being built field. The Estimator software will incorrectly calculate the value of your expression if a comma is used. In addition, if you use IF and THEN in your expression, you must have an ELSE clause. You cannot have an undefined variable in the Estimator software.

**Expression being built**
Where your expression is displayed. Do not use a comma when entering numbers.

**Function buttons**
Include addition (+), subtraction (-), greater than or less than, and IF THEN ELSE, among others.

If you manually enter the IF, THEN, ELSE or other word functions instead of using a button, the words must be all uppercase or all lowercase.

**CLEAR Button**
Erases the contents in the Expression being built field.

**EVALUATE Button**
Evaluates the contents in the Expression being built field. If the expression is valid, the value of the expression displays in the Expression value field. If the expression is invalid, an error message displays.

**HELP Button**
Opens the context-sensitive online Help for the Expression Builder.
Tree Values
When you click an Estimate value, a Function value, or a Constants value, it appears at your cursor in the Expression being built field.

Estimate
Data elements from elsewhere in the estimate. For example, you can select an item’s reference price or the overhead percentage from a cost sheet.

Functions
Functions that let you find trigonometric values such as the cosine or tangent for a number or value. Note that when you add a function to your expression, you must replace the word number with a number or value.

Constants
The mathematical constants e and pi.

Estimate Values
Once you click a element of the Estimate value, the fields available for that value to use in the expression are listed.

Expression value
The results once the expression is evaluated. If the expression is valid, the value of the expression is displayed. If the expression is invalid, an error message displays with the reason for the error.

Formula
Stored Formulas from the Code Table Formulas can be used in the expression builder.

If you receive an error, check your expression and correct it. Once you arrive at a valid result, click the OK button. The Expression Builder window closes and your result appears in the numeric field.

Field values that were built using the Expression Builder display in blue.

4.10 Closing an Estimate or Catalog

If you want to exit the estimate or catalog in which you are working but stay in Estimator, you can close the estimate or catalog and return to the Estimator main window. Select Close from the File menu to close the active window, as well as other related windows. If you made changes to the active window and did not save them, Estimator asks if you want to save your work before it closes the file. You should always save your work before you close an estimate or catalog unless you made changes you want to abandon.

As previously discussed, it is a good idea to save your work periodically. When Estimator gives you the option to save your work, you should click OK unless you specifically want to discard the changes you made since your last save.
4.11 Exiting Estimator

To exit Estimator, select Exit from the File menu. If you have made changes to your estimate since your last save, an Estimator dialog box asks if you want to save your work. Click YES to save changes and exit Estimator, NO to ignore the changes and exit Estimator, or CANCEL to cancel the exit and return to Estimator.
5. Working with Estimates

Estimates are made up of an estimate header, a Group List, and Item List. The header contains general information about the estimate, the groups contain related item information, and the Item List is a detailed list of estimate items. Estimator’s interface allows estimators to quickly enter estimate items and retrieve information from the Estimator catalogs.

5.1 Working with the Estimate Header

Estimator displays blank estimate window when you open a new estimate file. The Estimate Header window includes administrative information about an estimate.

5.1.1 Adding Estimate Header Information

If you have not yet created your estimate, you must open a new estimate file. To do this, select New from the File menu. Estimator displays the Estimate window for a new estimate (see Figure 5-1).
5-2 Working with Estimates

Note: If your new estimate does not display all the fields shown in the above figure, then use your mouse and click on the line dividing the group information from the header information. Without letting go of the mouse, drag the line so all fields are visible.

Estimator requires you to enter data into some (but not all) of the Estimate Header fields. This can be done at any time when creating the estimate, but it is recommended that the fields are filled in as soon as you know the information for those fields.

The PAGE 2 tab of the header window displays additional fields for the estimate, including the creator of the estimate, who checked the estimate, and the date it was checked (see Figure 5-2). The Estimated By field defaults to the name of the user who created the estimate, as written in the User’s List.

The NOTES tab is useful for storing information about the estimate that has no other field.
**Estimate Header Window Fields**

Any item selected from a drop-down list originates in a code table from the Current Catalog. Any item that is numeric can be entered as an equation or formula using the Expression Builder window. Estimator requires you to enter values for the Base Date, Work Type, and County fields if you are planning to use bid-based estimation for items because it uses these values to calculate bid-based estimates of unit prices for estimate items.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Estimate ID</td>
<td>The Estimate ID field contains the number the agency assigns to the estimate. This field can be up to 15 characters in length. However, if the estimate is going to be used in an AASHTOWare Project application, the field can only be 13 characters.</td>
</tr>
<tr>
<td>Spec Year</td>
<td>The Spec Year field displays the specification book year for the estimate. This field is based on the spec year of the Current Catalog.</td>
</tr>
<tr>
<td>Base Date</td>
<td>The Base Date field is the bid letting date for the active estimate.</td>
</tr>
<tr>
<td>Unit System</td>
<td>The Unit System field specifies the measurement system used in an estimate. The default value of the Units field reflects the measurement system of the current catalog - the metric system (Metric) or English system (English). You can change this field to M, E, or none (N).</td>
</tr>
<tr>
<td>Longitude of Midpoint</td>
<td>The Longitude of Midpoint field is used by AASHTOWare Project BAMS/DSS to draw maps with the estimate correctly placed. You can leave this field blank until you are ready to use AASHTOWare Project BAMS/DSS. Enter longitudes in the form degrees, minutes, seconds.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Latitude of Midpoint</strong></td>
<td>The Latitude of Midpoint field is used by AASHTOWare Project BAMS/DSS to draw maps with the project correctly placed. You can leave it blank until you are ready to use AASHTOWare Project BAMS/DSS. Enter latitudes in the form degrees, minutes, seconds.</td>
</tr>
<tr>
<td><strong>GPS Latitude of Midpoint</strong></td>
<td>Seconds are converted into decimal minutes. Seconds have the value of 0 to 60.</td>
</tr>
<tr>
<td><strong>GPS Longitude of Midpoint</strong></td>
<td>Seconds are converted into decimal minutes. Seconds have the value of 0 to 60.</td>
</tr>
<tr>
<td><strong>Federal/State Project Number</strong></td>
<td>The federal or state project number identifying the estimate.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>A short description of the estimate.</td>
</tr>
<tr>
<td><strong>Work Type</strong></td>
<td>The Work Type field code indicates the kind of work being done on the estimate.</td>
</tr>
<tr>
<td><strong>Highway Type</strong></td>
<td>The Highway Type field is a value that indicates the type of road being worked on (for example, asphalt, concrete, or dirt or two-lane or four-lane limited access).</td>
</tr>
<tr>
<td><strong>Urban/Rural Type</strong></td>
<td>The Urban/Rural Type field is a value that indicates the kind of area in which the work is being performed.</td>
</tr>
<tr>
<td><strong>Season</strong></td>
<td>The Season field is a value that indicates during what time of year the work is being performed.</td>
</tr>
<tr>
<td><strong>County</strong></td>
<td>The County field shows the primary county in which the work is being performed.</td>
</tr>
<tr>
<td><strong>District</strong></td>
<td>The district where a project or contract is located.</td>
</tr>
<tr>
<td><strong>Contingency Percent</strong></td>
<td>The Contingency Percent field is used to budget for unforeseen project work during construction, or in the earlier stages of project development to cover the provisions for information that is yet to be known about the project.</td>
</tr>
<tr>
<td><strong>Estimated By</strong></td>
<td>The Estimated By field contains the name of the person primarily responsible for developing the estimate for the active estimate. It is filled in by Estimator with the name of the person who created the new estimate, but it can be changed.</td>
</tr>
<tr>
<td><strong>Date Prepared</strong></td>
<td>The Date Prepared field contains the date you create the estimate. Estimator automatically enters the current date.</td>
</tr>
</tbody>
</table>
The Checked by field contains the name of the person who checks the estimate when it is completed. It must be manually entered.

The Date Checked field contains the date the person listed in the Checked by field checks the estimate.

The Approved by field contains the name of the person responsible for approving the completed estimate. It must be manually entered.

The Date Approved field contains the date the person listed in the Approved by field approves the Estimate estimate.

The Estimate Type field contains the type of estimate. It must be manually entered.

You must enter values for these fields as accurately as possible. If you must change the value of some of these data fields, Estimator needs to recalculate any items in the estimate that use bid-based estimation.

To see the values for these fields, click the down arrow next to the field. This shows a drop-down list of all field values in the currently selected catalog. You can sort these values by Description or by Descending Order by right-clicking on the down arrow next to the field and selecting the desired sort.

Once the estimate’s header window is complete, save your estimate by selecting **Save** from the **File** menu. You can also save your estimate as a template (see Section 5.1.3).

### 5.1.2 Changing Estimate Header Information

If you have permission to edit the active estimate, you can do so by typing over the information that already exists in the estimate field.

Open the estimate. Edit the desired fields. Once the changes have been completed, be sure to save your estimate by selecting **Save** from the **File** menu.

### 5.1.3 Using the Estimate as a Template

You can create a template of estimate information for use in Estimator.

Template can be used when you know you have data entries that are the same for multiple estimates. Instead of retying the same information into countless estimates, an estimate template stores the information to be readily available when needed. For example, if the same team of workers and the same items are going to be used for multiple jobs, then one estimate that contains this information can be created, saved as a
template, and used with modifications for each estimate. Each estimate created based on the template can be adjusted to fit the specific project.

A template can contain any amount of information. It can contain all the header information but no groups or items; it can contain solely groups and items, and no header information, or just some header information, or just some groups and items. The contents of the estimate depend on what information needs to be duplicated for the other estimates.

**Creating the Template**

Create the template by beginning an estimate as you would any other estimate. When saving, however, select **Save As** from the **File** menu. Estimator displays a Save As window. Open the **Templates** folder.

![Figure 5-4. Estimator Save As Window with File Types](image)

Select the down arrow next to the Save as Type field and select **Estimate Template Files (.ETM)**. Enter a name in the File Name field, and click **SAVE**. Estimator displays a Template User window.

![Figure 5-5. Template User Window](image)
If you select **YES**, then Estimator adds the user * to the estimate’s Users list. The asterisk (*) is a wildcard character that can be used in place of actual letters, numbers, and names. Use of the wildcard gives everyone permission to access the template to create a new estimate.

If you click **NO**, then you (the owner) are the only user able to access the template. Regardless of which option you select, you can change user options on the template’s user list.

**Accessing the Template**

Selecting **Open** from the **File** menu opens the Open Estimate window. To select a template, select the **Templates** folder, then click the down arrow next to the Files of Type field and select **Estimate Template Files (*.ETM)**.

**Note:** Your Templates folder may have a different name or location. The name of the folder where the templates are located is listed on the **URLS** tab of the Global Options window.
Select the template you wish to use and click OPEN. Estimator opens the selected template into its own window. You can then access it like you would any other estimate.

### 5.1.4 Setting the Estimate's Options

The Estimator system manager sets global options for each estimate, which determines the rounding level of the unit price and quantity, among other things. Even though you cannot change the global options, you can change the fields that relate to the open estimate (provided you have the privileges to change this information). You can also use the estimate options to select the catalog for the estimate.

To set your estimate options, select **Estimate Options** from the **Edit** menu while the estimate is open. Estimator displays the Estimate Options window. You can change the information in any of the fields.

The Bid History Data section allows you to choose between Display Data For All Spec Years or Display Data Only For The Catalog Spec Year. Prior to AASHTOWare Project BAMS/DSS 6.9a, the user may select either Display Data For All Spec Years” or “Display Data Only For The Catalog Spec Year in Estimator.” Beginning with AASHTOWare Project BAMS/DSS 6.9a, these selections will be grayed out depending on the options selected in AASHTOWare Project BAMS/DSS when running the HREG Model.

*Note:* The Bid History Data option only controls which data points are displayed in the scatterplot. Regardless of which value is selected by the estimator, this option does not change the unit price calculated for a given item.
If you are planning to only update prices and export the estimate to Cost Estimation or PES, then the Lock Estimate Except Price Related Data check box should be selected. If the estimate will be exported to Cost Estimation or PES, then the Only Trns•port Items and Codes Allowed check box should be selected. The last option, Only Trns•port Pricing Information Allowed, is currently not used by Cost Estimation or PES.

**Note:** Using Only Trns•port Items and Codes Allowed sets the decimal rounding places to what Cost Estimation and PES needs to get the same values as Estimator.

### 5.1.5 The Web Services Tab

If the System Manager has set up your Web Services option, then you may see an additional tab in any part of your estimate or catalog. The way this information is displayed depends on the way the transportation agency sets up the data. If there is no tab available, then no Web Service information has been entered.
Note: If a Microsoft Office program is used in Estimator's Web services, there may be issues with refreshing the document view when a window is resized. If the web services area becomes gray, resizing the window slightly will make the document visible. This is an issue with Microsoft OLE and not Estimator. Info Tech has reported this issue to Microsoft.

Another method for overcoming this issue is to save the Microsoft Office files as HTML formats such as HTM or MHT. These file formats refresh properly in Estimator's Web services when resized.

5.2 The Groups and All Items Tabs

Displayed at the bottom of the grid area of the estimate header window are two tabs - the GROUPS tab and the ALL ITEMS tab. Either tab can be used when you create your estimate. They contain the same information, but the information is added differently on each tab.

5.2.1 Introduction to the Groups Tab

When you use the GROUPS tab, the estimator creates groups in which items that relate to one another in some way are stored. This can include, for example, items that are all associated with a traffic light, or concrete barriers. Each group can contain an unlimited number of items, and the estimator can add the items in any order in a group.

When you first create an estimate, Estimator also creates one group for that estimate. To create a new group, make sure the estimate title is selected in the tree area, and select Add Group from the Edit menu. Estimator displays the group header window.
Once a group is created, the group header information must be completed. The Group Number field and the Group Increment are determined by your system manager and can be viewed in the Estimator global options. Enter a group description based on the items that will be added to the group.

Once the group header information is filled out, you can start adding items to your group.

5.2.2 Introduction to the All Items Tab

When you use the All Items tab, estimates are formed by adding items to the estimate, regardless of to what group they belong. Even though you are building the estimate in item order, you must still assign a group to each item as it is added to the estimate.

After you click the All Items tab, Estimator displays a grid with a blank row available for your first item. You can assign your item to a group that already exists, or you can create a new group for your item. To assign an already-existing group, click the down arrow next to the Group # cell and select the group from the drop-down list.

If you try to leave the cell without selecting a group, Estimator displays the Select Group window.
Use the drop down list to select a preexisting group, or click CREATE NEW GROUP to create a new group for your item. Estimator displays the Create New Group window. Here you can add the new group to your estimate.

![Create New Group Window](image)

**Figure 5-12. Create New Group Window**

While only the Group Number field is required, use the other fields to enter more information about your group:

- **Alt Code**
  Use this field to designate that a group is an alternate to another group. Each of the interchangeable or optional groups must be part of the same alternate set, which is designated by the first two characters of the alternate code. The third character of the alternate code should reflect the number of the group. For example if there are two groups that are considered alternates for each other, their alternate codes might be: Group 0001, Alt Code AA1; Group 0002, Alt Code AA2.

- **Group Description**
  Enter a free text description of the items that will be added to the group.

- **Supplemental Group Number**
  The Supplemental Group Number is an alphanumeric field at the Group/Category Level that allows additional values to be entered and tracked for each group, such as a construction change order tracking number.

When you are finished, click OK. Click CANCEL to return to the Select Group window.

When you are finished assigning your item to a group, click OK. Click CANCEL to return to the estimate without assigning a group. Once you click OK and return to the estimate, you can start adding information to your item.
5.3 Working with the Estimate Item List

The Item List contains all items that you have associated with an estimate. When a new estimate is created, the Item List is blank. The list also includes price bases and anything else attached to the items. The Item List can contain any number of items. On the GROUPS tab, the grid area contains the item list for the selected group. On the ALL ITEMS tab, the grid area contains the entire estimate item list. The entire estimate item list can also be viewed in the tree area if all groups are expanded to show their contents.

Finished Item Lists generally contain standard items found in the Estimator Standard Item Catalog; however, you can define nonstandard items to be included in an Item List, provided the estimate is not being used in an AASHTOWare Project application.

When you select an item in the tree area or in the grid, Estimator displays item information for these fields:

**Line Number**

The Line Number field refers to the item’s location in the estimate. Estimator saves this information and automatically generates new line numbers for newly added items.

**Item**

The Item field is a combination of letters, special characters, numbers, or both, assigned to standard items by the agency.

**Duplicate Item**

An item that appears more than once with the same unit system in a catalog or estimate. This column appears only if a duplicate item exists on the table and if verification messages are enabled from the Global Options.

**Quantity**

The Quantity value for an item indicates the number of units of the item to be used in the estimate.
**Unit Price**  
The Unit Price field shows the cost of one unit of an item. This value can be determined by the estimator or it can be calculated by Estimator from a cost sheet, bid history, or reference price. This field is filled in by Estimator if the information is available.

**Price Source**  
The Price Source field identifies the type of price basis used to determine the unit price of the item. If there are no active price bases attached to the item, then the Price Source field is *None*. If there is only one type of active price basis, then the Price Source field reflects that type of price basis. If there is more than one type of active price bases, the Price Source is *Multiple*. If the user creates a price basis for the item, the Price Source is *Ad Hoc*.

**Extension**  
The Extension field is the multiple of the item’s Unit Price and Quantity fields. Estimator automatically calculates the extended amount from your entries in the Unit Price and Quantity fields. You cannot enter the extended amount value; this field is filled in by Estimator.

**Description**  
The Description field contains a description of the item.

**Supplemental Description**  
The Supplemental Description is a more-specific description of an item. It is not required.

**Alt Code**  
The Alt Code is an agency-specific code for the item. It is not required.

Use this field to designate that an item or set of items is an alternate to another item or set of items. Each of the interchangeable or optional items must be part of the same alternate set, which is designated by the first two characters of the alternate code. The third character of the alternate code should reflect the number of the set. For example if there are two sets that are considered alternates for each other, their alternate codes might be: Item 601-10000, Alt Code AA1; Item 601-20000, Alt Code AA2.

**Unit**  
The Unit field identifies a specific unit of measurement provided for an item (HR for time in hours, CY for cubic yards, LF for linear feet, or LS for lump sum). If available, this field is filled in by Estimator.

**Exclude Item From Reference Price Calculations**  
This check box allows the user to determine whether an item should be included when a reference price is calculated as a percentage of the estimate total.

Use the NOTES tab of the Item header window to store additional information about the item. Notes for an item from the Standard Item Catalog are carried over with the item when the item is added to an estimate.
5.4 Adding Items to Your Estimate

Items can be added to your estimate while in the two tabbed folders - GROUPS and ALL ITEMS. Although the information for each item is the same, the way it is entered depends on which tab you are using.

Notes for an item from the Standard Item Catalog are carried over with the item when the item is added to an estimate.

5.4.1 Adding an Item While in the Groups Grid

Within the group window, you can add new items, modify or delete existing items, and modify the quantity and price basis information for any or all of the items in the Item List.

While in the estimate header window for the GROUPS tab, click the green GO button next to the group in the grid area whose items you wish to see. You can also click on the plus sign (+) of the group in the tree area, but using the grid give you more detailed item information. Estimator displays the group Item List window.

![Group Item List](image)

Figure 5-14. Group Item List

To add items to the group, select Add Item from the Edit menu. You can also add a new item by clicking in the empty Line # cell in the grid area of the group.

5.4.2 Adding an Item in the All Items Grid

Within the All Items grid, you can add new items, modify or delete existing items, and modify the quantity and price basis information for any or all of the items in the Item List.

While in the Estimate header window, select the ALL ITEMS tab. Click in the empty Group # cell in the All Items grid. Select a group from the drop down list or create your
own group from the Select Group window. After you assign a group to your item, you can enter the rest of the item information into the grid.

![Figure 5-15. All Items Item List](image)

### 5.4.3 Adding a Standard Item

You can add a new item to the Item List by selecting an item from the Standard Item Catalog list. The Standard Item Catalog items display when you select the down arrow next the Item field, whether you are on the GROUPS tab or the ALL ITEMS tab. If an estimate is set to be AASHTOWare Project (Trns•port)-compatible, then non-AASHTOWare Project items are displayed but not available.

![Figure 5-16. Add Item with Standard Item Catalog Displayed](image)

Select the desired item from the list. When you select an item in the Standard Item Catalog, Estimator copies the information for this item from the Standard Item Catalog and enters information in the Item, Item Description, and Unit fields. If one or more cost sheets, reference prices, bid histories, or a combination of prices bases are already attached to the item, Estimator includes copies of these attached price bases when it adds
the item to the Item List. Estimator uses the price basis designated as the active price basis to calculate and enter the Unit Price. The type of price basis used to determine the unit price is displayed in the Price Source field.

If the item does not have an attached price basis, you can add a unit price to the item. This changes the price source to *ad hoc*, meaning that it was manually entered and not derived from a price basis.

If you know the item number of the item, you can enter it directly into the Item field. Estimator displays the first item in the list that matches the entered information; for example, if you wanted to enter item 297(A) 42, when you type in the 2, the first item that starts with a 2 is displayed in the Item field. As you enter the subsequent numbers, the item in the Item field changes.

If you know what number your item starts with, you can type just that number into the Item field. Then, when you press the down arrow, the Standard Item Catalog list opens to that number. For example, if you know your item starts with a four, enter 4 into the Item field, and press the down arrow. The list opens to the items that begin with 4.

The Quantity field is required; Estimator does not supply this value. After the Unit Price and Quantity values have been determined, Estimator automatically calculates the extended amount.

Whether the Alt Code is required depends on your agency.

### 5.4.4 Using the Find Item Window

If you know the item number of an item, or a word or words included in the description, you can use that information to search for a particular item. You can also search for a unit of measurement or the unit system of English, metric, or none. The more information you enter about your item, the easier it will be to find.

Click the GO button next to the line number of the item for which you wish to find in the grid area of the Group window (for the GROUP tab) or the grid area of the Estimate header window (for the ALL ITEMS tab), or select the line number of the item in the tree area. You may have to create an item row if you are on the ALL ITEMS tab. Estimator displays the item window. Next to the Item field, a small button marked with an ellipsis (…) is visible. This is the FIND button.
Click the **FIND** button to bring up the Find Item window.

![Find Item Button](image)

**Figure 5-17. Find Item Button**

Enter the criteria in the appropriate fields for the item you wish to find and press the **TAB** key between each entry. Do not press **ENTER** or click **OK**, as this will select the first item on the list and return you to the Item window.

Each time you press **TAB**, the list of matches narrows to those items that fit the entered information. Once you have entered all the criteria for which you are searching, select the desired item by highlighting it in the Matches list, and click **OK**. If there are no items that match the search, double check your information or be less specific and enter the search criteria again.

**Note:** If an item is displayed with a line through it, it means the item does not match the unit system (English, metric, or none) of the estimate and cannot be selected.
Once you find the item you are searching for, select the item in the Matches list and click OK. Click CANCEL if you decide not to use any of the items.

**Expert Mode**

If the Expert Mode box is selected in the Find Item window, then the criteria entered in the Find fields must exactly match the item for which you are searching, or you must use wildcards to find the item for which you are searching.

For example, if you enter Bridge in the Description field when you are using Find Item in the regular mode, the Matches display every item in which the word Bridge appears somewhere in the description. In Expert Mode, however, you would have to enter the entire description - for example, Bridge Approach Panel, or Install Bridge Superstructure in order for Estimator to find a match, unless the item's entire description consists of the word Bridge.

![Figure 5-19. Find Item Expert Mode Box](image)

**Note:** You must still use the TAB key in Expert Mode for Find Item to function.

You can also use wildcards to search for an item. The two wildcards Estimator uses are the question mark (?) and the asterisk (*).

Using * finds any number of characters. For example, if you know the word Bridge is the last word of an item's description, but you are not sure what the first word is, you can enter *bridge in the Description field and press TAB. Estimator displays all items that contain Bridge as their last word.

Using ? will find only one character. Suppose you wanted to find items that have a one-character designation; for example, Remove G Light, or Remove 7 Light. Enter Remove
? Light in the Description field and press TAB. Estimator displays all items that have the words Remove and Light in it, with one character in between the two words.

You can also combine the use of the wild cards. If you enter ?t* in the Description field and press TAB, Estimator returns all items whose second letter is a T.

Once you find the item you are searching for, select the item in the Matches list and click OK. Click CANCEL if you decide not to use any of the items.

### 5.5 Sorting the Item List

You can sort the item list for the estimate from the ALL ITEMS tab, or sort each group's item list from the GROUPS tab. You can also sort Estimator's item list from the Item window before adding an item to your estimate. Estimator retains the sort order in the grid each time you access a sorted list, but the sort is not reflected in the tree area.

Estimator initially lists the items by Line # order. When you first click the desired sort column heading, Estimator sorts the items in ascending (A to Z, or 0 to 9) order, depending on the data in the field. Click again, and the sort order reverses to descending (Z to A, or 9 to 0).

#### 5.5.1 Sorting the Estimate and Group Item Lists

You can sort the order of items in the estimate's Item List and a group's item list by any of the column headings. Simply click the column heading in the grid area of the characteristic by which you wish to sort. For example, to sort by Description, just click the description column heading. The items in the tree do not reflect the sort.

When you save the estimate, Estimator also saves the order of the items in the grid. If you reorder the items in an Item List and save the estimate, the next time you open the estimate file the items in the Item List are sorted in the same order.

#### 5.5.2 Sorting the Items Before Adding an Item to Your Estimate

When adding an item to your estimate, you can sort the Estimate's Item List from the item window in numeric order or by description. To do this, you must be in the item window. Click the GO button next to the line number of the item for which you wish to add in the grid area of the GROUP or ALL ITEMS tabs, or select the line number in the tree area. Estimator displays the item window.

Right-click on the down arrow next to the Item field. Estimator displays the sort options.
You can choose to sort by either the item description or in descending order. If you choose to sort by item description or descending order and right-click on the down arrow again, you can then decide to sort by item ID, or in ascending order.

5.6 Modifying the Estimate Item List

Once your item list has been created for your estimate, you can change or delete the items on the list. You can add items to your item list at any time.

5.6.1 Changing an Item on the Estimate Item List

Select an item in the Item List to make changes to that item. You can change any value that is available and not shaded. Be aware, however, that changing a field that Estimator fills in automatically may change the behavior of the item. When more than one price basis is attached to the item, you can designate which of the attached price bases Estimator uses to determine the unit price for the item.

5.6.2 Deleting Items From the Estimate Item List

To delete an item from the Item List, select the item to delete. You can simultaneously select several items in one group or on the All Items grid by holding down the CTRL key and selecting items in the grid with the mouse. When you have selected the item(s) you want to delete, select **Delete Items** from the **Edit** menu or press the DELETE key on the keyboard. You can delete consecutive items by pressing and holding down the SHIFT key, selecting the first and last item, and then selecting **Delete Items** from the **Edit** menu.
5.7 Working with Item Price Bases

Estimator allows you to use any type of price bases to estimate the costs of the items in an estimate: cost sheets, bid histories, reference prices, and ad hoc. Estimator also allows you to combine price bases to estimate cost.

Every item in an Item List should have one or more attached price bases. You can view the attached price basis when the item is selected by clicking the green GO button next to the desired price basis in the grid or by selecting it in the tree area.

5.7.1 Working with Cost Sheets

A cost sheet provides a highly detailed estimate of the cost of an item by totaling the costs of all the equipment, labor, and materials needed to construct or produce the item. You can make production adjustments on the cost sheet to accommodate differences in terrain and other estimate-specific conditions.

You can display a cost sheet as long as the item selected has at least one cost sheet attached to it (whether or not it is the active price basis). You can also view cost sheets from the Standard Item Catalog and the Cost Sheet Catalog (see Chapter 7, Working With Catalogs and Code Tables).

Viewing Cost Sheets

To view the cost sheet for an item, select the plus sign for that item so it is expanded. Any price basis in the tree area marked with a C is a cost sheet.

Select the desired cost sheet by highlighting it in the tree area or clicking the GO button next to the cost sheet in the grid. Click the plus sign of the cost sheet to see the rate catalogs. If you are looking at a cost sheet for an item in a catalog, Estimator displays the selected cost sheet in a Cost Sheet window as shown in Figure 5-21.

![Figure 5-21. Cost Sheet Window](image-url)
Changing Cost Sheets

If you have permission to edit the estimate, you can make changes to cost sheets attached to items. Changes made in the cost sheet of an estimate, however, are not duplicated in the Cost Sheet Catalog.

You can assign a new cost sheet name to the cost sheet via the Cost Sheet Name field. Estimator does not require you to conform to cost sheet naming conventions that might be used by your agency. It is your responsibility to maintain compatibility with established cost sheet naming conventions.

You can add a new description for the cost sheet in the Description field. If changes are being made to a cost sheet attached to an estimate item to reflect particular estimate conditions, you might want to note such details in the cost sheet’s Description field.

If you click on the tabs for the Equipment, Labor, or Materials of the cost sheet, Estimator displays the Equipment List window, the Labor List window, or the Materials List window, respectively. This process is equivalent to choosing Equipment, Labor, Materials, or from the tree area.

Using the Rate Catalog Find Window

If you are adding an equipment record to the equipment list, a laborer to the labor list, or a material to the materials list, you can use the find window to locate the specific record to add to the list. If you know the name or a word or words included in the description of the rate catalog record you are adding to your cost sheet, you can use that information to search for the particular record. The more information you enter about your rate catalog record, the easier it will be to find.

When the rate catalog record is displayed in its own window, a small button marked with an ellipsis (…) is visible. This is the FIND button.

Figure 5-22. Find Button
Click the FIND button to bring up the Find window for the chosen catalog.

Enter the criteria in the appropriate fields for the record you wish to find and press the TAB key between each entry. Do not press ENTER or click OK, as this will bring you back to the window without selecting a record.

Each time you press TAB, the list of matches narrows to those records that fit the entered information. Once you have entered all the criteria for which you are searching, select the desired record by highlighting it in the Matches list, and click OK. If there are no records that match the search, double check your information or be less specific and enter the search criteria again.

**Expert Mode**

If the Expert Mode box is checked in the Find window, then the criteria entered in the Find fields must exactly match the record for which you are searching. For example, if you enter Bridge in the Description field when you are using Find in the regular mode, the Matches display every record in which the word Bridge appears somewhere in the description. In Expert Mode, however, you would have to enter the entire description - for example, Bridge Approach Panel, or Install Bridge Superstructure in order for Estimator to find a match, unless the record's entire description consists of the word Bridge.

**Sorting the Rate Catalogs Records**

You can sort each of the rate catalog records before adding a one to your cost sheet. First, you must add a record to the cost sheet. Then select the record so it appears in its own window. Right-click on the down arrow next to the Name field. Estimator displays the sort options.
You can choose to sort by either the description or in descending order. If you choose to sort by description or descending order and right-click on the down arrow again, you can then decide to sort by ID or in ascending order.

**Working with the Equipment List**

To view the Equipment List of the active cost sheet, select the **Estimate Equipment Set** in the tree area. This gives you a more detailed view of the Equipment List than just selecting the **EQUIPMENT** tab from the cost sheet window. Estimator displays the Equipment List of the active cost sheet in an Equipment List window as shown in Figure 5-25.

The Equipment List window displays a list of all the equipment used on the active cost sheet, including detailed quantity and pricing information for each piece of equipment. You can select the equipment record from the Equipment Rate Catalog or manually enter the data for each type of equipment into the Equipment List.
While an item can have any number of cost sheets attached to it, each cost sheet will always have one (and only one) Equipment List. The Equipment List is always present, even if it is empty.

**Equipment List Window Fields**

Click the GO button next to an equipment set to see the fields of information for each equipment record in the Equipment List. You can also expand the equipment record by clicking the plus sign next to it and selecting the desired equipment set.

**Equipment Name**
The Equipment Name field contains a unique code of letters, numbers, or both as assigned to each piece of equipment by the agency. (Estimator does not require you to follow agency code formats. It is your responsibility to conform to equipment code standards that may apply.)

**Equipment Description**
The Equipment description field contains a short description of the piece of equipment. This description is usually (but not always) unique.

**Equipment Rate**
The Equipment Rate field contains the cost of using one piece of the equipment for the period of time specified in the unit field. For example, a rate per unit of $50.00 means that the equipment costs $50.00 per day if the Unit field value is DY or $50.00 per hour if the Unit field value is HR.

The value specified in the Equipment Rate field might correspond to the rental cost of the equipment or the purchase plus maintenance cost of the equipment. In either case, all costs associated with using the equipment are included in this value.

**Quantity**
The Quantity field denotes the number of pieces of the specified equipment to be used in the construction or production of the item to which the cost sheet is attached.

**Total**
The Total field is a value representing the total cost of using the number of pieces of equipment specified in the Qty field for one complete day.

*Note:* You can use an equation or formula to derive the value of a numeric field by clicking the ellipses next to the field to bring up the Expression Builder window.

**Adding Equipment to the Equipment List**

If you have permission to edit the estimate that contains the cost sheet to which the Equipment List window belongs, you can add new types of equipment to the Equipment List and specify the number of pieces of each type of equipment to be used. Do this by selecting Add Equipment from the Edit menu when the Equipment Set is the active window, or by clicking the empty ID field in the Equipment Set grid area.
You can add a new type of equipment to the Equipment List by selecting the down arrow next to the Equipment Name field (if you are working from the tree area) or ID field (if you are working from the grid area) and choosing one of the pre-defined pieces of equipment displayed in the Equipment Rate Catalog list box. You can also manually entering the Equipment Name, Equipment Description, Quantity, or Equipment Rate values into the fields.

You can insert the equipment in a desired location instead of adding it to the bottom of the list. To do this, place your cursor on the equipment that is in the position you want your new equipment to occupy. Select Insert Equipment from the Edit menu. Estimator inserts the new equipment in the designated place.

**Changing the Equipment List**

If you have permission to edit the estimate that contains the cost sheet, you can change the selected equipment in the Equipment List window.

You can change the value of any field of the selected equipment by entering new information into the appropriate field.

**Deleting an Item from the Equipment List**

If you have permission to edit the estimate that contains the cost sheet, Estimator enables the Delete command on the Edit menu when the Equipment List window is displayed.

To delete an equipment record from the Equipment List, select the equipment you want to delete. You can simultaneously select several consecutive equipment records in the grid area of the Equipment List by holding down the SHIFT key and selecting equipment records in the grid with the mouse. When you have selected the equipment record(s) you want to delete, select Delete Equipment from the Edit menu or press the DELETE key on the keyboard. You can delete non-consecutive equipment records by pressing and holding down the CTRL key, selecting each record in the grid, and then selecting Delete Equipment from the Edit menu.

**Sorting the Equipment List**

You can sort the Equipment list by any of the column titles in ascending or descending order by clicking on the column title. This sorts the Equipment in ascending order based on the column title selected. If you click the column title again, Estimator sorts the Equipment in descending order based on the column title.

If you select ascending order on a numeric data field, the Equipment with the lowest number in the selected field appears first in the Equipment List and the item with the highest number appears last. If you select ascending order on a nonnumeric data field, the items in the Equipment List are ordered from the lowest to the highest number, then
from A to Z. An Equipment List sorted in descending order has its records placed in the opposite order.

When you save the estimate, Estimator also saves the order of the items. If you reorder the items in the Equipment List and save the estimate, the next time you open the estimate file the items in the Equipment List will be sorted in the saved order.

**Working with the Labor List**

To view the Labor List of the active cost sheet, select **Estimate Labor Set** on the tree view of the Estimate. This gives you a more detailed view of the Labor List than just selecting the LABOR tab from the cost sheet window. Estimator displays the Labor List window for the active cost sheet as shown in Figure 5-26.

![Figure 5-26. Labor List Window](Image)

The Labor List window displays a list of all the laborers used on the cost sheet, including detailed quantity and rate of pay information for each type of laborer. You can select the labor record from the Labor Rate Catalog or you can manually enter the data for each type of laborer into the Labor List.

An item can have any number of cost sheets attached to it, but each cost sheet always has one (and only one) Labor List. The Labor List is always present, even if it is empty.

**Labor List Window Fields**

Click the GO button next to a labor set to see the fields of information for each labor record in the Labor List. You can also expand the labor record by clicking the plus sign next to it and selecting the desired labor set.
| **Labor Name** | The Labor Name field contains a unique code of letters, numbers, or both as assigned to each type of laborer by the agency. (Estimator does not require you to follow agency labor code formats. It is your responsibility to conform to any standards that may apply.) |
| **Labor Description** | The Labor Description field contains a brief job description of the specific type of laborer. The description is usually (but not always) unique. |
| **Labor Wages** | The dollar amount paid to one laborer for one hour of an eight-hour time period. For example, labor wages of $18.00 means that each laborer of this type is paid $18 per hour. This rate should include the total burden caused by a laborer on this item (for example, FICA or benefits). Other overhead costs, such as maintaining a business office, are usually accounted for as an overhead percentage. |
| **Labor Overtime Wages** | The dollar amount paid to one laborer for each hour over eight in an eight-hour time period. For example, labor overtime wages of $27.00 means that each laborer of this type is paid $27 for each hour over eight hours in a work day. |
| **Quantity** | The total number of laborers needed of this type. |
| **Total** | The Total field shows the total cost of employing the number of laborers specified in the Quantity field for one complete day. Estimator uses values from the Quantity and Labor Wagers fields to calculate the value displayed in the Total field. |

**Note:** You can use an equation or formula to derive the value of a numeric field by clicking the ellipses next to the field to bring up the Expression Builder window.

### Adding Laborers to the Laborer List

If you have permission to edit the estimate that contains the cost sheet, you can add new types of laborers to the Labor List and specify the number of laborers of each type to be used. Do this by selecting **Add Laborer** from the **Edit** menu when the Labor List is the active window.

You can add a new type of laborer to the Labor List by selecting the down arrow next to the Labor Name field (if you are working from the tree area) or ID field (if you are working from the grid area) and selecting one of the pre-defined laborers displayed in the Labor Rate Catalog list box or by manually entering the Labor name, Labor Description, Labor Wager, Labor Overtime Wages, and Quantity, into the fields.
You can insert the laborer in a desired location instead of adding it to the bottom of the list. To do this, place your cursor on the labor record that is in the position you want your new laborer to occupy. Select **Insert Laborer** from the **Edit** menu. Estimator inserts the new laborer in the designated place.

**Changing the Labor List**

If you have permission to edit the estimate that contains the cost sheet, you can change the selected laborer in the Labor List window.

You can change the value of any field of the selected laborer by entering new information into the appropriate field.

**Deleting a Labor Record From the Labor List**

If you have permission to edit the estimate that contains the cost sheet, Estimator enables the Delete command on the Edit menu when the Labor List is displayed.

To delete a laborer record from the Labor List, select the laborer you want to delete. You can simultaneously select several consecutive laborer records in the Labor List by holding down the **SHIFT** key and selecting laborers in the grid area with the mouse. When you have selected the laborer record(s) you want to delete, select **Delete Labor** from the **Edit** menu or press the **DELETE** key on the keyboard. You can delete non-consecutive labor records by pressing and holding down the **CTRL** key, selecting each record, and then selecting **Delete Labor** from the **Edit** menu.

**Sorting the Labor List**

You can sort the Labor List by any of the column titles in ascending or descending order by clicking on the column title. This will first sort the laborers in ascending order based on the column title selected. If you click the column title again, Estimator sorts the laborers in descending order based on the column title.

If you select ascending order on a numeric data field, the laborers with the lowest number in the selected field will appear first in the Labor List and the item with the highest number will appear last. If you select ascending order on a nonnumeric data field, the items in the Labor List will be ordered from the lowest to the highest number, then from A to Z. A Labor List sorted in descending order has its items placed in the opposite order.

When you save the estimate, Estimator also saves the order of the items. If you reorder the items in the Labor List and save the estimate, the next time you open the estimate file the items in the Labor List will be sorted in the saved order.
Working with the Materials List

Select **Estimate Materials Set** in the tree area to display the Materials list for the active cost sheet as illustrated in Figure 5-27. This gives you a more detailed view of the Material List than just selecting the MATERIAL tab from the cost sheet window.

![Materials List Window](image)

Figure 5-27. Materials List Window

The Materials window displays a list of all the materials used on the active cost sheet, including detailed quantity and pricing information for each type of material. To see the individual material information, click the **GO** button next to the material you wish to see or select that material in the tree area. You can select the material record from the Material Rate Catalog or manually enter the data for each type of material into the Material List.

While an item can have any number of cost sheets attached to it, each cost sheet will always have one (and only one) Materials List. The Materials List is always present, even if it is empty.

**Materials Window Fields**

Click the **GO** button next to a material set to see the fields of information for each material record in the Material List. You can also expand the material record by clicking the plus sign next to it and selecting the desired material set.

<table>
<thead>
<tr>
<th>Material Name</th>
<th>The Material Name field contains a unique code of letters, numbers, or both as assigned to each type of material by the agency. (Estimator does not require you to follow an agency materials code format. It is your responsibility to conform to any standards that may apply.)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material Description</td>
<td>The Material Description field contains a brief description of the material. The description is usually (but not always) unique.</td>
</tr>
</tbody>
</table>
Material Price/Unit: The Material Price Per Unit field contains the cost of one unit of the material.

Material Unit: The Material Unit field contains the units by which the material is measured, for example, CY for cubic yards and LF for linear feet.

Quantity: The Quantity field contains the number of units of the material needed to produce the item to which the cost sheet is attached.

Total: The Total field contains the total cost of purchasing the amount of the material specified in the Quantity field.

Note: You can use an equation or formula to derive the value of a numeric field by clicking the ellipses next to the field to bring up the Expression Builder window.

Adding Materials to the Materials List

If you have permission to edit the estimate that contains the cost sheet, you can insert new materials into the Materials List and specify the quantity of the new materials to be used. Do this by selecting Add Material from the Edit menu when the Material List is the active window.

You can add a new type of material to the Material List by selecting the down arrow next to the Material Name field (if you are working from the tree area) or ID field (if you are working from the grid area) and selecting one of the pre-defined materials displayed in the Material Rate Catalog list box or by manually entering the Material Name, Material Description, Quantity, Price Per Unit, and Unit values in the fields in the Add Materials dialog box.

You can insert the material in a desired location instead of adding it to the bottom of the list. To do this, place your cursor on the material that is in the position you want your new material to occupy. Select Insert Material from the Edit menu. Estimator inserts the new material in the designated place.

Changing the Materials List

If you have permission to edit the estimate that contains the cost sheet, you can change the selected material element in the Materials List window.

You can change the value of any field of the selected material by entering new information into the appropriate field.
Deleting an Item from the Materials List

If you have permission to edit the estimate that contains the cost sheet, Estimator enables
the Delete command on the Edit menu when the Materials List window is displayed.

To delete a material from the Materials List, select the material you want to delete. You
can simultaneously select several consecutive materials in the Materials List window by
holding down the shift key and selecting materials in the grid area with the mouse.
When you have selected the material(s) you want to delete, select Delete Material from
the Edit menu or press the delete key on the keyboard. You can delete non-consecutive
materials by pressing and holding down the ctrl key, selecting each material, and then
selecting Delete Material from the Edit menu.

Sorting the Materials List

You can sort the materials list by any of the column titles in ascending or descending
order by clicking on the column title. This will first sort the materials in ascending order
based on the column title selected. If you click the column title again, Estimator sorts the
material in descending order based on the column title.

If you select ascending order on a numeric data field, the material with the lowest number
in the selected field will appear first in the Materials List and the item with the highest
number will appear last. If you select ascending order on a nonnumeric data field, the
items in the Materials List will be ordered from the lowest to the highest number, then
from A to Z. A Materials List sorted in descending order has its items placed in the
opposite order.

When you save the estimate, Estimator also saves the order of the items. If you reorder
the items in the Materials List and save the estimate, the next time you open the estimate
file the items in the Materials List will be sorted in the saved order.

5.7.2 Working with Reference Prices

You can display a reference price in an Item List window as long as the item selected has
at least one reference price attached to it (whether or not it is the active price basis). You
can also view the Reference Price from the Standard Item Catalog and the Reference
Price Catalog (see Chapter 7, Working with Catalogs and Code Tables).

Viewing Reference Prices

To view the reference price for an item, select that item in the tree area so it is expanded.
Any price basis marked with an R is a reference price.

Select the desired reference price by highlighting it in the tree area or clicking GO in the
grid. Estimator displays the selected reference price in a Reference Price window as
shown in Figure 5-28.
Reference Price Window Fields

Reference Price ID
The Name field displays the name of the reference price.

Unit Price
The Unit Price field displays the estimated cost of one unit of the estimate item to which the reference price is attached.

Percent of Estimate
Select this check box to indicate the reference price be calculated as a percentage of the estimate total. Enter the total percentage in the field that appears if this check box is selected.

Active Price Basis
The Active Price Basis check box determines if the reference price is used as a price basis.

Description
The Description field is a text field used by the estimator to detail the characteristics of the reference price. For example, this field might contain the name of the outside source from which the reference price was derived, the circumstances under which the reference price is appropriate, the date that the reference price was entered into Estimator, and the name or initials of the estimator who entered the reference price.

Changing a Reference Price

If you have permission to edit the estimate, you can change the reference price. Changes made to the reference price in an estimate are not reflected in the Reference Price catalog.

You can enter a new name for the reference price into the Reference Price ID field, a new price value for the reference price into the Unit Price field, and a new description into the Description field. The new description should explain the changes made to the reference price, the reason or basis for the changes, and include the name or initials of the user making the changes and the date the changes were made.
5.7.3 Working with Bid Histories

A bid history, information that has been derived by statistically analyzing past bids for an item, can be used to predict future bid prices for an item. There are two kinds of bid histories supported in Estimator: Average Prices and Regression Coefficients.

Average Prices predicts future bids on an item by determining the weighted average (total extended amount divided by total quantity) of past bids on the item.

Regression Coefficients use historical data (provided a sufficient amount exists) to fit the historical item bids into a formula that takes into account item quantity, inflation, estimate location, season of the year, and estimate work type. A statistical analysis model determines the coefficients of the formula that Estimator uses to predict a future bid price.

You can display a bid history as long as the item selected has at least one bid history attached to it (whether or not it is the active price basis). You can also view bid histories from the Standard Item Catalog and the Bid History Catalog (see Chapter 7, Working with Catalogs and Code Tables).

There are four fields that you can edit for a bid history (if you have the correct permissions):

- **Bid History ID**
  The unique identifier of the bid history

- **Item, if different**
  The item number to which this bid history belongs, if it is different than the Bid History ID.

- **Quantity per Item Unit**
  The conversion factor used to adjust the quantity of the bid history when a bid history for a different item is used. For example, if the actual item's unit of measure is feet and the bid history item is inches, the Quantity per Item Unit should be set to 12. If the units of measure for both items are the same, the default value of 1 should be used.

- **Active Price Basis**
  Indicates if the bid history is an active price basis.

**Viewing Bid Histories**

To view the bid history for an item, select the plus sign for that item so it is expanded. Any price basis in the tree area marked with a B is a bid history.

Select the desired bid history by highlighting it in the tree view or clicking the GO button in the grid. If you are looking at a bid history for an item, Estimator displays the selected bid history in a Bid History window as shown in Figure 5-29.
For bid histories residing in estimates, the bid history windows include graphs of unit price versus quantity for the bid history item. Shown here is a sample graph of the regression price by quantity, while an average price by quantity graph displays Avg. Qty. %tile.

The green lines indicate the items current quantity and price. You can find a specific price for quantity by placing your mouse on the graph, and pressing and holding down the right mouse button while finding that quantity and price on the graph.

The five colored lines on the graph represent the percentile in which the values are divided. This makes it easier to see where your quantity falls within the bid history regression plot.

### 5.7.4 Modifying Price Basis in an Estimate

Once a price basis is added to your element, you can modify it or delete it.

**Changing the Active Price Basis for an Item**

If the item being added to the Item List already has one or more attached price bases, Estimator uses the item’s designated active price basis to determine the unit price of the item. If more than one price bases is attached to the item, you can select any of the attached price bases to serve as the active price basis. An item can have more than one active price basis.

To view an attached price basis of an item, open your estimate and select the item in the tree area or click the green GO button next to the item in the grid area for a group or on the ALL ITEMS tab. Estimator displays the symbol for each of the attached price bases:

- **C** Cost Sheet
- **R** Reference Price
**Bid-based Price**

**Price Basis List**, shown as a folder icon as well

An ad hoc price basis does not display as an attached price basis.

To make a price basis inactive, highlight that price basis in the tree view and select **Toggle Active/Inactive** from the **Edit** menu. You can also uncheck the box in the **Active** column in the grid view for that price basis. An ad hoc price basis is automatically active. Estimator places a red X on the inactive price basis.

![Figure 5-30. Item in Estimator with One Active and One Inactive Price Basis](image)

To make the inactive price basis active, highlight that price basis in the tree view and select **Toggle Active/Inactive** from the **Edit** menu, or place a check in the **Active** column for that price basis.

**Deleting Price Bases from an Item**

To delete a price basis from an item, select the price basis in the tree view. Select the **Edit** menu and choose **Delete Price Basis List** for the desired price basis. This has no effect on other copies of the same price basis that might be included in a price basis catalog or that might be attached to other items in the same or different Estimator estimates; the delete only affects the selected item.

You can also delete the price basis from the grid area by highlighting it in the item window and selecting **Delete Price Bases** from the right mouse button menu.

If there is a possibility that the price basis might later be needed, you should make the price basis inactive instead of deleting it.
5.8 Updating Price Information

Estimator is able to update prices in estimates if rounding preferences, bid histories, rate catalog, or cost sheet information changes. Select the desired element to be updated and select **Update Price Information** from the **Edit** menu.

You reprice estimates to reconcile an imported estimate with bid histories and cost sheets in the current catalog. You use this command most often when you import an estimate from another system; it is unlikely that you would reprice an estimate you created because doing so would cause you to lose any modifications you have made to estimate.

Sometimes it may be desirable to use the most up-to-date cost sheet and bid history data in an existing estimate. The most common use is to reestimate items when new bid history is collected. Less frequently, you may wish to reprice an entire estimate (for example, if you import an estimate from another workstation). This is accomplished in both cases by using the Update Price Information command from the Edit menu.

You can update the entire estimate by selecting the estimate header before updating the price information. You can update specific price bases by selecting them in either the tree or grid area. If an item is selected, then only the price bases for that item are updated. If a group is selected then all price bases for each item in the group are updated. Whatever element is the active window is the only one updated.

![Note: It is recommended that you save your estimate before updating the price information.](image)

Once you select **Update Price Information** from the **Edit** menu, Estimator displays three updating choices.

![Figure 5-31. Update Selected Price Information Window](image)
Choose which repricing option you wish to use and click OK, or click CANCEL to not reprice the estimate.

**Refresh Time Dependent Data and Cost Sheet Structure**

After you create estimates, the price bases catalogs may occasionally be modified. For example, if a supplier changed his quote, then the reference price would change. To reflect these changes in your estimates, you need to refresh time dependent estimate prices.

Select **Refresh Time Dependent Data and Cost Sheet Structure** to replace the existing price bases an estimate uses with the updated price bases catalogs. Estimator compares the selected price basis in the estimate to the catalogs and then modifies the estimate's price bases according to any new or changed information that exists in the catalog.

**Refresh Time Dependent Data**

After you create estimates, the Reference Price Catalog, Bid History Catalog and Rate Catalogs may occasionally be modified. For example, if the minimum wage increased, the Labor Rate Catalog would need to be modified accordingly to reflect pay increases. If a supplier changed his quote, then the reference price would change. To reflect these changes in your estimates, you need to refresh time dependent estimate prices.

Select **Refresh Time Dependent Data** to replace the selected bid histories an estimate uses with bid histories from the Bid History Catalog and to replace the selected rates an estimate uses with rates from the Rate Catalogs. Estimator compares the selected items in the estimate to the catalogs and then modifies the estimate’s selected bid histories or cost sheets according to any new or changed information that exists in the catalog. (It writes in any new bid histories, equipment, labor, or materials rates from the Bid History Catalog, Equipment Rate Catalog, Labor Rate Catalog, and Materials Rate Catalog, respectively.)

**Restart**

Selecting **Restart** clears away all child options of the selected entity and replace the child options with the corresponding information in the Current Catalog. This option can be used by a single item, by a group for all items in that group, or by the estimate for all items in the estimate.

**5.9 Working with the Estimate Users List**

The Estimate Users List contains the username and clearance level of each user authorized to open the active estimate. Estimator checks the Estimate Users List when you try to open an estimate file. If your username is not in the estimate's Estimate Users
List, Estimator will not open the estimate and displays the error message shown in Figure 5-32.

![Estimator Error Message](image)

Figure 5-32. Not Authorized to Open Estimate Error Message

The Estimate Users List window can only be edited by those with owner or user permission. When a user creates a new estimate, he or she is automatically assigned owner permission of that estimate. A person with user privileges cannot assign owner privileges to anyone.

Those designated as a super-user also have access to the estimate, regardless of what privileges were set in the estimate's Users List.

If you have owner or user permission for the active estimate, Estimator enables the Estimate Users command on the Edit menu. Select **Estimate Users** from the **Edit** menu to display the Estimate Users List window for the active estimate (see Figure 5-33).

![Estimate Users List](image)

Figure 5-33. Estimate Users List Window

The Estimate Users List displays these fields of information for each Estimator user authorized to open the active estimate:

**User**
- The User field displays the username of an Estimator user authorized to open the estimate file.

**Agency**
- The Agency field is used to determine to which agency a user belongs.
Location
The Location field determines where in the agency a user belongs.

Estimate Access
The Estimate Access field displays your permission or clearance level for the active estimate.

Owner permission means you can view any window and edit any data in an estimate, including the Estimate Users List.

User permission means you can view any window and edit any data in an estimate, including the Estimate Users List. However, unlike a user with owner access, you cannot edit anyone on the Users List that has owner access.

Write permission means you have clearance to view and edit any window in an estimate.

Read permission means you have clearance to view any window in the estimate. A user with read permission cannot edit or change any data in an estimate.

5.9.1 Adding Users to the Estimate Users List
If you have owner or user privileges for an estimate, you can add new users to the Estimate Users List. Access the Estimate Users List. Click the ADD button to add a new user. Estimator adds a new line to the Users List into which you can add your new user.

![Figure 5-34. Add Estimate User Dialog Box](image)

Adding a Single User
You can type the name directly into the User field or use the down arrow to access a list of current Estimator users. Estimator automatically fills in the Agency and Location fields based on the agency and location brand of the copy of Estimator.
When the name of the new user displays in the User field, you must select a permissions level from the drop-down list (owner, user, write, or read) to indicate the privilege level for the new user being added to the Estimate Users List.

**Adding Users for an Agency/Location Pair**

If you enter * in the User field and add this username to the Estimate Users List, all authorized Estimator users at your Agency/Location pair can access the estimate. You can authorize users in a different agency and location by entering the specific agency and location name in the appropriate fields. If you enter * in the Agency or Location fields, any agency or location can access the estimate. Once you have added the appropriate information, the estimate can be opened by the assigned users once they receive it (from a disk, or attached to an e-mail message, etc).

Note: If you do not know the other users' Agency or Location, you must ask them for that information. The Agency for your DOT or Transportation Agency is the same as your own, and the location is 00000. For example, if your Agency/Location pair is EST 07181, then the DOT or Transportation Agency’s Agency/Location pair is EST 00000.

When you are done adding users to your estimate, click OK to return to the estimate, or ADD to add another user. If you click ADD, Estimator adds an additional line in the Estimate Users list window to add another user. If you click OK, Estimator returns you to your estimate with the new users added. You can click APPLY to save the changes you made and remain in the Users List.

### 5.9.2 Changing Estimate Users

If you have owner or user permission for a particular estimate, you can change the information about a user in the estimate’s Users List. A user with only user permission, however, can only change the information for users that are not owners. You can change the username in the User field or select a different permission level in the Estimate Permission box, or both.

Click OK to update the selected user in the Estimate Users list with the new data. Estimator returns you to the estimate to which you were changing the Users List.

### 5.9.3 Deleting Estimate Users

If you have owner or user privileges for an estimate, you can delete selected users from the Estimate Users List. To do this, access the Estimate Users List window.

You can select consecutive users in the Estimate Users List and delete them simultaneously by selecting the first user, pressing and holding down the SHIFT key, and selecting the last user. When you have selected the user(s) you want to delete, click the
DELETE button. You can delete non-consecutive users by pressing and holding down the CTRL key, selecting each user, and then clicking DELETE.

5.9.4 Sorting the Estimate Users List

You can sort the Users List by any of the column titles in ascending or descending order by clicking on the column title. This sorts the users in ascending order based on the column title selected. If you click the column title again, Estimator sorts the users in descending order based on the column title.

If you select ascending order on a numeric data field, the users with the lowest number in the selected field appear first in the Users List and the users with the highest number appear last. If you select ascending order on a nonnumeric data field, the users in the Users List are ordered from the lowest to the highest number, then from A to Z. A Users List sorted in descending order has its users placed from Z to A.

When you save the estimate, Estimator also saves the order of the users. If you reorder the users in an estimate Users List and save the estimate, the next time you open the estimate file the users in the Estimate Users List will be sorted in the same order.

5.10 Working with Estimator Funds

A fund package is created at the estimate level, and has a Fund ID, percent, Maximum Amount, Priority, and Fund Package Name. Fund Packages may have dollar limitations to provide adequate funding for the project, and may contain more than one fund. If a fund package has more than one fund, it must meet the following conditions:

- You must assign a priority level to each fund in the fund package to determine which funds are used first, second, and so on. The priorities must be sequential, beginning with 1 and increased by an increment of 1. A fund may not have a priority of 0 or any negative number.

- You can assign the same priority to more than one fund, but each fund within the priority must be unique. The participation percentages for all of the funds within that priority must also total 100.

- The lowest priority fund (which is highest numerically) must be unlimited, and at least one fund in each of the other priorities must have a limit. This allows the highest numerical fund to cover any excess funds not covered by the previous priority limited funds.

Example:
A group of items in a project has federal, state, and municipal funding. The municipal funding is limited to $5,000. After the $5,000 is used, the federal and state funds will split the remaining cost. Items would be assigned to fund package 1, which would have priority 1 funds for the federal, state, and municipal funds. The
municipal fund would have the dollar limit set to $5,000. There would also be priority 2 funds split between the federal and state funds only, with no dollar limits set.

Follow these steps to populate the fund package:

1. With the Estimate ID highlighted in the tree view, open the Funds tab of the detail pane.

2. Click in the cell for the first row, in the Fund ID field. This is a drop-down field where the Fund ID is selected and populated from the Fund Reference Data. The Description will be populated for the Fund ID selected.

3. Tab to the Percent field and enter a percent for the fund package.

4. Enter a maximum amount (if applicable).

5. Enter a priority for the fund and give it a name in the Fund Package field.

6. The fund package(s) can now be assigned at the group and item levels. Expand the tree view and select the first group.

7. In the detail pane, there is a drop-down field called Default Fund Package and a From Estimate Default check box. The drop-down menu should contain the fund package(s) previously created. To assign the group a fund package, select a fund from the Default Fund Package drop-down menu.

8. At the item level, select a fund from the Fund Package drop-down menu. The From Group Default and From Estimate Default check boxes automatically populate the fund package from the group default funding or the estimate default funding.

5.10.1 Printing the Estimate Funding Summary Report

In order to print the Funding Summary Report in Microsoft Excel, you must first generate the report in Estimator through the Generate Fund Report function.

It is assumed that funds and fund packages have been assigned to an estimate. Follow these steps to generate the Funding Summary Report:

1. In Estimator, open an estimate (with funds and fund packages).

2. Select Edit, and then Generate Fund Report.

3. Estimator creates and opens a Microsoft Excel Fund Summary Report with the following worksheets:

| Funding By Group and Item | Shows the estimate funding assignments at the Group and Item levels. |

---
<table>
<thead>
<tr>
<th><strong>Fund Totals</strong></th>
<th>Shows the total funded amount for each fund package.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Fund Details</strong></td>
<td>Shows the funds available as entered in the Funding Grid View for the estimate.</td>
</tr>
<tr>
<td><strong>Group Summary</strong></td>
<td>Shows the summary of funding activity at the Group level.</td>
</tr>
<tr>
<td><strong>Item Summary</strong></td>
<td>Shows the summary of funding activity at the Item level.</td>
</tr>
<tr>
<td><strong>Fund Summary</strong></td>
<td>Shows the summary of funds used across fund packages.</td>
</tr>
<tr>
<td><strong>Fund Package Summary</strong></td>
<td>Shows the summary of fund packages and the funds they use at the Item and Group levels.</td>
</tr>
</tbody>
</table>
6. Additional Estimator Features

There are many features of Estimator that we have not examined. This chapter offers a brief discussion of some of the many valuable functions that Estimator offers to help in the creation of estimates.

6.1 Estimate Extra Data

The Extra Data option is useful when you want to include information in the estimate that is not included in Estimator, but you would like to see in the final estimate. The extra data fields can be added to the entire estimate, a group, or an item. You can add the extra fields to existing estimates, or set permanent extra fields to include every time you open a new estimate. If you find yourself entering data fields to each new estimate, setting permanent extra fields helps you save time and effort.

If you are exporting the estimate into an XML or Excel file, the extra data information appears as part of the estimate.

6.1.1 Adding Extra Data to an Estimate

With your estimate open, select Estimate Extra Data from the Edit menu or click the EXTRA DATA tab while the estimate name is selected in the tree view. Estimator displays the Estimate Extra Data window (see Figure 6-1).
If you accessed the Extra Data window through the Edit menu, click **ADD ROW**. The Add Element window appears.

In both the Add Element window and the **EXTRA DATA** tab, enter the name of the field in the **Name** field. Enter the value that you want to appear in the estimate. Enter a description in the **Description** field. This field is not necessary, but it can help you identify what the field represents. For example, if you name the data field **LOCAT1**, you may forget what **LOCAT1** represents. You can add **Location field** in the **Description** field.
Once you've entered the information, click OK to return to the Extra Data window or save your estimate. If you are going to add more extra data fields using the Add Element window, click ADD MORE. Click CANCEL to return to the Extra Data window without adding the extra data.

Once you are back in the Estimate Extra Data window, click CLOSE to return to your estimate. Click DELETE ROW to delete the selected Extra Data row, or click ADD ROW to add another value to the Extra Data list.

6.1.2 Adding Extra Data to a Group

With your estimate open, select the group to which you want to add the extra data field. Extra data fields in groups appear as part of the estimate in an XML or Excel file.

Select Group Extra Data from the Edit menu or click the EXTRA DATA tab. Estimator displays the Group Extra Data window.

![Figure 6-4. Group Extra Data Window](image1)

![Figure 6-5. Group Extra Data Tab](image2)

If you accessed the Extra Data window through the Edit menu, click ADD ROW. The Add Element window appears.
In both the Add Element window and the EXTRA DATA tab, enter the name of the field in Name field. Enter the value that you want to appear in the Value field. Enter a description in the Description field. This field is not necessary, but it can help you identify what the field represents. For example, if you entered `jobcatcode1` in the Name field, you may forget what jobcatcode1 represents. You can add **Job Code 1** in the Description field.

Once you've entered the information, click OK to return to the Extra Data window or save your estimate. If you are going to add more extra data fields using the Add Element window, click ADD MORE. Click CANCEL to return to the Extra Data window without adding the extra data.

Once you are back in the Group Extra Data window, click CLOSE to return to your estimate. Click DELETE ROW to delete the selected Extra Data row, or click ADD ROW to add another value to the Extra Data list.

### 6.1.3 Adding Extra Data to an Item

With your estimate open, select the item to which you want to add the extra data field. Select **Item Extra Data** from the **Edit** menu or click the EXTRA DATA tab. Estimator displays the Item Extra Data window.
If you accessed the Extra Data window through the Edit menu, click **ADD ROW**. The Add Element window appears.

In both the Add Element window and the **EXTRA DATA** tab, enter the name of the field in the **Name** field. Enter the value that you want to appear in the estimate in the **Value** field. Enter a description in the **Description** field. This field is not necessary, but it can help you identify what the field represents. For example, if the field **Name** is
**jobitemcomment**, you may forget what jobitemcomment represents. You can add **Item Comment** in the Description field.

Once you’ve entered the information, click OK to return to the Extra Data window or save your estimate. If you are going to add more extra data fields using the Add Element window, click ADD MORE. Click CANCEL to return to the Extra Data window without adding the extra data.

Once you are back in the Item Extra Data window, click CLOSE to return to your estimate. Click DELETE ROW to delete the selected Extra Data row, or click ADD ROW to add another value to the Extra Data list.

If you are exporting this estimate into an XML or Excel file, the information appears as part of the estimate.

### 6.1.4 Changing Extra Data Fields

If you have made an error in a field that is specific to the estimate, access the extra data field through the Edit menu and fix the error. You may have to create a new extra data field and delete the old one in order to fix the error.

### 6.2 Check for Catalog Updates

Estimator has the ability to connect to a server, see if there are new or updated catalog files on that server, download them, and import them into the Current Catalog. This allows agencies to place updated information on a server and gives Estimator the ability to update itself.

When you first logged on to Estimator, you had the option to download new files that were detected. You can also do this when you are already logged in to Estimator.

Depending on what type of update is available, you may not be able to update the catalog. If you see there are catalog updates that you cannot load into Estimator, talk to your system administrator about getting them.

Make sure the Current Catalog is the one you want to have updated. Then select **Check for Catalog Updates** from the **Catalog Tools** menu. Estimator displays the Check for Updates window.
Follow the instructions on the Update Catalog Wizard to update your Current Catalog. You can choose which parts of the catalog update to download in the Select Items for Download window.

Check which items you want to update in the Name checkbox. When you are finished, click NEXT. If the catalog does not update, a window appears to explain the reason.
Once you continue with the updating process, the Wizard informs you that the updates are about to be downloaded. Continue to follow the Wizard's instructions.

If you have a catalog with the same name as the catalog you are importing, Estimator asks if you want to overwrite the existing file. If you chose not to overwrite the file, Estimator opens a Save As window for you to give the catalog a unique name.

**Note:** Estimator saves the overwritten files by appending the word OLD and a version number to the end of the name.

When you are done, click FINISH.

### 6.3 Deleting Inactive Price Bases

You can delete inactive price bases from an item, a group, or the entire estimate.

Make sure that only the price bases you want to delete are marked inactive within the chosen item, group, or estimate. You will not be able to choose which inactive price bases you want deleted from the chosen element- all that are marked inactive will be deleted.
Select the item or group from which you want to delete the inactive price bases, or the estimate ID if you are deleting them from the entire estimate. Then select **Delete Inactive Price Bases** from the **Edit** menu.

### 6.4 Adding Non-standard Items to the Estimate

On some estimates, the estimator might need to use an item that does not appear in the Standard Item Catalog because the Estimator Standard Item Catalog has been limited to only common items. When this is the case, you must determine the values for each field and enter the data manually.

On other estimates, the new, non-standard item you want to create may be substantially similar to an existing item in the Standard Item Catalog. If this is the case, you can use the standard item in the catalog as the basis for the new item. Basing a new item on an existing item eliminates the need to enter existing information; only a new Item Number and differing values need to be added. This is especially useful if the non-standard item can use the price bases already attached to a standard item as a starting point.

Alternatively, an estimate requires a unique item that is unlike any in the Standard Item Catalog. You must assign the new item a unique Item and Item Description and determine Unit and Quantity values and any appropriate Price Basis. After you establish this information, Estimator can determine the Unit Price.

#### 6.4.1 Creating a Non-standard Item From an Item in the Standard Item Catalog

Follow these steps:

1. Create a new estimate or open an existing estimate.
2. Select the group for which you want to add the non-standard item or add a new item to the **ALL ITEMS** tab.

3. Select **Add Item** from the **Edit** menu for the group. This adds a blank item to the estimate.

4. Select the item to add to your estimate.

5. Change the item number to a unique number and update the other item fields as appropriate. If the item is not unique, a new item appears in the item header window with a new description.

6. Save your work.

### 6.4.2 Creating a Non-standard Item Without Using the Standard Item Catalog

Follow these steps:

1. Create a new estimate or open an existing estimate.

2. Select the group for which you want to add the non-standard item or add a new item to the **ALL ITEMS** tab.

3. Select **Add Item** from the **Edit** menu for the group. This adds a blank item to the estimate.

4. Enter the desired item information in the appropriate fields. Make sure you assign the item a unique item number.

5. You can attach a rate catalog to your item by selecting **Add** from the **Edit** menu and choosing the appropriate catalog.

6. Save your work.

You can add a price basis to your item, and it will be given the designation of ad hoc in the **Price Source** field for the item. An ad hoc price basis is the price basis for an item that does not have a cost sheet, reference price, or bid history assigned to it in Estimator. When you add a price basis to an item, regardless of type, all fields of the new price basis will be empty. Fill in the new price basis information. You can not create an ad hoc bid history price basis.

### 6.5 Renumbering Estimate Items

If you inserted or moved items in your estimate, then your estimate line numbers might have different increments between each item and not increment by the option set up in the Global Options window. While this is acceptable in Estimator, you may want to
renumber the items to give your estimate a uniform look. You can do this either by using the Renumber Estimate Items command or the Renumber Using Current Order command. When you use either of these commands, the items in each group of your estimate are renumbered. You can use the Renumber Selected Items command to renumber only specific items.

You must be in an item grid in order to use the Renumber Using Current Order or Renumber Selected Items commands.

Note: This section discusses estimate line numbers and groups incrementing by five. Your estimate may increment differently, depending on the field in the Global Options tabbed folder window.

Estimator will not renumber estimate items beyond 9999 in order to comply with other AASHTOWare Project applications. If you are renumbering estimate items and the line numbers will exceed 9999, Estimator gives you the option of either canceling the renumbering command or overriding the line number increment set on the Global Options window.

If you add an item that would make the line numbers exceed 9999, Estimator will number that item 9999. It is recommended that you use one of the renumbering commands after all the new items have been added.

6.5.1 Renumber Estimate Items

The Renumber Estimate Items command makes the line numbers in every group increment by the number indicated on the Global Options window. However, it does not change the order of the items in the groups.

For example, suppose you sorted an estimate group based on the unit price.
In this example, the group's line numbers are not in sequential order, nor are they incremented by five, as set in the Global Options. However, the group is sorted correctly based on the unit price of each item.

If you select **Renumber Estimate Items** from the **Edit** menu, Estimator keeps the line numbers in the same order as they were before the sort, but renumbers them so that they increment by five, starting at 0005 in the first group and incrementing that group by five first before incrementing the second group.
The line numbers and items are in the same order as before, but each item in each group now increments by five.

6.5.2 Renumber Using Current Order

If you select the **Renumber Using Current Order** command from the **Edit** menu, Estimator makes the line numbers in every group increment by the number on the Global Options window, and changes the order of the numbers so that each line is sequential.
If you compare Figures 6-15 and 6-16, you will see that each item is in the same location. However, the line numbers are numbered depending on which option you chose.

### 6.5.3 Renumber Selected Items

If you select the **Renumber Selected Items** command from the **Edit** menu, Estimator renumbers the selected items based on the starting number entered and the item increment on the Global Options tabbed folder window.

Select the items to be renumbered in an item grid, either on the **ALL ITEMS** tab or by selecting a group in the tree area. Select **Renumber Selected Items** from the **Edit** menu. Estimator displays the Renumber Selected Items window.

![Renumber Selected Items Window](image)

Enter the new item number for your selected items and click **OK**. Estimator renumbers the selected items based on your item number start and the item increment option on the **NUMERIC/ROUNDING** tab in the Global Options. If renumbering your items caused duplicate line numbers, Estimator alerts you of this.
6.6 Pricing an Item as a Percentage of the Estimate

Estimator gives you an option when using reference prices. You can price a reference price using a unit price, or you can make the price a percentage of the estimate's total.

If you are pricing the item as a percentage of the estimate, select the Percent of Estimate check box. The price field becomes unavailable and is not calculated in the estimate total. Enter the percentage in the Percent of Estimate field. The price for this item will be the percentage of the sum of the extended amounts of all the item price bases that are not percentage reference price bases.

6.7 Excluding an Item as Part of the Percentage Price

There may be times when you don’t want to include an item in a percentage reference price. When that happens, select the Exclude Items From Reference Price Calculations check box on the item detail page.
Figure 6-19. Exclude Item From Reference Price Calculations
7. Working With Catalogs and Code Tables

Highway construction estimation is based on experience and past estimates. Estimators use a core set of information to develop several different estimates. Estimator catalogs store core information for use in estimation. The Estimator catalogs and code tables make data readily available through a well-organized, easy-to-use interface. You can quickly use information from the catalogs and code tables in your estimates.

Please see Chapter 4 of the *Estimator System Manager’s Guide* for information on editing catalogs and code tables.

7.1 Working With Catalog Information

When you first start Estimator, the current catalog is ready to use. To see which catalog is the Current Catalog, select *Show Open Catalogs* from the *Catalog Tools* menu. Estimator displays the catalog header and these available fields:

- **Name**
  The Name field contains the name of the currently loaded catalog.

- **Spec Year**
  The Spec Year field is the Specbook Year for the standard item catalog.

- **Description**
  The Description field is a brief comment about the contents of the catalog. It should indicate the measure of the catalog, along with more descriptive information.

If you have super-user status, you can change any or all of the user-modifiable catalog information values, plus import catalog information to update the catalogs. Super-users can also assign other users edit privileges for the Standard Item Catalog, Bid History Catalog, Cost Sheet Catalog, Reference Price Catalog, L/E/M Catalog, code tables, and catalog imports. For more information about super users, please read the Estimator’s *System Manager’s Guide*. 
You can also see which catalog an estimate is using by selecting Estimate Options from the Edit menu when your estimate is open.

7.2 The Standard Item Catalog

The Standard Item Catalog contains the construction items and pricing information available to estimate the cost of an estimate. Use the Standard Item Catalog to add items to the estimate Item List. As a non super-user, you can view the items in the Standard Item catalog and add them to your estimate, and you can edit items if granted that privilege by a super-user.

7.2.1 Viewing the Standard Item Catalog

To view the Standard Item Catalog window, select Show Open Catalogs or Open a Catalog from the Catalog Tools menu. Select Standard Item Catalog in the tree area. Estimator displays the Standard Item Catalog window shown in Figure 7-1.

![Figure 7-1. Standard Item Catalog Window](image)

As shown in the figure above, the fields in the Standard Item Catalog are unavailable. This means you do not have the ability to edit the catalog. Super-users can grant this ability to other users.
Standard Item Catalog Window Fields

Item
The Item field is a unique combination of letters, special characters, or numbers assigned to standard items by the agency. Estimator does not require you to follow an agency item code format. It is your responsibility to conform to any standards, if they apply.

Duplicate Item
An item that appears more than once with the same unit system in a catalog or estimate.

Description
The Description field includes the name of the item, a brief description of the item, or both.

Unit
The Unit field is a specific unit of measurement that must be provided for each item (HR for time in hours, CY for cubic yards, LF for linear feet, LS for lump sum, etc.).

Unit System
The Unit System field is the system of measurement used for the unit. It is either M for metric, E for English, or N for None.

Req Supp Desc?
The Require Supplemental Description field indicates whether a supplemental description is needed for the item.

Trns•port?
The Trns•port field indicates whether the item came from an AASHTOWare Project (Trns•port) application.

Fixed Price Flag
The Fix Price flag is assigned to an item indicating that the bid pricing is restricted to that price.

Viewing Cost Sheets Attached to a Standard Item Catalog Item

Select an item in the Standard Item Catalog that has at least one cost sheet attached to it. Estimator displays a Cost Sheet window specific to the item you selected in the Standard Item Catalog. Click GO to see the cost sheet in its own catalog.
As shown in the figure above, the fields in the Cost Sheet Catalog are unavailable. This means you do not have the ability to edit the catalog. Super-users can grant this ability to other users.

**Viewing Bid Histories Attached to a Standard Item Catalog Item**

Select an item in the Standard Item Catalog that has at least one bid-based price attached to it. Estimator displays the Bid History Catalog window specific to the item you selected in the Standard Item Catalog. Click the GO button to see the bid history in its own catalog.

As shown in the figure above, the fields in the Bid History Catalog are unavailable. This means you do not have the ability to edit the catalog. Super-users can grant this ability to other users.
**Viewing Reference Prices Attached to a Standard Catalog Item**

Select an item in the Standard Item Catalog that has at least one reference price attached to it. Estimator displays a Reference Price Catalog window that is specific to the item you selected in the Standard Item Catalog. Click the GO button to see the reference price in its own catalog.

As shown in the figure above, the fields in the Reference Price Catalog are unavailable. This means you do not have the ability to edit the catalog. Super-users can grant this ability to other users.

### 7.3 Working With Price Basis Catalogs

Cost sheets, reference prices, and bid histories are classified as *price bases*. Estimator price basis catalogs store the price bases you can attach to estimate items. If you have permission to edit the price basis catalogs, please see the Estimator’s *System Manager’s Guide* for instructions.

Before you view any of these catalogs, you must select **Show Open Catalogs** or **Open a Catalog** from the **Catalog Tools** menu to display the Current Catalog.

#### 7.3.1 Cost Sheet Catalog

Estimator's Cost Sheet Catalog contains the existing cost sheets you can use to calculate the costs of items in an estimate. Select the Cost Sheet Catalog to display the Cost Sheet Catalog window shown in Figure 7-5.
As shown in the figure above, the fields in the Cost Sheet Catalog are unavailable. This means you do not have the ability to edit the catalog. Super-users can grant this ability to other users.

**Viewing a Cost Sheet in the Cost Sheet Catalog**

To view a cost sheet in the Cost Sheet Catalog, either click on the cost sheet in the tree area or click the GO button next to the cost sheet in the grid area. If you have permission to edit the Cost Sheet Catalog, you can edit the cost sheet when it is displayed in its own window.

**7.3.2 Bid History Catalog**

Estimator's Bid History Catalog contains all the bid histories you can use to estimate the costs of items in an estimate.
Select Bid History Catalog to display the Bid History window shown in Figure 7-6.

![Figure 7-6. Bid History Catalog Window](image)

As shown in the figure above, the fields in the Bid History Catalog are unavailable. This means you do not have the ability to edit the catalog. Super-users can grant this ability to other users.

**Viewing a Bid History in the Bid History Catalog**

When the Bid History Catalog window is the active window, you can view a bid history in its own window. Either click the GO button next to the desired bid history in the grid area or click the bid history in the tree area.

**Viewing the Bid History Data Catalog**

To view data derived from the BAMS/DSS HREG model that make up the Bid History regressions, open the Bid History Data Catalog. Scrolling through the Bid History Data Catalog displays data used to create the Bid Histories.

### 7.3.3 Reference Prices Catalog

Estimator's Reference Price Catalog contains all the reference prices you can use to estimate the costs of items in an estimate. You can view the Reference Price Catalog at any time after you log on to Estimator by selecting Show Open Catalogs or Open A Catalog from the Catalog Tools menu.
Select Reference Price Catalog to display the Reference Price Catalog window shown in Figure 7-7.

![Reference Price Catalog Window](image)

As shown in the figure above, the fields in the Reference Price Catalog are unavailable. This means you do not have the ability to edit the catalog. Super-users can grant this ability to other users.

**Viewing a Reference Price in the Reference Price Catalog**

When the Reference Price Catalog window is the active window, Estimator enables the Reference Price command regardless of your permission level. Select the reference price in the tree area or click the Go button next to the reference price in the grid area. Estimator displays the selected reference price.

### 7.4 Working With Rate Catalogs

Estimator includes rate catalogs you can use to store equipment, labor, and material rates you can attach to items in an estimate. Because equipment, labor, and materials are generally associated with cost sheets, you use the rate catalogs to refine your cost sheet calculations. You can add, change, and delete rates from the catalog if you have permission to edit the rate catalogs. Please see the Estimator’s *System Manager’s Guide* for instructions.

You can view the rate catalogs at any time after you log on to Estimator. You access the catalogs by selecting **Show Open Catalogs** or **Open A Catalog** from the **Catalog Tools** menu. The rate catalogs are listed in the tree area under the price bases catalogs.
As shown in the figure above, the fields in the Rate Catalog are unavailable. This means you do not have the ability to edit the catalog. Super-users can grant this ability to other users.

### 7.4.1 Equipment Rate Catalog

Your Estimator system manager stores information about all commonly used equipment in the Equipment Rate Catalog. Unless you have permission to edit the Equipment Rate Catalog, you cannot modify the contents of the catalog; however, all Estimator users can copy selected equipment from the catalog directly into the equipment lists of their estimates’ cost sheets.

Estimator's Equipment Rate Catalog contains all the equipment you can use to estimate the cost sheet in an estimate. You can view the Equipment Rate Catalog at any time once you have logged on to Estimator by viewing the Current Catalog.

Select **Equipment Rate Catalog** to display the Equipment Rate Catalog window shown in Figure 7-9.
Your Estimator system manager stores information about all commonly used laborers in the Labor Rate Catalog. Unless you have permission to edit the Labor Rate Catalog, you cannot modify the contents of the catalog; however, all Estimator users can copy selected laborers from the catalog directly into the labor lists of their estimates’ cost sheets.

Estimator's Labor Rate Catalog contains all the laborers (and the pay rate information for each laborer) you can use to estimate the cost sheets in an estimate. You can view the Labor Rate Catalog at any time after you log on to Estimator by viewing the Current Catalog.

Choose Labor Rate Catalog to display the Labor Rate Catalog window shown in Figure 7-10.
7.4.3 Material Rate Catalog

Your Estimator system manager stores the necessary information about all commonly used materials in the Material Rate Catalog. Unless you have permission to edit the Material Rate Catalog, you cannot modify the contents of the catalog; however, all Estimator users can copy selected materials from the catalog directly into the Materials List of their estimates’ cost sheets.

Estimator's Material Rate Catalog contains all the material rates you can use to estimate the cost sheets in an estimate. You can view the Material Rate Catalog at any time after you log on to Estimator by viewing the Current Catalog.

Select **Material Rate Catalog** to display the Material Rate Catalog window shown in Figure 7-11.

![Figure 7-11. Material Rate Catalog Window](image)

7.5 Working With Code Tables

The Code Tables are visible when the Current Catalog is open. To view the code tables, select **Show Open Catalogs** or **Open A Catalog** from the **Catalog Tools** menu.
As shown in the figure above, the fields in the Code Table Catalogs are unavailable. This means you do not have the ability to edit the catalog. Super-users can grant this ability to other users.

Code tables are used to fill in the estimate header information as well as other fields. Your Estimator system manager stores the necessary information about all commonly used codes in the Code Table Catalogs.

For more information about working with code tables, please see the Estimator System Manager’s Guide.

7.6 Printing Catalog Reports

The Estimator catalog document typically has all supported entities and may have thousands of records per type. Consequently, you are not able to print the entire catalog. Instead, the print capabilities are broken into contextual subsets of the catalog. There are two types of reports: detailed for a single catalog element and tabular for multiple catalog elements.

Single Catalog Element Detailed Reports:

- A detailed printout of a single catalog item and its associated price bases. The display format of the item will be the same as the price basis detail reports.
- A detailed printout of a single catalog cost sheet and its child labor, equipment, and materials rates.
- A detailed printout of a single catalog bid history element.
- The detailed printouts of catalog reference prices, catalog labor/material/equipment rates, and catalog code table entities will be implemented by using each elements' tabular report format with only a single element displayed in the report. This is because these elements have simple data models and the data expressed in the tabular reports for these elements is comprehensive.

Multiple Catalog Elements Tabular Reports:

- One or more catalog items without associated price bases.
- One or more catalog cost sheets without associated child rate information, including regression or average data, reference price elements, and labor elements.
- One or more catalog material elements.
- One or more catalog equipment elements.
- One or more catalog code table elements.

All reports will support page headers and footers. The left-hand side page header will be the report entity and the right hand side page header will be the current page number and total number of pages (for example: Page 2 of 5). The left hand side page footer will be the document name and the right hand side will be the date. All numeric fields display to the number of decimal places you see when viewed in Estimator.

The data interface between Crystal Reports will be accessed via *.ttx files that define field names and values.

To print a catalog element, make sure that element is in the active window and select **Print** from the **File** menu. A window displays.

Select your print options and click **OK**.

### 7.7 Finding Catalog Elements

Estimator allows you to search the catalogs for specific items and price bases, and makes it easy to add those elements to your current estimate from inside the estimate window. If you know the code of an item or ID number for a price basis, or words included in the description, you can use that information to search for the catalog element. The more information you enter in the available fields for your search, the easier the element will be to find.

In the catalog, the Find windows are used to find and navigate to a particular catalog element. This occurs when you select **Find** from the **Catalog Tools** menu and choose the desired element. A Find window for the element appears. You enter the search
criteria and select the element. After it is selected, the catalog grid view displays with the element selected in the grid view.

The Find Windows can also be used to incorporate a particular catalog element into an estimate. You must first add the element to the estimate, whether it is an item or a price basis for an item. The Find Item window is discussed in Section 5.4.4.

To use the Find window to add a price basis to the estimate item, open the price basis information window from the item by clicking the green GO button next to the price basis. Select the ellipses (…) next to the price basis ID field to access the Find window.

- **Note:** When using the Find window, you can only search for the one type of price basis that was selected in the estimate item.

![Find Cost Sheet Window](image)

**Figure 7.13. Find Cost Sheet Window**

Enter the criteria in the appropriate fields for the price basis you wish to find; in Figure 7-13, a cost sheet. Press the TAB key between each entry. Do not press ENTER or click OK, as this will select the first match on the list and return you to the price basis window.

Each time you press TAB, the list of matches narrows to the price bases that fit the entered information. Once you have entered all the criteria for which you are searching, select the desired price basis by highlighting it in the Matches list, and click OK. If there are no entries that match the search, double check your information or be less specific and enter the search criteria again.

Once you find the price basis for which you are searching, select it in the Matches list and click OK. Click CANCEL if you decide not to use any of the price bases.

### 7.7.1 Expert Mode

If the Expert Mode box is checked in the price basis Find window, then the criteria entered in the Find fields must exactly match the specific type of price basis for which
you are searching, or you must use wildcards to find the price basis for which you are searching.

Figure 7-14.  Find Cost Sheet Expert Mode Box

For example, if you enter **Quantity** in the Description field when you are using the Find window in the regular mode, the Matches display every specified price basis (cost sheet, bid history, or reference price) in which the word *Quantity* appears somewhere in the description. In Expert Mode, however, you would have to enter the entire description - for example, **Large Quantity**, or **Small Quantity** in order for Estimator to find a match, unless the price basis's entire description consists of the word *Quantity*.

You can also use wildcards to search for the price basis. The two wildcards Estimator uses are the question mark (?) and the asterisk (*).

Using * finds any number of characters. For example, if you know the word Quantity is the last word of the description, but you are not sure what the first word is, you can enter *quantity* in the Description field and press TAB. Estimator displays all price bases (cost sheet, bid history, or reference price) that contain Quantity as their last word.

Using ? will find only one character. Suppose you wanted to find a specific type of price basis that has a one-character designation; for example, Remove G Light, or Remove 7 Light. Enter **Remove ? Light** in the Description field and press TAB. Estimator displays all price bases of the desired type that have the words Remove and Light in it, with one character in between the two words.

You can also combine the use of the wild cards. If you enter ?t* in the Description field and press TAB, Estimator returns all price bases whose second letter is a T.

Once you find the price basis for which you are searching, select it in the Matches list and click OK. Click CANCEL if you decide not to use any of the price bases.
7.8 Scheduling Catalog Imports

The Catalog Import Scheduler, accessed from the Catalog Tools menu, allows users to schedule catalog updates for individual catalog elements, specifically CESITEM.CSV, IBIDHIST.CSV, and Code Table Excel and .txt files.

![Catalog Update Scheduler](image)

Figure 7-15. Catalog Update Scheduler

After clicking New Schedule, you can select a catalog to update and then browse your system for an .xls, .xlsx, .csv, or .txt file from which to import data. Note that if you are scheduling a recurring import, AASHTOWare Project Estimator will always look to this location for the .xls, .xlsx, .csv, or .txt file. If the location of the import file changes, select the schedule and click Remove Schedule, and then create a new schedule to replace it.

Once you have selected a catalog and import file, select a Date and Time and set a Repeat Schedule:

- Daily - Specific time on a daily schedule.
- Weekly - Specific time on a weekly schedule.
- Monthly - Specific time on a monthly schedule.
- No repeat - Specific time without recurring.

Click OK when finished.
8. Importing and Exporting

Estimator stores each estimate and catalog in separate data files. You can use Estimator’s import and export capabilities to export data into an AASHTOWare Project program, word processor, spreadsheet, or database program, or import information created in external programs into Estimator. See the Estimator System Manager’s Guide and the Estimator Interaction Guides for more details.

Estimator’s data security measures are enforced when you import catalogs or export estimates. Estimator imports catalog data only for users that have permission to edit that catalog. You can export any estimate that you can at least read.

When importing, Estimator looks at the entity being imported to determine if it is a catalog or estimate, and places it accordingly.

8.1 Importing Catalogs

The Import command allows the system manager to supplement or replace the Estimator catalogs with catalog information provided from another Estimator workstation or outside application.

Depending on your Estimator permissions, you may not be able to import a catalog. If you try to import a catalog but do not have the Catalog Import flag checked in the Estimator Users table, an import error message appears.
If you are able to import catalogs, please refer to the *Estimator System Manager's Guide* for details.

### 8.2 Importing Estimates

To import an estimate, select **Import** from the **File** menu. Estimator displays the Import dialog box.

![Import Dialog Box](image)

When the Import dialog box displays, it lists all files in the current directory that have an extension of files that can be imported. If the file you want to import is not in this directory, use the Look In field to select the correct directory. Select the file and click **OPEN**.

Estimator opens the newly imported estimate. Select **Verify Estimate** from the **Edit** menu. This shows you what, if any, errors the imported estimate has.
You can update selected price information from imported projects to reconcile an imported project with price bases in the Current Catalog using the Update Price Information command (see Chapter 5).

8.2.1 Importing an Excel Spreadsheet as an Estimate Using Estimator

Estimator supports importing Excel file versions 97 through 2003 (XLS files) and Excel version 2007 (XLSX files). To import an Excel spreadsheet as an estimate, select Import from the File menu. Estimator displays the Import dialog box.

![Figure 8-3. Import Dialog Box](image)

If the file you want to import is not in this directory, use the Look In field to select the correct directory. Select the file and click OPEN. Estimator displays the Import Spreadsheet Wizard.

When using Estimator to import estimate-level data, the Estimate Import Spreadsheet Wizard displays the following screen:
When importing a new estimate, Estimator automatically assigns the worksheet name as estimate data items and extra data fields in XML or Excel format. Select the Estimate-level data first and then select OK.

Once the Estimate-level data is imported, select the appropriate **Estimate Options** from the **Edit** menu and select OK.
When importing item data, go to **File**, then **Import**, and go through the Import Spreadsheet Wizard again.
Estimator displays the Row and Column and determines contains headings that match the Estimator entities. You can override the selection by typing in alternate Row and Column information. When the worksheet or range you want is selected, and the Row and Column information is correct, click NEXT. Estimator displays the second page of the Import Wizard.

![Figure 8-8. Estimate Import Spreadsheet Wizard – Second Page](image)

If the column headings in your Excel file do not match the fields in Estimator, you will need to tell Estimator which columns to use for which fields when importing. For example, on the second page of the import wizard as shown in Figure 8-8, the estimate being imported does not have a column named Group or one named Supplemental Description. Therefore, those fields are left blank by the Import Wizard.

To enter the corresponding columns in the Estimator fields, first highlight the name of the column in the left pane. Then click in the corresponding field on the right side. Do this until each field is properly matched.

When all the fields for Estimator contain the correct data, click OK. Estimator imports and displays the estimate.

When importing extra data, go to **File**, then **Import**, and go through the Import Spreadsheet Wizard again.
If an item or group Extra Data ID field does not match an existing item or group, the permanent extra data will not be imported. If there are duplicate permanent extra data rows with the same name and attached to the same item, the first one will be imported, provided that “Do Not Overwrite” under Edit > Estimate Options in Estimator is selected. If “Overwrite” is selected, then the last permanent extra data will import. When all the fields for Estimator contain the correct data, click OK. Estimator imports and displays the estimate.

Select **Verify Estimate** from the **Edit** menu. This shows you what errors, if any, the imported estimate has.

### 8.2.2 Importing Project Data From Design Systems Using aecXML

Estimator can import project data from external design systems via the aecXML Infrastructure Project.

Make sure that the Current Catalog is the one you want associated with your estimate. Then select **Import** from the **File** menu. Estimator displays the Import window. Select the XML file you want to import and click **OPEN**. When the estimate imports successfully, Estimator opens the project data as an Estimate. Select **Verify Estimate** from the **Edit** menu. This shows you what, if any, errors the imported estimate has.

### 8.3 Exporting Catalogs

The Export command allows anyone with read access to export part or all of an Estimator catalog for use on a different Estimator workstation. See the *Estimator System Manager's Guide* for details.

Select the catalog you want exported and open it so it is displayed in the Estimator window. Select the catalog title or the parts of the catalog that you want exported and
select **Export** from the **File** menu. Estimator displays the options specific for the type of export you desire. Select your export options and click **OK** to export the catalog.

### 8.4 Exporting Estimates

You must have at least read access to an estimate in order to export it. To export the estimate from Estimator, you must display the estimate in the current window. Select **Export** from the **File** menu. Estimator displays the dialog box shown in Figure 8-10.

![Figure 8-10. Export Project Dialog Box](image)

**Note:** If exporting to AASHTOWare Project Cost Estimation or PES, the Latitude of Midpoint (DDMMSS) and Longitude of Midpoint (DDDMMSS) values must be positive numbers.

You can chose to export an estimate one of seven ways.

Exporting as an XML Estimate File exports the estimate as an XML file. It can then be imported into PES 5.5a or later, CES 5.3a or later, or another software application. You can save the file with the default file name or a new file name, but keep the XML extension so it can be imported in PES 5.5a or later or CES 5.3a or later.

**Note:** If you are using Estimator 2.5a and PES 5.9b-1 or earlier or CES 5.7a or earlier, the data in the Longitude at Midpoint field, the Latitude at Midpoint field, the District field, and the Federal/State Project Number field will export from Estimator but not import into PES or AASHTOWare Project Cost Estimation. You can enter the relevant information manually in PES or AASHTOWare Project Cost Estimation™.
Selecting PES Project File (5.4a or earlier) or PES Load Proposal Prices File (5.4a or earlier) makes the estimate available to use in PES 5.4a or earlier. These options direct Estimator to either export the pricing information contained in the estimate or to not export it.

Exporting to an HTML Report File exports the estimate as an HTML file. The estimate can then be posted on the Internet.

Select CSV file to export the estimate to a CSV (comma-separated value) file. The estimate can then be opened in a program that supports the CSV format.

Users wishing to export the file to use in Excel should choose either the Excel 97-2003 Workbook option or the Excel 2007 Workbook option. This saves the estimate as an XLS or XLSX file. Once it is saved, Excel opens to display the file. Only the Group, Item, Item Unit, Item Description, Item Supplemental Description, Quantity, and Unit Price fields are exported.

Note: If a supplemental description is over 40 characters for an item in the estimate you are exporting to PES, PES divides the supplemental description into the Supplement Description 1 field and the Supplemental Description 2 field. Only whole words are saved in each field, so a word in the Supplemental Description 1 field extending beyond the 40 characters would be placed in the Supplemental Description 2 field. If this causes the Supplemental Description 2 field to extend beyond 40 characters, the extra characters will be truncated.

Any extra data fields are included in the XML or Excel export.

Once you have determined which way you want to export your data, click SAVE, or click CANCEL to not export and return to the estimate. If you click SAVE, Estimator exports the file as the desired file type.
# Appendix A: Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Active Price Basis</strong></td>
<td>The price basis of an item that is used by Estimator to calculate the Unit Price of the item.</td>
</tr>
<tr>
<td><strong>Active Estimate</strong></td>
<td>The one open estimate (out of many) that will currently be affected by commands.</td>
</tr>
<tr>
<td><strong>Active Window</strong></td>
<td>The one open window that will currently be affected by commands.</td>
</tr>
<tr>
<td><strong>Ad Hoc</strong></td>
<td>A type of price basis that relies on the estimator's abilities to determine item prices.</td>
</tr>
<tr>
<td><strong>Agency</strong></td>
<td>Used as part of the brand to distinguish a group of Estimator users (see Brand, Location).</td>
</tr>
<tr>
<td><strong>Ascending</strong></td>
<td>The ordering of a list with the lowest value first and each successive value occurring later in the alphabet or number system. The list of numbers 10, 20, 40 and the list of codes A25, C11, Z44 are in ascending order (see Descending).</td>
</tr>
<tr>
<td><strong>Bid-based Price</strong></td>
<td>Unit price for a work item that is derived in Estimator using one of three estimation methods, which, listed in order of priority, are regression, averages, and historical/reference price.</td>
</tr>
<tr>
<td><strong>Brand</strong></td>
<td>Used to distinguish the different agencies and locations using Estimator (see Agency, Location).</td>
</tr>
<tr>
<td><strong>Catalog</strong></td>
<td>A collection of commonly used elements stored by Estimator. Those with catalog edit or import access store and update information in the catalogs. Elements in a catalog are not associated with a particular estimate and can be used in any estimate.</td>
</tr>
<tr>
<td><strong>Code Table Catalogs</strong></td>
<td>Catalogs that contain information used to fill in drop-down list options. These values can be entered manually or imported from another source by those with catalog edit and import privileges.</td>
</tr>
<tr>
<td>------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Check Box</strong></td>
<td>A dialog box component that allows you to select options. Any number of these square boxes might be present and you might select none, some, or all of them (see Radio Button and List Box).</td>
</tr>
<tr>
<td><strong>Click</strong></td>
<td>The act of pressing and releasing one of the buttons on the mouse, generally the left mouse button.</td>
</tr>
<tr>
<td><strong>Combo Box</strong></td>
<td>A dialog component that contains a fixed list of choices. Only one of the choices can be active at a time. The combo box will have a scroll bar to aid in moving through the list (see Radio Button, Check Box, and List Box).</td>
</tr>
<tr>
<td><strong>Control Menu</strong></td>
<td>A menu in the upper-left corner of every window which contains commands that change the size of, move, or close the active window.</td>
</tr>
<tr>
<td><strong>Cost Sheet</strong></td>
<td>Utility used to tally the costs of the equipment, labor, and materials needed to complete an item. Cost sheets are only used for cost-based estimation.</td>
</tr>
<tr>
<td><strong>Descending</strong></td>
<td>The ordering of a list with the highest value first and each successive value occurring earlier in the alphabet or number system. The list of numbers 40, 20, 10 and the list of codes Z44, C11, A25 are in descending order (see Ascending).</td>
</tr>
<tr>
<td><strong>Dialog Box</strong></td>
<td>A box displayed on the screen in which you enter information. It might contain text boxes, list boxes, radio buttons, and check boxes.</td>
</tr>
<tr>
<td><strong>Double Clicking</strong></td>
<td>The act of quickly pressing a mouse button twice in succession.</td>
</tr>
<tr>
<td><strong>Drag and Drop</strong></td>
<td>The act of using the mouse move an element from one location to another. First, highlight the desired element. Next, press and hold down the left mouse button and move the cursor to the desired location for the element. Drop the element in that location by releasing the left mouse button.</td>
</tr>
<tr>
<td><strong>Duplicate Item</strong></td>
<td>An item that appears more than once with the same unit system in a catalog or estimate.</td>
</tr>
<tr>
<td><strong>Equipment</strong></td>
<td>Any mechanical tool or contrivance that must be bought, rented, or leased.</td>
</tr>
<tr>
<td><strong>Estimate</strong></td>
<td>Estimates, which are made up of estimate header information and group and item lists, store the items used in a construction estimate, the price bases, and supporting information about the contract.</td>
</tr>
<tr>
<td><strong>Estimator</strong></td>
<td>A computer program designed to estimate the cost of a construction project with cost-based and bid-based estimation.</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td><strong>Extra Data</strong></td>
<td>Information the user wishes to store in Estimator that has no designated place.</td>
</tr>
<tr>
<td><strong>Expression Builder</strong></td>
<td>Estimator function that allows the user to find a value for a numeric field by using a formula to derive that value.</td>
</tr>
<tr>
<td><strong>File</strong></td>
<td>An entity that stores all information associated with exactly one estimate or exactly one catalog and its elements.</td>
</tr>
<tr>
<td><strong>Grid Area</strong></td>
<td>Usually in the right pane of a catalog or estimate window, the grid area displays a list of the entity selected in the tree area.</td>
</tr>
<tr>
<td><strong>Group</strong></td>
<td>An overall heading for related items in an estimate.</td>
</tr>
<tr>
<td><strong>Group List</strong></td>
<td>A list displayed in the tree or grid area of an estimate of all the groups in that estimate.</td>
</tr>
<tr>
<td><strong>Header Information</strong></td>
<td>Header Information contains general information about the element with which it is associated. For an estimate, this includes the spec year, highway type, and county; for an item, this includes the unit price and system of measurement; for a catalog, this includes the name and description.</td>
</tr>
<tr>
<td><strong>Highlight</strong></td>
<td>To shade an area to give it emphasis. Can be performed with a mouse by pointing and clicking on the beginning of the area and dragging until the desired area is shaded.</td>
</tr>
<tr>
<td><strong>Item</strong></td>
<td>Stored in the Standard Item Catalog, items are the basic units of an estimate.</td>
</tr>
<tr>
<td><strong>Item List</strong></td>
<td>For an estimate, the item list is a list of all the items that comprise the estimate groups. For the Standard Item Catalog, it is a list of all the items in the catalog.</td>
</tr>
<tr>
<td><strong>Labor</strong></td>
<td>For costing purposes, labor is defined as work performed by people.</td>
</tr>
<tr>
<td><strong>List</strong></td>
<td>A collection of related elements found in a catalog or formed by an estimator using Estimator. Each list is associated with a specific catalog or estimate.</td>
</tr>
<tr>
<td><strong>List Box</strong></td>
<td>A dialog box component that contains a list of choices. Only one of the choices can be selected at a time. The list box will have a scroll bar to aid in moving through the list (see Radio Button, Check Box, and Combo Box).</td>
</tr>
<tr>
<td><strong>Location</strong></td>
<td>Used as part of the brand to distinguish groups of Estimator users (see Agency, Brand).</td>
</tr>
<tr>
<td>-------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Material</strong></td>
<td>Any quantifiable physical entity which is consumed in the performance of an item of work (excluding power or fuel for equipment).</td>
</tr>
<tr>
<td><strong>Menu</strong></td>
<td>A list of related commands that can be pulled down and viewed simultaneously.</td>
</tr>
<tr>
<td><strong>None</strong></td>
<td>A privilege level of None means that the user can not access a new estimate.</td>
</tr>
<tr>
<td><strong>Owner</strong></td>
<td>A privilege level of Owner means that the user can edit a new estimate as well as change information on the estimate's User list.</td>
</tr>
<tr>
<td><strong>Password</strong></td>
<td>A code that Estimator uses to identify you. This code is used in conjunction with your username when you want to tell Estimator who you are. You must keep your password secret at all times to prevent other people from accessing your files without your knowledge.</td>
</tr>
<tr>
<td><strong>Price Basis</strong></td>
<td>A method used to determine an item's price. Price bases include one or more cost sheets, bid histories, and reference prices. Ad hoc is a different type of price basis that relies on the estimator's abilities to determine item prices.</td>
</tr>
<tr>
<td><strong>Price Bases Catalogs</strong></td>
<td>The Cost Sheet, Bid History, and Reference Price Catalogs, they comprise the bases of the ways the estimate can be estimated.</td>
</tr>
<tr>
<td><strong>Privileges/Permissions</strong></td>
<td>The level of access to a new estimate. The access levels are owner, user, write, read, and none.</td>
</tr>
<tr>
<td><strong>Production Rate</strong></td>
<td>The number of units of an item generated in one day of work.</td>
</tr>
<tr>
<td><strong>Radio Button</strong></td>
<td>A dialog box component that allows you to select one option from a small group of related options. A circular button (see List Box and Check Box) represents each choice.</td>
</tr>
<tr>
<td><strong>Rate Catalogs</strong></td>
<td>The Equipment Rate, Labor Rate, and Material Rate Catalogs, used to comprise the information for the Cost Sheet Catalog.</td>
</tr>
<tr>
<td><strong>Read</strong></td>
<td>A privilege level of Read means that a user can access a new estimate, but not make any changes to it.</td>
</tr>
<tr>
<td><strong>Reference Price</strong></td>
<td>A price used as the basis for estimating an item’s cost. Reference prices may be stipulated directly or they may be derived from formulas.</td>
</tr>
</tbody>
</table>
**Roll Up Quantity**  A system management function on the **GENERAL** tab of the Global Options, it allows you to total the quantities of an item across groups for use with bid-based pricing.

**Scroll Bar**  A rectangular box that is present in list boxes or windows. The bar contains up and down scroll arrows and a scroll box. The scroll bar allows you to move through text to view sections that are not currently visible. To use the bar for scrolling, click on the scroll box and drag it up or down. Alternatively, you can click on the scroll arrows to produce the same results.

**Scrolling**  The up or down shifting of text that occurs when you move your cursor to see parts of the text that are not currently visible (see Scroll Bar).

**Spec Year**  A base year used for pricing purposes. The spec year is used to ensure that all pricing information within an estimate is correct for the time period encompassed by the estimate.

**Super-User**  A user granted special privileges. A super-user has automatic owner access to new estimates, can edit and import new catalogs, and can change fields for a user in the Users Table.

**Supplemental Group Number**  The Supplemental Group Number is an alphanumeric field at the Group/Category Level that allows additional values to be entered and tracked for each group, such as a construction change order tracking number.

**Text Box**  A dialog box component that accepts input that is typed in or copied from an Estimator catalog.

**Tree Area**  Usually in the left pane of a catalog or estimate window, the tree area displays all the entities that comprise an estimate or catalog.

**User**  A privilege level of User means that a user can edit a new estimate and make changes to the estimate's User list, but not change any fields for a user designated as an Owner.

**Users List**  For Estimator, it is a list of all users, their real names, and new estimate and catalog access permission. For an estimate, it is a list of all users with privileges to at least read the estimate.

**User Permission**  A user's right to view and edit the information in an estimate. Each estimate can have one or more people listed as users. User permission differs from owner permission in that someone with user permission cannot view or edit the User List for the estimate.
**Username**

The name by which Estimator knows you. Estimator uses your name and password to verify who you are so that you can work on Estimator estimates for which your username is listed as an authorized user.

**Web Services**

An option set by the System Manager to allow parts of estimates or catalogs to view information over the Internet set up by the transportation agency.

**Wild Card**

A character that can substitute for one or more characters. The asterisk wild card (*) can substitute for one or more characters whereas the question mark wild card (?) can substitute for only a single character. For example, the wild card in the name 1989?.est can substitute for 1989A. est, 1989X. est, or 1989!. est. Estimator uses wild cards in file names and user security permission codes.

**Write**

A privilege level of Write means that a user can edit a new estimate.